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FEATURES 

Easy evaluation of the ADT7516

Can be used to emulate ADT7517 and ADT7519

Evaluation software included 

USB interface to PC 

Powered from USB interface 

APPLICATIONS 

Portable battery-powered instruments 

PCs 

Smart battery chargers 

Telecommunications systems 

Electronic test equipment 

Domestic appliances 

Process controls 

INTRODUCTION 

The ADT7516 evaluation board allows the ADT7516 digital 

temperature sensor, 4-channel ADC and quad DAC to be 

quickly and easily evaluated using a PC. Using the evaluation 

board and its accompanying software, the ADT7516 evaluation 

board can be interfaced to any PC running Windows® XP, 

Windows 2000 or higher, via one of the computer’s USB ports. 

The two other parts in the family, the ADT7517 and ADT7519, 

differ only in that they have 10-bit and 8-bit DACs, respectively. 

The ADT7516 evaluation board can be used to emulate the 

ADT7517 by setting the two LSBs of the DACs to zero and for 

the ADT7519 by setting the four LSBs of the DACs to zero. 

The evaluation board allows all the input and output functions 

of the ADT7516 to be exercised without the need for external 

components. The software allows control and monitoring of the 

ADT7516’s internal registers. 

EVALUATION SYSTEM PACKAGE CONTENTS 

The evaluation system package contains the following items:  

• The ADT7516 evaluation board data sheet on CD 

• The ADT7516 evaluation board 

• Evaluation software on CD 

• USB A to Mini-B cable 

 

http://www.analog.com/ADT7516
http://www.analog.com/en/prod/0%2C2877%2CADT7517%2C00.html
http://www.analog.com/en/prod/0%2C2877%2CADT7519%2C00.html
http://www.analog.com/en/prod/0%2C2877%2CADT7517%2C00.html
http://www.analog.com/en/prod/0%2C2877%2CADT7519%2C00.html
http://www.analog.com/en/prod/0%2C2877%2CADT7517%2C00.html
http://www.analog.com/en/prod/0%2C2877%2CADT7519%2C00.html
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EVALUATION BOARD HARDWARE 
The ADT7516/ADT7517/ADT7519 combine a 10-bit 

temperature-to-digital converter and a quad 12-/10-/8-bit  

DAC, respectively, in a 16-lead QSOP. This includes a band  

gap temperature sensor and a 10-bit ADC to monitor and 

digitize the temperature reading to a resolution of 0.25°C. The 

ADT7516/ ADT7517/ADT7519 operate from a single 2.7 V to 

5.5 V supply. The input voltage range on the ADC channels is 

0 V to 2.28 V, and the input bandwidth is dc. The reference for 

the ADC channels is derived internally. The output voltage of 

the DAC ranges from 0 V to VDD, with an output voltage settling 

time of typically 7 ms. 

The ADT7516/ADT7517/ADT7519 provide two serial inter- 

face options, a 4-wire serial interface that is compatible with 

SPI, QSPI™, MICROWIRE™, and DSP interface standards and a  

2-wire SMBus/I2C interface. These products feature a standby 

mode that is controlled via the serial interface. 

The ADT7516 evaluation board contains the following main 

components, which can be identified from the printed circuit 

board (PCB) silkscreen and the schematic diagram (see 

Figure 15 to Figure 19): 

• ADT7516 IC, U9 

• USB microcontroller, U1 

• Interface buffers and analog switches 

• Power LED, D1 

• Interrupt LED, D2 

• Temperature Sensor, Q1 

• Photo diode sensor, U14 

• Bargraph driver and LED bargraph, U12/U8 

• Connector for USB interface, J1 

• DAC output connector, J2 

• VREF input connector, P1 

• AIN analog input connector, P2 

• LDAC push-button, S1 

USING THE HARDWARE 

The hardware is extremely simple to use. Before connecting the 

evaluation board to a USB port on the PC, using the USB A to 

Mini-B cable provided, make sure the software is installed. No 

external power supply is required. 

MINI-B USB CONNECTOR, J1 

The connections to J1 are shown in Table 1. 

Table 1. J1 Connections 

J1 Pin  Mini-B Function  

1  5 V  

2  −Data  

3  +Data  

4  Key (Not Used—Connected to Ground)  

5  Ground  

The communication between the Mini-B plug and the rest of 

the evaluation board is handled by the USB microcontroller, U1. 

DAC OUTPUT CONNECTOR, J2 

The output of any one of the four DACs (selected by the 

software) is available on this connector. 

VREF INPUT CONNECTOR, P1 

The architecture of one DAC channel consists of a resistor 

string DAC followed by an output buffer amplifier. The refer-

ence voltage for the selected DAC is determined by the on-chip 

reference of 2.28 V or an external reference voltage, which may 

be connected to P1. 

AIN ANALOG INPUT CONNECTOR, P2 

The ADT7516/ADT7517/ADT7519 offers four single-ended 

analog input channels, which range from 0 V to 2.28 V, or  

0 V to VDD. This analog input may be connected using P1. 

TEST POINTS 

Various system logic signals and the individual DAC outputs 

are available at the test points on the board. 

 

http://www.analog.com/ADT7516
http://www.analog.com/en/prod/0%2C2877%2CADT7517%2C00.html
http://www.analog.com/en/prod/0%2C2877%2CADT7519%2C00.html
http://www.analog.com/ADT7516
http://www.analog.com/en/prod/0%2C2877%2CADT7517%2C00.html
http://www.analog.com/en/prod/0%2C2877%2CADT7519%2C00.html
http://www.analog.com/ADT7516
http://www.analog.com/en/prod/0%2C2877%2CADT7517%2C00.html
http://www.analog.com/en/prod/0%2C2877%2CADT7519%2C00.html
http://www.analog.com/en/prod/0%2C2877%2CADT7517%2C00.html
http://www.analog.com/en/prod/0%2C2877%2CADT7519%2C00.html
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EVALUATION BOARD SOFTWARE 
The software allows the ADT7516’s functions to be controlled 

from a PC via an easy-to-use interface operating under Windows 

XP, Windows 2000, or higher. The contents of the device’s 

internal registers can be easily read or altered through a user 

friendly interface, while the Visual Display dialog box gives a 

graphical display of temperature and voltage and allows the 

overtemperature limit to be altered using a slider control. 

INSTALLING THE SOFTWARE 

To install the software, insert the CD. Click Start > Run, and 

enter X:ADT7516Eval.exe, where X is the letter of your CD 

drive, and then click OK. 

Alternatively, run Windows Explorer or My Computer, select 

the CD drive, and double-click the ADT7516 v2.0.2.exe icon. 

The installer extracts the files needed to install the software  

and starts the InstallShield® Wizard. 
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Figure 1. InstallShield Wizard Startup Screen 

Click Next > to continue the installation. Various installation 

options are available, depending on whether a version of the 

software is already installed. A license agreement appears if  

this is a completely new installation. Click Yes to accept the 

agreement and continue with the installation. 

If you want to install the software in the default folder shown, click 

Next >. Otherwise, click Browse and choose a different folder. 

Select the folder in which to install the program and click OK. 

You are given the option of a Typical, Compact, or Custom 

installation of the software. Select the desired option, then click 

Next >.  

If Custom is selected, a window appears allowing individual 

components to be installed. Uncheck any components you do not 

wish to install, and click Next >.  

If a Typical or Compact installation is selected, omit this  

step, and the Select Program Folder dialog box will appear 

immediately. This allows you to select the program folder to 

add program icons. Select the desired folder and click Next >. 

InstallShield now installs the program files to the selected 

folders. 

Click Finish to complete the installation. 

If an existing version of the software is found during installation, 

you may modify the existing installation by adding or removing 

components, repair the installation by replacing existing files 

with ones from the CD (useful if a file has been corrupted), or 

uninstall the entire software package. 

Select the desired option and click Next >. If Modify is selected, 

you may add or remove components. If Repair is selected, all of 

the installed files are replaced with new files from the CD.  

If Remove is selected, a prompt appears to confirm the complete 

removal of the software. Click OK to confirm removal of the 

software. During removal of the software, you may need to 

confirm removal of some files. 

These files may be used by other Analog Devices, Inc.’s software. 

If no other Analog Devices software is installed on the system,  

it is safe to delete the files. To remove all shared files without 

further prompting, check Don't display this message again 

before clicking Yes. 

Click Finish to complete the maintenance procedure. 
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USING THE SOFTWARE 

When using the software, first ensure that the evaluation board 

is connected to the USB port and the Power LED D1 is on.  

To start the software, click Start > All Programs > Analog 

Devices > ADT7516 Evaluation Software > ADT7516 

Evaluation Software. 

The software searches for the evaluation board and initializes it. 
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Figure 2. ADT7516 Found 

If the evaluation board is not found, the message in Figure 3 

appears. If this happens, check that the evaluation board is 

correctly connected, that D1 is lit, and then try again. 
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Figure 3. ADT7516 Not Found 
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Figure 4. Menu and Icon Bar 

At the top of the program window is a series of drop-down 

menus and menu icons that can be used to access the various 

functions of the software (see Figure 4 and the following list)  

or use the Settings menu to select these functions. 

Register Tree Icon: Displays a tree of the device registers. 

Configuration Icon: Allows the device to be configured.  

Graph Display Icon: Displays graphs of temperature and 

voltage. The View menu can also be used to select these 

functions. 

DAC Output Control Icon: Allows the DAC outputs to be 

adjusted. The Settings menu can also be used to select these 

functions. 

Interrupts and Limits Icon: Sets up interrupts and limits. 

Data Log Icon: Allows data to be logged and saved. The File 

menu can also be used. 

Multiple windows for the previous software functions can be 

open and active simultaneously. The Window menu shows 

which window is on top and allows any window to be brought 

to the front. 

Configuration 

Click the Configuration icon or use the Device menu to access 

the Configuration dialog box, which allows the ADT7517 to be 

set up. It consists of a set of four tabs that allow various functions 

of the device to be configured. 

http://www.analog.com/en/prod/0%2C2877%2CADT7517%2C00.html
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Figure 5. Device Options 

The Devices Options tab (see Figure 5) selects or 

enables/disables various options: 

• Monitoring 

• Power Down 

• Averaging 

• Interrupt 

• Active Low INT Polarity 

• SPI Interface 

Note that if the ADT7516 SPI interface is enabled, to switch 

back to I2C interface, it is necessary to exit the software, dis-

connect the board, and start again. 

The Pin AIN1 to Pin AIN3 are multiplexed and their operation 

can also be toggled here.  
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Figure 6. DAC Options 

The DAC Options tab (see Figure 6) selects the output range 

for each DAC (0 to VRef or 0 to 2 VRef). It allows the thermal 

voltage function of the device to be configured, where the 

ADT7516 operates as a temperature-to-voltage converter,  

with DAC A controlled by the on-chip temperature sensor,  

and DAC B controlled by the external temperature sensor.  

The temperature corresponding to 0 V output can be set by 

adjusting the analog offset for each channel, and the resolution 

for the thermal voltage function can be set to 8 bits or 10 bits. 
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Figure 7. LDAC Options 

The LDAC Options tab (see Figure 7) selects how the DACs are 

updated. They can be updated manually from the LDAC pin  

by pressing S1, when the MSBs are written to one of the DACs 

(three different options are available), or from the LDAC 

register. If the LDAC register is selected, the buttons on the 

right of the dialog box are active and clicking on one of them 

updates the corresponding DAC. 
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Figure 8. Reference Options 

The Reference tab (see Figure 8) selects the internal 2.28 V 

reference for DACs A and B and DACs C and D, or an external 

reference connected to P1. If an external reference voltage is 

used, its value should be specified in the box provided. This 

allows the DAC value to be scaled correctly. 

http://www.analog.com/en/prod/0%2C2877%2CADT7517%2C00.html
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Register Access

Click the Register Tree icon or use the View menu to select the 

Register Map Access window. 
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Figure 9. Register Map Access Window 

The Register Map Access dialog box (see Figure 9) allows the 

contents of individual registers to be viewed, and those registers 

that are read/write can have their contents changed. The window 

on the left shows the registers arranged by function as a tree. 

The branches can be expanded or contracted by double clicking 

the desired labels or the + or − symbols. 

The name of the register, its address, and its contents in hexa-

decimal, decimal, and binary are displayed. The register contents 

can be read by clicking Read, or set to continuous reading by 

checking the Continuous Read box. Those registers that are 

read/write can have their contents changed by clicking on 

individual bits of the binary display to toggle them, or by 

entering a decimal or hexadecimal value in the Read and Write 

section and clicking Write. 

Graphing 

Click the Graph Display icon or use the View menu to access 

the Graphing window (see Figure 10). 

0
4

8
2

7
-0

1
7

 

Figure 10. Graphing Window 

The Graphing dialog box (see Figure 10) allows the internal or 

external temperature, VDD, the DAC outputs, or Pin AIN1 to 

Pin AIN4 to be displayed as a rolling graph. Measurement 

limits can also be displayed. To view the graphic data in more  

or less detail, move the arrow pointers on the X- and Y-axes to 

zoom in or zoom out. 

DAC Control 

Click the DAC Output Control icon or use the Device menu to 

access the DAC Control window (see Figure 11). 

0
4

8
2

7
-0

1
8

 

Figure 11. DAC Control Dialog Box 

The DAC Control dialog box allows the individual DACs to be 

controlled manually without having to manipulate the DAC 

registers directly. A DAC can be selected and controlled using 

the check boxes and the slider. 
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Setting Interrupts and Limits 

Click the Interrupts and Limits icon or use the Device menu 

to access the Interrupt Settings dialog box (see Figure 12). 
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Figure 12. Interrupt Settings Dialog Box 

The nine interrupt sources are shown on the left-hand side of 

the window. When an interrupt is asserted, corresponding 

green status indicator turns red. Interrupts can be masked by 

checking the box next to the name of the interrupt source. High 

and low limits for the measured parameters can be set using the 

slider controls. 

Data Logging 

Click the Data Log icon or use the File menu to access the 

Logging/Save/Recall dialog box. 
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Figure 13. Data/Save/Recall Dialog Box 

The Logging/Save/Recall dialog box (see Figure 13) allows you 

to set which inputs are logged and the log interval. Once this is 

set up, the window in Figure 14 appears. 
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Figure 14. Opening or Creating a Log File 

You can use the Open window (see Figure 14) to open an 

existing log file or create a new log file by typing in a new file 

name. After selecting an existing file or typing a new file name, 

click Open to begin data logging, and then click Start Logging. 

To stop data logging, click Stop Logging. Note that the Graphing 

function must be running during data logging or the data does 

not change. 
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EVALUATION BOARD SCHEMATICS AND ARTWORK 

04827-001

 

Figure 15. ADT7516 Evaluation Board Schematic Part 1 
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04827-002

 

Figure 16. ADT7516 Evaluation Board Schematic Part 2  
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04827-003

 

Figure 17. ADT7516 Evaluation Board Schematic Part 3 
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04827-004

 

Figure 18. ADT7516 Evaluation Board Schematic Part 4 
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Figure 19. ADT7516 Evaluation Board Silkscreen 
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Figure 20. ADT7516 Evaluation Board PCB Layout (Component Side) 
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Figure 21. ADT7516 Evaluation Board PCB Layout (Solder Side) 
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ORDERING INFORMATION 
BILL OF MATERIALS 

Table 2. Parts List for EVAL-ADT7516EB Evaluation Board 

Name  Part Type  Value  Tolerance Part Description  

AIN1 to AIN3 TESTPOINT    Red testpoint  

C1, C2 CAP  22 pF   50 V NPO SMD ceramic capacitor  

C3  CAP+  47 μF   10 V SMD tantalum capacitor  

C4  CAP+  2.2 μF   10 V SMD tantalum capacitor  

C5 to C10, C12 to C16, C18, C19, C21 to C30 CAP  0.1 μF   16 V X7R multilayer ceramic capacitor  

C11  CAP+  10 μF   10 V SMD tantalum capacitor  

C17  CAP  1 μF   10 V DC Y5V ceramic capacitor  

C20  CAP+  10 μF   10 V SMD tantalum capacitor  

D1  LED    Light emitting diode green 

D2  LED    Light emitting diode red  

J1  USB-MINI-B    USB Mini-B connector (usb-otg)  

J2  CON\POWER    2 pin terminal block (5 mm pitch)  

P1  SMB    50 Ω SMB jack  

P2  SMB    50 Ω SMB jack  

Q1  2N3906    PNP bipolar transistor  

Q2  BC807-40LT1    Low power bipolar transistor  

R1  RES  0R  1%  SMD resistor  

R2, R4, R5, R11, R12, R15, R17, R21 RES  10 kΩ 1%  SMD resistor  

R3, R6 RES  100 kΩ  1%  SMD resistor  

R7, R20 RES  1 kΩ 1%  SMD resistor  

R13  RES  1.2 kΩ  1%  SMD resistor  

R14  RES  3.9 kΩ 1%  SMD resistor  

S1  SW-PUSH-SMD    SMD push button switch (sealed 6 mm x 6 mm)  

T1 to T7, T9 to T11 TESTPOINT    Black testpoint  

T8, T12 to T15 TESTPOINT    Red testpoint 

U1  CY7C68013-CSP    USB Microcontroller  

U2  ADP3303-3.3    Precision low dropout voltage regulator  

U3  24LC64    64 kΩ I2C serial EEPROM  

U4  ADG774    Low voltage quad SPDT switch  

U5  TMP36    Low voltage temperature sensor  

U6, U7 ADG604    CMOS 4-channel multiplexer  

U8  LED_BAR_ARRAY   LED bar array  

U9  ADT7516    Four channel ADC and quad voltage output DAC  

U10, U11, U13 ADG821    Dual SPST switches  

U12  LM3914    IC driver dot bar display 20PLCC 

U14  TSL250R    Sensor, L/volts TSL250R TAOS 

VOUTA to VOUTD TESTPOINT    Red testpoint 

Y1  XTAL-CM309S  24 MHz  Plastic SMD crystal  
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ORDERING GUIDE ESD CAUTION 
Model Description 

EVAL-ADT7516EB Evaluation Board 
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NOTES 

 

©2007 Analog Devices, Inc. All rights reserved. Trademarks and  
 registered trademarks are the property of their respective owners. 
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