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Preface

INTRODUCTION

This chapter contains general information that will be useful to know before using the 

Thermal/Linear Intelligent Sensor PICtail™ Plus Daughter Board. Items discussed in 

this chapter include:

• Document Layout

• Conventions Used in this Guide

• Warranty Registration

• Recommended Reading

• The Microchip Web Site

• Development Systems Customer Change Notification Service

• Customer Support

• Document Revision History

DOCUMENT LAYOUT

This document describes how to use the Thermal/Linear Intelligent Sensor PICtail™ 

Plus Daughter Board to provide the signal conditioning circuits necessary to interface 

thermal and linear sensor signals to a dsPIC® Digital Signal Controller (DSC) or a 

PIC24H Microcontroller (MCU). The manual layout is as follows: 

• Chapter 1. “Introduction” – This chapter introduces the Thermal/Linear 

Intelligent Sensor PICtail™ Plus Daughter Board (also referred to as the Daughter 

Board throughout this document) and provides an overview of the features.

• Chapter 2. “Hardware” – This chapter identifies the major hardware components 

of the Daughter Board and provides a functional overview.

• Chapter 3. “Thermal Interface Demonstration” – This chapter describes a 

simple program that demonstrates how to use the Daughter Board to capture and 

process signals from a common type of temperature sensor: a K-type 

thermocouple.

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 

documentation are constantly evolving to meet customer needs, so some actual dialogs 

and/or tool descriptions may differ from those in this document. Please refer to our web site 

(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 

page, in front of the page number. The numbering convention for the DS number is 

“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the 

document.

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help. 

Select the Help menu, and then Topics to open a list of available on-line help files.
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• Chapter 4. “Linear Interface Demonstration” – This chapter describes a simple 

program that demonstrates how to use the Daughter Board to capture and 

process signals from any generic linear sensor through the Linear Sensor 

Interface.

• Appendix A. “Schematics and Layout” – This appendix provides detailed 

circuit schematics and board layout diagrams of the Daughter Board.
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CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS

Description Represents Examples

Arial font:

Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer

Quotes A field name in a window or 

dialog

“Save project before build”

Underlined, italic text with 

right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK

A tab Click the Power tab

N‘Rnnnn A number in verilog format, 

where N is the total number of 

digits, R is the radix and n is a 

digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>

Courier New font:

Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be 

any valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 

character: { | }

Choice of mutually exclusive 

arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 

user

void main (void)
{ ...
}
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WARRANTY REGISTRATION

Please complete the enclosed Warranty Registration Card and mail it promptly. 

Sending in the Warranty Registration Card entitles users to receive new product 

updates. Interim software releases are available at the Microchip web site.

RECOMMENDED READING

This user's guide describes how to use Thermal/Linear Intelligent Sensor PICtail™ 

Plus Daughter Board. Other useful documents are listed below. The following 

Microchip documents are available and recommended as supplemental reference 

resources.

• “dsPIC33FJ12GP201/202 Data Sheet” (DS70264)

• “MCP601/1R/2/3/4 2.7V to 6.0V Single Supply CMOS Op Amps” (DS21314)

• “MCP616/7/8/9 2.3V to 5.5V Micropower Bi-CMOS Op Amps” (DS21613)

• “TC1047/TC1047A Precision Temperature-to-Voltage Converter” (DS21498)

• “Explorer 16 Development Board User’s Guide” (DS51589)

• “16-bit 28-pin Starter Development Board User’s Guide” (DS51656)

Readme Files

For the latest information on using other tools, read the tool-specific Readme files in 

the Readmes subdirectory of the MPLAB IDE installation directory. The Readme files 

contain update information and known issues that may not be included in this user’s 

guide.
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THE MICROCHIP WEB SITE 

Microchip provides online support via our web site at www.microchip.com. This web 

site is used as a means to make files and information easily available to customers. 

Accessible by using your favorite Internet browser, the web site contains the following 

information:

• Product Support – Data sheets and errata, application notes and sample 

programs, design resources, user’s guides and hardware support documents, 

latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical 

support requests, online discussion groups, Microchip consultant program 

member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip 

press releases, listing of seminars and events, listings of Microchip sales offices, 

distributors and factory representatives

DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE

Microchip’s customer notification service helps keep customers current on Microchip 

products. Subscribers will receive e-mail notification whenever there are changes, 

updates, revisions or errata related to a specified product family or development tool of 

interest.

To register, access the Microchip web site at www.microchip.com, click on Customer 

Change Notification and follow the registration instructions.

The Development Systems product group categories are:

• Compilers – The latest information on Microchip C compilers and other language 

tools. These include the MPLAB C18 and MPLAB C30 C compilers; MPASM™ 

and MPLAB ASM30 assemblers; MPLINK™ and MPLAB LINK30 object linkers; 

and MPLIB™ and MPLAB LIB30 object librarians.

• Emulators – The latest information on Microchip in-circuit emulators.This 

includes the MPLAB ICE 2000, MPLAB ICE 4000, and MPLAB REAL ICE™

• In-Circuit Debuggers – The latest information on the Microchip in-circuit 

debugger, MPLAB ICD 2.

• MPLAB® IDE – The latest information on Microchip MPLAB IDE, the Windows® 

Integrated Development Environment for development systems tools. This list is 

focused on the MPLAB IDE, MPLAB SIM simulator, MPLAB IDE Project Manager 

and general editing and debugging features.

• Programmers – The latest information on Microchip programmers. These include 

the MPLAB PM3 and PRO MATE II device programmers and the PICSTART® 

Plus and PICkit™ 1 development programmers.
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CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative

• Local Sales Office

• Field Application Engineer (FAE)

• Technical Support

Customers should contact their distributor, representative or field application engineer 

(FAE) for support. Local sales offices are also available to help customers. A listing of 

sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://support.microchip.com

DOCUMENT REVISION HISTORY

Revision A (December 2008)

This is the initial release of this document.
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Chapter 1.  Introduction

Thank you for purchasing Microchip Technology's Thermal/Linear Intelligent Sensor 

PICtail™ Plus Daughter Board. This board provides the signal conditioning circuits 

necessary to interface thermal and linear sensor signals to a dsPIC® Digital Signal 

Controller (DSC) or a PIC24H microcontroller (MCU). 

The Thermal/Linear Intelligent Sensor PICtail Plus Daughter Board is used with either 

the Explorer 16 Development Board or the 16-bit 28-pin Starter Development Board to 

demonstrate the acquisition, analog-to-digital conversion (dsPIC DSC or PIC24H 

devices) and signal processing of typical sensor signals using the architectural and 

peripheral features of dsPIC DSC devices.

This chapter introduces the Thermal/Linear Intelligent Sensor PICtail Plus Daughter 

Board (simplified as Daughter Board throughout this document) and provides an 

overview of the features. Topics covered include:

• Overview

• Board Setup

1.1 OVERVIEW

The Daughter Board fits into the expansion slot on the Explorer 16 Development Board 

and interfaces between an external sensor and the dsPIC33F or PIC24H device on the 

Explorer 16 Development Board. The Daughter Board is intended to support the 

development of intelligent sensor processing applications using Microchip's 16-bit DSC 

and MCU device families.

Alternately, the Daughter Board may be plugged into the pin header on the 16-bit 

28-pin Starter Development Board using connector J2 (refer to Figure 2-1 in 

Chapter 2. “Hardware” for the location of this connector).

The differential output signals from the thermocouple (not provided with the Daughter 

Board) are amplified, passed through an anti-aliasing filter and routed to the 

Analog-to-Digital Converter (ADC) module on the dsPIC33F or PIC24H device for 

software processing. A TC1047A temperature sensor IC is also provided on the board. 

The output of this temperature sensor is passed through another anti-aliasing filter and 

routed to the ADC.

The Daughter Board also provides a generic linear signal interface to which any 

single-ended sensor output (or even an artificially synthesized signal) can be supplied. 

Just like the thermocouple and TC1047A output signals, this linear signal is conditioned 

using an anti-aliasing filter, but it is also level-shifted in order to allow bipolar sensor 

signals to be sampled by the unipolar ADC on the dsPIC33F or PIC24H device.

The Explorer 16 Development Board (or 16-bit 28-pin Starter Development Board) 

supplies power to the Daughter Board.

The Daughter Board is shown in Figure 1-1. This document reflects the usage of the 

Daughter Board with the Explorer 16 Development Board; however, the 16-bit 28-pin 

Starter Development Board has similar set up requirements. 
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FIGURE 1-1: THERMAL/LINEAR INTELLIGENT SENSOR PICtail™ PLUS DAUGHTER BOARD

1.2 BOARD SETUP

Figure 1-2 shows a photograph of the Daughter Board plugged into an Explorer 16 

Development Board. A K-type thermocouple is connected to the Daughter Board. For 

demonstration purposes, a portable function generator is also shown connected to the 

Daughter Board. In a real application development environment, this may be 

substituted for any other linear sensor signal.

A 9V power supply and the MPLAB® REAL ICE™ in-circuit emulator are plugged into 

the Explorer 16 Development Board. MPLAB REAL ICE in-circuit emulator is required 

to operate the demonstration programs provided with the board package; however, for 

actual usage an MPLAB ICD 2 or any other programmer/debugger may be used. The 

two demonstration programs show the capture and processing of signals obtained from 

the thermocouple interface and from the generic linear signal interface, respectively.
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FIGURE 1-2: THERMAL/LINEAR INTELLIGENT SENSOR PICtail™ PLUS DAUGHTER BOARD 

SETUP
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Chapter 2.  Hardware

This chapter identifies the major hardware components of the Thermal/Linear 

Intelligent Sensor PICtail Plus Daughter Board and provides a functional overview. 

Topics covered include:

• Hardware Components

• Functional Overview

2.1 HARDWARE COMPONENTS

Figure 2-1 identifies the key hardware components of the Daughter Board. The 

numbered board components are described in Table 2-1.
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FIGURE 2-1: DAUGHTER BOARD HARDWARE COMPONENTS

TABLE 2-1: DAUGHTER BOARD COMPONENTS

1

2

3

4

5

6

7

11
8

9

10

12

13

Number Name Component Description

1 J4 Explorer 16 PICtail™ Plus connector

2 J2 16-bit 28-pin Starter Development Board connector

3 U2 Anti-aliasing low-pass filter for thermocouple signal

4 U3 Differential amplifier for thermocouple signal

5 U5 Anti-aliasing low-pass filter for linear signal

6 J5 Jumper for input offset calibration of differential amplifier

7 R38 Potentiometer for differential amplifier output offset adjustment

8 U6 Anti-aliasing low-pass filter for temperature sensor IC signal

9 JP2 Jumper to include or bypass level shifter

10 U7 Level shifter for linear signal

11 R30 Potentiometer for level shifter adjustment

12 J1 Thermocouple connector

13 J3 Linear signal connector
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2.1.1 Explorer 16 PICtail Plus Connector (J4)

The Daughter Board connects to the Explorer 16 Development Board using edge 

connector J3. The Daughter Board uses the following Explorer 16 signals:

• +3.3V power

• Ground

• dsPIC33F or PIC24H device ADC module inputs (3 inputs)

2.1.2 16-bit 28-pin Starter Development Board Connector (J2)

This connector allows the Daughter Board to be connected to Microchip's 16-bit 28-pin 

Starter Development Board. The Daughter Board uses the following Explorer 16 

signals:

• +3.3V power

• Ground

• dsPIC33F or PIC24H device ADC module inputs (3 inputs)

2.1.3 Anti-Aliasing Low-Pass Filter for Thermocouple Signal (U2)

The anti-aliasing low-pass filter uses the two op amps in the MCP617 dual op amp IC. 

The output of the differential amplifier uses an anti-aliasing low-pass 4th-order 

Sallen-Key structure to filter the signal and provide a cut-off frequency of 3300 Hz.

2.1.4 Differential Amplifier for Thermocouple Signal (U3)

The thermocouple differential amplifier uses three op amps in the MCP619 quad op 

amp IC. The fourth op amp buffers the reference voltage provided to the differential 

amplifier as well as the level shifter circuit. The output from a thermocouple is a pair of 

analog voltage signals. The differential amplifier converts this signal pair into a 

single-ended voltage signal for the on-chip ADC in the dsPIC33F or PIC24H device. 

The external resistors R5, R6, R7 and R8 have been selected to provide an amplifier 

gain of 249.

2.1.5 Anti-Aliasing Low-Pass Filter for Linear Signal (U5)

The anti-aliasing low-pass filter uses the two op amps in the MCP617 dual op amp IC. 

The output of the level shifter circuit uses an anti-aliasing low-pass 8th-order 

Sallen-Key structure to filter the signal and provide a cut-off frequency of 3300 Hz.

2.1.6 Jumper for Offset Calibration of Differential Amplifier (J5)

The jumper J5 can be used as a possible method of calibrating the output offset voltage 

of the differential amplifier. To do this, install the jumper and measure the output voltage 

at test point TP4.

2.1.7 Potentiometer for Differential Amplifier Output Offset 
Adjustment (R38)

The constant output offset voltage can be adjusted manually by the user by rotating the 

screw on potentiometer R38, either clockwise or counterclockwise. Rotating the 

potentiometer screw clockwise increases the offset, whereas rotating it in a 

counterclockwise direction decreases the offset. The offset can range from 0V to 1.65V.

2.1.8 Anti-Aliasing Low-Pass Filter for Temperature Sensor IC Signal 
(U6)

The anti-aliasing low-pass filter uses the two op amps in the MCP617 dual op amp IC. 

The output of the differential amplifier uses an anti-aliasing low-pass 4th-order 

Sallen-Key structure to filter the signal and provide a cut-off frequency of 3300 Hz.
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2.1.9 Jumper to Include or Bypass Level Shifter (JP2)

The jumper JP2 determines whether the level shifter circuit will be included in the linear 

signal chain or bypassed completely. To include the level shifter, install the jumper in 

the 1-2 position (indicated by the arrow marked adjacent to the jumper on the Daughter 

Board). To bypass the level shifter and supply the linear input signal directly to the 

anti-aliasing low-pass filter, install the jumper in the 2-3 position.

2.1.10 Level Shifter for Linear Signal (U7)

The level shifter circuit is implemented using the MCP602 dual op amp IC. Op amp A 

works in conjunction with the external components to provide the required level shift, 

and op amp B serves as a buffer.

2.1.11 Potentiometer for Level Shifter Adjustment (R30)

Users can manually adjust the level provided by the level shifter by rotating the screw 

on the potentiometer R30. The level of the signal mid-point can range from 0V to 3.3V, 

depending on the potentiometer adjustment. Rotating the potentiometer screw 

clockwise increases the signal level, whereas rotating it in a counterclockwise direction 

decreases the signal level.

2.1.12 Thermocouple Connector (J1)

The Daughter Board contains a standard K-type thermocouple connector labeled J1. 

A thermocouple with the appropriate receptacle can be inserted directly into the 

connector. 

2.1.13 Linear Signal Connector (J3)

Connector J3 contains a pair of test points, which allow users to supply an external 

linear signal, either from a real sensor or generated artificially for development 

purposes.
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2.2 FUNCTIONAL OVERVIEW

The block diagram shown in Figure 2-2 illustrates the operation of the Daughter Board.

FIGURE 2-2: DAUGHTER BOARD BLOCK DIAGRAM

2.2.1 Thermocouple Signal Conditioning

The incoming signals come from the differential voltage outputs of a thermocouple (not 

included with the Daughter Board) plugged into thermocouple connector J1. These 

signals are amplified by a differential amplifier implemented using three operational 

amplifiers in an MCP619 quad op amp device. The external components of the 

differential amplifier have been selected to provide amplification by a factor of 249.

The fourth op amp in this device is used to provide a constant 1.65V voltage reference 

to the differential amplifier as well as to the level shifter circuit (described in 

Section 2.2.3 “Linear Sensor Signal Conditioning”). Depending on application 

requirements, the user can adjust the output offset of the differential amplifier by 

adjusting the potentiometer R38.

Some users may choose to perform input offset calibration of the differential amplifier. 

This can be accomplished by mounting a capacitor (C3) and installing a jumper on J5.

The single-ended output of the differential amplifier is routed to an MCP617 dual op 

amp device. The two op amps in this device are configured to serve as an anti-aliasing 

low-pass filter, in a 4th-order Sallen-Key structure. This limits the bandwidth of the input 

signal to approximately 3300 Hz. The output of this filter is routed to pin 69 of the PICtail 

Plus interface header J4 on the Explorer 16 Development Board, for analog-to-digital 

conversion and further processing by a dsPIC33F or PIC24H device. For a 

dsPIC33FJ12GP202 Plug-in Module (PIM), this pin is routed to the ADC input AN9 of 

the dsPIC33FJ12GP202 device.

2.2.2 Temperature Sensor IC Signal Conditioning

A TC1047A temperature sensor IC is provided on the Daughter Board. The output 

voltage of the temperature sensor IC has an amplitude of 10 mV per degree Celsius 

and a constant output voltage offset of 500 mV. This signal is primarily intended to ease 

the implementation of cold junction compensation in the application software by 

providing an approximate reference for the temperature of the Daughter Board itself. 

However, the TC1047A can also be used independently as an alternative temperature 

sensor. 
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The single-ended output of the TC1047A device is routed to an MCP617 dual op amp 

device. The two op amps in this device are configured to serve as an anti-aliasing 

low-pass filter, identical to the filter used in the thermocouple signal conditioning circuit. 

The output of this filter is routed to pin 70 of the PICtail Plus interface header J4 on the 

Explorer 16 Development Board, for analog-to-digital conversion and further 

processing by a dsPIC33F or PIC24H device. For a dsPIC33FJ12GP202 PIM, this pin 

is routed to the ADC input AN8 of the dsPIC33FJ12GP202 device.

2.2.3 Linear Sensor Signal Conditioning

The Daughter Board also contains a generic signal interface for any linear sensor 

signals with a maximum peak-to-peak voltage of 3.3V. The signal can come from a 

sensor located external to the board; alternately, it can simply be an artificially 

generated signal (e.g., from a function generator) used to model a particular sensor 

output during application development. Whatever the source, the signal can be 

supplied to pins 1 and 2 on connector J3, or only supplied to pin 1 with pin 2 grounded.

Often, the signal may be bipolar, which means it can have values less than 0V. Since 

the signal is required to be sampled by the on-chip ADC on a dsPIC33F or PIC24H 

device, its level must be shifted up such that the signal becomes unipolar, so that it 

stays above 0V at all times. This functionality, illustrated in Figure 2-3, is provided by a 

level shifter circuit on the Daughter Board. The level shifter is implemented using one 

op amp of an MCP602 dual op amp device. This level shifter circuit is essentially an 

inverting differential amplifier, with the non-inverting input derived from the positive 

voltage rail. The level of the signal midpoint can be adjusted (between 0V and 3.3V) 

using potentiometer R30, and the level shifter circuit can be included or bypassed by 

installing a jumper in the 1-2 position (indicated on the Daughter Board by an arrow 

beside the jumper) or the 2-3 position, respectively, of jumper JP2.

The other op amp in the MCP602 acts as a buffer. A buffer is essentially a non-inverting 

amplifier with unity gain, and prevents the output circuit from loading the input circuit 

and distorting the signals as a result.

The output of the buffer is provided to an anti-aliasing low-pass filter, implemented as 

an 8th-order Sallen-Key structure. The output of this filter is routed to pin 38 of the 

PICtail Plus interface header J4 on the Explorer 16 Development Board, for 

analog-to-digital conversion and further processing by a dsPIC33F or PIC24H device. 

For a dsPIC33FJ12GP202 PIM, this pin is routed to the ADC input AN7 of the 

dsPIC33FJ12GP202 device.

FIGURE 2-3: LEVEL SHIFTER OPERATION
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Chapter 3.  Thermal Interface Demonstration

This chapter describes a simple program that demonstrates how to use the Daughter 

Board to capture and process signals from a common type of temperature sensor: a 

K-type thermocouple. Topics covered include:

• Overview

• Hardware Setup

• Software Setup

• Running The Demonstration

3.1 OVERVIEW

The CD that accompanies the Daughter Board contains a thermal interface 

demonstration application. All files pertaining to this demonstration are located in the 

following folder on the CD: demo\Thermal Interface Demo.

As shown in Figure 3-1, this sample application uses the Daughter Board to perform 

signal conditioning on the output of a K-type thermocouple, and uses the on-chip ADC 

of the dsPIC33FJ12GP202 device to convert the signal to a digital form.

The TC1047A temperature sensor IC on the Daughter Board is utilized to perform cold 

junction compensation in the application software. In addition, the application software 

uses the Digital Signal Processing (DSP) features of the dsPIC33F architecture to 

perform averaging and linearization of the converted sensor output samples. 

Finally, the application converts the linearized voltage to its corresponding temperature 

equivalent, and displays this temperature in the Watch window and the Data Monitor 

and Control Interface (DMCI) using the MPLAB REAL ICE in-circuit emulator.

FIGURE 3-1: THERMAL INTERFACE DEMONSTRATION

AN9 
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Block 
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dsPIC33FJ12GP202

in-circuit emulator) 
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The demonstration program consists of the following basic software elements:

• ADC Driver

• Averaging and Cold Junction Compensation Function

• Linearization

3.1.1 ADC Driver

The ADC driver reads the incoming signals from the thermocouple and the temperature 

sensor IC (after signal conditioning by the differential amplifier and anti-aliasing filter) 

on the 12-bit ADC channels AN9 and AN8, respectively. The source code file, 

adcDrv1.c, contains the ADC initialization function initAdc1() as well as the ADC 

Interrupt Service Routine (ISR).

The thermocouple signal samples are stored in a 128-sample array named TC_Buff 

and the TC1047A signal samples are stored in a 128-sample array named CJC_Buff.

3.1.2 Averaging and Cold Junction Compensation Function

The thermocouple samples stored in TC_Buff are added with the running sum being 

accumulated in accumulator A. Similarly, accumulator B is used to add all of the 

TC1047A samples stored in CJC_Buff. This accumulation is performed very efficiently 

using a DO loop instruction.

Note that the voltage generated by the thermocouple does not compensate for the 

temperature of the cold junction (which refers to the ends of the thermocouple that are 

plugged into the connector on the board). The temperature of the cold junction is 

typically very close to the temperature of the board surface; therefore, the TC1047A 

temperature sensor IC samples are used as the cold junction reference. Since 

accumulators A and B now contain the running sum of the thermocouple and TC1047A 

respectively, the two accumulators are added to each other using the 32-bit 

accumulator-to-accumulator ADD instruction. 

Finally, the SAC instruction is utilized to store the result back into the variable 

AverageVoltage. Moreover, as part of the accumulator write-back, the data is shifted 

right by 7 bits, resulting in a division by 128. Therefore, the variable AverageVoltage 

now contains the average cold-junction-compensated sensor voltage output.

3.1.3 Linearization

For many temperature sensors, including thermocouples, the sensor output does not 

have an exact linear relationship to the physical quantity (temperature, in this case) 

being measured. Therefore, the output voltage must be linearized. A common method 

of linearizing sensor output voltages is to compute a standard polynomial. This 

demonstration utilizes a standardized polynomial for K-type thermocouples, as shown 

in Equation 3-1.

EQUATION 3-1: K-TYPE THERMOCOUPLE POLYNOMIAL

Since the voltages and higher-order coefficients are small in magnitude in this 

application, the demonstration only computes a 2nd-order polynomial and neglects the 

higher-order coefficients. This operation is performed by the Linearize() function in 

the Linearize.s source file. Dual-operand DSP instructions such as MAC and MPY 

have been utilized to compute this polynomial in only seven instruction cycles, and the 

linearized result is stored in the variable LinearOut.

Finally, the main application converts the linearized voltage into a floating point variable 

named Temperature, which provides the absolute temperature of the thermocouple 

junction in degrees Celsius.

VO 25.132785( ) VIN 60.883423( ) VIN
2

...+⋅–⋅=
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3.2 HARDWARE SETUP

To use this demonstration, you will need the following hardware:

• Thermal/Linear Intelligent Sensor PICtail™ Plus Daughter Board

• Explorer 16 Development Board

• dsPIC33FJ12GP202 Plug-In Module (MA330015)

• PC running the following software: 

- MPLAB IDE software, version 8.10 or higher

- MPLAB C30 compiler, version 3.01 or higher 

• MPLAB REAL ICE in-circuit emulator

• Any standard K-type thermocouple with a connector

Before programming or running the demonstration application, make the following 

hardware connections:

1. Plug in a K-type thermocouple into the J1 socket of the Daughter Board.

2. Insert the Daughter Board into the J5 socket of the Explorer 16 Development 

Board.

3. On the Explorer 16 Development Board, insert a dsPIC33FJ12GP202 PIM.

4. On the Explorer 16 Development Board, make sure that switch S2 is set to the 

PIM position and the jumper J7 is set to the PIC24 position.

5. Connect the Explorer 16 Development Board to the MPLAB REAL ICE in-circuit 

emulator using an RJ-11 cable, and connect the MPLAB REAL ICE in-circuit 

emulator to the PC using a USB cable. 

6. Connect a 9V power supply to the Explorer 16 Development Board.

3.3 SOFTWARE SETUP

To program the demonstration application into the dsPIC33FJ12GP202 device and set 

up the required software tools, perform the following steps:

1. Open the demo\Thermal Interface Demo\Thermal_Demo.mcw 

workspace in MPLAB IDE.

2. Select Project>Build All to compile and link the demonstration application 

program. Make sure the code compiles and links with no errors.

3. If the MPLAB REAL ICE in-circuit emulator is not enabled, enable it by selecting 

Debugger>MPLAB REAL ICE. Make sure the PC connects to the MPLAB REAL 

ICE in-circuit emulator and the dsPIC33FJ12GP202 device is detected.

4. If the DMCI window is not open, open it by selecting Tools>Data Monitor and 

Control Interface. The window should open with the Data Capture: LinearOut 

graph highlighted in the Dynamic Data View tab (and the corresponding box 

checked), as shown in Figure 3-2. 

If you do not see this graph, click the Load Profile button at the bottom of the 

DMCI window, browse to the demo\Thermal Interface Demo folder, and 

open the Thermal_Demo.dmci file. This will load the characteristics and data 

setup and format information for the graph. 
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FIGURE 3-2: DMCI DYNAMIC DATA VIEW

5.  If the Watch window is not open, open it by selecting View>Watch. You should 

see the Temperature and LinearOut variables displayed with the blue and 

brown diamonds visible in the Update column, as shown in Figure 3-3. If either 

of the two diamonds is dimmed, you will need to right click and enable Runtime 

Watch and Runtime Capture for the LinearOut variable.
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FIGURE 3-3: WATCH WINDOW CONFIGURATION

6. Select Debugger>Program to program the demonstration application into the 

dsPIC33FJ12GP202 device.

3.4 RUNNING THE DEMONSTRATION

To run the demonstration and observe the results, perform the following steps:

1. While in MPLAB IDE, select Debugger>Reset to reset MPLAB REAL ICE 

in-circuit emulator.

2. Select Debugger>Run to run the demonstration program. 

3. Allow the program to run for a few seconds, and then halt program execution by 

selecting Debugger>Halt.

4. You should see the temperature value displayed in the Watch window variable 

Temperature. Note that a temperature close to 25 degrees Celsius is displayed 

if the thermocouple junction is kept at room temperature.

5. If you see a significantly smaller or larger temperature value displayed, adjust the 

R38 potentiometer screw using a small screwdriver and repeat steps 1-4 until 

you see a temperature close to room temperature (i.e., 25ºC).

6. Repeat steps 1-3, but this time with the thermocouple junction either dipped in a 

hot liquid, touching a warm surface, or simply held tightly between your fingers. 

As long as the program is running, you should see the LinearOut variable 

value in the Watch window continuously increasing and decreasing with 

temperature. You should also see the corresponding graph in the DMCI window 

rising and falling with temperature. On halting the program execution, you should 

see the current temperature displayed in the Watch window.
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NOTES:
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Chapter 4.  Linear Interface Demonstration

This chapter describes a simple program that demonstrates how to use the Daughter 

Board to capture and process signals from any generic linear sensor through the linear 

sensor interface. 

4.1 DEMONSTRATION OVERVIEW

The CD that accompanies the Daughter Board contains a linear interface demonstra-

tion application. All files pertaining to this demonstration are located in the following 

folder on the CD: demo\Linear Interface Demo.

As shown in Figure 4-1, this sample application uses the Daughter Board to perform 

signal conditioning on an incoming 3200 Hz sinusoidal signal, and uses the on-chip 

ADC of the dsPIC33FJ12GP202 device to convert the signal to a digital form. A 

1700 Hz noise source is artificially added to the sampled signal in software, thereby 

modeling the effect of narrowband noise on a sampled sensor signal. 

In addition, the application software uses the DSP features of the dsPIC33F architec-

ture to filter out the 1700 Hz narrowband noise using a highly selective notch filter. The 

filtering is performed using the Finite Impulse Response (FIR) filtering function from the 

DSP library, which is included with the MPLAB C30 compiler.

The noise-corrupted input signal (filter input) and the noise-free output signal (filter 

output) are plotted on the Data Monitor and Control Interface (DMCI) using the MPLAB 

REAL ICE in-circuit emulator.

FIGURE 4-1: LINEAR INTERFACE DEMONSTRATION

The demonstration program consists of the following basic software elements:

• ADC Driver

• Notch Filter

AN7 

Data Monitor and Control Interface 

(MPLAB® REAL ICE™

dsPIC33FJ12GP202

Conditioned 3200 Hz 
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4.1.1 ADC Driver

The ADC driver reads the incoming signals from the linear interface (after signal 

conditioning by the level shifter and anti-aliasing filter), on the 12-bit ADC channel AN7. 

The source code file, adcDrv1.c, contains the ADC initialization function 

initAdc1() as well as the ADC ISR.

Noise samples from the constant table NoiseSamples are added to successive input 

samples, and the composite sample is then stored in a variable named 

SignalNoiseIn.

4.1.2 Notch Filter

The Notch.s file contains the coefficients and other parameters of a 63-tap FIR filter 

designed using the dsPIC DSC Filter Design tool. This filter has been designed to sup-

press narrowband (single-tone) noise at 1700 Hz while not attenuating the desired 

3200 Hz signal. The filtered output sample is stored in a variable named SignalOut.

The actual filtering operation is performed using a pre-compiled function named FIR() 

from the DSP library in the MPLAB C30 compiler. The DMCI utility in MPLAB REAL ICE 

in-circuit emulator can be used to observe the filter input and output samples during run 

time.

4.2 DEMONSTRATION HARDWARE SETUP

To use this demonstration, you will need the following hardware:

• Thermal/Linear Intelligent Sensor PICtail Plus Daughter Board

• Explorer 16 Development Board

• dsPIC33FJ12GP202 Plug-In Module (MA330015)

• PC running the following software: 

- MPLAB IDE software, version 8.10 or higher

- MPLAB C30 compiler, version 3.01 or higher 

• MPLAB REAL ICE in-circuit emulator

• Any signal source such as a function generator that can generate a bipolar sinu-
soidal signal with its mid-point at 0V. For example, a Model 3001 Portable Audio 
Generator from BK Precision was used for testing the linear interface. The signal 
should be sufficiently attenuated (e.g., -20 dB) so as not to cause signal clipping 
or saturation.

Before programming or running the demonstration application, make the following 

hardware connections:

1. Connect the signal from the function generator (or other signal source) between 

the positive and negative test points on the Linear Signal Connector J3 of the 

Daughter Board.

2. Set up the function generator to generate a 3200 Hz sinusoidal signal. Adjust the 

amplitude as needed.

3. On the Daughter Board, make sure the JP2 jumper is set to the 1-2 position (i.e., 

include the level shifter circuit in the signal path). Pin 1 of the jumper is indicated 

by an arrow adjacent to the pin.

4. Insert the Daughter Board into the J5 socket of the Explorer 16 Development 

Board.

5. On the Explorer 16 Development Board, insert a dsPIC33FJ12GP202 PIM.

6. On the Explorer 16 Development Board, make sure the switch S2 is set to the 

PIM position and the jumper J7 is set to the PIC24 position.

7. Connect the Explorer 16 Development Board to the MPLAB REAL ICE in-circuit 

emulator using an RJ-11 cable, and connect the MPLAB REAL ICE in-circuit 

emulator to the PC using a USB cable. 

8. Connect a 9V power supply to the Explorer 16 Development Board.
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4.3 DEMONSTRATION SOFTWARE SETUP

To program the demonstration application into the dsPIC33FJ12GP202 device and set 

up the required software tools, perform the following steps:

1. Open the demo\Linear Interface Demo\Linear_Demo.mcw workspace 

in MPLAB IDE.

2. Select Project>Build All to compile and link the demonstration application 

program. Make sure the code compiles and links with no errors.

3. If the MPLAB REAL ICE in-circuit emulator is not enabled, enable it by selecting 

Debugger>MPLAB REAL ICE. Make sure the PC connects to the MPLAB REAL 

ICE in-circuit emulator and that the dsPIC33FJ12GP202 device is detected.

4. If the DMCI window is not open, open it by selecting Tools>Data Monitor and 

Control Interface. This should open the DMCI window with the Data Capture: 

SignalNoiseIn and Data Capture: SignalOut graphs highlighted (and the 

corresponding boxes checked) in the Dynamic Data View tab. 

If you do not see this graph, click the Load Profile button at the bottom of the 

DMCI window, browse to the demo\Linear Interface Demo folder, and 

open the Linear_Demo.dmci file. This will load the characteristics and data 

setup and format information for the graph. 

5. If the Watch window is not open, open it by selecting View>Watch. You should 

see the SignalNoiseIn and SignalOut variables displayed with the 

corresponding blue diamonds visible in the Update column, as shown in 

Figure 4-2. If either of the two blue diamonds is dimmed, you will need to right 

click and enable Runtime Capture for that particular variable.

FIGURE 4-2: WATCH WINDOW CONFIGURATION

6. Select Debugger>Program to program the demonstration application into the 

dsPIC33FJ12GP202 device.
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4.4 RUNNING THE DEMONSTRATION

To operate the demonstration and observe the results, perform the following steps:

1. While in MPLAB IDE, select Debugger>Reset to reset MPLAB REAL ICE 

in-circuit emulator.

2. Select Debugger>Run to run the demonstration program. 

3. Allow the program to run for a few seconds, and then halt program execution by 

selecting Debugger>Halt. 

You should see the input and output signal sample values plotted on the two 

graphs in the DMCI window. The plotting with stop after the DMCI's internal 

8000-sample data buffer becomes full. However, due to the large number of data 

points, the graph is not easy to analyze at this point. Therefore, the number of 

data points needs to be reduced using steps 4 through 6.

4. Right click the SignalNoiseIn plot in the DMCI window and select Extended Func-

tions>Customization, as shown in Figure 4-3.

FIGURE 4-3: DMCI EXTENDED FUNCTIONS
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5. In the Customization dialog box, choose the Selected radio button. Then, from 

the list of data points, select the first 200 points as shown in Figure 4-4.

FIGURE 4-4: DMCI DATA CAPTURE CUSTOMIZATION

6. Repeat steps 4 and 5 for the SignalOut graph.

Now that only 200 signal samples are displayed on the plots, it should be appar-

ent that the SignalNoiseIn signal is a combination of two sinusoidal frequency 

components as expected: the incoming 3200 Hz signal and the 1700 Hz noise 

added in software. The SignalOut signal should resemble a relatively pure 

3200 Hz sinusoidal signal. The expected appearance of the graphs is shown in 

Figure 4-5.
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FIGURE 4-5: FILTER INPUT AND OUTPUT SIGNALS

7. If the signal mid-point (DC level) has a significant offset from 0V, adjust the R30 

potentiometer screw using a small screwdriver and repeat steps 1 through 6 until 

you see a well-shaped pair of graphs, as shown in Figure 4-4. If the 

SignalNoiseIn looks like a single 1700 Hz sinusoidal signal, check your function 

generator output and increase its amplitude as needed. Otherwise, if the signals 

look clipped or saturated, decrease the signal amplitude on your function 

generator.
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Appendix A. Schematics and Layout

This appendix contains the layout and schematics for the Thermal/Linear Intelligent 

Sensor PICtail™ Plus Daughter Board.

FIGURE A-1: THERMAL/LINEAR INTELLIGENT SENSOR PICtail™ PLUS DAUGHTER BOARD 

LAYOUT
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FIGURE A-2: THERMAL/LINEAR INTELLIGENT SENSOR PICtail™ PLUS DAUGHTER BOARD 

SCHEMATIC (SHEET 1 OF 3)
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