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Copyrights

© Cypress Semiconductor Corporation, 2015. The information contained herein is subject to change without notice. Cypress
Semiconductor Corporation assumes no responsibility for the use of any circuitry other than circuitry embodied in a Cypress
product. Nor does it convey or imply any license under patent or other rights. Cypress products are not warranted nor
intended to be used for medical, life support, life saving, critical control or safety applications, unless pursuant to an express
written agreement with Cypress. Furthermore, Cypress does not authorize its products for use as critical components in life-
support systems where a malfunction or failure may reasonably be expected to result in significant injury to the user. The
inclusion of Cypress products in life-support systems application implies that the manufacturer assumes all risk of such use
and in doing so indemnifies Cypress against all charges.

Any Source Code (software and/or firmware) is owned by Cypress Semiconductor Corporation (Cypress) and is protected by
and subject to worldwide patent protection (United States and foreign), United States copyright laws and international treaty
provisions. Cypress hereby grants to licensee a personal, non-exclusive, non-transferable license to copy, use, modify, create
derivative works of, and compile the Cypress Source Code and derivative works for the sole purpose of creating custom
software and or firmware in support of licensee product to be used only in conjunction with a Cypress integrated circuit as
specified in the applicable agreement. Any reproduction, modification, translation, compilation, or representation of this
Source Code except as specified above is prohibited without the express written permission of Cypress.

Disclaimer: CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS
MATERIAL, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials
described herein. Cypress does not assume any liability arising out of the application or use of any product or circuit
described herein. Cypress does not authorize its products for use as critical components in life-support systems where a
malfunction or failure may reasonably be expected to result in significant injury to the user. The inclusion of Cypress’ product
in a life-support systems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies
Cypress against all charges.

Use may be limited by and subject to the applicable Cypress software license agreement.

PSoC and CapSense are registered trademarks and PSoC Creator, PRoC, and EZ-BLE are trademarks of Cypress
Semiconductor Corp. All other trademarks or registered trademarks referenced herein are property of the respective
corporations.

Flash Code Protection

Cypress products meet the specifications contained in their particular Cypress PSoC Data Sheets. Cypress believes that its
family of PSoC products is one of the most secure families of its kind on the market today, regardless of how they are used.
There may be methods, unknown to Cypress, that can breach the code protection features. Any of these methods, to our
knowledge, would be dishonest and possibly illegal. Neither Cypress nor any other semiconductor manufacturer can
guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as ‘unbreakable’.

Cypress is willing to work with the customer who is concerned about the integrity of their code. Code protection is constantly
evolving. We at Cypress are committed to continuously improving the code protection features of our products.
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Safety Information

Regulatory Compliance

The CY8CKIT-043 PSoC® 4 M-Series Prototyping Kit is intended for use as a development platform
for hardware or software in a laboratory environment. The board is an open system design, which
does not include a shielded enclosure. This may cause interference to other electrical or electronic
devices in close proximity. In a domestic environment, this product may cause radio interference. In
such cases, take adequate preventive measures. In addition, this board should not be used near any
medical equipment or RF devices.

Attaching additional wiring to this product or modifying the product operation from the factory default
may affect its performance and cause interference with other apparatus in the immediate vicinity. If
such interference is detected, suitable mitigating measures should be taken.

The CY8CKIT-043 PSoC 4 M-Series Prototyping Kit, as shipped from the factory, has been verified
to meet with requirements of CE as a Class A product.

4

A

The kit contains ESD-sensitive devices. Electrostatic charges readily
accumulate on the human body and any equipment, and can discharge
without detection. Permanent damage may occur on devices subjected
to high-energy discharges. Proper ESD precautions are recommended
to avoid performance degradation or loss of functionality. Store unused
kit boards in the protective shipping package.

End-of-Life/Product Recycling

This kit has an end-of life five years from the date of manufacture
mentioned on the back of the box. Contact your nearest recycler to
dispose the kit.
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General Safety Instructions

ESD Protection

ESD can damage boards and associated components. Cypress recommends that you perform
procedures only at an ESD workstation. If such a workstation is not available, use appropriate ESD
protection by wearing an antistatic wrist strap attached to the chassis ground (any unpainted metal
surface) on your board when handling parts.

Handling Boards

The CY8CKIT-043 PSoC 4 M-Series Prototyping boards are sensitive to ESD. Hold the board only
by its edges. After removing the board from its box, place it on a grounded, static-free surface. Use a
conductive foam pad if available. Do not slide board over any surface.
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Thank you for your interest in the CY8CKIT-043 PSoC® 4 M-Series Prototyping Kit. This kit is
designed as an easy-to-use and inexpensive prototyping platform. It supports the PSoC 4 M-Series
device family, delivering a complete system solution for a wide range of embedded applications at a
very low cost. The PSoC 4200M device is an expansion of the PSoC 4 device family, which offers
more flash, GPIOs, and programmable analog and digital blocks. The PSoC 4200M device is a true
programmable embedded system-on chip, integrating custom analog and digital peripheral
functions, memory, and an ARM® Cortex®-M0 microcontroller on a single chip. The programmable
analog and digital peripheral functions allow higher flexibility, in-field tuning of the design, and faster
time-to-market.

The PSoC 4 M-Series Prototyping Kit offers an open footprint breakout board to maximize the end-
utility of the PSoC 4200M device. This kit provides a low-cost alternative to device samples while
providing a platform to easily develop and integrate the PSoC 4200M device into your end-system.
In addition, the board includes the following features:

Onboard CMOD capacitors to enable CapSense® development
Bypass capacitors to ensure high-quality ADC conversions

An LED to provide feedback

A push button to provide a simple user input

Load capacitors to connect the 32-kHz external crystal oscillator
3.3-V to 5.5-V operation

The PSoC 4 M-Series Prototyping Kit also integrates the Cypress KitProg, which enables onboard
programming, debugging, and bridging functionality, such as USB-UART and USB-I2C. The KitProg
is used to program and debug the target PSoC 4200M device (see Figure 1-1). The prototyping kit
allows you to separate the KitProg board from the PSoC 4 M-Series target board.

1.1 Kit Contents

This kit contains only the PSoC 4 M-Series Prototyping Kit board.
Figure 1-1. CY8CKIT-043 PSoC 4 M-Series Prototyping Kit

KitProg PSoC 4200M Target
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.2 PSoC Creator

PSoC Creator™ is a state-of-the-art, easy-to-use integrated design environment (IDE). It introduces
revolutionary hardware and software co-design, powered by a library of preverified and
precharacterized PSoC Components. With PSoC Creator, you can:

1.

oD

Drag and drop Components to build your hardware system design in the main design workspace
Codesign your application firmware with the PSoC hardware

Configure Components using configuration tools

Explore the library of 100+ Components

Review Component datasheets

Figure 1-2. PSoC Creator Features
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PSoC Creator also enables you to tap into an entire tool ecosystem with integrated compiler chains
and production programming programmers for PSoC devices.

For more information, visit www.cypress.com/psoccreator. Visit PSoC Creator training page for video
tutorials on learning and using PSoC Creator.
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1.2.1 PSoC Creator Code Examples

PSoC Creator includes a large number of code examples. These examples are available from the
PSoC Creator Start Page, as Figure 1-3 shows.

Code examples can speed up your design process by starting you off with a complete design,
instead of a blank page. The code examples also show how PSoC Creator Components can be

used for various applications. Code examples and documentation are included, as shown in
Figure 1-4 on page 10.

In the Find Example Project dialog shown in Figure 1-4, you have several options:

m Filter for examples based on architecture or device family, that is, PSoC 3, PSoC 4, or
PSoC 5LP; project name; or keyword.

Select from the menu of examples offered based on the Filter Options.
Review the example project’s description (on the Documentation tab).

Review the code from the Sample Code tab. You can copy the code from this window and paste
to your project, which can help speed up code development.

m Create a new project (and a new workspace if needed) based on the selection. This can speed

up your design process by starting you off with a complete, basic design. You can then adapt that
design to your application.

Figure 1-3. Code Examples in PSoC Creator
G
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Figure 1-4. Code Example Projects with Sample Code
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1.2.2 Kit Code Example

In addition to the examples built into PSoC Creator, this kit includes a simple example, which can be
used to quickly evaluate the functionality of this kit. The example is described in the Code
Examples chapter on page 33. In addition, the chapter also includes a section explaining how to use
PSoC Creator code examples with the kit by taking one example.

1.2.3 PSoC Creator Help

Visit the PSoC Creator home page to download the latest version of PSoC Creator. Then, launch
PSoC Creator and navigate to the following items:

Quick Start Guide: Choose Help > Documentation > Quick Start Guide. This guide gives you
the basics for developing PSoC Creator projects.

Simple Component example projects: Choose File > Example project.... These example
projects demonstrate how to configure and use PSoC Creator Components.

Starter designs: Choose File > New > Project > PSoC 4100M / PSoC 4200M Starter Designs.
These starter designs demonstrate the unique features of the PSoC 4 M-Series.

System Reference Guide: Choose Help > System Reference Guides. This guide lists and
describes the system functions provided by PSoC Creator.

Component datasheets: Right-click a Component and select Open Datasheet, as shown in
Figure 1-5 on page 11. Visit the PSoC 4 Component Datasheets page for a list of all PSoC 4
Component datasheets.

Document Manager: PSoC Creator provides a document manager to help you to easily find and
review document resources. To open the document manager, choose the menu item Help >
Document Manager.
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1.3 Getting Started
This guide will help you get acquainted with the PSoC 4 M-Series Prototyping Kit:

The Software Installation chapter on page 13 describes the installation of the kit software. This
includes installation of PSoC Creator IDE for development and debugging the applications, and
PSoC Programmer for programming hex files.

The Kit Operation chapter on page 16 describes the major features of the PSoC 4 M-Series
Prototyping Kit and functionalities such as programming, debugging, and the USB-UART and
USB-IC bridges.

The Hardware chapter on page 20 details the hardware content of the kit and the hardware
operation.

The Code Examples chapter on page 33 describes code examples that will help you create your
own PSoC 4 M-Series projects.

The Appendix on page 42 provides schematics, details about programming the kit using
MiniProg3, and the bill of materials (BOM).

1.4 Additional Learning Resources

Cypress provides a wealth of information at www.cypress.com to help you to select the right PSoC
device for your design, and to help you to quickly and effectively integrate the device into your
design. For a comprehensive list of resources, see KBA86521, How to Design with PSoC 3, PSoC 4,
and PSoC 5LP. The following is an abbreviated list for PSoC 4:

Overview: PSoC Portfolio and PSoC Roadmap

Product Selectors: PSoC 1, PSoC 3, PSoC 4, or PSoC 5LP. In addition, PSoC Creator includes a
device selection tool.

Datasheets: Describe and provide electrical specifications for the PSoC 4 device family
CapSense Design Guide: Learn how to design capacitive touch-sensing applications with the
PSoC 4 family of devices.

Application Notes and Code Examples: Cover a broad range of topics, from basic to advanced
level. Many of the application notes include code examples. Visit the PSoC 3/4/5 Code Examples
webpage for a list of all available PSoC Creator code examples. To access code examples from
within PSoC Creator, see PSoC Creator Code Examples on page 9.
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m Technical Reference Manuals (TRM): Provide detailed descriptions of the architecture and
registers in each PSoC 4 device family.

m Development Kits:

o CY8CKIT-040, CY8CKIT-042, and CY8CKIT-044 are easy-to-use and inexpensive develop-
ment platforms. These kits include connectors for Arduino-compatible shields and Digilent
Pmod peripheral modules.

o CYB8CKIT-049 and CY8CKIT-043 are very low-cost prototyping platforms for sampling PSoC 4
devices.

o The MiniProg3 kit provides an interface for flash programming and debug.

m Knowledge Base Articles (KBA): Provide design and application tips from experts on using the
device.

m PSoC Creator Training: Visit www.cypress.com/go/creatorstart/creatortraining for a
comprehensive list of video trainings on PSoC Creator.

m Learning From Peers: Visit www.cypress.com/forums to meet enthusiastic PSoC developers
discussing the next generation embedded systems on Cypress Developer Community Forums.

1.5 Technical Support

If you have any questions, our technical support team is happy to assist you. You can create a
support request on the Cypress Technical Support page.

If you are in the United States, you can talk to our technical support team by calling our toll-free
number: +1-800-541-4736. Select option 2 at the prompt.

You can also use the following support resources if you need quick assistance.
m Self-help
m Local Sales Office Locations

1.6 Document Conventions

Table 1-1. Document Conventions for Guides

Convention Usage

Courier New Displays file locations, user entered text, and source code:
C:\...cd\icc\

Italics Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Creator User Guide.

[Bracketed, Bold] Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open Represents menu paths:
File > Open > New Project

Bold Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman Displays an equation:
2+2=4

Text in gray boxes Describes Cautions or unique functionality of the product.
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2. Software Installation

This chapter describes the steps to install the software tools and packages on a computer for using
the PSoC 4 M-Series Prototyping Kit. This includes the IDE on which the projects will be built and
used for programming.

2.1 Before You Begin

All Cypress software installations require administrator privileges, but these are not required to run
the software after it is installed. Close any other Cypress software that is currently running before
installing the kit software.

Note: By default, the kit contents are installed in C:\Program Files\Cypress for a 32-bit
machine and C:\Program Files (x86) \Cypress for a 64-bit machine. This folder will contain
the kit example project. To open this example, it is recommended to use the procedure described in
the Code Examples chapter on page 33. That procedure will create an editable copy of the example
in a path that you chose so that the original installed example will not be modified.

2.2 Install Software

Follow these steps to install the PSoC 4 M-Series Prototyping kit software:

1. Download the kit software from www.cypress.com/CY8CKIT-043. The kit software is available for
download in three formats.

a. CYB8CKIT-043 Kit Setup: This installation package contains the files related to the kit including
PSoC Creator and PSoC Programmer. However, it does not include the Windows Installer or
Microsoft .NET framework packages. If these packages are not on your computer, the installer
directs you to download and install them from the Internet.

b. CY8CKIT-043 Kit Only: This executable file installs only the kit contents, which include a kit
code example, hardware files, and user documents. This package can be used if all the
software prerequisites (listed in step 5) are installed on your computer.

c. CY8CKIT-043 DVD ISO: This file is a complete package, stored in a DVD-ROM image format,
that you can use to create a DVD or extract using an ISO extraction program such as Win-
RAR. The file can also be mounted similar to a virtual CD/DVD using virtual drive programs
such as Virtual CloneDrive and MagiclSO. This file includes all the required prerequisite soft-
ware, utilities, drivers, hardware files, and user documents.

2. If you have downloaded the ISO file, mount it on a virtual drive. Extract the ISO contents if you do
not have a virtual drive to mount. Double-click cyautorun.exe in the root directory of the extracted
content or mounted ISO if "Autorun from CD/DVD" is not enabled on the computer. The
installation window will appear automatically.

Note: If you are using the "Kit Setup" or "Kit Only" file, then go to step 4 for installation.
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3. Click Install CY8CKIT-043 Kit to start the kit installation, as shown in Figure 2-1.

Figure 2-1. Kit Installer Screen

=3 CYBCKIT-043

Cypress Semiconductor Corporation, Al rights reserved

4. Select the directory in which you want to install the PSoC 4 M-Series Prototyping kit-related files.
Choose the directory and click Next.

5. When you click Next, the PSoC 4 M-Series Prototyping kit installer automatically installs the
required software, if it is not present on your computer. Following are the required software:
a. PSoC Creator 3.2 or later: This software is also available at www.cypress.com/psoccreator.

b. PSoC Programmer 3.23 or later: This is installed as part of PSoC Creator installation
(www.cypress.com/programmer).

6. Choose the Typical/Custom/Complete installation type (select 'Typical' if you do not know which
one to select) in the Product Installation Overview window, as shown in Figure 2-2. Click Next
after you select the installation type.
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Figure 2-2. Product Installation Overview
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7. Read the License agreement and select | accept the terms in the license agreement to
continue with the installation. Click Next.

8. When the installation begins, a list of packages appears on the installation page. A green check
mark appears next to each package after successful installation.

9. Enter your contact information or select the check box Continue Without Contact Information.
Click Finish to complete the kit installation.

10.After the installation is complete, the kit contents are available at the following location:
<Install Directory>\CY8CKIT-043 PSoC 4 M-Series Prototyping Kit
Default location:

Windows OS (64-bit):

C:\Program Files (x86)\Cypress\CY8CKIT-043 PSoC 4 M-Series Prototyping Kit
Windows OS (32-bit):

C:\Program Files\Cypress\CY8CKIT-043 PSoC 4 M-Series Prototyping Kit

Note: For Windows 7/8/8.1 users, the installed files and the folder are read-only. To use the installer
code example, follow the steps outlined in the Code Examples chapter on page 33.

Uninstall Software

The software can be uninstalled using one of the following methods:

1. Go to Start > All Programs > Cypress > Cypress Update Manager and select the Uninstall
button next to the product that needs to be uninstalled.

2. Go to Start > Control Panel > Programs and Features for Windows 7 or Add/Remove
Programs for Windows XP; choose the product and select the Uninstall/Change button.
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3. Kit Operation

This chapter introduces you to the features of the PSoC 4 M-Series Prototyping Kit. It describes the
programming and debugging functionality, KitProg USB-UART and USB-I°C bridges, and the
method to update the KitProg firmware.

3.1 Theory of Operation

Figure 3-1 shows the block diagram for the PSoC 4 M-Series Prototyping Kit.

Figure 3-1. Block Diagram of PSoC 4 M-Series Prototyping Kit
|

KitProg I/O Header
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PSoC 4200M 1/O Header
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|
|
|
|
|
: v User SW
\ 4
UART : >
- «2C | >
use |~ | KitProg |_swp ! A PSoC 4200M <«
» < I
RESET N> 10 Pin
| Debug
| (Foot-print
only)
| User
: LED
Power Status | (Fool-print
LED LED |
I EZ-BLE
| (Foot-print
RE%ET@ : only)
|
|
|
|

KitProg Section PSoC 4200M Section

The PSoC 4 M-Series Prototyping Kit is simplistic in design and provides complete access to
develop applications using the PSoC 4200M device family. This kit supports the following features:

m KitProg: It is an onboard programmer/debugger, which enables the user to program and debug
the target PSoC 4200M device. It can also act as a USB-UART and USB-I2C bridge. When used
as a standalone module, it can be used to program devices of PSoC 3, PSoC 4, or PSoC 5
families through the SWD interface. For more details on the KitProg functionality, refer to the
KitProg User Guide.

m Expansion Headers: The PSoC 4 M-Series Prototyping kit brings all I/Os of the target device to
the two expansion headers, enabling the user to have maximum access to the capabilities of the
PSoC 4200M device.
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m User LED: The onboard LED can be used to display outputs from the PSoC 4200M device. This
includes modulating the brightness of the LED to notify different states of the device.

m Push Button (SW): The push button can be used to provide input to the PSoC 4200M device.
to ground and resets the PSoC 4200M device.

Note: The switch connects the PSoC 4200M pin to ground when pressed. Therefore, you need to
configure the PSoC 4200M pin as resistive pull-up for detecting the switch press.
m Reset Button: This button is used for the following purposes:
|

o Reset the PSoC 4200M device: When pressed, it connects the XRES line of the PSoC 4200M
functionality, refer to the KitProg User Guide.

o Bootload the KitProg: When pressed while connecting the kit's PCB USB connector to the
USB port of the PC, the KitProg enters bootloader mode. For more details on the KitProg
to reset the PSoC 4200M device using a switch.

Note: When the two boards are separated, the user can mount the SW2 button on the target board

EZ-BLE: It is a fully integrated, 10x10x1.8 mm, fully certified, programmable BLE module

designed for ease-of-use and reduced time-to-market. You can use the EZ-BLE module to add
Section 4.2.7 EZ-BLE PRoC Module on page 30 for details.

to the KitProg's SWD programming lines.

3.2

BLE capabilities to the board. The board only includes a footprint for the module. Refer to

m 10-pin program/debug header: This header provides support for program/debug via the
KitProg

m DPDT switch: This switch is used to select the KitProg's SWD target (PSoC 4200M or EZ-BLE).
gram/debug functionality is already provided by the on-board KitProg.

By default, this switch is not populated on-board and the PSoC 4200M SWD lines are hard-wried

MiniProg3's 10-pin program/debug header. This header is not populated by default as the pro-

location: <Install Directory>\CY8CKIT-043

The KitProg is a multi-functional system, which includes a programmer, debugger, USB-I2C bridge,
functionality. The KitProg is integrated in most PSoC development kits. For more details on the

and a USB-UART bridge. The Cypress PSoC 5LP device is used to implement the KitProg

KitProg functionality, refer to the KitProg User Guide available on the kit web page or in the following

PSoC 4 M-Series
<version>\Documentation\KitProg User Guide.pdf. This is also accessible from inside
PSoC Creator by clicking on the kit name on the Start page (left pane) and then selecting User
Guide for KitProg from the list of available documents (right pane).

Prototyping Kit\
Programming and Debugging the PSoC 4 Target Device

The target PSoC 4 device can be programmed and debugged using the built-in KitProg. Before
programming the device, ensure that PSoC Creator and PSoC Programmer are installed on your
computer. See Install Software on page 13 for more information.

Programming Using PSoC Creator

1. Connect the kit to the computer through the PCB USB connector, J6, as shown in Figure 3-2. The

kit will enumerate as a composite device when you plug in the PSoC 4 M-Series Prototyping kit to
your computer for the first time. The kit drivers should be automatically installed.
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Figure 3-2.

Connecting the PSoC 4 M-Series Prootying Kit to a Computer

2. Open the desired project in PSoC Creator from File > Open > Project/Workspace. This
provides the option to browse and open a previously saved project. If you want to open the
example project provided with the kit, follow the instructions in the Code Examples chapter on
page 33.

3. Select Build > Build Project or press [Shift] [F6] to build the project as shown in Figure 3-3.

Figure 3-3. Build an Example Project

J CE97634 PSoC 4 Breathing LED - PSoC Creator 3.2 [C:\.\CE97634 PSoC 4 Breathing LEC
Eile Edit View Project _ﬂm Debug  Tools Window Help

el N - B (¥ Build CE97634 PSoC 4 Breathing LED  Shift+F6 I
ok Bt & #* [0 Clean CE97634 PSoC 4 Breathing LED I

WVorkspace Explorer (1 project) #5  Clean and Build CE97634 PSoC 4 Breathing LED

W -4
=72 Project 'CE97634 PSo( o
LB TopDesign.cysch X Generate Application
(4P CE97634 PSoC 4 Brea 2] Generate Project Datasheet
L3 Header Files

2
=43 Source Files |§
€] main.c
*3. CE47634 PSoC 4 Breathing LED.pdf ;
g ’T
f

4. If there are no errors during build, program the firmware into the kit by choosing Debug >
Program or press [Ctrl] [F5], as shown in Figure 3-4. This programs the target PSoC 4200M
device on the PSoC 4 M-Series Prototyping Kit; the kit is now ready for use.
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Figure 3-4. Programming Device From PSoC Creator
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Debugging Using PSoC Creator

For debugging the project using PSoC Creator, follow steps 1 to 3 from Programming Using PSoC
Creator on page 17 followed by these steps:

1. Click the Debug icon # or press [F5]. Alternatively, you can choose Debug > Debug.
2. When PSoC Creator opens in Debug mode, use the buttons on the toolbar to debug your appli-
cation.

For more details on using the debug features, refer to section 3.2 of the KitProg User Guide.

Programming Using PSoC Programmer

PSoC Programmer (3.23 or later) can be used to program existing .hex files into the PSoC 4 M-
Series Prototyping Kit. Refer to section 3.3 of the KitProg User Guide for a detailed explanation on
how to program using PSoC Programmer.

USB-UART Bridge

The KitProg can act as a USB-UART bridge. The UART lines between the KitProg and the target are
hard-wired on the board, through the snappable area, with UART_RX assigned to P7[1] and
UART_TX assigned to P7[0] on PSoC 4200M. For more details on the KitProg USB-UART function-
ality, refer to section 5 of the KitProg User Guide.

USB-IC Bridge

The KitProg can function as a USB-I?C bridge and communicate with the Bridge Control Panel
(BCP) software utility. The I2C lines on the PSoC 4200M device are P4[1] (SDA) and P4[0] (SCL),
which are hardwired on the board to the 12C lines of the KitProg. The USB-I°C supports I°C speeds
of 50 kHz, 100 kHz, 400 kHz, and 1 MHz. For more details on the KitProg USB-I’C functionality,
refer to section 6 of the KitProg User Guide.

Updating the KitProg Firmware

The KitProg firmware normally does not require any update. You can use PSoC Programmer to
update the KitProg firmware. Refer to section 3.5 of the KitProg User Guide for more details.
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4.1 Board Details

The PSoC 4 M-Series Prototyping Kit consists of the following blocks:
PSoC 4200M device U2 (CY8C4247AZI-M485)

PSoC 4200M headers J1 and J2

PSoC 4200M 10-pin program/debug header J5 (footprint only)
KitProg (PSoC 5LP) device U1 (CY8C5868LTI-LP039)

KitProg headers J8 and J9

SWD connection J3 and J7

USB finger connector J6

EZ-BLE™ PRoC™ module U4 (footprint only)

One DPDT switch SW4 to select the SWD target device (footprint only)
One blue LED LED1 (User)

One amber LED LED2 (Power)

One green LED LED3 (Status)

User push button SW1

Reset buttons SW2 (footprint only) and SW3

External reference capacitor C3 (SARADC bypass)

CapSense capacitors (CMOD C10 and CTANK C13)

Current measurement jumper J4 (footprint only)

Perforated ‘snappable’ board design
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4.2 Hardware Details

4.21 Target Board

The target board uses the PSoC 4200M device. PSoC 4 is a scalable and reconfigurable platform
architecture for a family of programmable embedded system controllers with an ARM Cortex-MO
CPU. It combines programmable and reconfigurable analog and digital blocks with flexible automatic
routing. The PSoC 4200M device family, based on this platform architecture, is a combination of a
microcontroller with digital programmable logic, programmable analog, programmable interconnect,
high-performance analog-to-digital conversion, opamps with comparator mode, and standard
communication and timing peripherals. The PSoC 4200M products are fully compatible with
members of the PSoC 4 platform for new applications and design needs. The programmable analog
and digital subsystems allow flexibility and in-field tuning of the design. For more information, refer to
the PSoC 4 web page and the PSoC 4200M Family Datasheet.

Figure 4-2. Schematic of PSoC 4 (Target)
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4.2.2 KitProg Board

PSoC 5LP on the KitProg board is used to program and debug the target PSoC 4 device. The
KitProg PSoC 5LP connects to the USB port of the computer through the PCB USB connector and to
the SWD interface of the target PSoC 4 device. See the KitProg User Guide for additional details
and functions provided by the KitProg.

Figure 4-3. Schematic of PSoC 5LP (KitProg)
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Power Supply System

connections:

Hardware
you can use the 5-V supply from the USB connection to power the system. You can also connect an
m 5V from the KitProg USB (J6)

The power supply system on this board is dependent on the power source. For most applications,
of the board)

external power supply to the board for low-voltage applications. The kit supports the following
pins accordingly.

that the board

m 3.3V to5.5V from aregulated supply connected to VDD (this will not power the KitProg section
get device. The KitProg measures the target voltage and adjusts the logic levels on the programming

Note: To use an external power supply, while the KitProg is connected to the PCB USB, remove the
D1 diode from the board. This ensures that VTARG supply from the KitProg is not supplied to the tar-
connections.

4.2.3.1

Method 1:

Note that this prototyping kit does not have any onboard ESD protection circuitry. Therefore,
Measure PSoC 4 Current Consumption

the power source for the PSoC 4 M-Series Prototyping Kit must be of a high quality to ensure

is protected from any over-current conditions and swapped-power

You can measure current consumption of the PSoC 4200M device by using one of these methods:
Method 2:

1. Separate the KitProg board by 'snapping' the perforated edge between the two boards.
424

2. Power the remaining prototyping board via any of the VDD or VTARG terminals.

3. Place an ammeter in series with the VDD or VTARG connection to measure current consumption.

1. Remove the resistor R22 and install a 2-pin jumper in the supplied holes of J4.

Board Separation (Snapping)

This method can be used either with USB power or with power supplied to one of the VTARG pins
but NOT when supplying power to one of the VDD pins.

2. Connect an ammeter across the 2-pin jumper to measure the current to the PSoC 4200M device.

rated edge.

The PSoC 4 M-Series Prototyping Kit consists of both a PSoC 4200M and a KitProg board. To sepa-
rate the two boards for evaluation or development, break the two boards apart at the built-in perfo-

The easiest method of separating the two boards is to place the kit on the edge of a table, where the
edge of the table is directly below the perforated edge and the smaller KitProg board is off the table
edge. Press gently on the KitProg board and snap the two boards apart. If any material is removed
from the edge of the boards, use shears to clean up the edge of the kit. Note that once the boards

are separated, direct UART and I2C connections between the PSoC 4200M device and KitProg are

lost. This is because the traces connecting the UART and 12C lines are cut off during the separation.
However, you can access the KitProg's UART and 12C lines through headers J8 and J9.
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Figure 4-4. PSoC 4 M-Series Prototyping Kit Broken into Two Parts
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Header Connections

Hardware

The PSoC 4 M-Series Prototyping Kit supports a number of unpopulated headers on both the

KitProg and the target PSoC 4 boards.

Functionality of J1 and J2 Headers (Target Board)

The target board contains two, dual-inline, headers (J1 and J2). Both are 1x29 pin headers and
include all of the I/Os available on the PSoC 4200M device. These headers support all of the avail-
able ports, GND, VDD, and connections to passive elements and user-input devices. The J1 and J2
headers support 100-mil spacing, so you can solder connectors to connect the target board to any

development breadboard.

Figure 4-5. J1 and J2 Headers
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Table 4-1. J1 Header Pin Details

Table 4-2. J2 Header Pin Details

PSoC 4 M-Series Prototyping Kit GPIO PSoC 4 M-Series Prototyping Kit GPIO

Pin Signal Description Pin | Signal Description
J1_01 /IXRES |GPIO J2_01 |VDDD |Power
J1_02 P5[0] GPIO J2_02 |GND Ground
J1_03 P5[1] GPIO J2_03 |PO[7] GPIO/SW (SW1)
J1_04 P5[2] GPIO J2_04 |PO[6] GPIO
J1_05 P5[3] GPIO J2_05 |PO[5] GPIO/XTAL_OUT
J1_06 P5[5] GPIO J2_06 |PO[4] GPIO/XTAL_IN
J1_07 P1[0] GPIO J2_07 |PO[3] GPIO
J1_08 P1[1] GPIO J2_08 |PO[2] GPIO
J1_09 P1[2] GPIO J2_09 |PO[1] GPIO
J1_10 P1[3] GPIO J2_10 |PO[0] GPIO
J1_11 P1[4] GPIO J2_11 |P7[1] GPIO/->UART_RX
J1_12 P1[5] GPIO J2_12 |P7[0] GPIO/<-UART_TX
J1_13 P1[6] GPIO/LED (LED1) J2_13 |P4[6] GPIO
J1_14 P1[7] GPIO/SAR BYPASS J2_14 |P4[5] GPIO
J1_15 P2[0] GPIO J2_15 |P4[4] GPIO
J1_16 P2[1] GPIO J2_16 |P4[3] GPIO/CTANK
J1_17 P2[2] GPIO J2_17 |P4[2] GPIO/CMOD
J1_18 P2[3] GPIO J2_18 |P4[1] GPI0/12C_SDA
J1_19 P2[4] GPIO J2_19 |P4[0] GPI0O/12C_SCL
J1_20 P2[5] GPIO J2_20 |P3[7] GPIO
J1_21 P2[6] GPIO J2_21 |P3[6] GPIO
J1_22 P2[7] GPIO J2_22 |P3[5] GPIO
J1_23 P6[0] GPIO J2_23 |P3[4] GPIO
J1_24 P6[1] GPIO J2_24 |P3[3] GPIO/SWDCLK
J1_25 P6[2] GPIO J2_25 |P3[2] GPIO/SWDIO
J1_26 P6[4] GPIO J2_26 |P3[1] GPIO/->BLE_RX
J1_27 P6[5] GPIO J2_27 |P3[0] GPIO/<-BLE_TX
J1_28 GND Ground J2_28 |VDDA |Power
J1_29 VDDIO |Power J2_29 |GND Ground

4.2.5.2

Functionality of J7 and J3 Headers (PSoC 4200M to KitProg)

Hardware

The KitProg and target boards each contain a 1x5-pin header. These headers provide a physical
connection between the two devices. Specifically, the connection includes the SWD interface,
required to program/debug the target PSoC 4200M device, power, ground, and reset.
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Table 4-3. Pin Details of J7 Header Table 4-4. Pin Details of J3 Header
PSoC 5LP KitProg Header (J7) PSoC 4 M-Series Prototyping Kit GPIO (J3)

Pin Signal Description Pin Signal Description

J7_01 VTARG |Power J3_01 [VTARG |Power

J7_02 GND Ground J3 02 |GND Ground

J7_03 P12.4 PROG_XRES J3_03 [XRES |XRES

J7_04 P12.3 PROG_SWDCLK J3_04 |P3.3 SWDCLK

J7_05 P12.2 PROG_SWDIO J3_05 |P3.2 SWDIO

When the boards are separated, the KitProg board can be used to program any other PSoC 3,
PSoC 4, or PSoC 5LP device family member via J7.

4.2.5.3 Functionality of J8 and J9 Headers (KitProg)

The KitProg board contains two, dual-inline, headers (J8 and J9). Both are 1x7-pin-headers, used to
provide access to several pins of the PSoC 5LP to support advanced features such as a low-speed
oscilloscope and a low-speed digital logic analyzer. These headers also contain the KitProg bridge
pins (USB to UART and USB to IZC) that can be used when the two boards are separated.

The J8 and J9 headers support 100-mil spacing, so you can solder connectors to connect the
KitProg board to any development breadboard.

Figure 4-7. J8 and J9 Headers

cooocoonp

POWER
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Table 4-5. Pin Details of J9

Table 4-6. Pin Details of J8

Hardware

PSoC 5LP to KitProg Header (J9) PSoC 5LP to KitProg Header (J8)
Pin Signal Description Pin | Signal Description
J9 01 |VBUS [Power J8 01 |GND Ground
J9 02 GND Ground J8_02 P3.0 GPIO
J9_03 P12.5 GPIO J8_03 P3.4 GPIO
J9 04 |P12.0 [GPIO/2C_SCL J8_04 P3.5 GPIO
J9 05 |P12.1  |GPIO/I2C_SDA J8_05 P3.6 GPIO
J9 06 |P12.6 |GPIO/UART_RX J8_06 P0.0 GPIO
J9 07 |P12.7 |GPIO/UART_TX J8:07 PO.1 GPIO
4.2.6 User and Passive Inputs

4.2.6.1 Push Button

The target PSoC 4 board contains a single push button connected to the PO[7] pin on the
PSoC 4200M device. This button can be used for general user inputs or to control different states in
an application.

4.2.6.2 Reset/Boot Button

Figure 4-8. Push Button on the Board

SWi
P0_7 1A 3 2A
| _1B 5 2B |
SW

User Button

A4

The KitProg board contains a push button connected to the XRES pins on the target PSoC 4200M
and EZ-BLE devices. The button is also connected to P12_4 of the KitProg device. This button
serves two functions:

m Reset the PSoC 4200M and EZ-BLE devices: When this button is pressed, the XRES lines of the

PSoC 4200M and EZ-BLE are connected to ground, which, in turn, resets the devices.

m Bootload the KitProg: When this button is held down while plugging the KitProg into the USB port
of the PC, the KitProg enters the bootloader mode. In this mode, bootloadable applications can
be downloaded on the KitProg device. The bootloader mode is indicated by the green LED

(LED3) flashing.
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Figure 4-9. Reset/Boot Button
RESET 1A S5 2A
[ 1B 5 G 2B
SWitch™
Target Reset/Boot Switch
Reset Button
The target board provides a footprint for a surface-mount switch, which can be used to reset the
PSoC 4200M and EZ-BLE devices when the two boards are separated.
Figure 4-10. Reset (RST) Button
SwW2
/XRES 1A : 2A
O O
[ 1B O O 2B |
No Load
Reset Button Vv
4.2.6.3 LEDs

The PSoC 4 M-Series Prototyping kit contains three LEDs:

m The amber LED: Indicates that the board is powered from the PCB USB connector. This LED will
not light when the board is powered from VDD or VTARG directly.

m The green LED: Indicates the KitProg status, connected to P3[1] of the KitProg PSoC 5LP
device. For more details on the KitProg status LED, refer to the KitProg User Guide.

m The blue LED: This is the user LED, connected to P1[6] of the target PSoC 4200M device.
Figure 4-11. Power LED

VBUS

LED2
RO 560 ohm 2 H } LA 1

POWER LED Amber
Power LED
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Figure 4-12. Status LED
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4.2.6.4 System Capacitors

The PSoC 4 M-Series Prototyping Kit has five capacitors in addition to power supply decoupling
capacitors:

m A SAR ADC bypass capacitor (C3): Required for proper ADC sampling at higher frequencies.

m Two CapSense capacitors (CMOD and CTANK): Required for proper CapSense functionality.

m Two biasing capacitors (C9 and C12): Required to interface an external 32-kHz crystal oscillator.
Note: The crystal oscillator is not placed on the board; it can be soldered on pins PO[5] and PO[4].

Figure 4-14. System Capacitors Circuit Diagram

CMOD CTANK SAR BYPASS
P4_2 P4_3 P1_7 PO 5 [lce
[[18pF
G10 c13 c3

2200 pF 10nF

—1.0uF 1
PO_4 ||c12
| [36 pF

kHz Crystal Load Caps
427 EZ-BLE PRoC Module

The board includes a footprint for mounting an EZ-BLE PRoC Module. The EZ-BLE PRoC Module is
a fully integrated, 10x10x1.8 mm, fully certified, programmable module designed for ease-of-use
and reduced time-to-market. It contains Cypress’s PRoC BLE chip, two crystals, chip antenna,
shield, and passive components. Refer to AN96841 - Getting Started With EZ-BLE PRoC Module for
more details. Visit www.cypress.com/ez-bleprocmodule/ to buy the EZ-BLE module.

CYB8CKIT-043 PSoC® 4 M-Series Prototyping Kit Guide, Doc. #: 001-97606 Rev. ** 30


http://www.cypress.com/ez-bleprocmodule/
http://www.cypress.com/?rID=110316
http://www.cypress.com/ez-bleprocmodule/

PERFORM

Hardware

Figure 4-15. EZ-BLE Connections
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The EZ-BLE module includes the following connections to the PSoC 4200M and KitProg:

m UART connections to PSoC 4200M through zero-ohm resistors R28 and R27 (see Figure 4-16
and Table 4-7).
12C connections to KitProg and PSoC 4200M. See Table 4-7 for details.

SWD connections to KitProg through the DPDT switch SW4. The SWD connections are shared
between the PSoC 4200M and EZ-BLE devices. By default, SW4 is not populated and the Kit-
Prog SWD connections are hardwired to PSoC 4200M through zero-ohm resistors, R18 and R16.

Table 4-7. EZ-BLE Connections

EZ-BLE Connections

EZ-BLE PSoC 4 KitProg Description
BLE_TX, P1.5 P3.0 - GPIO/UART_TX
BLE_RX, P1.4 P3.1 - GPIO/UART_RX
BLE_SDA, P5.0 P4.1 12C_SDA, P12.1 GPIO/12C_SDA
BLE_SCL, P5.1 P4.0 I12C_SCL, P12.0 GPIO/12C_SCL
BLE_SWDIO, P0.6 - SWDIO, P12.2 SWD /O
BLE_SWDCLK, P0.7 |- SWDCLK, P12.3 SWD clock

To program the EZ-BLE module using Kitprog, follow these instructions:

1. Populate the DPDT switch, SW4. Refer to row no. 36 in Appendix A.3 Bill of Materials on page 45
for the part number of the switch to be used.

2. Populate the EZ-BLE PROC module, U4 (footprint on the bottom of the board)
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3. Remove the zero-ohms resistors R18 and R16

4. Move the DPDT switch to position A as shown in Figure 4-16 to program PSoC 4200M and to
position B as shown in Figure 4-17 to program the EZ-BLE module

Figure 4-16. SW4 Position for Programming PSoC 4200M

SR PR ) LJ
an-538 D2 Al
BLE.VDD
SW4

3 04 05 0.7
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5. Code Examples

This chapter explains the code example provided along with the PSoC 4 M-Series Prototyping Kit as
well as how to use the built-in PSoC Creator examples with the kit. To access the code example,
download and install the CY8CKIT-043 PSoC 4 M-Series Prototyping Kit setup file from
www.cypress.com/CY8CKIT-043. After installation, the code example will be available in the
Firmware folder in the installation location.

For more code examples, visit the PSoC 3, PSoC 4, and PSoC 5 code examples page, which lists all
PSoC Creator code examples available across application notes, kits, and PSoC Creator.

5.1 Using the Kit Code Example

Follow these steps to open and use the code example provided with the kit.

1. Launch PSoC Creator from Start > All Programs > Cypress > PSoC Creator<version> >
PSoC Creator <version>.

2. On the Start Page, click CY8CKIT-043 under Examples and Kits > Kits. The code example
CE97634 PSoC 4 Breathing LED, shipped with the kit, appears (see Figure 5-1).

3. Click on the example project and save it at a desired location.
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Figure 5-1. Open Example Project from PSoC Creator
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Code Examples

4. Build the example project by choosing Build > Build <Project Name>, as shown in Figure 5-2. A
.hex file is generated after a successful build process.

Figure 5-2. Build Example Project from PSoC Creator
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: §' TopDesign.cysch

4 Generate Application

(4P CE97634 PSoC 4 Brea =] Generate Project Datasheet

L3 Header Files
=43 Source Files
€] main.c
*3. CE97634 PSoC 4 Breathing LED.pdf

J| s:uauoduoj_

aysereq

’T

5. Connect the PSoC 4 M-Series Prototyping kit to the PC using the KitProg PCB USB port, J6, as
described in Programming Using PSoC Creator chapter on page 17 to program the kit with this
code example. If this is the first time the kit is connected, wait for drivers to be installed.

6. Choose Debug > Program in PSoC Creator as shown in Figure 5-3.
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Figure 5-3. Program Device in PSoC Creator
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Code Examples

7. PSoC Creator opens the programming window if the device is not yet acquired. Select KitProg
and click the Port Acquire button, as shown in Figure 5-4.

Figure 5-4. Port Acquire

Select Debug Target
% KitProg/OEOF0B2A011A3400

KitProg/0EOFOB2A011A3400

POWER =3
VOLTAGE_ADC = 4833
FREQUENCY = 2000000
PROTOCOL = SWD

KitProg version Expecting 2.10, but
found 2.11. Please use PSoC
Programmer GUI to upgrade
firmware.

Show all targets V]

[ Port Setting ’ Port Acquire ]

8. After the device is acquired, it is shown in a tree structure below the KitProg. Click the Connect
button and then OK to exit the window and start programming, as shown in Figure 5-5.
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Figure 5-5. Connect Device From PSoC Creator and Program
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Show all targets v I | Connect ‘l

9. Once programming is successful, the blue LED (LED1) on the board should start displaying the
breathing effect at approximately 1-Hz rate. From the Workspace Explorer in PSoC Creator, open
the CE97634 PSoC 4 Breathing LED.pdf as shown in Figure 5-6. This document provides details
of the code example.

a

v

Figure 5-6. Project Datasheet - CE97634 PSoC 4 Breathing LED.pdf
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5.2 Using Built-in PSoC Creator Code Examples with the Kit

Follow these steps to open and use the built-in PSoC Creator examples.

1. Launch PSoC Creator from Start > All Programs > Cypress > PSoC Creator<version> >
PSoC Creator <version>.

2. On the Start Page, click Find Example Project... under Examples and Kits, as shown in
Figure 5-7.

Figure 5-7. PSoC Creator Find Example Project...

Lx St;tri:Page____________ B

PSoC® Creator™

w
g
[n]
ik -
Recent Projects
g Create New Project...
§ Open Existing Project .
;
I Getting Started
g PSolC Creator Start Page
# Quick Stant Guide
3_ Intro to PSaC
| Intto to PSeC Creatos
| PSal Creator Training
E Design Tutarials
| & Getting Started With PSoC 3

i1}

Getting Started With PSoC 4
Gelting Stasted With PSoC 5LP
Getting Started with PSoC 4 BLE
Getting Statted with PRaC BLE

Examples and Kits

Fmd Exarple Project .,
5 Kits
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3. In the Find Example Project window, set the Device Family to PSoC 4200M as shown in
Figure 5-8.
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Figure 5-8. Selecting PSoC 4200M Device Family in Find Examples Window
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4. You can use any project that appears in the list with the kit. As an example, we will select the
ADC_SAR_Seq_DieTemp_PSoC4 project and see how to use it with CY8CKIT-043.

5. Select the ADC_SAR_Seq_DieTemp_PSoC4 project and click the Create New Workspace but-
ton. Save the workspace to a desired location. See Figure 5-9.
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Figure 5-9. ADC_SAR_Seq_DieTemp_PSoC4 Code Example
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6. This example project measures an input voltage in the range 0 to 1.024 V on a pin and sends the
measured voltage and device die temperature over UART. In addition, the project controls the
brightness of an LED using a PWM based on the value measured by the ADC. Map the UART
and LED pins as shown in Figure 5-10 to use the example with the kit. The pin used to measure
an analog input voltage using the ADC can be mapped to any pin.
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Figure 5-10. cydwr Settings for CY8CKIT-043

Code Examples
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7. For CY8CKIT-043, make sure the device used is CY8C4247AZI-M485 as shown in Figure 5-11.
Build the project and program the kit as explained in Using the Kit Code Example on page 33.

Figure 5-11. Device Selector Settings
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| e

) View Datasheet EH Hige/Show Columns... * Resetto Defaults

%
pocaom | [ [ [ [_[_[_T_
CYICAMTATA-MASY | BRMCMO | PSor a200m | as-Lofe | 43| 18] 1) - | v
CYSCAZTAZAMIES | ARMCMD | PSoc 4200M | 64ToFP | 43| 13| 16| | 3| v
CYICA4TATIIMATS | ARMCMO | Psoc 4200m | 64ToR? | 43| 28] 16] - @
i 48 138 3f 51
CYSCAZATAZS-MATS | ARMCMO | PsoC 4200 | 64-ToF? | 43| 18] 1) - @
Cvec4zeTAzs a3 | ARMCMD | Psoc4zoom | ao-Lofe | 43| 18| 16| -] m| v
CYICARTATS-ME05 | ARMCMO | Psoc da0m | s4-Tore | 43| 128 18] - s1| v
CYBCAZTLTIMATS | ARMCMO| PSoC 42000 | e6-QF| 45| 128] 16] -| 5|

4

29 of 381 devices Found | Cleas Filters |

8. Open ADC_SAR_Seq_DieTemp_PSoC4.pdf from the Workspace Explorer to learn more about
the example project and its configuration.See Figure 5-12.
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Code Examples

Figure 5-12. Project Datasheet: ADC_SAR_Seq_DieTemp_PSoC4

iWorkspn:e Explorer (1 project)
2 g

S TopDesign.cysch

=1L Header Files
] device.h

=13 Source Files
c] main.c

& Workspace 'ADC_SAR_Seq_DieTermp_PSoC403' (1 Prc
=] j Project 'ADC_SAR_Seq DieTemp_PSoC403' [C

) ADC_SAR_Seq_DieTernp_PSoC403.cydwr

[ ADC_S&R Seq DieTemp_PSoC4.pdf |

> X

sysuoduol | 204n0!

seyEq

9. You can view the die temperature value and ADC measured voltage through any terminal emula-
tor program like PuTTY or HyperTerminal. Refer to chapter 5 of the KitProg User Guide for details
on how to configure and use the software with KitProg. The UART used in the example uses con-
figuration provided in Table 5-1. The output with PUTTY software is shown in Figure 5-13.

Table 5-1. UART Settings

UART Parameter Setting
Data bits 8
Stop bits None
Parity bits None
Baud rate 115200 bps

Figure 5-13. ADC_SAR_Seq_DieTemp_PSoC4 Output in PuTTY

2P COMS67 - PuTTY

=
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PSoC 4 M-Series Prototyping Kit Schematics
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EZ-BLE PRoC Module

PCA: 121-60220-01
PCB: 600-60250-01
FAB DRW: 610-60247-01
ASSY DRW: 620-60255-01
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2 Programming the PSoC 4 M-Series Prototyping Kit Using
MiniProg3/KitProg

The target board allows you to program the PSoC 4200M device using a MiniProg3 or an external
KitProg via the 5-pin SWD header or the 10-pin JTAG header. To do this, connect wires or a 5-pin
100-mil spaced header to J3 or a 10-pin JTAG header to J5 on the target board. The PSoC 4 M-
Series Prototyping kit supports both power cycle and reset programming modes.

Figure A-1. Connecting CY8CKIT-043 to MiniProg3

‘I i"" . 3 e =
— =ZCYPREES W |

FERTORM

MiniProg3 __.

Note: CY8BCKIT-002 MiniProg3 is not part of the PSoC 4 M-Series Prototyping kit contents and can
be purchased from the Cypress Online Store.
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A.3 Bill of Materials
Item | Qty Reference Value Description Manufacturer Mfr Part Number
PCB, 112 mm x 24.13
i N L e e
Silk = WHITE
C1,C4,C5,C6,C8,C
o |14 ;2)@1;(0:12{;(0:;3(0: 01 uFd )c(;g\g (c);foF;o.wF 10V10% | 15 Gorporation cB:/1005X5R1A104K050
34
C3,C15,C16,C17,C
3 |13 g;gg?ggggg?g 1.0 uFd (2:?\7 )(CE,'EF{R&“S'SC1B&UF Taiyo Yuden TMK107BJ105KA-T
32
4 |1 leo 18 oF ﬁég (():4%12 18PF 60V 1% |\ o (DBRM155501 H180FAO1
= |1 lcto 2200 pFd g‘QPNgEF({) 8202500PF 50V | \1irata (DBRM2165C1 H222JA01
6 1 Cc12 36 pF ,c\l;';g (():4%2 36PF 50V 5% Murata Electronics SRM1555C1 H360JA01
N P P 10000 pFd gQPNgEE 81 é)sooopF 50V | \1urata (DBRM219501H103JAO1
8 |1 |D1 MBRO520L ZDC')(\)/DS%E%'?TTKY 0.5A ZS:;‘;T'" Semicon- | \1pR0520L
9 |1 |F1 EIZCFE:‘:‘e“a' g%ﬁi fg\? fzefgttgﬂg‘ Bel Fuse Inc 0ZCHOO50FF2G
10 [1 |LED1 gﬁﬁrE"ED '65(')35"33'#5' CLEAR, Lite-On Inc LTST-C170TBKT
1 1 LED2 ,I:;vt\gzrr LED I6§(I)35589|\5/IIEI)M AMB DIFF ,;\(/easgo Technolo- HSMA-C170
12 [1 |LED3 ?;tltgﬁ LED SEES%TA%EN CLEAR Chicago Miniature | CMD17-21VGC/TR8
13 3 L1,L2,L3 ?ggﬁ:zM @ ':IEXEO%OC?’HP 330 OHM Murata Electronics | BLM18SG331TN1D
14 |2 |R2,R3 15K ?/Eﬁv?'\gfo;s}( OHMS% | panasonic- ECG | ERJ-2GEJ153X
15 |2 |R4,R5 22E ToEv?/ gz’(')g 220HM1% 1/ | oo nasonic - ECG | ERJ-2RKF22R0X
16 [2 |R6,R8 2.2K ?;%ébéKs%%M VIOW | panasonic - ECG | ERJ-3GEYJ222V
17 |2 |R7,R22 ZERO ;EA%O'O OHM 1/8W 0805 | 5 asonic-ECG | ERJ-6GEYOR0OV
18 [1 |R9 560 ohm 55083586&[?'*“" VIOWS% | bonasonic - ECG | ERJ-3GEYJ561V
19 |2 |R10,R12 30K ifﬁvi'\gfogw OHMS% | panasonic - ECG | ERJ-2GEJ303X
20 |12 2117',?127,?{12?)?12?: ZERO gﬁ%o'o OHM 1/8W 0603 | 5 1 asonic-ECG | ERJ-3GEYOR0OV
R24,R26,R27,R28
21 |1 |R15 560 ohm 55085 586“2[?”'\" V8WS% | panasonic - ECG | ERJ-6GEYJ561V
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mm

ductor

Item | Qty Reference Value Description Manufacturer Mfr Part Number
RES 820 OHM 1/8W 5% .
22 1 R19 820 ohm 0603 SMD Panasonic - ECG ERJ-3GEYJ821V
SW PUSH- SWITCH TACTILE SPST-
23 |2 SW1,SW3 BUTTON NO 0.05A 32V C&K Components | KMR221GLFS
68QFN PSoC 5LP chip for Cvoress Semicon-
24 |1 U1 PSoC 5LP USB debug channel and yp CY8C5868LTI-LP039
L2 ductor
USB-Serial interface
2% 1 |u2 PSoC 4200M | 68TQFP PSoC 4M gggt;erss Semicon- | ~ygc4247AZ1-M485
MOSFET 2P-CH 20V .
26 1 U3 DUAL PMOS 430MA SOT-563 ON Semiconductor |NTZD3152PT1G
Label
LBL, PCA Label, Vendor
Code, Datecode, Serial Cvoress Semicon-
27 |1 |NnA N/A Number 121-60220-01 | 1 ystor
Rev 03 (YYWWV- u
VXXXXX)
No load components
CAP CER 0.1UF 10V 10% . C1005X5R1A104K050
28 |2 C2,C30 0.1 uFd X5R 0402 TDK Corporation BA
CAP CERAMIC 1.0UF .
29 |1 Cc7 1.0 uFd 25V X5R 0603 10% Taiyo Yuden TMK107BJ105KA-T
CONN HEADR BRKWAY .
30 1 J4 HDR 1x2 100 02POS STR TE Connectivity 9-146280-0-02
50MILKEYED | CONN HEADER 10 PIN
31 1 J5 SMD 50MIL KEYED SMD Samtec FTSH-105-01-L-DV-K
RES SMD 4.7K OHM 5% .
32 1 R1 4.7K 1/10W 0402 Panasonic - ECG ERJ-2GEJ472X
33 |1 R25 ZERO 55%0.0 OHM 1/8W 0805 Panasonic - ECG ERJ-6GEYORO0OV
RES 4.7K OHM 1/10W .
34 |1 R23 47K 5% 0603 SMD Panasonic - ECG ERJ-3GEYJ472V
SW PUSH- SWITCH TACTILE SPST-
35 |1 SW2 BUTTON NO 0.05A 32V C&K Components | KMR221GLFS
SWITCH SLIDE DPDT .
36 |1 SW4 DPDT SW 200MA 12V Copal Electronics CL-SB-22B-02T
TEST POINT 43 HOLE 65 | Keystone Electron-
37 |1 TP5 BLACK PLATED BLACK ics 5001
TEST POINT 43 HOLE 65 | Keystone Electron-
38 |4 TP1,TP2,TP3,TP4 |[RED PLATED RED ics 5000
EZ-BLE PRoC BLE Mod- Cvoress Semicon-
39 |1 U4 EZ-BLE ule, 10mMmMX10mm X 1.8 yp CYBLE-022001-00

CY8CKIT-043 PSoC® 4 M-Series Prototyping Kit Guide, Doc. #: 001-97606 Rev. **

46




Revision History

CY8CKIT-043 PSoC®4 M-Series Prototyping Kit Guide Revision History

Document Title: CY8CKIT-043 PSoC® 4 M-Series Prototyping Kit Guide
Document Number: 001-97606

Revision | Issue Date (eIl & Description of Change
Change
* 06/25/2015 |MSUR New kit guide

CY8CKIT-043 PSoC® 4 M-Series Prototyping Kit Guide, Doc. #: 001-97606 Rev. **

47



	Contents
	Regulatory Compliance
	General Safety Instructions

	1. Introduction
	1.1 Kit Contents
	1.2 PSoC Creator
	1.2.1 PSoC Creator Code Examples
	1.2.2 Kit Code Example
	1.2.3 PSoC Creator Help

	1.3 Getting Started
	1.4 Additional Learning Resources
	1.5 Technical Support
	1.6 Document Conventions

	2. Software Installation
	2.1 Before You Begin
	2.2 Install Software
	2.3 Uninstall Software

	3. Kit Operation
	3.1 Theory of Operation
	3.2 KitProg
	3.3 Programming and Debugging the PSoC 4 Target Device
	3.3.1 Programming Using PSoC Creator
	3.3.2 Debugging Using PSoC Creator
	3.3.3 Programming Using PSoC Programmer

	3.4 USB-UART Bridge
	3.5 USB-I2C Bridge
	3.6 Updating the KitProg Firmware

	4. Hardware
	4.1 Board Details
	4.2 Hardware Details
	4.2.1 Target Board
	4.2.2 KitProg Board
	4.2.3 Power Supply System
	4.2.3.1 Measure PSoC 4 Current Consumption

	4.2.4 Board Separation (Snapping)
	4.2.5 Header Connections
	4.2.5.1 Functionality of J1 and J2 Headers (Target Board)
	4.2.5.2 Functionality of J7 and J3 Headers (PSoC 4200M to KitProg)
	4.2.5.3 Functionality of J8 and J9 Headers (KitProg)

	4.2.6 User and Passive Inputs
	4.2.6.1 Push Button
	4.2.6.2 Reset/Boot Button
	4.2.6.3 LEDs
	4.2.6.4 System Capacitors

	4.2.7 EZ-BLE PRoC Module


	5. Code Examples
	5.1 Using the Kit Code Example
	5.2 Using Built-in PSoC Creator Code Examples with the Kit

	A. Appendix
	A.1 PSoC 4 M-Series Prototyping Kit Schematics
	A.2 Programming the PSoC 4 M-Series Prototyping Kit Using MiniProg3/KitProg
	A.3 Bill of Materials

	Revision History
	CY8CKIT-043 PSoC®4 M-Series Prototyping Kit Guide Revision History


