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1 Overview
This document gives instructions towards implementing the demo software available for the
Tower F-RAM Module (TWR-FRAM). The TWR-FRAM module is designed to work with the

Freescale Tower System.
The Tower F-RAM demo software features:

e Control of processor peripherals (SPI and 12C)
e Access of serial memory (SPI and 12C)

e Programming of state savers

e Access of parallel memory (coming soon)
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2 HW/SW Requirements
Hardware

e TWR-FRAM module
e TWR-K53N512 (software developed and tested on this platform)
o Note: This board is designed to meet the Tower System Module interface so
other Freescale Tower MCU modules are compatible for development.
o TWR-ELEV
e miniUSB-to-USB cable (available in TWR-K53N512 kit)

Software

e Windows OS

e |AR Embedded Workbench for ARM

o Keil uVision4

e PE Micro OSBDM Virtual Serial Toolkit

TWR-FRAM Quick Start Guide
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3 Hardware Instructions

After unpacking the TWR-FRAM Kkit, notice the “RAMTRON” printing on the TWR-FRAM. This is the
primary side of the board and should be connected to the Primary Elevator. If the jumpers have not
been changed, it is suggested to place the board on the top level of the elevator.

Battery clip
(3V battery included) 256-Kb I?C Serial F-RAM

1-Mb SPI
Serial F-RAM 4-Mb Parallel
F-RAM
256-Kb 8-bit nonvolatile
RGN .. . : 0. ."0". .o 1.9 g GPIO State Saver
Processor A bbi i S it M S ol
Companion Sl - - \ e

RVAHTRDM» § E— .
T Primary (Functional)
_ Connections

256-Kb I°C RTC/ 256-Kb SPIRTC/
Processor Companion  Processor Companion

Go ahead and construct the Tower System. Make sure to connect the primary side of all the Tower
modules to the primary elevator. The primary side of each board is indicated by the white line along
the connector (this can be seen below the RAMTRON label in the picture above). The primary elevator
is indicated by white PCl connectors.
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Assembled TWR-FRAM Memory Module with Freescale Tower System
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4 Jumper Instructions and Table
This section provides the jumper table and configuration instructions to interface with demo
software.

4.1 Jumper Instructions

The TWR K53N512 has multiple channels for 12C and SPI communication and there are jumpers
on the TWR-FRAM to allow for all possible communication channels. The demo software
communicates via 12C0 and SPI0 channels.

For 12CO (Elevator pins B50 and B51) : Set J12 and J13 to 2-3
For SPIO (Elevator pins B44, B45, B46 and B48): Set J4, J7, J8, J10 to 2-3

To enable FM33256 and disable FM25V10: Set J32 to 1-2 and J38 to 2-3

A-pin jumper

3-pin jumper

B-pin jumper

2
> -
= 4
-
2
o
=
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4.2 Jumper Table

Jumper Option Type Setting Description
J1 DSPI Voltage 4-pin 1-2 DSPI voltage 1.6V

2-3 DSPI voltage 3.0V

*3-4* DSPI voltage 1.8V

12 VTWR Voltage 4-pin 1-2 VTWR voltage 5V
*3-4* VTWR voltage 3.3V

J3 DSPI PWR 4-pin 1-2 /SHDN DSPI via pin B22
*3.4% /SHDN DSPI via pin A35

J4 SPI MISO 6-pin 1-2 Connect to pin B11

*2-3*% Connect to pin B44

4-5 Connect to pin B56

J5 DSPI D1 6-pin 1-2 Connect to pin B11

*2-3% Connect to pin B44

4-5 Connect to pin B56

J6 DSPI DO 6-pin 1-2 Connect to pin B10

*2-3* Connect to pin B45

4-5 Connect to pin B57

17 SPI MOSI 6-pin 1-2 Connect to pin B10

*2-3% Connect to pin B45

4-5 Connect to pin B57

J8 SPI SCK 6-pin 1-2 Connect to pin B7

*2-3*% Connect to pin B48

4-5 Connect to pin B58

J9 DSPI CLK 6-pin 1-2 Connect to pin B7

*2-3% Connect to pin B48

4-5 Connect to pin B58

J10 SPI CS 6-pin 1-2 Connect to pin B9

*2-3* Connect to pin B46

4-5 Connect to pin B47

5-6 Connect to pin B55

J11 DSPI CS 6-pin 1-2 Connect to pin B9

*2-3% Connect to pin B46

4-5 Connect to pin B47

5-6 Connect to pin B55

J12 12C SCL 6-pin 1-2 Connect to pin A7

*2-3*% Connect to pin B50
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4-5 Connect to pin B57
J13 12C SDA 6-pin 1-2 Connect to pin A8
*2-3% Connect to pin B51
4-5 Connect to pin B56
J14 INTERRUPT 6-pin 1-2 Connect to pin B58
*2-3* Connect to pin B56
4-5 Connect to pin B62
J15 RESET 6-pin 1-2 Connect to pin A62
*2-3% Connect to pin A47
4-5 Connect to pin A63
116 State Saver Enable 3-pin *1-2% Connects EN pin to B35
2-3 Connects EN pin to gnd
J17 FM31L278 RESET 3-pin 1-2 Connects to RESET jumper
*2-3% Disconnects pin from RESET jumper
J18 FM31L278 PFO 3-pin 1-2 Connects to INTERRUPT jumper
*2-3% Disconnects pin from INTERRUPT jumper
J23 FM31T378 RESET 3-pin 1-2 Connects to RESET jumper
*2-3* Disconnects pin from RESET jumper
124 FM31T378 INT 3-pin 1-2 Connects to INTERRUPT jumper
*2-3% Disconnects pin from INTERRUPT jumper
J25 FM31T378 FOUT 3-pin 1-2 Connects to INTERRUPT jumper
*2-3* Disconnects pin from INTERRUPT jumper
J26 FM31T378 PFO 3-pin 1-2 Connects to INTERRUPT jumper
*2-3* Disconnects pin from INTERRUPT jumper
132 FM33256B /CS 3-pin 1-2 Disconnects from SPI CS jumper
*2-3% Connects pin to SPI CS jumper
J33 FM33256B ACS 3-pin 1-2 Connects to INTERRUPT jumper
*2-3% Disconnects pin from INTERRUPT jumper
J36 FM33256B PFO 3-pin 1-2 Connects to INTERRUPT jumper
*2-3* Disconnects pin from INTERRUPT jumper
137 FM33256B RESET 3-pin *1-2%* Connects to RESET jumper
2-3 Disconnects pin from RESET jumper
J38 FM25V10 /CS 3-pin 1-2 Connects to SPI CS jumper
*2-3% Disconnects pin from SPI CS jumper
Enables '138 decoder to drive chip
Jae FM22L16 SELECT 3-pin *1-2% enables to FM22L16 devices
Disables '138 decoder from driving chip
2-3 enables to FM22L16 devices
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5 Software Instructions

5.1 IAR Embedded Workbench for ARM
To develop on and access the IAR project demos built for the TWR-K53N512, it is necessary to

download IAR Embedded Workbench for ARM.

Note: Please check that you have the latest version of IAR Embedded Workbench for ARM
installed (i.e. these projects were developed on version 6.4 and are confirmed to NOT work
on version 6.1).

Go to IAR home website (www.iar.com) under the “Software Download” section and download
IAR Embedded Workbench for ARM processors.

Follow the instructions of the install executable.

5.2 Keil pVision4
To develop on and access the Keil project demos built for the TWR-K53N512, it is necessary to
download Keil puVision4.

Note: Please check that you have the latest version Keil pVision4 for MDK-ARM installed.

Go to Keil home website (www.keil.com) and select “Product Downloads” under the “Software
Downloads” section. Download Keil MDK-ARM.

Follow the instructions of the install executable.

You will also need to download and install the Freescale Kinetis OSJITAG drivers for Keil.
(http://www.keil.com/download/docs/408.asp)

5.3 PE Micro OSBDM Virtual Serial ToolKkit

This package is used mainly for the drivers to interface with the OSJTAG and its serial terminal
capabilities. A different serial terminal application can be used but it is still necessary to get the
appropriate drivers if it is intended to use the OSITAG.

Go to the PE Micro OSBDM website (www.pemicro.com/osbdm). Download the package by
following the “OSBDM Virtual Serial Toolkit” link. Use the pdf installation instructions for the
drivers and toolkit by following the link “Installation & Operation of the OSBDM”.

TWR-FRAM Quick Start Guide 10



RaEMTRON

5.4 Connect the Tower System to PC
If you have not already, connect the USB cable to the TWR-K53N512 miniUSB port.

If this is the first time you have connected the Tower System with a PC containing updated P&E drivers,
the PC may indicate that the firmware needs to be updated (Follow the instructions for the OSBDM
Virtual Serial Toolkit if these have not been installed and updated).

[ 2
B Updating firmware of PAE Interface... |.':'|—EII$J

Interface hardware detected with old firmware.
Updating... (Please Wait)

Current Firmware: 29.07
Update Firmware: 30.21

Verifving MCU flash bytes at Address S00004660 : Success.

b

Once the system is connected, the onboard demo should be running.
Go to Start -> All Programs -> P&E OSBDM OSJTAG Virtual Serial Toolkit ->Utilities->Terminal Utility

Make sure the settings are:

Port: <appropriate COM> (“USB COM” works on this PC)
Baud: 115200

Parity: None

Bits: 8

Click “Open Serial Port” and text should appear below the button saying “Open.”

At this point, everything necessary to interface with the demos should be available.

TWR-FRAM Quick Start Guide 11
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6 Demo Instructions for IAR
The demo software can be downloaded at www.ramtron/go/towerFRAM.com . Unzip

“TWR_FRAM_demos”. The directory structure is as follows:

. TWE_FR&M_demos
. build
| iar
. config files
J hello_world
| i2c_mem
| parallel_mem
| spi_mem
| statesawver
| SIC
| commaon
| cpu
J drivers
| platforms

| projects

Inside the build folder, this contains the IAR workspaces for each project. The src folder contains the
source files for the projects.

TWR-FRAM Project Descriptions:
SPI_mem — provides example code for interfacing with the F-RAM SPI devices FM33256B and

FM25V10. For the processor companion part (FM33256B), the code will activate the RTC, set the time
and date, read from the event counters, and write data to the memory.

NOTE: The SPI_mem project can only interact with one SPI device at a time. By default, the
program in interface with the processor companion (FM33256B). To interface with the FM25V10,
comment the define for the FM33256B and uncomment the define for FM25V10 (like shown below).
Then, recompile the project.

#include "k53_spi.h"
J/available devices

//define FM33256B
#define FM25V10

12C_mem — provides example code for interfacing with the F-RAM 12C devices FM31T378,
FM31256, and FM24W256. For the processor companion parts (FM31T378 and FM31256), the code will
activate the RTC, set the time and date, read from the event counters, and write data to the memory of
all 3 components.

statesaver — provides example code of interfacing with the FM1106 devices. The state savers
are connected to LEDs and the project will light a pattern by controlling the FM1106.

parallel_mem — provides example code of interfacing with the FM22L16 devices.

TWR-FRAM Quick Start Guide 12
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6.1 Running the demo

1. StartlAR
a. Start -> All Programs -> IAR Systems -> IAR Embedded Workbench for ARM -> IAR
Embedded Workbench

. 1-Zip -
. Accessories
. Autoltv3
. Carrera
. Cisco Systems VPN Client
, DW WLAN
. Freescale CodeWarrior
. Freescale Medical GUI
. Freescale MQX 38 [
, Games
. HI-TECH Software
J LAR Systems
@ IAR Systems License Activation
@ AR Systems License Manager
. IAR Embedded Workbench for ARM
% IAR Embedded Warkbench
| IAR Product Information Log File

m

a Release notes (English)
é_] Release notes (Japanese)
, IAR Embedded Workbench for STMi
, iTunes

. Maintenance

. Microchip

. Microsoft Office

. Microsoft Silverlight

. Microsoft Silverlight 3 SDK
. Microsoft SQL Server 2008

. Microsoft Sync Framework -

1 Back

| Search programs and files 02 |

2. Open the demo workspace
a. File-> Open ->Workspace...
b. Go to the desired project under {unzip directory}/TWR_FRAM_demos/build/iar/
c. Open the IAR IDE Workspace in the project folder

TWR-FRAM Quick Start Guide
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ge' Open Workspace g

{ : ) _ % build » iar » statesaver » - |‘, ‘ Sedich statesaver 2 |
Organize = MNew folder fiagw @
S Favortes MName Date moedified Type

B Desktop . RAM_128KB 6/12/2012 8:38 AM File folder
& Downloads | settings 6/12/2012 8:38 AM File folder
| Recent Places (A statesaver 5/8/2012 413 PM IAR IDE Work

- Type: IAR IDE Workspace
= Libraries Size: 174 bytes
Date modified: 5/8/2012 4:13 PM

Lol Computer
& Local Disk ()

eb MNetwork

4 . ] »

File name: - [Workspac_e Files (*.eww) ']

[ Open Iv] [ Cancel I

3. Rebuild and Execute in debugger
a. Select: Project-> Rebuild All
b. Select: Project -> Download and Debug
i. 1AR may ask for a changed reference for the “crt0.s” assembly file. Direct it
towards the crt0.s file located:
{unzip directory}/TWR_FRAM_demos/src/cpu/crt0.s

TWR-FRAM Quick Start Guide
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% statesaver - IAR Embedded Workbenchvll.i')ﬂm - -— -
File Edit  View Project Debug Disassembly JTAG Tools Window Help )
D@ & i@l | eI r e EH YRS DD
Sl d X
L = |M(53]Zlc|crm|uart|start|mmon|k53_mwer|pmtf|io|pmc|sm|sysinit
RAM_128KE T void main (void)
i £ B, {
Files & & E SHAFRE
B [ statesaver_k... v = for{int v = 0; ¥<5; w++){
[ comman init GPIO();
[ drivers
[ = printf{"\nTurn on LEDs!!\n");
@ [ plattarrms //emulates a clock tick
I—E[:Iprojed GPIOC PTOR = (1 << 5SS CLK SHIFT); //Inverts output (0 -> 1 or1 -> 0)
| I— isrh pause{DEL:jv e
ate S aaT GPIOC_PTO Get Alternative File
Output
L30utp printf{™of | Could not find the following source file:
| C\Users‘semley'\Desktop  TWR_FRAM_demos'src'cputertls
Ei int
=] {or{:l_n * Suggested altemative:
srinl| | e

GPIOD | =
GPIOD Lsn e Hio

GEIOD ¥ | [ f possible, dont show this dislog again

GPIOE |
GPICE_|

GBIOE_PTOR |= (1 << LED& SHIFT);: !
GPIOE_PTCR |= {1 << LED7 SHIFT);

GPIOE_PTOR |= (1 << LEDS SHIFT);

Sinh = in mhav():
Pl i ]

statezaver_kb3 tower

Log

Thu Sep 06, 2012 14:33:29: Loaded debugees: ENTWR_FRAM_dermosibuildiiarstatesaveBAM_128KB\Exehstatesaver_kB3_tower.out
Thu Sep 06, 2012 14:33:30: CPU reset by debugger.

Thu Sep 06, 2012 14:33:30:

Thu Sep 06, 2012 14:33:30: Software resetwas performed

Thu Sep 06, 2012 14:33:30: Target reset

Debug Log | Build

o

a
Iy
=1

o
o
&

Readwv
c. Select: Debug -> Go

d. Select: Debug -> Stop Debugging (when ready to quit Debug mode)

TWR-FRAM Quick Start Guide 15
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6.2 Creating a New Project
There is an executable called “make_new_project” located in:

{unzip directory}/TWR_FRAM_demos/build/iar/

Run the executable and a terminal opens asking for the name of the new project.

B | CAUsers\jhunter\Freescale\TWR_FRAM_demos\build\iar\make_new_project.exs |ﬂ|&|

cript to create a new project bhased off the hello_world project
Hew project name:

L

Enter the new project name and you will see the directory appear in the build and src folders.

TWR-FRAM Quick Start Guide 16
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7 Demo Instructions for Keil
The demo software can be downloaded at www.ramtron/go/towerFRAM.com . Unzip
“TWR_FRAM_demos”. The directory structure is as follows:

4 | TWR_FRAM_demos

4 . build

> g iar

4 . kel
| i2c_mem

. parallel_mem
| spi_mem
J statesaver

* e SIC

Inside the build folder, this contains the Keil workspaces for each project. The src files are contained in
the build folder for each project as well.

TWR-FRAM Project Descriptions:

SPI_mem — provides example code for interfacing with the F-RAM SPI devices FM33256B and
FM25V10. For the processor companion part (FM33256B), the code will activate the RTC, set the time
and date, read from the event counters, and write data to the memory.

NOTE: The SPI_mem project can only interact with one SPI device at a time. By default, the
program in interface with the processor companion (FM33256B). To interface with the FM25V10,
comment the define for the FM33256B and uncomment the define for FM25V10 (like shown below).
Then, recompile the project.

#include "k53 _spi.h”

Slavailashle devices
f/define FM33256B
#define FM25V1O0

12C_mem — provides example code for interfacing with the F-RAM 12C devices FM31T378,
FM31256, and FM24W256. For the processor companion parts (FM31T378 and FM31256), the code will
activate the RTC, set the time and date, read from the event counters, and write data to the memory of
all 3 components.

statesaver — provides example code of interfacing with the FM1106 devices. The statesavers
are connected to LEDs and the project will light a pattern by controlling the FM1106.

parallel_mem — provides example code of interfacing with the FM22L16 devices.

7.1 Running the demo
1. Start Keil

TWR-FRAM Quick Start Guide 17
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a. Start -> All Programs -> Keil uVision4

H Adobe Reader X

ﬂ‘!} Apple Software Update
@ Default Programs

@ Desktop Gadget Gallery
% Internet Explorer (G4-bit)
(= Internet Explorer

W Keil uVisiond

& Microsoft SkyDrive
B Movie Maker

® Photo Gallery

&9 Safari

£ Windows Anytime Upgrade
&) windows DVD Maker
E=5 Windows Fax and Scan
5 Windows Live Mail

& Windows Live Messenger
€ Windows Media Center
@ Windows Media Player
1 Windows Update

< XPS Viewer

g 7-Zip

| Accessories

| Autoltv3

2. Open the demo workspace
a. Project-> Open Project
b. Go to the desired project under {unzip directory}/TWR_FRAM_demos/build/keil/
c. Open the pVision4 Project in the project folder

TWR-FRAM Quick Start Guide
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|| Fie Ean  view [Projeet | Fash
B e rlale 6@l A
£ ey Hew Multi Projest Workspace.., I : : .
S EMe 2
Project L
Cloge Project
NEEERTT 7
S5 Seue G Dot ’
Estary  Manage '
] st
& 55 project Select Device far Targel Taigel L',
. or >
[ stante Femove Bem
) Teter & i far Target Target e b 1or1 -2
18] senal
Clean Larget
5 Build target ¥
& Rebuild all target files
& Balh Build.
2 Transiate C | KINETESS12 50 Ca-F7
54 Sing huila
Wil ) KINETES12_
26 KINETESS12, 50 memizc mem,wpro
3 g KINETISS1 250 L L mem.ripeey ¥ i 0N
ez 1 -0
4 ) KINETESS12_5C LR
e X551 ey Br 1 -> Q)
6
7
e
§e Ll (g uvpn)
10 i 9! _ClyiPrag Clgawproy
oL 2 =TT TEDT NNIIITT
199 PTE->FIOR |= (1 €¢ LERG_SATFT):
150
151 clock tick
152 << 3% _CLE SHIFT): //I put { 9 =» L gz 1 <> 0)
153 pause (DELAY_VAL) :
154 PTC-3FTCR = (1 ¢¢ S5 CLK_SHIFT}: //Tnvere: oo 1) le
155 b |
186 | princf("\nDone! 1hn"):
157 while(l):
i Teturn 0F
i5n |y
| [P | & 160 =
H et *
'a‘n]ﬁ-: U] | il .
Build Cutput LR =]
v
Cpen & uvHion urapect Femicro D5 NagMultiik/ Oy

® S

<« build » keil » statesaver

-
Select Project File

R

v [ 44|

Search statesgver

o]

Organize « New folder

= oy

0 @

s

iy Favorites
B Desktop
& Downloads
‘E:-_T\_l Recent Places

4@ SkyDrive

= Libraries
|=_-‘?| Documents
Ji Music
|| Pictures
B2 Videos

m

1M Computer
&, Local Disk [C3)

MName

& statesaver

Date modified

8/6/2012 9:43 AM

L)

Type

u¥isiond Pro

- lPrpjed Files (*.uvproj; *.uvmpw v]

Coem ) |

Cancel ]

3. Make that the debugger is configured for Pemicro OSJtag/Multilink/Cyclone

TWR-FRAM Quick Start Guide
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a. Select: Project -> Options for Target
b. Click Debug Tab
c. Select “Pemicro OSJtag/Multilink/Cyclone” on the right and select “Use:” radio button
d. Click OK
- == B
kd Cptions for Target Target 1' ﬂ
Device I Target l Dutput I Listing I User I CJ'CHI Asm I Linker Debug | Litilties I
™ Use Simulator Settings I| @ se: |F'emic:ro OSJtangurtilink.fC.yclo_li Settings |
[ Limit Speed to Real-Time Altera Blaster Cortex Debugger &
. Stellans ICDI
e - Signum Systems JTAGet — gl
¥ Load Application at Startup W Runto mainf) [~ Load JLINK / | Trace Cortex 7 it
Initizlization File: Initizlizatid ST-Link (Deprecated Version)
= ULINK Fro Cortex Debugger - :
| _] Edit | !.\Dbg_H. MULink Diebugger 3 _I Edt... |
o - e = Silabs UDA Debugger
Restore Debug Session Seftings——————————————— Restore ST Do
¥ Breakpoints ¥ Toolbox ¥ B J
W Watch Windows & Peformance Analyzer W et 5
v Memary Display v Memary Display

CPU DLL: Parameter: Diriver DLL: Parameter:
|SAHMCM3.DLL i-MPU gsmmcma.DLL |—MPU
Diglog DLL: Parameter: Dialog DLL: Farameter:
iDCM.DLL I-pCM'i lTCM.DLL I-pCMd

Ok | Cancel _| Defauts | Help |

4. Rebuild and Execute in debugger
a. Select: Project-> Rebuild all target files
b. Select: Debug -> Start/Stop Debug Session
c. Select: Debug -> Run
d. Select: Debug -> Stop Debugging (when ready to quit Debug mode)

TWR-FRAM Quick Start Guide



