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Introducing the DPS310/368 Kit2Go

Summary of features

Q@ Comlpatible with Arduino IDE - Fast and easy access to measurement
results

@ On-board DPS310/368:
— Pressure operation range: 300 —1200 hPa.
— Temperature operation range: -40 — 85 °C.
— Pressure sensor precision: + 0.002 hPa (or £0.02 m)
— Temperature accuracy: + 0.5°C
— DPS368 is IPx8 certified: Temporary immersion of 50m for 1 hour

@ XMC1100 (ARM® Cortex™-MO0 based)

On-board J-Link Lite Debugger
— Realized with XMC4200 Microcontroller

Power over Micro-USB (Plug&Play)

Sensor measurements available through 12C or SPI interface
ESD and reverse current protection

2x User LEDs

Pin Header 1x9 and 1x8 (Shield2Go form factor)

Pin out on top (head) is directly connected to the pins of the DPS

@

eeeeee

@

Breakable head for individual sensor usage
—  After breaking, head and MCU/Debugger Peripherals can still be used
independently

@ Standard delivery interface mode is I2C
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Introduction

Q)
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The DPS310/368 is a miniaturized digital barometric air pressure
sensor with ultra-high precision (2 cm) and a low current
consumption, capable of measuring both pressure and temperature

Due to the robust package of the DPS368, it can withstand harsh
environments e.g. 50 m under water for one hour (IPx8)

Both pressure sensor elements are based on a capacitive sensing
principle which guarantees high precision during temperature
changes. The small package makes the DPS310/368 ideal for
mobile applications and wearable devices

The internal signal processor converts the output from the pressure
and temperature sensor elements to 24 bit results. Each unit is
individually calibrated and the calibration coefficients calculated
during this process are stored in the calibration registers. The
coefficients are used in the application to convert the measurement
results to high accuracy pressure and temperature values

The result FIFO can store up to 32 measurement results, allowing
for a reduced host processor polling rate. Temperature and
Pressure measurement results are readable through the serial 12C
or SPI interface making it easily and quickly accessible by e.qg.
Arduino IDE or Platform.lO with Arduino Extension

Copyright © Infineon Technologies AG 2022. All rights reserved.
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Link to Datasheet and Product Page

Link to Datasheet and Product Page



https://www.infineon.com/dgdl/Infineon-DPS368-DataSheet-v01_01-EN.pdf?fileId=5546d46269e1c019016a0c45105d4b40
https://www.infineon.com/cms/en/product/sensor/pressure-sensors/pressure-sensors-for-iot/dps368/
https://www.infineon.com/dgdl/Infineon-DPS310-DS-v01_00-EN.pdf?fileId=5546d462576f34750157750826c42242
https://www.infineon.com/cms/en/product/sensor/pressure-sensors/pressure-sensors-for-iot/dps310/
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Board Information &—/

@ Connect the Micro-USB to your PC to power up the Kit2Go. PWR LED
turns green indicating proper power supply

@ Micro-USB delivers 5 V to power-up the Kit2Go. When breaking the board
apply no more than 3.3 V to the DPS

@ Pin out on the bottom (HEAD) is directly connected to the pins of the
DPS310/368

@ |f the head is broken off:
— Two capacitors are connected to the DPS310/368
— MCU and Debugger can still be used
A To use the I12C mode, place a pull-up resistors on the lines between
VDDIO-SDI and VDDIO-SCK (max. 10kQ each)
— Debugger can also be accessed via SV1

\———————

. )
. DPS368

D vooo; s00 (&)
§ MR

@ Software compatible with Arduino and library fully integrated into the
Arduino IDE with help of Infineon’s GitHub page.

Ll >
”1)VDD.L . GND' )

@ Standard delivery of the board (in terms of interface mode) is I12C with
Address 0x77 when the 0 Ohm resistors are soldered as shown on the
right picture

@ Sales Name: KIT_DPS310_2G0O and KIT_DPS368 2GO
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https://github.com/Infineon/XMC-for-Arduino

Kit2Go PCB Details

The

DPS Pressure Kit2Go

Legend

| Information

I12C/SPI Switch

Infineon

MicroUSB Supply

A Labelling of Pins in Datasheet
[/ Pin Number in Arduino IDE
I Physical Pin Number

A Warning

! {lo £

ilofl| X

Configuration for I2C
BN/
B X
Configuration for SPI
[T B=/F o)
AR

I

IFX54211 MBV33

XMC4200 Debugger

Power LED

Debug Pins

XMC1100

@ Additional Information
Not Connected

A Max voltage on any pin
is 4 V.

If board is powered through
3.3V pin, it is not recommended to
power through USB and vice versa

@ LED1 & LED?2 are user LEDs and
correspond to Arduino Pins 14&15
respectively.

@ I2C pull-up resistors are
already integrated.

Vi.i
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e \ 5
Analog AO 13 TR, T2 7 - UART: RX
Analog Al P2.9 o p) L5 ]15I FXI. 6 - UART: TX
12C: SDA/A2 — 11 AXBEHE <. O l4 g P0.15 N lm GPIO
I2C: SCL/A3 10 AZEH 1 0 (13 gro.14 W GPIO
Ground GND i 5 e ]12' R 3 — SPI: SS/PWM3
Power 6 HEERe RN 2 ~ SPI: SCK/PWM2
Interrupt/GPIO3 — 9 7 '. p B A 1 SPI: MOSI/PWM
PWMO 8 8 “ceon! 9 g P0.6 WU SPI: MISO

I AL R

e 07 e B Switch I12C/SPI

" Solder Bridges J1&J2

Ground = 1 ~fKelly - 8 [ - 3 4 - SDI W] SDI
CSBN ,CSBI7( 3.SCK SCK
VDDIO gl VDDIOg 6 2I Solel- 6 — SDO
VDD Wy VDD g 5 1 g GND Wi Ground

- DPS368
or
DPS310

www.infineon.com
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Board Schematic (XMC2Go related) ({nfineon

Power Supply
WV

XMC Debugger []

pa—
P0.8 | | d
S0 " not powere
PO.6 T |,.-— '
PO.5 T

owered
OF ot

IC201 IFX54211 MBV33

OUT |-

(T8 ]
|
[t
c20 IIﬁuFIDlDB _Ii

100nF /0402
c201
g B

'é' % PO.3 T
- = pQ.2 48 DEBUG_LED#
14 0.1 =
Q P0.0 2
i GND
GND GND
LEDs
@ The Infineon DC-DC converter transforms the 5 V of the T LED2 %\Z e
Micro-USB to 3.3 V for the MCU, Debugger and EERVES LEDL %T RT/0603

Peripherals circuits

@ The green PWR LED indicates a proper power supply for
the Kit2GO

@ The 2 green User-LEDs (LED1 -> P1.0 and LEDZ2 ->P1.1)

might be configured separately by pulling-up the according
GPIOs

R1 — 680R/0402

‘ LI
| | R2 680R/0402

Q
Z
o
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Board Schematic (DPS310/368 related) (afineon

SPI/I*C Selection Circuit

L3% 3
SDI
28
10k 30 1%
pcspa | R | B SPT MOSI
OB 150W/ 5% ORS00V /3%
+3V3
SCK
15
10k 50W/ 1%
I2C SCL EL2 B2 sPI 8CK
OB150W 5% OBU 150V 5%
INT/GPIO3 | t] = $DO
@
] " Fl1 K13
_ ”ICID* R, | BB SPIMISO
[% DR/ 150W/ 5% OB 150W 5%
100k/50V/1% o
Qal
GMD
T
SPI CS N c-\
i
3
Rls R4 10k/50W 1%
—| 1+ 1}
OR/150V/5% OR/150V/5%
@
Qal
CSE N
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Circutt, if the head

DPS310/368 1s broken off
Power Supply Decoupling Shield2Go Head
%iﬂnf - 1 [ 5 DD
i@ DPS310/368 J 2CDE ‘; _%
e AldRUCe S | D10 GND [ SDI 4 8
.jonf — _ S vop oo M I 1 l
Default Mode (0Q-Resistors R711,R12,R13 and R14 soldered):

12C with optional interrupt

Secondary Mode (0Q-Resistors R21,R22,R23 and R24 soldered):
SPI1 4-Wire

J1 Jumper: If soldered, enables the pull-down resistor on the
interrupt pin and changes the 12C address from 0x77 to 0x76

J2 Jumper: If soldered, connects the INT/GPIO3 pin

Copyright © Infineon Technologies AG 2022. All rights reserved.



Arduino: The Arduino IDE (Infineon

_ Arduino is a hardware-software prototyping
Arduino IDE environment IDE developed by arduino.cc:

— |nstallation Details for Windows:
Click here

— Installation Details for Linux:
Click here

— Installation Details for Mac OS:
Click here

ARDUINO

— Installation Details for Portable IDE:
Click here

Arduino Quick Start
— What is Arduino? Click here

11/2/2022

Extended information about the Arduino environment.

Click here

How to import libraries? Click here

How to install additional boards? Click here

Problems related to Arduino? Click here for troubleshooting

Copyright © Infineon Technologies AG 2022. All rights reserved.


https://www.arduino.cc/en/Guide/Windows
https://www.arduino.cc/en/Guide/Linux
https://www.arduino.cc/en/Guide/MacOSX
https://www.arduino.cc/en/Guide/PortableIDE
https://www.arduino.cc/en/Guide/Introduction
https://www.arduino.cc/en/Guide/Environment
https://www.arduino.cc/en/Guide/Libraries
https://www.arduino.cc/en/Guide/Cores
https://www.arduino.cc/en/Guide/Troubleshooting

SEGGER J-Link

11/2/2022

In order to use and program the Infineon XMC
microcontroller in the Arduino IDE, SEGGER J-Link must
be installed on your PC

Please follow this link to SEGGER J-Link and install the J-
Link Software and Documentation Pack for your operating
system

The XMC-for-Arduino installs the XMC Flasher tool used
to flash the compiled firmware (.hex) into the XMC device,
which requires Java(TM) SE Runtime Environment to
be installed in the host system. Click here to download.

Open the Arduino IDE
Navigate to File=>Preferences

Paste the following URL into the 'Additional Boards
Manager URLSs' input field:
https://github.com/Infineon/Assets/releases/downloa
d/current/package_infineon_index. json

@ DP5_Kits2Ge | Arduine 1.8.19 — O
File Edit Sketch Tools Help

MNew Ctrl+M

Open... Ctrl+0

Open Recent

Sketchbook

Examples b

Close Ctrl+W

Save Ctrl+5

Save As... Ctrl+5hift+5

Page Setup  Ctrl+5Shift+P » here, to run once:

Print Ctrl+P

Preferences  Ctrl+Comma

(infineon

Preferences

Settings  Metwork

Sketchbook location:

Editor language: System Default + | (requires restart of Arduino)

Editor font size: 14

Interface scale: Automnatic | 100 5 % (requires restart of Arduino)

Theme: Default theme - | (requires restart of Arduino)
Show verbose output during: [ compilation  [_] upload

Compiler warnings: MNone
[[] pisplay line numbers [[] Enable Code Folding
Verify code after upload

Chedk for updates on startup

[] use external editor
Save when verifying or uploading
[[] Use accessibility features

C:\Users), ‘AppData'Local\arduino 15Ypreferences. tut

-

-_—

0K

Browse

Cancel

Copyright © Infineon Technologies AG 2022. All rights reserved.



https://www.segger.com/downloads/jlink
https://www.java.com/en/download/
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Setup Arduino IDE - Board

&) DPS_Kits2Go | Arduino 1.8.19 — Oa *
File Edit Sketch Tools Help

Auto Format Ctrl+T
Archive Sketch
DPS_Kits2Go Fix Encoding & Reload

Open the Arduino IDE
Navigate to Tools=>Board=>Boards Manager... o ”

Type in “xmc*” and install Infineon‘s XMC Microcontroller T

void setup(]

BO a rd S o 1 Board: "Arduino Mega or Mega 2560" ; Boards Manager...
f/ put yo

Processor "ATmega236l (Mega 2560)" 3 Arduino AVR Boards *

After installation navigate to Tools=>Board=>XMC Family and | MChmly
select XMC1100 XMC2Go O borisMumager I | x

Type |All w | | HmC

O 6 6

Infineon's XMC Microcontroller ~

by Infineon Technologies AG version 1.4.0 INSTALLED

Boards included in this package:

XMC1100 Boot Kit, XMC1100 XMC2Go, XMC1100 H-Bridge 2Go, XMC1300 Boot Kit, XMC1300 Sense2Gol, XMC4700 Relax Kit,
¥MC4700 DEMO Radar BE.

Online Help
More Info

Select version « Install Remaove

&) DPS368_Kit2Go | Arduino 1.8.19 = O *
_File Edit Sketch__TooIs_ Hel_p

Auto Format Ctrl+T

Archive Sketch

Fix Encoding & Reload

Manage Libraries... Ctrl+Shift+| 7
Serial Monitor Ctrl+Shift+M

Serial Plotter Ctrl+Shift+L

WiFi101 / WiFiNINA Firmware Updater

Board: "XMC1100 XMC2Go" ¢ Boards Manager...

id loop ()
// put yoy s
- T Serial Output Selection: "PC" q Arduino AVR Boards  *
Port 1 HMC Famnily | XMC1100 Boot Kit
Get Board Info i [®  XMC1100 XMC2Go
XMC1100 H-Bridge 2Go
Programmer >
Biin Bootioaer AMC1300 Boot Kit
XMC1300 Sense2Gol

DEMO Radar BB XMC4700
AMC4700 Relax Kit

11/2/2022 Copyright © Infineon Technologies AG 2022. All rights reserved.




Setup Arduino IDE - Library

For the DPS310:

Navigate to Sketch=>Include Library=>Manage Libraries...

Type “dps”in the search bar

Install “DigitalPressureSensor” by Infineon Technologies
Alternative:

O Visit our GitHub Repository and download the library as a .zip file

Navigate to Sketch=>Include Library=>Add .ZIP Library... and add the
recently installed library

For the DPS368:
O Visit our GitHub Repository and download the library as a .zip file

Navigate to Sketch=>Include Library=>Add .ZIP Library... and add the
recently installed library

Note
Regularly check your installed libraries for updates

O In case of problems, please visit the corresponding GitHub Repository
and open an issue to get further help

11/2/2022
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@ Library Manager
y g

Type Al « | Topic | All w | |dps

Blues Wireless Notecard Pseudo Sensor

by Blues Wireless

Sensor class used for Notecard testing and examples. NotecardPseudoSensor provides an API interface in the internal sensors
of the Notecard. The geal is to enable focus on other Notecard transactions, by abstracting this interaction with the Notecard.
Mare info

DigitalPressureSensor

by Infineon Technologies Version 1.0.7 INSTALLED
This library provides an Interface for Infineon's DP53210 Pressure Sensor. The DPS series are highly-sensitive pressure
ensors (with temperature compensation) that can be connected via SPI or I2C.

More info )
& Infineon / DPS368-Library-Arduino  Public

Select version

<> Code (© lssues 3 11 Pull requests () Actions [ Projects [ wiki @ Security |22 Insig
¥ dp: Pt 1
d. m updati yth Giope

[} LICENSEmd
[} READMEmd
[3 keywords.txt
[ libraryjson

3 livrary.properties

ng build status to
Preparing relea DPS3
Preparing relea DPS36
updated the version of the library
Flle Edit | 3Ketch | loocls Help
Verify/Compile Ctrl+R
Upload Ctrl+U
DFS38 Upload Using Programmer  Ctrl+Shift+ L)
void s

Export compiled Binary Ctrl+Alt+5

/i p
Show Sketch Folder Crl+ K

Include Library

Manage Libraries...

Add File...
Add .ZIP Library...

id loop() {
S/ put your main code here, to run rg Arduino libraries
Bridge
EEPROM
Esplora
Ethernet
Firmata
G5M
HID
Keyboard

Copyright © Infineon Technologies AG 2022. All rights reserved.
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https://github.com/Infineon/DPS368-Library-Arduino
https://github.com/Infineon/DPS310-Pressure-Sensor

Infineon

Example with DPS368 Kit2Go

(&) DPS388_Kit2Go | Arduine 1.8.19
File Edit Sketch Tools Help

@ Connect the DPS368 Kit2Go to your Computer via e )
Micro-USB o >
Close Crl+W ﬂ?:DispIa}r . Serial
::As... E:lr:zhifns Htrings ’ Mor:itor
After having installed the DPS368 library and the sy S | g s ’ "

11.Arduin

XMC Family boards, navigate to File=>Examples 1@ scnvagomay - o

Examples
Sketch Tools Hel_p_

P IZ:50:30.527 —>

14:50:40.527 -> 16 temperature values found:

= ) 14:50:40.527 -> 29.80 degrees of Celsius

Esplora ¥ i2¢_hackgroun o _ ]
14:50:40.574 -»> 29.79 degrees of Celsius

PiCk the example you Iike (depending On your IZC/SPI Ethernet pinclude <ops3es.n> " 14:50:40.620 —> 20.78 degrees of Celsius

Fitiniata - [P — 14:50:40.620 -»> 29.8]1 degrees of Celsius
Dps368 Opjec

configuration) and click on the upload Button (make 500 e 2060 e o civo

Cuit Ctri+ 0 Adafruit C}
' Bridge

LiquidCry 14:50:40.715 -» 28.82 degrees of Celsius

] Robot Col ;:ij Aceup] 14:50:40.715 -> 29.81 degrees of Celsius

Sure Oar IS O , 14:50:40.761 -»> 28.82 degrees of Celsius
o Gerial.begn 0E00); 14:50:40.807 —> 20.83 degrees of Celsius

5D MRS 14:50:40.807 —> 29.82 degrees of Celsius

Servo 14:50:40.854 -> 29,82 degrees of Celsius
Call in to initialize Dps368PressureSensor )
e //Call begin to initialize Dps3G8PressureSens 14:50:40.854 —> 20.82 degrees of Celsius
{ T rametar 0x76 i he b ddve The d 1 de o ]
pacenrey //The parameter 0x76 is the bus address. The default ad 14:50:40.901 —> 20.83 degrees of Celsius

SeleCt the related COM port from TOO/S=>P0rt and R Stepper //Dps3€5PressuraJensor.begin Wiz, 0x7€); 14:50:40.901 — 20,83 digreen:of Celaius

//Use the commented line kel instead to use the defaul

open the serial monitor with the set baud rate (see i 3¢ s o
sketch/code with Serial.begin(<baud rate>);) G ‘S e

Softwares 14:50:41.083 -> 96215.35 Pascal

<p| o 14:50:41.083 -> 96215.39 Pascal
y 14:50:41.083 -> 96215.52 Pascal
° . Wire T 14:50:41.111 > 96215.48 Pascal
@ Follow the same steps for the DPS310 Kit2Go A -
Examples [¥] Autoscroll [] Show timestamp Newlne | |9600baud
DigitalPressure5ensor 2|
DPS268 Barometric Pressure Sensor : i2c_background

iZc_command

iZc_interrupt

spi_background

spi_command

spi_interrupt

11/2/2022 Copyright © Infineon Technologies AG 2022. All rights reserved.
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\ Important Warning

NOT
POSSIBLE
A Again, the DPS310/368 has a
maximum rating of 4 V ST
A Third party boards with 5 V logic, e.qg. :

-----
-----
-----

the Arduino Uno, Calillionoel

i = o8
sy b\l S .
nE S
LR KSP w2 TXOR D
4s 2  u i RXO 40
.. o
.. .
P B, . A A BN A R A (IR AT S B SO A
— = ]

power is connected to the 3.3 V pin
as the interface lines, e.g. SDA/SCL,
will still be driven by 5V

A Please use appropriate level shifting
for these boards

LEVEL SHIFTER eof tassslassss g
Gy oaay o

11/2/2022 Copyright © Infineon Technologies AG 2022. All rights reserved.
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1 2 3 4 5 6 7 8
DPS310.SchDoc
Connection Ports
SPI .
SPL_MOSI Modular S2G1_Pinout
SPI MOSI = — i
iSO - SPL MISO A
o i LbAe P0.9 — Szls N SPI >
SCK SPL SCK 2C SDA £2:10 P2.10 | N
—~ ‘ P0.8 P0.8 SCK
SCL = P2.11
25 2C SDA oo P0.6 Ho(d MISO
SDA = .
12C 2C SCL P0.7 = MOSI
SCL =
INT/GPIO3 INT/GPIO3 L
SPI1/12C Selection Circuit DPS310
+3V3 .
SDI Power Supply Decoupling
10k/50V/1% +3V3 +3V3 B
12C_SDA R21 SPI_MOSI —[
OR/150V/5% OR/150V/5% _SDI 3 SDI VDDIO |6 YDDIO
SCK 4 SCK VDD 8 VDD
+3V3 SDO 5 iC4 C5
SCK SDO | 0.10u/6.3Vde _ 0.10u/6.3Vdc
CSB N CSB_N ggg i
29 —
10k/50V/1% DPS310
I2C_SCL R12_ R22  gp] SCK
— . —  E—
OR/150V/5%  OR/150V/5% GND GND GND GND
INT/GPIO3 1 I%I 2 SDO
Solder Jumper 2 Pins
1 fj 2 RI3 R23  SPI_ MISO Shield2Go Head
— — C
Solder Jumper 2 Pins OR/150V/5% OR/150V/5%
4
100k/S0V/1%
S2G_2A
GND L[ —15 vbD
2 | "6 VDDIO
SCK 31 17
+3V3 SDI__ 4 [ 3
SPL CS_N
3 GND GND |
RI4 R24 10k/50V/1%
—
OR/150V/5% OR/150V/5%
CSB_N
Default Mode (ZERO Ohm resistors 11,12,13,14 are soldered) - I?C with Interrupt ——
. . L]
(Optional) Infineon
Secondary Mode (ZERO Ohm resistors 21,22,23,24 are soldered) - SP1 4 Wire - D
Title
. . . . DPS310-PS2GO-Kit
J 1. Jumper - Can be soldered to enable the pull-down resistor on the interrupt pin (thig Variant [N Variations] T p—
will also change the address of the sensor from 0x77 to 0x76) S T Document Nams R TRev
A3 DPS310-PS2GO-Kit V1.0
J2 Jumper - Can be soldered to connect the INT/GPIO3 pin Author: , _
Date: 27.01.2022 Time: 10:50:05 [ SVN Revision: 6a271a99e872f0dfdcd6241b5de]
| Sheet of 2
4 5 6 7 8




1 2 3 4 5 7 8
DPS368.SchDoc
Connection Ports
SPI .
SPL_MOSI Modular S2G1_Pinout
SPI MOSI = — i
iSO - SPL MISO A
o i LbAe [ P09 — Szls N SPI >
SCK SPL SCK 2C SDA £2:10 P2.10 | N
- [ P08 20 SCK
SCL = P2.11
2C - 12C_SDA I P0.6 PO. MISO
E .
12C 2C SCL [ P07 20 MOSI
SCL #¥————————
s INT/GPIO3 |
SPI1/12C Selection Circuit DPS368
+3V3 Power Supply Decoupling
SDI
10k/50V/1% .
12C_SDA R21 SPI_MOSI C5 V3
OR/150V/5% OR/150V/5% {
100nF
+3V3
DPS368
+3V3
SCK C4 zg_glo g VDDIO GND ;
—— VDD  GND
29
10K/50V/1% 100nF CSBN 24 csp N s sor
RI2 R22 SCK 4 SDI 5—5p0 AL
2C_SCL RI2 R2  SpPI SCK GND sck  spo =—SPO  &xp
— —  E—
OR/150V/5%  OR/150V/5% DPS368
INT/GPIO3 1 I%I 2 SDO
Solder Jumper 2 Pins
1 fj 2 RI3 R23  SPI_MISO Shield2Go Head
— — C
Solder Jumper 2 Pins OR/150V/5% OR/150V/5%
4
100k/S0V/1%
S2G_2A
GND L[ —15 vbD
2 | "6 VDDIO
SCK 31 17
+3V3 SDI__ 4 [ 3
SPL CS_N
3 GND GND |
RI4 R24 10k/50V/1%
—
OR/150V/5% OR/150V/5%
CSB_N
Default Mode (ZERO Ohm resistors 11,12,13,14 are soldered) - I?C with Interrupt ——
. . L]
(Optional) Infineon
Secondary Mode (ZERO Ohm resistors 21,22,23,24 are soldered) - SP1 4 Wire - D
Title
. . . . DPS368-PS2GO-Kit
J 1. Jumper - Can be soldered to enable the pull-down resistor on the interrupt pin (thig Variant [N Variations] T p—
will also change the address of the sensor from 0x77 to 0x76) S T Document Nams R TRev
A3 DPS368-PS2GO-Kit V1.0
J2 Jumper - Can be soldered to connect the INT/GPIO3 pin Author: , _
Date: 27.01.2022 Time: 10:42:22 [ SVN Revision: 6a271a99e872f0dfdcd624 |b5de|
| Sheet of 2
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1 2 3 4 5 6 7 8
On-board Debugger including a UART to USB Bridge
[ ]
+3V3
Configure wiggler-P0.5 as USIC Tx but only active while X-spy function is| sel ected
Configure wiggler-P0.4 as USIC_Rx but only active while X-spy function is| selectedy
680R/ 0402
X 1 1 " V m 4 Debug Connection Concept 1101 R101
I n SPI Master  UOCO 21 | o po.s |42 3
SW DI R GPIOP1.3 SWCLK 22 P2'4 P0'7 43 s
P2.10 p2.10 SW IN M SO DX0B- P1. 4 23 szs PD.E 44 ,_%
] P0.8 £0.8 m: S DOUTO- P1. 5 22 P2:2 PO:S 2> R102 |_|1 0OR 0402 TX_XMC4200 =
Pl P2.11 SWOLK CLK_Qur SCLKOUT-P1. 1 25 | opoy po.a |46 ERX*XMCMOO f(’ a8
cs_aut SELQO- P1. 0 26 | oo po.3 47 a4
) 48 DEBUG_LED#
INT/GPIO3 g 0.7 SPI Sl ave UoGt §§ i £
] - CS_IN DX2A- P2. 3 po.0 2
Pi nHeader XMC1100 CLK_IN DX1A- P2. 4 ’
X1 PULL Select GPIOPO.8 Digital 35 R103 ——100R/ 0402 L
ACTIVE SO IETI ( = [ Fis/em ]
P2.7/P2.8 1 P27/P2.8 P26 16 _r2.6 ADC mg |E2
P2.9 2 P2.9 P2.0 AI'N P14.9 p1.2 |38
P2.10 3 P2110 PO 1‘5 p1.1 |39 swWCIk R104 — 100R/ 0402 T
P2.11 I P0.14 UART2 (DM2) U1CO P10 |40 —
GND 5 GND Pi) 9 RXD RXD DX0A- PO. 4 )
+3v3 6 +3V3 P0-8 XD TXD DQUTO- PO. 5 P |28
P0.0 7 PO.O P0‘7 TX_ENABLE GPI O PO. 7 “4'8 20 COMLED
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	NetIC101_43
	Pins
	IC101-43


	NetIC101_44
	Pins
	IC101-44


	NetIC101_45
	Pins
	IC101-45
	R102-1


	NetIC101_47
	Pins
	IC101-47


	NetLED1_C
	Pins
	LED1-C
	R1-2


	NetLED2_C
	Pins
	LED2-C
	R2-2


	NetLED101_A
	Pins
	LED101-A
	R101-2


	NetX101_4
	Pins
	X101-4


	P0.0
	Pins
	IC1-15
	X1-7

	NetLabels
	P0.0
	P0.0
	P0.0

	Ports
	P0.0


	P0.5
	Pins
	IC1-16
	X1-8

	NetLabels
	P0.5
	P0.5


	P0.6
	Pins
	IC1-17
	X1-9

	NetLabels
	P0.6
	P0.6
	P0.6

	Ports
	P0.6


	P0.7
	Pins
	IC1-18
	X1-10

	NetLabels
	P0.7
	P0.7
	P0.7

	Ports
	P0.7


	P0.8
	Pins
	IC1-19
	X1-11

	NetLabels
	P0.8
	P0.8
	P0.8

	Ports
	P0.8


	P0.9
	Pins
	IC1-20
	X1-12

	NetLabels
	P0.9
	P0.9
	P0.9

	Ports
	P0.9


	P0.12
	Pins
	IC1-21
	P1-TP

	NetLabels
	P0.12


	P0.13
	Pins
	IC1-22
	P2-TP

	NetLabels
	P0.13


	P0.14
	Pins
	IC1-23
	X1-13

	NetLabels
	P0.14
	P0.14


	P0.15
	Pins
	IC1-24
	X1-14

	NetLabels
	P0.15
	P0.15


	P2.0
	Pins
	IC1-1
	X1-15

	NetLabels
	P2.0
	P2.0


	P2.6
	Pins
	IC1-4
	X1-16

	NetLabels
	P2.6
	P2.6


	P2.6[0..0],P2.0[0..0],P0.15/SWCLK[0..0],P0.14/SWD[0..0],P0.9[0..0],P0.8[0..0],P0.7[0..0],P0.6[0..0],P0.5[0..0],P0.0[0..0],P2.11[0..0],P2.10[0..0],P2.9[0..0],P2.7/P2.8[0..0]
	NetLabels
	P2.6


	P2.7/P2.8
	Pins
	IC1-5
	X1-1

	NetLabels
	P2.7/P2.8
	P2.7/P2.8


	P2.9
	Pins
	IC1-6
	X1-2

	NetLabels
	P2.9
	P2.9


	P2.10
	Pins
	IC1-7
	X1-3

	NetLabels
	P2.10
	P2.10
	P2.10

	Ports
	P2.10


	P2.11
	Pins
	IC1-8
	X1-4

	NetLabels
	P2.11
	P2.11
	P2.11

	Ports
	P2.11


	Q200
	Pins
	C109-1
	IC101-29
	Q101-3

	NetLabels
	Q200


	SWCLK
	Pins
	IC101-22
	IC101-39
	R104-1

	NetLabels
	SWCLK
	SWCLK


	USBVCC
	Pins
	D101-A
	X101-1

	NetLabels
	USBVCC


	WUSB_DM
	Pins
	IC101-3
	R105-1

	NetLabels
	WUSB_DM


	WUSB_DP
	Pins
	IC101-4
	R106-1

	NetLabels
	WUSB_DP


	WVDDC
	Pins
	C105-1
	C106-1
	C108-1
	IC101-6
	IC101-31

	NetLabels
	WVDDC



	Ports
	INT/GPIO3
	P0.6
	P0.7
	P0.8
	P0.9
	P1.0/LED1
	P1.0/LED1
	P1.1/LED2
	P1.1/LED2
	P1.2/SWCLK
	P1.2/SWCLK
	P1.3/SWD
	P1.3/SWD
	P2.10
	P2.11
	RX_XMC4200
	RX_XMC4200
	TX_XMC4200
	TX_XMC4200





