ANALOG _EVAL- |
DEVICES ADUX1020- EVAL- SDP User S;gz

One Technology Way « P.O. Box 9106 « Norwood, MA 02062-9106, U.SA. « Tel: 781.329.4700 « Fax: 781.461.3113 .
www.analog.com

Evaluating the ADUX1020 Photometric Sensor for Gesture and Proximity

FEATURES

ADUX1020 full configuration
Register level
Parameter level
Graph views
Time seriesview
Gesture recognition view
UDP transfer capability

EVALUATION KIT CONTENTS

ADUX1020-EVAL-MCM standard evaluation board
EVAL-SDP-CB1Z controller board

Mini USB cable

ADDITIONAL EQUIPMENT NEEDED

PCrunning Windows 7 operating system
ADUX1020-EVALZ-LED daughterboard (optional)

ONLINE RESOURCES

ADUX1020 data sheet
Optical Gesture Evaluation Tool

GENERAL DESCRIPTION

The ADUX1020-EVAL-SDP evaluation kit provides users with
asimple means of interfacing with the ADUX1020, collecting
datafrom the ADUX1020, and evaluating gesture recognition
capabilities.

The ADUX1020-EVAL-SDPisakit that includesthe EVAL-
DP-CB1Z and the ADUX1020-EVAL-MCM.

The evaluation kit requiresthe Optical Gesture Evaluation
Tool, which can be downloaded from the ADUX1020-EVAL-
SDP product page, agraphical user interface (GUI) that provides
userswith low level and high level configurability, rea-timedata
analysis, and user datagram protocol (UDP) transfer capability so
theevaluation board can easily interfaceto a PC.

The USB port of the PC powersthe ADUX1020-EVAL-SDP

kit. On-board voltage regulators provide voltage supplies for
the ADUX1020.

Theevaluation board schematicsindicate signal names for easy
identification. For additional information on the functionality of
the ADUX1020, refer to the ADUX1020 data sheet.

ADUX1020-EVAL-SDP EVALUATION KIT PHOTOGRAPH

PLEASE SEE THELAST PAGE FORAN IMPORTANT
WARNING AND LEGAL TERMS AND CONDITIONS.
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EVALLUATION BOARD SCFTWARE QU K START PROCHDURES

INSTALLING THE OPTICAL GESTURE EVALUATION
TOOL

Download the Optical Gesture Evaluation Tool software package
from the ADUX1020-EVAL-SDP product page. Unzip thedown-
loaded software folder, run the enclosed AD|_Optical Gesture
EvaluationTool.exefile, and follow the promptsfor installing
the Optical Gesture Evaluation Tool software (see Figure 2). For
further information, follow the full installation guideincluded
with the Optical Gesture Evaluation Tool softwarein the
downloaded folder.

D Optical Gesture Evaluation Tool w1.5.0 Setup

[E= RER =)

Welcome to the Optical Gesture
Evaluation Tool ¥v1.5.0 Setup Wizard

This wizard will guide you through the installation of Optical
Gesture Evaluation Tool v1.5.0,

It is recommended that wou close all other applications
before starking Setup, This will make it possible to update
relevant syskem files without having to reboot vour
computer.

Click Mext to continue,

Figure 2. Optical Gesture Evaluation Tool Setup
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To start the Optical Gesture Evaluation Tool application,
navigateto the ADI_OpticalGesture EvaluationTool from the
Sart menu and click the ADI_OpticalGesture_EvaluationT ool
icon (seeFigure 3).

Analog Devices
ADL OpticalGesture_EvaluationTool
Adux102x
|: ADL Optical Gesture_Ewvaluatic
{9 Uninstall
Figure 3. Navigate to Optical Gesture Evaluation Tool from Start Menu
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At startup, the Optical Gesture Evaluation Tool application
automatically checksif theinstalled Optical Gesture Evaluation
Tool softwareversion isup to date. If thereisanewer version
available, the user isprompted to download the newest version.

EVALUATION BOARD USB CONNECTION

Ensurethe provided EVAL-SDP-CB1Z controller board and
ADUX1020-EVAL-MCM connect together and connect to a PC
viathe USB cableincluded with the evaluation kit. After the
Optical Gesture Evaluation Tool application opens, click File>
Connect (seeFigure 4) and select SDP ASIC Bridge (Debug).
TheOptical Gesture Evaluation Tool then acknowledgesthe
ADUX1020-EVAL-SDPkit is connected.

[: Optical Gesture Evaluation Tool
File | Yiew  Tools  Help
| Connect v |l SDP ASIC Bridge (Debug)
Disconnect UART AZIC Bridge (Debug)
Cump Register Yiew
Load Cfg
Sawe Cfg Marme
Bpply Config
Exit %

Figure 4. SDP ASC Connection

CONFIGURING THE ADUX1020-EVAL-SDP
EVALUATIONKIT

Before operating the ADUX1020-EV AL-SDP kit, connect any
jumper across Header J7 on the ADUX1020-EVAL-MCM. If
using the ADUX1020-EV ALZ-LED daughterboard, disconnect
the jumper from Header J7.

To operatethe ADUX1020 in gesture detect mode, click File >
Load Cfg. Select the 004_ADUX1020_StandardR1.dcfg file
and click Open (see Figure 5).

Flegarnss 104 AL S ander 52 fy

14766-005

Figure 5. Loading the Configuration File

Next, click View > Off-Chip Analysisand Gesture View to open
the Graph XY] tab (see Figure 6). With the evaluation board
positioned so there areno objects around it within at least 220 cm
radius, click the Channel Auto Calibration button to calibratethe
ADUX1020-EVAL-SDPkit. The Optical Gesture Evaluation Tool
then acknowledgesif calibration is successful.
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GESTURE RECOGNITION
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Figure 6. Running the Channel Auto Calibration

STREAMING DATA

Pressthe Play button to begin streaming data from the evaluation
board. Move an object or hand within 15 cm abovethe
ADUX1020 to see the corresponding output of the device on the
graphs. The Y Ratio vs X Ratio graph showsthe calculated x, y
position of the object above the device (see Figure 7). The Intensity
graph showsthe average intensity of reflected light seen by the
device, represented in ADC codes.
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Figure 7. Graph of Sreaming Data

To view the gesture recognition capability, navigate to the Gesture
Analysis Algorithm tab and select LSLF Swipe determination
from the drop-down menu. Click the Play button if the device

isnot already streaming data.

Move a hand within 15 cm above the device and swipein any of
thefour indicated directions. Alternatively, the center indicator
can be activated by quickly lowering a hand towards the sensor
(see Figure 8).
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Figure 8. Gesture Recognition Algorithm Tab

For more detailed information Optical Gesture Evaluation Tool
and additional features of the software, see the Optical Gesture
Evaluation Tool User Manual, which can be found in the Help
> Help Topicsmenu.
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ACDITIONAL BEVALLATION BOADS

HIGH POWER LED DAUGHTERBOARD

The ADUX1020-EVALZ-LED isan optional daughterboard for
thestandard ADUX1020-EVAL-MCM evauation board. It
functionsas a high-power LED driver intended for gesture
recognition at distances greater than 15cm.

Tousethe ADUX1020-EVALZ-LED, attach it to the
ADUX1020-EVAL-MCM evauation board asshown in Figure 9.
Thedaughter-board connectsto the ADUX1020-EVAL-MCM
viafive pins, labeled on the daughterboard as GND, GND1,
LEDX, 3.3V, and VLED. These pins on the daughterboard plug
into five smilarly spaced test pointson the ADUX1020-EVAL-
MCM labeled o1, JL.2, L3, J.4, and J5. When connecting the
ADUX1020-EVALZ-LED, ensure Header J7 on the
ADUX1020-EVAL-MCM isnot connected, as shown in Figure
9.

Operation and configuration of the ADUX1020-EV AL-SDP with
the ADUX1020-EV ALZ-LED daughterboard followsthe
instructionslisted in the Evaluation Board Software Quick Start
Procedures section.

14766-009

Figure 9. Connecting the ADUX1020-EVALZ-LED Daughterboard
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Figure 10. ADUX1020-EVAL-MCM Evaluation Board Schematic
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Figure 11. ADUX1020-EVALZ-LED High power LED daughterboard Schematic
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ESD Caution
ESD (electrostatic discharge) sensitive device. Charged devices and circuit boards can discharge without detection. Although this product features patented or proprietary protection
‘m circuitry, damage may occur on devices subjected to high energy ESD. Therefore, proper ESD precautions should be taken to avoid performance degradation or loss of functionality.

Legal Termsand Conditions

By using the evaluation board discussed herein (together with any tools, components documentation or support materials, the “Evaluation Board”), you are agreeing to be bound by the terms and conditions
set forth below (“Agreement”) unless you have purchased the Evaluation Board, in which case the Analog DevicesSandard Termsand Conditions of Sale shall govern. Do not use the Evaluation Board until you
have read and agreed to the Agreement. Your use of the Evaluation Board shall signify your acceptance of the Agreement. This Agreement is made by and between you (“Customer”) and Analog Devices, Inc.
("ADI"), with its principal place of business at One Technology Way, Norwood, MA 02062, USA. Subject to the terms and conditions of the Agreement, ADI hereby grantsto Qustomer a free, limited, personal,
temporary, non-exclusive, non-sublicensable, non-transferable license to use the Evaluation Board FOREVALUATION PURPOSES ONLY. Qustomer understands and agreesthat the Evaluation Board isprovided
for the sole and exclusive purpose referenced above, and agrees not to use the Evaluation Board for any other purpose. Furthermore, the license granted is expressly made subject to the following additional
limitations: Qustomer shall not (i) rent, lease, display, sell, transfer, assign, sublicense, or distribute the Evaluation Board; and (ii) permit any Third Party to access the Evaluation Board. Asused herein, the term
“Third Party” includes any entity other than ADI, Customer, their employees, affiliates and in-house consultants. The Evaluation Board isNOT sold to Qustomer; all rights not expresdy granted herein, including
ownership of the Evaluation Board, are reserved by ADI. CONAIDENTIALITY. This Agreement and the Evaluation Board shall all be considered the confidential and proprietary information of ADI. Customer may
not disclose or transfer any portion of the Evaluation Board to any other party for any reason. Upon discontinuation of use of the Evaluation Board or termination of this Agreement, Customer agrees to
promptly return the Evaluation Board to ADI. ADDITIONAL RESTRCTIONS Qustomer may not disassemble, decompile or reverse engineer chips on the Evaluation Board. Customer shall inform ADI of any
occurred damages or any modifications or alterations it makes to the Evaluation Board, including but not limited to soldering or any other activity that affectsthe material content of the Evaluation Board.
Modifications to the Evaluation Board must comply with applicable law, including but not limited to the FoHS Directive. THERMINATION. ADI may terminate this Agreement at any time upon giving written
notice to Customer. Qustomer agreesto return to ADI the Evaluation Board at that time. LIMITATION OF LIABILITY. THE EVALUATION BOARD PROVIDED HEREUNDER IS PROVIDED “AS IS” AND ADI MAKES NO
WARRANTIES OR REPRESENTATIONS OF ANY KIND WITH RESPECT TO IT. ADI SPECIACALLY DISCLAIMS ANY REPRESENTATIONS, ENDORSEMENTS GUARANTEES, OR WARRANTIES, EXPRESS OR IMPLIED,
REATED TO THE EVALUATION BOARD INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTY OF MERCHANTABILITY, TITLE ATNESS FOR A PARTICULAR PURPOSE OR NONINFRNGBVIENT OF
INTELLECTUAL PROPERTY RGHTS IN NO EVENT WILL ADI AND ITS LICENSORS BE LIABLE FOR ANY INCIDENTAL, SPECIAL, INDIRECT, OR CONSEQUENTIAL DAMAGES RESULTING FROM CUSTOMER'S
POSSESSON ORUSE OF THEEVALUATION BOARD, INCLUDING BUT NOT LIMITED TO LOST PROATS, DELAY COSTS, LABORCOSTS ORLOSSOF GOODWILL. ADI'S TOTAL LIABILITY FROM ANY AND ALL CAUSES
SHALL BE LIMITED TO THE AMOUNT OF ONE HUNDRED US DOLLARS ($100.00). EXPORT. Customer agrees that it will not directly or indirectly export the Evaluation Board to another country, and that it will
comply with all applicable United Satesfederal laws and regulationsrelating to exports. GOVERNING LAW. This Agreement shall be governed by and construed in accordance with the substantive lawsof the
Commonwealth of Massachusetts (excluding conflict of law rules). Any legal action regarding this Agreement will be heard in the state or federal courts having jurisdiction in Suffolk County, Massachusetts, and
Qustomer hereby submits to the personal jurisdiction and venue of such courts. The United Nations Convention on Contracts for the International Sale of Goods shall not apply to this Agreement and is
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