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© Cypress Semiconductor Corporation, 2018. This document is the property of Cypress Semiconductor Corporation and its
subsidiaries, including Spansion LLC ("Cypress").  This document, including any software or firmware included or referenced
in this document ("Software"), is owned by Cypress under the intellectual property laws and treaties of the United States and
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applicable law, Cypress reserves the right to make changes to this document without further notice. Cypress does not
assume any liability arising out of the application or use of any product or circuit described in this document.  Any information
provided in this document, including any sample design information or programming code, is provided only for reference pur-
poses.  It is the responsibility of the user of this document to properly design, program, and test the functionality and safety of
any application made of this information and any resulting product.  Cypress products are not designed, intended, or autho-
rized for use as critical components in systems designed or intended for the operation of weapons, weapons systems,
nuclear installations, life-support devices or systems, other medical devices or systems (including resuscitation equipment
and surgical implants), pollution control or hazardous substances management, or other uses where the failure of the device
or system could cause personal injury, death, or property damage ("Unintended Uses").  A critical component is any compo-
nent of a device or system whose failure to perform can be reasonably expected to cause the failure of the device or system,
or to affect its safety or effectiveness.  Cypress is not liable, in whole or in part, and you shall and hereby do release Cypress
from any claim, damage, or other liability arising from or related to all Unintended Uses of Cypress products.  You shall
indemnify and hold Cypress harmless from and against all claims, costs, damages, and other liabilities, including claims for
personal injury or death, arising from or related to any Unintended Uses of Cypress products.
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F-RAM, and Traveo are trademarks or registered trademarks of Cypress in the United States and other countries.  For a more
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Safety Information

Regulatory Compliance
The CY8CKIT-148 PSoC 4700S Inductive Sensing Evaluation Kit is intended for use as a evaluation
platform for hardware or software in a laboratory environment. The board is an open system design,
which does not include a shielded enclosure. This may cause interference to other electrical or
electronic devices in close proximity. In a domestic environment, this product may cause radio
interference. In such cases, you may be required to take adequate preventive measures. In addition,
this board should not be used near any medical equipment or RF devices.

Attaching additional wiring to this product or modifying the product operation from the factory default
settings may affect its performance and cause interference with other apparatus in the immediate
vicinity. If such interference is detected, suitable mitigating measures should be taken.

The PSoC 4700S Inductive Sensing Evaluation Kit, as shipped
from the factory, has been verified to meet with requirements of
CE as a Class A product.

The CY8CKIT-148 PSoC 4700S Inductive Sensing Evaluation Kit
contains electrostatic discharge (ESD) sensitive devices. Electrostatic
charges readily accumulate on the human body and any equipment, and
can discharge without detection. Permanent damage may occur on
devices subjected to high-energy discharges. Proper ESD precautions
are recommended to avoid performance degradation or loss of
functionality. Store unused CY8CKIT-148 PSoC 4700S Inductive
Sensing Evaluation Kit boards in the protective shipping package.

End-of-Life/Product Recycling

This kit has an end-of life five years from the date of manufacture
mentioned on the back of the box. Contact your nearest recycler for
discarding the kit.
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Safety Information

General Safety Instructions

ESD Protection
ESD can damage boards and associated components. Cypress recommends that you perform
procedures only at an ESD workstation. If such a workstation is not available, use appropriate ESD
protection by wearing an anti-static wrist strap attached to the chassis ground (any unpainted metal
surface) on your board when handling parts.

Handling Boards

The CY8CKIT-148 PSoC 4700S Inductive Sensing Evaluation Kit board is sensitive to ESD. Hold
the board only by its edges. After removing the board from its box, place it on a grounded, static-free
surface. Use a conductive foam pad if available. Do not slide board over any surface.
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1. Introduction

The PSoC 4700S Inductive Sensing Evaluation Kit is designed as an easy-to-use and inexpensive
evaluation platform. The PSoC 4700S Inductive Sensing Evaluation Kit supports the PSoC 4700S
device, delivering a complete system solution for a wide range of embedded applications at a very
low cost. The PSoC 4700S device is a true programmable embedded system-on chip, integrating
custom digital peripheral functions, memory, and an ARM® Cortex®-M0+ MCU on a single chip with
flexible automatic routing. The programmable digital peripheral functions allow higher flexibility, in-
field tuning of the design, and faster time-to-market. It is a combination of MCU with standard
communication and timing peripherals, and a inductive sensing system with best in class
performance.

The PSoC 4700S Inductive Evaluation Kit offers a complete solution for Inductive Sensing
Technology with PSoC 4700S device. This kit provides a low-cost alternative to device samples
while providing a platform to easily develop and integrate the PSoC 4700S device into your end-
system. In addition, the board includes the following features:
■ Seven LEDs to provide feedback for 4700S device
■ KitProg2 Status LED and Mode switch
■ Three Inductive Sensing button coils and one Proximity coil for Inductive Sensing evaluation
■ Reset switch
■ USB Type-C Connector
■ 3.3 V operation

The CY8CKIT-148 PSoC 4700S Inductive Sensing Evaluation Kit also integrates a Cypress
KitProg2 that enables onboard programming, debugging, and bridging functionalities, such as 
USB-UART and USB-I2C. 
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1.1 Kit Contents
The PSoC 4700S Inductive Sensing Evaluation Kit contains a PSoC 4700S Evaluation board,
Metal Target, USB Type-A to Type-C Cable and Quick Start Guide. 

Figure 1-1.  CY8CKIT-148 PSoC 4700S Inductive Sensing Evaluation Kit 

Figure 1-2.  Metal Target 
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1.2 PSoC Creator
PSoC Creator™ is a state-of-the-art, easy-to-use integrated design environment (IDE). It introduces
revolutionary hardware and software co-design, powered by a library of pre-verified and pre-
characterized PSoC Components. With PSoC Creator, you can:
1. Drag and drop Components to build your hardware system design in the main design workspace.
2. Co-design your application firmware with the PSoC hardware.
3. Configure Components using configuration tools.
4. Explore the library of 100+ Components.
5. Review Component datasheets.

Figure 1-3.  PSoC Creator Features

PSoC Creator also enables you to tap into an entire tool ecosystem with integrated compiler chains
and programmers for PSoC devices.

For more information, visit www.cypress.com/psoccreator. Visit the PSoC Creator Video Training
Page for video tutorials on learning and using PSoC Creator.

 

www.cypress.com/psoccreator
http://www.cypress.com/?rID=40547
http://www.cypress.com/?rID=40547
http://www.cypress.com/?rID=40547
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1.2.1 PSoC Creator Code Examples
PSoC Creator includes a large number of code examples. These examples are available from the
PSoC Creator Start Page, as shown in Figure 1-4 or from the menu File > Code Example....

Code examples can speed up your design process by starting you off with a complete design,
instead of a blank page. The code examples also show how PSoC Creator Components can be
used for various applications. Code examples and documentation are included, as shown in
Figure 1-5 on page 11.

From the Find Code Example dialog shown in Figure 1-5 on page 11, you can:
■ Filter for examples based on architecture or device family, that is, PSoC 3, PSoC 4, or PSoC 5LP, 

project name, or keyword.
■ Select from the list of examples offered based on the Filter Options.
■ Review the code example’s description (on the Documentation tab).
■ Review the code from the Sample Code tab. You can copy the code from this window and paste 

to your project, which can help speed up code development.
■ Create a new project (and a new workspace if needed) based on the selection. This can speed 

up your design process by starting you off with a complete, basic design. You can then adapt that 
design to your application.

Figure 1-4.  Code Examples in PSoC Creator



CY8CKIT-148 PSoC® 4700S Inductive Sensing Evaluation Kit Guide, Doc. #: 002-23165 Rev. *B 11

Introduction

Figure 1-5.  Code Example Projects with Sample Code

1.2.2 Kit Code Examples
You can access the installed kit code examples from the PSoC Creator Start Page. To access these
examples, expand Kits under Start; then, expand the specific kit to see the code examples. For a list
of code examples that you can use on this kit, see Code Examples chapter on page 28.

1.2.3 PSoC Creator Help
Launch PSoC Creator and navigate to the following items:
■ Quick Start Guide: Choose Help > Documentation > Quick Start Guide. This guide gives you 

the basics for developing PSoC Creator projects.
■ Simple Component Code Examples: Choose File > Code Example. These examples 

demonstrate how to configure and use PSoC Creator Components. To access examples related 
to a specific Component, right-click the Component in the schematic or in the Component 
Catalog. Select Find Code Example in the context menu that appears.

■ System Reference Guide: Choose Help > System Reference Guides. This guide lists and 
describes the system functions provided by PSoC Creator.
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1.2.4 Component Datasheets
Right-click a Component and select Open Datasheet (see Figure 1-6).

Figure 1-6.  Opening Component Datasheet

1.3 Getting Started
This guide will help you get acquainted with the PSoC 4700S Inductive Sensing Evaluation Kit:
■ The Software Installation chapter on page 16 describes the installation of the kit software. This 

includes installation of the PSoC Creator IDE for development and debugging the applications, 
and PSoC Programmer for programming hex files.

■ The Kit Operation chapter on page 22 describes the major features of the PSoC 4700S Inductive 
Sensing Evaluation Kit and functionalities such as programming, debugging, and the USB-UART 
and USB-I2C bridges.

■ The Code Examples chapter on page 28 describes multiple code examples that will help you 
understand how to create your own PSoC 4700S projects.

■ The Appendix chapter on page 35 describes the hardware content of the kit and the hardware 
operation, Kit Schematics, and the bill of materials (BOM).



CY8CKIT-148 PSoC® 4700S Inductive Sensing Evaluation Kit Guide, Doc. #: 002-23165 Rev. *B 13

Introduction

1.4 Additional Learning Resources
Cypress provides a wealth of data at www.cypress.com to help you select the right PSoC device for
your design, and to help you quickly and effectively integrate the device into your design. For a com-
prehensive list of resources, see KBA86521, How to Design with PSoC 3, PSoC 4, and PSoC 5LP.
The following is an abbreviated list for PSoC 4:
■ Overview: PSoC Portfolio and PSoC Roadmap.
■ Product Selectors: PSoC 4 Product Selector. In addition, PSoC Creator includes a device 

selection tool.
■ Datasheets: Describe and provide electrical specifications for the PSoC 4000, PSoC 4100, 

PSoC 4200, PSoC 4100M, PSoC 4200M, PSoC 4200L, PSoC 4100S Plus and PSoC 4700S 
devices.

■ CapSense Design Guide: Learn how to design capacitive touch-sensing applications with the 
PSoC 4 and PSoC Analog Coprocessor family of devices.

■ Inductive Sensing Design Guide: Learn how to design inductive sensing applications with the 
PSoC 4 family of devices. 

■ Application Notes and Code Examples: Cover a broad range of topics, from basic to advanced. 
Many of the application notes include code examples. Visit the PSoC 3/4/5 Code Examples 
webpage for a list of all available PSoC Creator code examples. To access code examples from 
within PSoC Creator, see PSoC Creator Code Examples on page 10.

■ Technical Reference Manuals (TRM): Provide detailed descriptions of the architecture and 
registers in each PSoC 4 device family.

■ Development Kits:
❐ CY8CKIT-041, CY8CKIT-046, CY8CKIT-044, CY8CKIT-042, and CY8CKIT-040 are easy-to-

use and inexpensive development platforms. These kits include connectors for Arduino™ 
compatible shields and Digilent Pmod Peripheral Modules.

❐ CY8CKIT-043, CY8CKIT-049, CY8CKIT-145, CY8CKIT-146, and CY8CKIT-149 are very low-
cost prototyping platforms for sampling PSoC 4 devices.

❐ CY8CKIT-001 is a common development platform for all PSoC family devices.
❐ The MiniProg3 device provides an interface for flash programming and debug.

■ Knowledge Base Articles (KBAs): Provide design and application tips from experts on using the 
device. 

■ PSoC Creator Training: Visit www.cypress.com/go/creatorstart/creatortraining for a 
comprehensive list of video training on PSoC Creator.

■ Learning from Peers: Visit community.cypress.com/welcome to meet enthusiastic PSoC develop-
ers discussing the next-generation embedded systems on Cypress Developer Community 
Forums.

1.5 Technical Support
For assistance, visit Cypress Support or contact customer support at +1 (800) 541-4736 Ext. 3 (in
the USA) or +1 (408) 943-2600 Ext. 3 (International).

You can also use the following support resources if you need quick assistance:
■ Self-help (Technical Documents).
■ Local Sales Office Locations.

http://www.cypress.com/
http://www.cypress.com/?id=4&rID=77024
http://www.cypress.com/?id=4&rID=77024
http://www.cypress.com/psoc
http://www.cypress.com/?rID=86788
http://www.cypress.com/?id=4976
http://www.cypress.com/psoccreator
http://www.cypress.com/documentation/datasheets/psoc-4-psoc-4000-family-datasheet-programmable-system-chip-psoc
http://www.cypress.com/documentation/datasheets/psoc-4-psoc-4100-family-datasheet-programmable-system-chip-psoc
http://www.cypress.com/documentation/datasheets/psoc-4-psoc-4200-family-datasheet-programmable-system-chip-psoc
www.cypress.com/documentation/datasheets/psoc-4-psoc-4100m-family-datasheet
www.cypress.com/documentation/datasheets/psoc-4-psoc-4200m-family-datasheet
www.cypress.com/documentation/datasheets/psoc-4-psoc-4200l-family-datasheet
www.cypress.com/psoc4100splusdatasheet
http://www.cypress.com/?rID=78578&source=an79953
http://www.cypress.com/search/all?f[0]=meta_type%3Atechnical_documents&f[1]=resource_meta_type%3A574&f[2]=field_related_products%3A1297
http://www.cypress.com/search/all?f[0]=meta_type%3Asoftware_tools&f[1]=field_related_products%3A1297&f[2]=software_tools_meta_type%3A579
http://www.cypress.com/?rID=101641
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=117&id=4749&applicationID=0&l=0
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=110&id=4749&applicationID=0&l=0
http://www.cypress.com/CY8CKIT-041
http://www.cypress.com/CY8CKIT-046
http://www.cypress.com/CY8CKIT-044
http://www.cypress.com/cy8ckit-042
http://www.cypress.com/CY8CKIT-040
http://www.cypress.com/CY8CKIT-043
http://www.cypress.com/CY8CKIT-049
http://www.cypress.com/CY8CKIT-145
www.cypress.com/CY8CKIT-146
www.cypress.com/CY8CKIT-149
http://www.cypress.com/go/CY8CKIT-001
http://www.cypress.com/go/cy8ckit-002
https://community.cypress.com/community/knowledge-base-articles
http://www.cypress.com/go/creatorstart/creatortraining
https://community.cypress.com/welcome
http://www.cypress.com/support
http://www.cypress.com/search/all?f%5b0%5d=meta_type%3Atechnical_documents
http://www.cypress.com/?id=1062
www.cypress.com/http://www.cypress.com/psoc4700sdatasheet 
http://www.cypress.com/documentation/application-notes/an219207-inductive-sensing-design-guide 
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1.6 Document Conventions
Table 1-1.  Document Conventions for Guides

Convention Usage

Courier New Displays file locations, user entered text, and source code:
C:\...cd\icc\

Italics Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Creator User Guide.

[Bracketed, Bold] Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open Represents menu paths:
File > Open > New Project

Bold Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman Displays an equation:
2 + 2 = 4

Text in gray boxes Describes Cautions or unique functionality of the product.
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1.7 Acronyms
Table 1-2.  Acronyms Used in this Document

Acronym Description
ADC Analog-to-Digital Converter
BCP Bridge Control Panel
BLE Bluetooth Low Energy
BOM Bill of Materials
CE Code Example
CMOD Modulator Capacitor
CMP Comparator
CTANK Shield tank capacitor
DAC Digital to Analog Converter
DPDT Double-Pole, Double-Throw
ECO External Crystal Oscillator
ESD Electrostatic Discharge
GPIO General Purpose Input/Output
I2C Inter-Integrated Circuit
IDAC Current DAC
IDE Integrated Design Environment
KBA Knowledge Based Article
LED Light-Emitting Diode
PSoC Programmable Systems-on-Chip
SAR Successive Approximation Register
SCB Serial Communication Block
SRAM Static Random Access Memory
SWD Serial Wire Debug
TCPWM Timer, Counter, Pulse Width Modulator
UART Universal Asynchronous Receiver Transmitter
USB Universal Serial Bus
WCO Watch Crystal Oscillator



CY8CKIT-148 PSoC® 4700S Inductive Sensing Evaluation Kit Guide, Doc. #: 002-23165 Rev. *B 16

2. Software Installation

This chapter describes the steps to install the software tools and packages on a PC for using the
PSoC 4700S Inductive Sensing Evaluation Kit. This includes the IDE on which the projects will be
built and used for programming.

Note: Latest MagSense™ component needs to be installed manually before starting any code
example related to Inductive Sensing. Please refer Installing the MagSense Component on page 20
for more details.

2.1 Before You Begin
To install Cypress software, you will require administrator privileges. However, they are not required
to run the software that is already installed. Before you install the kit software, close any other
Cypress software that is currently running.

2.2 Install Software
Follow these steps to install the PSoC 4700S Inductive Sensing Evaluation kit software:
1. Download the PSoC 4700S Inductive Sensing Evaluation kit software from www.cypress.com/

CY8CKIT-148. The kit software is available in three formats for download.
a. CY8CKIT-148 Kit Only: This executable file installs only the kit contents, which include kit 

code examples, hardware files, and user documents. This package can be used if all software 
prerequisites (listed in step 5) are installed on your PC.

b. CY8CKIT-148 Kit Setup: This installation package contains the files related to the kit 
including PSoC Creator and PSoC Programmer. However, it does not include the Windows 
Installer or Microsoft .NET framework packages. If these packages are not on your PC, the 
installer will direct you to download and install them from the Internet.

c. CY8CKIT-148 DVD ISO: This file is a complete package stored in a DVD-ROM image format 
that you can use to create a DVD or extract using an ISO extraction program such as WinZip 
or WinRAR. The file can also be mounted like a virtual CD/DVD using virtual drive programs 
such as Virtual CloneDrive and MagicISO. This package includes all required software, 
utilities, drivers, hardware files, and user documents.

2. If you have downloaded the ISO file, mount it on a virtual drive. Extract the ISO contents if you do 
not have a virtual drive to mount. Double-click cyautorun.exe in the root directory of the extracted 
content or mounted ISO if “Autorun from CD/DVD” is not enabled on the PC. The installation 
window will appear automatically.
Note: If you are using the Kit Setup or Kit Only file, then go to step 4 for installation.

www.cypress.com/CY8CKIT-148
www.cypress.com/CY8CKIT-148
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3. Click Install CY8CKIT-148 Kit to start the kit installation as shown in Figure 2-1.

Figure 2-1.  Kit Installer Screen

4. Select the directory in which you want to install the PSoC 4700S Inductive Sensing Evaluation 
Kit-related files. Click Next.
When you click Next, the PSoC 4700S Inductive Sensing Evaluation kit installer automatically 
installs the required software, if it is not present on your PC. Following are the required software:
a. PSoC Creator 4.2 or later: This software is available for download separately at 

www.cypress.com/psoccreator.
b. PSoC Programmer 3.27.1 or later: This is installed as part of PSoC Creator installation 

(www.cypress.com/programmer).

www.cypress.com/psoccreator
www.cypress.com/programmer
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5. Choose the Typical, Custom, or Complete installation type in the Product Installation Overview 
window, as shown in Figure 2-2. Click Next.
Note: Typical installation is recommended, however you can choose according to your 
requirement.

Figure 2-2.  Product Installation Overview

6. Read the License agreement and select I accept the terms in the license agreement to 
continue with the installation. Click Next. When the installation begins, a list of packages appears 
on the installation page. A green check mark appears next to each package after successful 
installation.

7. Enter your contact information or select the check box Continue Without Contact Information. 
Click Finish to complete the PSoC 4700S Inductive Sensing Evaluation kit installation. 

After the installation is complete, the kit contents are available at the following location:
<Install_Directory>\CY8CKIT-148 PSoC 4700S Inductive Sensing Evaluation 

Kit

Default location:

Windows OS (64-bit):
C:\Program Files (x86)\Cypress\CY8CKIT-148 PSoC 4700S Inductive Sensing 

Evaluation Kit

Windows OS (32-bit):
C:\Program Files\Cypress\CY8CKIT-148 PSoC 4700S Inductive Sensing 

Evaluation Kit

Note: For Windows 7/8/8.1 and later users, the installed files and the folder are read-only. To use the
installer code examples, follow the steps outlined in the Code Examples chapter on page 28. 
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2.3 Installing PSoC 4700S Device in PSoC Creator
Below steps need to be followed in order to install PSoC 4700S device into PSoC Creator.
1. Run PSoC Creator 4.2.
2. Go to Tools > Find new devices in PSoC Creator. The Device Update Installer window will 

pop-up.

Figure 2-3.  Device Update Installer

3. Click on the Install Button.
4. Restart PSoC Creator. Note that this is an important step. The devices will only be available 

after PSoC Creator is restarted.

The devices should now be available in the device selector when you create a new project.

From the dropdown list, select PSoC 4700S.

Figure 2-4.  Device Selection 
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2.4 Installing the MagSense Component
To install the MagSense Component, Click Tools > Find new components. Figure 2-5 shows this
step.

Note: This step is mandatory for kit examples to work.

Figure 2-5.  Tools Tab for finding New Components 

Select the MagSense Component and click Install Checked Components. This will install the
MagSense Component in your software.

Note: You can skip this step if the MagSense Component is pre-installed in PSoC Creator.

Figure 2-6.  Component Installation 
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2.5 Uninstall Software
The software can be uninstalled using one of the following methods:
1. Go to Start > All Programs > Cypress > Cypress Update Manager and select Uninstall.
2. Go to Start > Control Panel > Programs and Features for Windows 7 or Add/Remove 

Programs for Windows XP and select Uninstall/Change.
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3. Kit Operation

This chapter introduces you to different features of the PSoC 4700S Inductive Sensing Evaluation
Kit. This primarily includes the programming and debugging functionalities, KitProg2 USB-UART and
USB-I2C bridges, and the procedure to update the KitProg2 firmware.

3.1 Theory of Operation
Figure 3-1 shows the block diagram for the PSoC 4700S Inductive Sensing Evaluation Kit.

Figure 3-1.  Block Diagram of PSoC 4700S Inductive Sensing Evaluation Kit 

The PSoC 4700S Inductive Sensing Evaluation Kit is simplistic in design and focuses on providing
you with complete access to develop applications using the PSoC 4700S device. This kit supports
the following features:
■ PSoC 4700S I/O Headers: The PSoC 4700S Inductive Sensing Evaluation board brings all 

important GPIOs of the target PSoC 4700S device to the expansion header/connector. This 
provides maximum access to the capabilities of the PSoC 4700S device.

■ Feedback LEDs: The onboard LEDs, LED1 to LED7 can be used to display outputs from the 
PSoC 4700S device.
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■ Three Inductive Sensing Button Coils: Three Inductive Sensing button coils are provided on 
the kit. To evaluate the button coils, a metal overlay has been placed on top of them.

■ Reset Button: This button is used to reset the PSoC 4700S device when pressed.
■ Power LED: This LED indicates power is being supplied to the board.
■ PSoC 4700S Device: This is the target device (CY8C4745AZI-S413) on the board.
■ 5-pin Programming Header: This is an external programming header that can be used to 

program the PSoC 4700S device using a MiniProg3. Typically this connection is not required 
since the kit contains an integrated KitProg2.

■ Current Measurement Jumper: Using this jumper (J3), you can measure the current consumed 
by the PSoC 4700S device. This jumper is populated by default. You must remove the jumper 
and measure current using an ammeter.

■ USB Type-C Connector: Using this USB Type-C connector (J2), you can connect the kit to a PC 
using USB Type-A to Type-C Cable.

■ PSoC 5LP: This is an onboard programmer/debugger utilizing a PSoC 5LP 
(CY8C5868LTI-LP039), which enables you to program and debug the target PSoC 4700S 
device. It can also act as a USB-UART and UART-I2C bridge. 

■ KitProg2 Mode Selection Switch: This button is used to switch between the KitProg2 modes as 
shown in Table 3-1. You can also use this button to provide an input to the PSoC 5LP in custom 
applications. Note that the switch connects the PSoC 5LP pin to ground when pressed. For more 
details, see the KitProg2 User Guide.

■ KitProg2 Status LED: This LED gives the programming/mode status of KitProg2.
Note: Press mode switch SW1 to toggle between programming modes.

Table 3-1.  KitProg2 Mode Switching

KitProg2 Programming Modes a

a. Toggling between programming modes can be done by pressing mode switch SW1.

Status LED (LED9)

KitProg2 Program/Debug Mode (PPCOM mode) (default) ON
CMSIS-DAP Programming Mode OFF

http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
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3.2 Programming and Debugging the Target PSoC 4700S Device
The target PSoC 4700S device can be programmed and debugged using the KitProg2. Before
programming the device, make sure that PSoC Creator and PSoC Programmer software are
installed on the PC. See Install Software on page 16 for more information.

3.2.1 Programming Using PSoC Creator
1. Connect the Evaluation board to the PC through the USB Type-C Connector(J2) as shown in

Figure 3-2. The kit enumerates as a composite device. If you are plugging in the PSoC 4700S
Evaluation Kit to your PC for the first time, the kit drivers will be installed automatically. The
amber status LED (LED9) will turn ON to indicate successful enumeration. If the amber status
LED (LED9) is OFF, press and release the Mode switch to change modes. If the amber LED still
does not turn on, see the KitProg2 User Guide for details on the KitProg2 status and
troubleshooting instructions.

Figure 3-2.  Connecting the PSoC 4700S Evaluation Kit to a Computer 

2. Open the desired project in PSoC Creator. From the PSoC Creator, go to File > Open > Project/
Workspace. You can browse and open an existing project. If you want to open one of the code 
examples provided with the kit, follow the instructions in the Code Examples chapter on page 28.

http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
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3. Select the option Build > Build <Project_Name> or press [Shift] [F6] to build the project as 
shown in Figure 3-3.

Figure 3-3.  Build a Code Example 

4. If there are no errors during build, program the firmware onto the kit by choosing Debug > 
Program or press [Ctrl] [F5], as shown in Figure 3-4. This programs the target PSoC 4700S 
device on the PSoC 4700S Evaluation Kit, and the kit is ready to use.

Figure 3-4.  Program Device in PSoC Creator
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3.2.2 Debugging Using PSoC Creator
For debugging the project using PSoC Creator, follow steps 1–3 from Programming Using PSoC
Creator on page 24 followed by these steps:

1. Click the Debug icon  or press [F5]. Alternatively, you can use the option Debug > Debug.
2. Once the PSoC Creator opens in Debug mode, use the buttons on the toolbar to debug your 

application.

For more details on using the debug features, see section 3.3 of the KitProg2 User Guide.

3.2.3 Programming Using PSoC Programmer
PSoC Programmer (3.27.1 or later) can be used to program existing .hex files into the PSoC 4700S
Evaluation Kit. For a detailed explanation on how to program using PSoC Programmer, see the
Programming Using PSoC Programmer section in the KitProg2 User Guide.

3.2.4 Mass Storage Programming
Note: Mass Storage Programming is not supported in this kit. CMSIS-DAP programming mode is
supported in this kit.

3.3 USB-UART Bridge
The KitProg2 on the PSoC 4700S Evaluation Kit can act as a USB-UART bridge. The UART lines
between the KitProg2 and the target are hard-wired on the board, with UART_RX assigned to P3[0]
and UART_TX assigned to P3[1] on target PSoC 4700S device. For more details on the KitProg2
USB-UART functionality, see the USB-UART Bridge section in the KitProg2 User Guide. 

Figure 3-5.  UART Connection between KitProg2 and PSoC 4700S Device 

http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide


CY8CKIT-148 PSoC® 4700S Inductive Sensing Evaluation Kit Guide, Doc. #: 002-23165 Rev. *B 27

Kit Operation

3.4 USB-I2C Bridge
The KitProg2 can function as a USB-I2C bridge and can communicate with the software utility Bridge
Control Panel (BCP). The BCP is installed as part of the installation package for the kit. The I2C lines
on the target PSoC 4700S device are P1[1] (SDA) and P1[0] (SCL), which are hardwired on the
board to the I2C lines of the KitProg2. The USB-I2C supports I2C speeds of 50 kHz, 100 kHz,
400 kHz, and 1 MHz. For more details on the KitProg2 USB-I2C functionality, see the USB-I2C
Bridge section in the KitProg2 User Guide.

Figure 3-6.  I2C Connection between KitProg2 and PSoC 4700S Device 

3.5 Updating the KitProg2 Firmware
The KitProg2 firmware normally does not require any update. You can use the PSoC Programmer
software to update the KitProg2 firmware if necessary. For a detailed explanation on how to update
the KitProg2 firmware, see Updating the KitProg2 Firmware in the KitProg2 User Guide.

http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
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4. Code Examples

This chapter explains the code examples provided with the PSoC 4700S Inductive Sensing
Evaluation Kit. To access these code examples, download and install the CY8CKIT-148
PSoC 4700S Inductive Sensing Evaluation Kit setup file from the kit web page: 
www.cypress.com/CY8CKIT-148. After installation, you can access the code example from the
PSoC Creator Start Page as shown in Figure 4-1.

4.1 Using the Kit Code Examples
Follow these steps to open and use the code examples.
1. Launch PSoC Creator from the Windows Start menu (Start > All Programs > Cypress > 

PSoC Creator <version> > PSoC Creator <version>).
2. On the Start page, select Start > Kits > CY8CKIT-148. A list of code example appears as shown 

in Figure 4-1.
3. Click the desired code example and save it at a desired location. For the remaining steps, 

CE222867_MagSense_With_Feedback_LEDs.cywrk is used as a reference.

Figure 4-1.  Open Code Example from PSoC Creator 

www.cypress.com/CY8CKIT-059
www.cypress.com/CY8CKIT-059
www.cypress.com/CY8CKIT-148
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4. Build the code example by choosing Build > Build <Project Name> as shown in Figure 4-2. A 
.hex file is generated after a successful build process.

Figure 4-2.  Build Code Example from PSoC Creator

5. Connect the PSoC 4700S  Evaluation kit to the PC using the KitProg2 USB Type-C connector J2 
as described in Programming Using PSoC Creator chapter on page 24 to program the kit with 
this code example. If you are connecting the kit to the PC for the first time, wait for driver 
installation to complete before proceeding to the next step.

6. Choose Debug > Program in PSoC Creator as shown in Figure 4-3.

Figure 4-3.  Program Device in PSoC Creator 
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7. If the device is already acquired, programming will complete automatically and the result will 
appear in the PSoC Creator status bar at the left bottom of the screen. If the device is yet to be 
acquired, the Select Debug Target window will appear. Select KitProg2/<serial number> and 
click Port Acquire as shown in Figure 4-4.

Figure 4-4.  Port Acquire

8. After the device is acquired, it appears in the tree structure below the KitProg2/<serial 
number>. Select the device then click OK / Connect to exit the window and start programming 
as shown in Figure 4-5.

Figure 4-5.  Connect Device from PSoC Creator and Program
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9. Code Example Operation:
This code example showcases the features of an Inductive Sensing button coils and Proximity 
coils in CY8CKIT-148 PSoC 4700S Inductive Sensing Evaluation Kit. This code example 
demonstrates the use of Inductive Sensing technology for button coils and Proximity using the 
PSoC 4700S device. As soon as you touch a button, the corresponding LED will glow. When you 
bring the metal target close to the proximity sensing coil of about 2 cm, the number of LEDs 
glowing on the board increases as you bring the target closer.

10.To understand detailed operation of the code example, open 
CE222867_MagSense_With_Feedback_LEDs.pdf as shown in Figure 4-6.
Note: When you operate the button or proximity sensor for a longer duration of about two 
seconds, the auto-reset feature will automatically disable the button or proximity and its 
corresponding LED. 

Figure 4-6.  Project Datasheet - CE222867_MagSense_With_Feedback_LEDs.pdf 
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4.2 Using Built-in PSoC Creator Code Examples with the Kit
Follow these steps to open and use the built-in PSoC Creator examples:
1. Launch PSoC Creator from Start > All Programs > Cypress > PSoC Creator<version> > 

PSoC Creator <version>.
2. On the Start page, click Find Code Example... under Start or follow the menu File > Code 

Example... as shown in Figure 4-7.

Figure 4-7.  PSoC Creator Find Code Example 
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3. In the Find Code Example window, set the Device family to PSoC 4700S as shown in 
Figure 4-8.

Figure 4-8.  Selecting PSoC 4700S Device in Find Code Example Window 

4. You can select the CE222867_MagSense_With_Feedback_LEDs project and see how to use it 
with the CY8CKIT-148 kit.

5. Select the CE222867_MagSense_With_Feedback_LEDs project and click Create Project as 
shown in Figure 4-9. Save the workspace to a desired location.
Note: The code example that appears in PSoC Creator with the installer package is same as the 
code example which is extracted using these steps.

Figure 4-9.  CE222867_MagSense_With_Feedback_LEDs Code Example 
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6. Open CE222867_MagSense_With_Feedback_LEDs.pdf from the Workspace Explorer to learn 
more about the code example and its configuration. See Figure 4-10.

Figure 4-10.  Project Datasheet: CE222867_MagSense_With_Feedback_LEDs 
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A. Appendix

A.1 Board Details
The PSoC 4700S Inductive Sensing Evaluation Kit consists of the following blocks:
■ PSoC 4700S device (CY8C4745AZI-S413)
■ PSoC 4700S I/O headers/Coil Expansion connectors J4, and J6 (FPC connector)
■ Three Inductive Sensing Coil Buttons
■ KitProg2 (PSoC 5LP) device (CY8C5868LTI-LP039)
■ SWD connection header J1
■ USB Type-C connector J2
■ Seven blue feedback LEDs; LED1, LED2, LED3, LED4, LED5, LED6, LED7 
■ One amber LED, LED9 (KitProg2 Status)
■ One amber LED, LED8 (Power)
■ One Push Button SW2 (Reset)
■ One Push Button SW1 (KitProg2 Mode)
■ Current Measurement Jumper J3 

Figure A-1.  PSoC 4700S Inductive Sensing Evaluation Kit Pin Details
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A.2 Hardware Details

A.2.1 Target Board
The target board uses the PSoC 4700S device. PSoC 4700S is a scalable and reconfigurable
platform architecture for a family of programmable embedded system controllers with M0+ CPU. It
combines programmable and reconfigurable digital blocks with flexible automatic routing. The
PSoC 4700S device, based on this platform architecture, is a combination of a MCU with digital
programmable logic, programmable interconnect, and standard communication and timing
peripherals. PSoC 4700S will be fully compatible with members of the PSoC 4 platform for new
applications and design needs. The digital subsystems allow flexibility and in-field tuning of the
design. For more information, see the PSoC 4700S webpage and the PSoC 4700S Datasheet.

Figure A-2.  Schematic of PSoC 4700S Device (Target)

http://www.cypress.com/PSoC4700S
www.cypress.com/psoc4700sdatasheet
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A.2.2 KitProg2 Board
A PSoC 5LP on the KitProg2 board is used to program and debug the target PSoC 4700S device.
The KitProg2 PSoC 5LP connects to the USB port of the PC through the USB Type-C connector and
to the SWD interface of the target PSoC 4700S device.

Figure A-3.  Schematic of PSoC 5LP (KitProg2) 



CY8CKIT-148 PSoC® 4700S Inductive Sensing Evaluation Kit Guide, Doc. #: 002-23165 Rev. *B 38

Appendix

A.2.3 Power Supply System
The power supply system on this board is dependent on a power source for most applications. You
can use the 5 V supply from the USB connection to power the system. This 5 V is dropped to 3.3 V
through a voltage regulator which powers the PSoC 4700S device. You can also connect an external
power supply to the board for low-voltage applications. However, in this scenario it is recommended
not to power the on board regulator using the USB Type C header. Also we recommend to use a low
noise power supply using the VDDD testpoints for best experience with MagSense. 

Note: A noisy power output can cause a reduction in performance of MagSense. 

A.2.3.1 Measure PSoC 4700S Device Current Consumption

To measure the current consumption of the PSoC 4700S device, remove the jumper at J3 and
connect an ammeter to it.

This method can be used either with USB power or with the power supplied to one of the VTARG
pins but NOT when supplying power to one of the VDDD pins.

After measuring the current consumption, populate the jumper for normal operations.

Note: After removing the jumper, the system may have some leakage current due to the voltage
monitoring section of kitprog2. To get rid of the leakage current completely from KitProg2, remove
R26.

Figure A-4.  Current Measurement 
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A.2.4 Header Connections
The PSoC 4700S Inductive Sensing Evaluation Kit supports a number of unpopulated headers on
both the Kit-Prog2 and the target PSoC 4700S boards.

A.2.4.1 Functionality of J1 Header (Programming/Debug Header)

Header J1 is the programming header. This header can be used to program the target device using
any kind of external programmer like MiniProg3.

Figure A-5.  J1 Header 

A.2.4.2 Functionality of J5 Header (Communication Header)

These headers provide I2C/ UART communication lines. These can be used to communicate with
external systems for general applications as well as debug.

Figure A-6.  J5 Header 

A.2.4.3 Functionality of Connector J2 (USB Type-C Connector)

This connector on the kit enables you to connect the kit to the PC using USB Type-A to Type-C on J2
(USB Type-C Connector).

Figure A-7.  USB Type-C Connector
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A.2.5 User and Passive Inputs

A.2.5.1 Reset Switch

When the Reset button is pressed, the XRES line of the PSoC 4700S device is pulled to ground,
which resets the target device.

Figure A-8.  Reset (RST) Switch 

A.2.5.2 Mode Switch (KitProg2)

The KitProg2 board contains a push button connected to P1.2 of the PSoC 5LP. When this button is
pressed, it toggles between KitProg2 mode and CMSIS-DAP Mode. For more details, see the 
KitProg2 User Guide.

Figure A-9.  Mode Switch 

http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
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A.2.5.3 Inductive Sensing Button Coils

Three Inductive Sensing buttons (BTN1, BTN2, and BTN3) are provided onboard to demonstrate the
Inductive Sensing button functionality of the PSoC 4700S device. 

Note: Inductive Sensing button aluminum overlay thickness of 0.5 mm and the adhesive below the
aluminium (0.2 mm) is an important parameter for tuning.

Figure A-10.  Inductive Sensing Button Coils and Circuit 
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There are four components required in the MagSense configuration:
1. The tank capacitors C41, C46, and C51 are used to determine the resonant frequency of the coil. 

The tank capacitors are necessary components onboard.
2. The series resistors R32, R39, and R49 are used to increase or decrease the signal.
3. C59, C60, and C61 are series capacitors at the LX lines used to optimize the power consumption 

at VDD. These capacitors are not necessary, however they can be used for stringent power 
applications.

4. DC blocking capacitor at the RX pin as shown in Figure A-10. This capacitor should be placed as 
close as possible to the device.
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Overlay design

Overlay design is a very important parameter for Inductive Sensing applications. Overlay design has
three major areas to be decided:
1. Aluminum overlay thickness
2. Polycarbonate adhesive thickness
3. Cutout area of the sensor on the adhesive layer

Figure A-11 shows the mechanical dimension of the overlay and adhesive layer for this kit.

The thickness of overlay is an important parameter to decide the sensitivity of the coil response to
MagSense. However, with lower thickness of overlay, the lifetime of the board reduces. 0.5 mm
thickness is typically an optimal choice from a button sensitivity and lifetime point of view. 

Figure A-11.  Mechanical Dimension of the metal overlay 

Caution: A higher Newton force on the overlay causes
deflection throughout the overlay causing false triggering
throughout the coils. User is expected to press the buttons
slightly enough to get the feedback. Pressing the overlay harder
can even deform the overlay.
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A.2.5.4 Inductive Sensing Proximity Coil

An Inductive Sensing proximity coil is provided onboard to demonstrate the Inductive Sensing
proximity functionality of the PSoC 4700S device. To demonstrate this feature, a metal target is
provided along with the kit. The proximity sensor is triggered at around 2 cm distance from the coil.

Figure A-12.  Proximity Sensor Coil and Circuit 
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Figure A-13 shows the functionality of the proximity sensor with metal target. These are the two
recommended ways of holding the metal target.

Note: The resonant frequency of the coil depends on the Inductance as well as the parasitic
capacitance. When a user touches the coil with the finger, there is a shift in resonant frequency due
to the change in parasitic capacitance. This change results in touch detection. To prevent the touch
detection, the sensitivity of the sensor can be reduced by increasing the threshold of the sensor
however that may result into lesser range of proximity.

Figure A-13.  Proximity Sensor demonstration 

Note: The features of the components are the same as those described in “Inductive Sensing Button
Coils” on page 41.
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A.2.5.5 Functionality of FPC Connector

An FPC Connector is provided onboard. This FPC connector can be used to extend the user design
with daughter boards mating with the FPC connector to operate with full functionality. FPC
connectors are considered low noise connectors which are good for MagSense functionality.

Figure A-14.  FPC Connector 

Note: To design a board for an FPC connection, CY8CKIT-148 compatible system, all circuitry
except for the DC coupling capacitor at the RX line needs to be designed. 
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A.2.5.6 Functionality of I/O Header J4

I/O header J4 pins are the multiplexed pins of the FPC connector. To work with the I/O headers, load
C52, C53, C54, C55, C56, and C57.

Note: To design a board for the J4 connector, CY8CKIT-148 compatible system, all circuitry except
for the DC coupling capacitor at the RX line needs to be designed. 

Figure A-15.  I/O Header 

A.2.5.7 LEDs

The PSoC 4700S Inductive Sensing Evaluation Kit contains nine LEDs:
■ The Amber Power LED (LED8): Indicates that the board is powered from the USB Type-C 

connector. This LED will not glow when the board is powered from VTARG directly.
■ The Amber Status LED (LED9): Indicates the KitProg2 status. This LED is connected to P1[4] of 

the KitProg2 PSoC 5LP device. 
❐ Table 3-1 on page 23 shows the various modes of status LED. 

■ The blue LEDs (LED1 to LED7): These are the feedback LEDs connected to the target 
PSoC 4700S device.

Note: Feedback LEDs (LED1 to LED7) will not work at 1.8 V, other LEDs may work with very low
brightness. 

Figure A-16.  Power and Status LEDs 
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Figure A-17.  Proximity and Button Feedback LEDs 
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A.2.5.8 System Capacitors

The CY8CKIT-148 PSoC 4700S Inductive Sensing Evaluation Kit has eight capacitors in addition to
the power supply decoupling capacitors:
■ One CapSense capacitor (CMOD): Required for CapSense functionality of the PSoC 4700S 

device (This is No Load).
■ Two Inductive Sensing capacitors (CINTA and CINTB): Required for Inductive Sensing function-

ality of the PSoC 4700S device. 

Note: These capacitors are also required for Mutual capacitive sensing functionality.

Figure A-18.  System Capacitors Circuit Diagram 

A.3 PSoC 4700S Inductive Sensing Evaluation Kit Schematics
See the schematic file available in the following path in the kit software installed:

<Install_Directory>\CY8CKIT-148 PSoC 4700S Inductive Sensing Evaluation

Kit\<version>\Hardware\CY8CKIT-148 Schematic.pdf

A.4 Bill of Materials
See the BOM file available in the following path in the kit software installed:

<Install_Directory>\CY8CKIT-148 PSoC 4700S Inductive Sensing Evaluation

Kit\<version>\Hardware\CY8CKIT-148 PCBA BOM.xlsm
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