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Chapter 1

Introduction

This tutorial provides comprehensive information that will help you understand how to create a
FPGA design and run it on you DE2i-150 development board. The following sections provide a
quick overview of the design flow, explain what you need to get started, and describe what you will

learn.

1.1 Design Flow

Figure 1-1shows the FPGA design flow block diagram.

The standard FPGA design flow starts with design entry using schematics or a hardware description
language (HDL), such as Verilog HDL or VHDL. In this step, you can create a digital circuit that is
implemented inside the FPGA. The flow then proceeds through compilation, simulation,

programming, and verification in the FPGA hardware.

Figure 1-1 Design Flow

This tutorial guides you through all of the steps except for simulation. Although it is not covered in
this document, simulation is very important to learn, and there are entire applications devoted to
simulating hardware designs. There are two types of simulation, Functional and Timing Functional
simulation allows you to verify that your code is manipulating the inputs and outputs appropriately.
Timing (or post place-and-route) simulation verifies that the design meets timing and functions

appropriately in the device.
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1.2 Before You Begin

This tutorial assumes the following prerequisites

B You generally know what a FPGA is. This tutorial does not explain the basic concepts of

programmable logic.

B You are somewhat familiar with digital circuit design and electronic design automation (EDA)

tools.

B You have installed the Altera Quartus II 12.0sp1 software on your computer. If you do not have

the Quartus II software, you can download it from the Altera web site at www.altera.com/download.

B You have a DE2i-150 Development Board on which you will test your project. Using a
development board helps you to verify whether your design is really working.

B You have gone through the quick start guide and/or the getting started user guide for your

development kit. These documents ensure that you have:

e Installed the required software.
e Determined that the development board functions properly and is connected
to your computer.

Next step you should installed the USB-Blaster driver, Plug in the 12-volt adapter to provide power
to the board. Use the USB cable to connect the rightmost USB connector (the one closest to the
VGA FPGA) on the DE2i-150 board to a USB port on a computer that runs the Quartus II software.
Turn on the power switch on the DE2i-150 board.

The computer will recognize the new hardware connected to its USB port and Power on the board
as shown in Figure 1-3, but it will be unable to proceed if it does not have the required driver
already installed. The DE2i-150 board is programmed by using Altera USB-Blaster mechanism. If
the USB-Blaster driver is not already installed, the New Hardware Wizard in Figure 1-3 will

appear.

1¢rm www.terasic.com

WWW. LEragIg. com




B8 86 ' BEgE

Figure 1-2 Connection Setup

Found New Hardware Wizard

Welcome to the Found New
Hardware Wizard
Wwindows will zearch for current and updated software by

looking on your computer, on the hardware installation CO, or on
the "Windows Update "Web site [with vour permizzion).

Eead our privacy policy

Can Windows connect to "Windows Update to search for
software?

() e, this time only
() s, now and every time | connect a device
() Mo, not this time

Click Mest to continue.

¢ Back | Mext > ][ Cancel

Figure 1-3 Found New Hardware Wizard

Since the desired driver is not available on the Windows Update Web site, select “No, not this time”

in response to the question asked and click Next. This leads to the window in Figure 1-4.
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Found New Hardware Wizard

Thes vaizard helps you install softwase for:

Altera USB-Blaster

[ ) If your hardware came with an installation CD
22 o floppy disk. insert it now.

‘What do pou want the wizard to do?

(7 Install the software automatically (Fecommended)
(%) Install from a list or specific location [Advanced)

Click Mext to continue,

<Back || Mewt> | [ Cancel |

Figure 1-4 The driver is found in a specific location

The driver is available within the Quartus II software. Hence, select Install from a specific location

and click Next to get to Figure 1-5.

Found New Hardware Wizard
Please choose your search and installation options. \\
s

(%) Search for the best driver in these locations,

Use the check boxes below to limit or expand the default search, which includes local
paths and removable media, The best diver found will be installed.

[¥] Seaich removable media (floppy, CD-ROM...)
Include this lacation in the search:

C:haltera\91hquartushdiversiusb-blaster's32 v

) Don't search. | will choose the diver to install

Choose this option to select the device driver from a list. Windows does not guarantes that
the diver you choose will be the best match for your hardware,

[ < Back ” Newt > ]I Cancel ]

Figure 1-5 Specify the location of the driver

Now, choose Search for the best driver in these locations and click Browse to get to the pop-up box
in Figure 1-6 Find the desired driver, which is at location C:\altera\12.0\quartus\drivers\usb-blaster.
Click OK and then upon returning to Figure 1-5 click Next. At this point the installation will
commence, but a dialog box in Figure 1-7 will appear indicating that the driver has not passed the

Windows Logo testing. Click Continue Anyway.
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Browse For Folder

Select the Folder that contains drivers for wour hardware,

= [T quartus ~
I3 bin
) bing4
[C3) commaon
[C3) cusp
= ) drivers
[ i3s6
I3 sentinel
= [5) usb-blaster
[ e
) =64

[E:

To view any subfolders, click a plus sign abowe,

[ Ok ] [ Cancel

Figure 1-6 Browse to find the location

Hardware Installation

1 E The software vou are nstaling for this hardweare;
*
Altera LSB-Blaster

Continuing your installation of this software may impair
or destabilize the correct operation of pour system
either immediately or in the future. Microzoft strongly
recommends that you stop this installation now and
contact the hardware vendor for software that has
passed Windows Logo testing.

| Continue Arpway | | STOP installation |

Figure 1-7 There is no need to test the driver

The driver will now be installed as indicated in Figure 1-8 Click Finish and you can start using the
DE2i-150 board.
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Found New Hardware Wizard

Completing the Found New
Hardware Wizard

The vaizard has firmshed instaling the software for:

@ Altera USB-Blaster

Click, Finish to close the wizad

Figure 1-8 The driver is installed

1.3 What You Will Learn

In this tutorial you will perform the following tasks:

Create a design that causes LEDs on the development board to blink at a speed that is controlled by
an input key—This design is easy to create and gives you visual feedback that the design works. Of
course, you can use your DE2i-150 board to run other designs as well. For the LED design, you will
write Verilog HDL code for a simple 32-bit counter, add a phase-locked loop (PLL) megafunction
as the clock source, and add a 2-input multiplexer megafunction. When the design is running on the

board, you can press an input switch to multiplex the counter bits that drive the output LEDs.

Becoming familiar with Quartus II design tools—This tutorial will not make you an expert (Please
reference DE2i-150 tut_quartus_intro_verilog document), but at the end, you will understand basic
concepts about Quartus II projects, such as entering a design using a schematic editor and HDL,

compiling your design, and downloading it into the FPGA on your DE2i-150 development board.

Develop a foundation to learn more about FPGAs—For example, you can create and download
digital signal processing (DSP) functions onto a single chip, or build a multi-processor system, or
create anything else you can imagine all on the same chip. You don’t have to scour data books to
find the perfect logic device or create your own ASIC. All you need is your computer, your
imagination, and an Altera DE2i-150 FPGA development board.
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Chapter 2

Assign The Device

You begin this tutorial by creating a new Quartus II project. A project is a set of files that maintain
information about your FPGA design. The Quartus II Settings File (.qsf) and Quartus II Project File
(.gpf) files are the primary files in a Quartus II project. To compile a design or make pin

assignments, you must first create a project.

2.1 Assign The Device

1. In the Quartus II software, select File > New Project Wizard. The Introduction page opens. See

Figure 2-1

ew Froject Wizard

Introduction

The Mew Project Wizard helps you create a new project and preliminary project settings, induding the following:

Project name and directory

Mame of the top-evel design entity
Project files and libraries

Target device family and device
EDA tool settings

*he e

You can change the settings for an existing project and specify additional project-wide settings with the Settings command (Assignments menu). You can use
the various pages of the Settings dialog box to add functionality to the project.

[]:Don't show me this introduction again

< Back Finish [ Cancel ] [ Help ]

Figure 2-1 New Project Wizard introduction
2. Click Next.

3.  Enter the following information about your project:
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a. What is the working directory for this project? Enter a directory in which you will store your

Quartus II project files for this design.

b. For example, E:\\My_design\my_first_fpga.

c.  File names, project names, and directories in the Quartus II software cannot contain spaces.
d. What is the name of this project? Type my_first_fpga.

e. What is the name of the top-level design entity for this project? Type my_first_fpga. See
Figure 2-2.

4 New Project Wizard

Directory, Name, Top-Level Entity [page 1 of 5]

what is the working directory for this project?

E_E:ﬂt"ly_design,."m\,'_ﬁrst_Fpga |E]
‘What is the name of this project?

i_-l-'nv_ﬁrst_fpgal [
What is the name of the topdevel design entity for this project? This name is case sensitive and must exactly match the entity name in the design file,
my_first_foga ]

Use Existing Project Settings. . ]

[ < Back ] I Mext > ] [ Finish ] [ Cancel ] [ Help ]

Figure 2-2 Project information

f.  Click Next.

g. You will assign a specific FPGA device to the design and make pin assignments. See Figure

2-3.
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- New Project Wizard

Family & Device Settings [page 3 of 5]
Select the family and device you want to target for compilation,
Device family Show in 'Available devices' list
Eamily: |Cydone IV GX Vi Package: |.\'-\.n3-I Vl
Devices: |.~‘«|I Pin count: i.ﬂ.ny Vl
Target device Speed grade: |A""’ vl
{J Auto device selected by the Fitter Name filter: | |
(=) Specific device selected in ‘Available devices' list Show advanced devices HardCopy compatible only
Other: nfa
Available devices:
Hame Core Voltage LEs User I/0s GXB Transmitter Channel PMA GXB Receiver Channel PMA ~
(S USRS P SR L e SN S ) P P s FErs ] i £
EP4CGX150CF2317 | 1.2V 1149750 | 287 4 4 |1
EP4CGX150DF27CT | 1.2V | 149750 | 426 |8 3 11
EP4CGX150DF27CE | 1.2V | 149750 | 426 8 8 13
EP4ACGX150DF2717 | 1.2V 149750 426 a8 8 1
EP4CGX150DF31C7 | 1.2V 143760 __l
EP4CGX1500F31CE | 1.2V | 149750 SDS |1
EP4CGX150DF3117 | 1.2V | 143750 | 508 8 1w
4 | >
Companion device
HardCopy:
Limit DSP & RAM to HardCopy device resources
[ < Back J ’ Mext = ] [ Einish l ’ Cancel J [ Help J

Figure 2-3 Specify the Device Example
h.  Click Finish.

4.  When prompted, choose Yes to create the my_first_fpga project directory. You just created
your first Quartus II FPGA project. See Figure 2-4.
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% Quartus II 32-hit - E:/Hy_design/my first fpga/my first fpga - my first_fpga

File Edit View Project Assignments Processing Tools Window Help @ Search altera.com
[DEBEHE & L 2@ o o [ isthe MY oGRS TP TDHEY @8 L 0 ®

Project Navigator @ax

Entity
Cydone IV GX: EP4CGX150DF31C7
% my_first_foga 8]

i1 Il | > i@ = 5.1;:@\\}_\,,

&y Hierarchy Files " & Design Units |

— Y QUARTUS'I
:

Task | & Time
= -
= b‘ Analysis & Synthesis

[ Edit settings.

BB view Report

' Analysis & Elaboration
- P Partition Merge

@ View Quartus Il
Information

%

- N - i 5 #® Documentation

§ X W <<Searchz> V|

@ || Type Message

]

21\ System _\_Processing /% ExtraInfo /\_Info /\_Warning /\_Critical Warning /\_Error /\_Suppressed /% Flag /

2

% Location: Locate

0% 00:00:00

Figure 2-4 my_first_fpga project
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Chapter 3

Design Entry

3.1 Add a PLL Megafunction

This section describes How to Add a PLL Megafunction

In the design entry step you create a schematic or Block Design File (.bdf) that is the top-level
design. You will add library of parameterized modules (LPM) functions and use Verilog HDL code
to add a logic block. When creating your own designs, you can choose any of these methods or a

combination of them.

1. Choose File > New > Block Diagram/Schematic File (see Figure 3-1 to create a new file,
Block1.bdf, which you will save as the top-level design.

Mew Quartus II Project
=) Design Files
AHDL File

EDIF File
Qsys System File
State Machine File
SystemVerilog HDL File
Td Script File
VHDL File
Verilog HDL File
= Memory Files
Hexadecimal (Intel-Format) File
Memory Initialization File
= Werification/Debugging Files
In-System Sources and Probes File
Loagic Analyzer Interface File
SignalTap II Logic Analyzer File
= Other Files
AHDL Include File
Block Symbol File
Chain Description File
Synopsys Design Constraints File
Text File

[ QK ] [ Cancel ] [ Help

Figure 3-1 New BDF

2. Click OK.

12
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3. Choose File > Save As and enter the following information.

e File name: my_first_fpga
e Save as type: Block Diagram/Schematic File (*.bdf)

4. Click Save. The new design file appears in the Block Editor (see Figure 3-2).

& Quartus IT 32-bit — E:/Hy design/my first fpga/ay first fpga — my first fpea (=1
Fle Edit View Project Assignments Processing Tocls Window Help & [searchaleracom | @
DEHG & % BAE © | [nisthe MY s @RG T r TGO HEE @B A WD
[project Navigator . 98 x r% -n:\:_ﬁrst_fpga-bdf B | B ) o ..

o BraMmADs-O11NNNOC N N[5y »iH»

Cydone IV GX: EP4CGY 1500F31C7
- my_first_fpga e?@

< | ¥

Hierarchy | Files || o Design Units |

Tasks #8 x|l

Flow: iCompiIah’on V| [Cusbomize...J

Task ® Time
| & W Compile Design =
= P Analysis & Synthesis | N

- [ Edit Settings

i E WE_'N R‘_eport
i W Analysis &Elaboration
& P Partition Merge ~
< I | >
X'| X l? < <Search=> v

|
@ Type| Message

8|
ﬁ‘ System /\ Processing /\_Extra Info /\_Info /\ Warning /Y Critical Warning /\_Error /\ Suppressed f\ Flag /
@ 2

%HLc-caﬂon: Locate

104, 201 | 0% 00:00:00

Figure 3-2 Bank BDF
5. Add HDL code to the blank block diagram by choosing File > New > Verilog HDL File.
6. Click OK to create a new file Verilogl.v, which you will save as simple_counter.v.
7.  Select File > Save As and enter the following information (see Figure 3-3).

e File name: simple_counter.v

e Save as type: Verilog HDL File (*.v, *.vlg, *.verilog)

13
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{RIFE (1) |L':} my_first_fpga ‘_V_J s |=_°F v
= oo

RIS

([
£

BN
LR

Fl_EsffE

iR ) | -l {#7F @)
{RIF2ER (T |‘.l’eril-:-g HOL Files (k. w % wlg * verilnlj HEiE

v 4dd file to cument project

—

Figure 3-3 Saving the Verilog HDL file
The resulting empty file is ready for you to enter the Verilog HDL code.

8. Type the following Verilog HDL code into the blank simple_counter.v file (see Figure 3-4 The

Verilog File of simple_counter.v).
/1t has a single clock input and a 32-bit output port
module simple_counter (

CLOCK_50,

counter_out

input CLOCK_50;
output [31:0] counter_out;

reg [31:0] counter_out;

14
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always @ (posedge CLOCK_50) /l on positive clock edge
begin
counter_out <= #1 counter_out + 1;// increment counter

end

endmodule // end of module counter

4 Quartus IT 32-bit — E:/Hy_design/my first_fpga/my first fpga — my first fpga

File Edit WView Project Assignments Processing Tools Window Help & |Se |°
e e e ez e T T [ T
DEHT S i@ oo i M RY L, EEO TP 0D ET @Y
|Project Navigator 8| [  myfstfpgabst [0 | £ smpecunterys @ |
1 Ll -
— B ey A%RAK 18 B B | —=
CydoneIVGx:EP%GXLSUDFhC? 1 f/It has a single clock input and a 32-bit output port
2 [Hmodule simple counter |
* my_first_fpoa =
y_first_fog 6?@ i CLOCE_ 50,
4 counter out
S )i
2] input CLOCE 30 ;
7 output counter out;
" 8 reg Counter out;
< | * 3 -
. 10 always @ (posedge CLOCK 50) S/ on positive clock edge
N . e . | - =
% Hierarchy | Fies | o Design Units 11 g e
Tasks Q& x| 12 counter out <= #1 counter out + 1;// increment counter
s 3 end
Flow: |Compilation V| [Customjze...] 14 endmodule // end of module counter
| 15 |
Task & Time
| B P Compile Design | E
| & P Analysis &Synthesis | =
Lo [ Edit settings
- B view Report
- P Analysis & Elaboration |
E P Partition Merge B
| Ll | b Fall >
Xl % [V <esearch> ~ |
5 |
£ Type Message
=
E:i‘\ System /% Processing /\ Extra Info /\ Info /% Warning /\ Critical Warning /\ Error /\ Suppressed /\ Flag /
%!F_c-cauon: ke
0% 00:00:00

Figure 3-4 The Verilog File of simple_counter.v
9. Save the file by choosing File > Save, pressing Ctrl + s, or by clicking the floppy disk icon.

10. Choose File > Create/Update > Create Symbol Files for Current File to convert the
simple_counter.v file to a Symbol File (.sym).You use this Symbol File to add the HDL code to
your BDF schematic.

The Quartus II software creates a Symbol File and displays a message (see Figure 3-5).
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¥ Quartus IT

i J Create Symbaol File was successful

Figure 3-5 Create Symbol File was Successful
11. Click OK.
12. To add the simple_counter.v symbol to the top-level design, click the my_first_fpga.bdf tab.
13. Choose Edit > Insert Symbol.
14. Double-click the Project directory to expand it.
15. Select the newly created simple_counter symbol by clicking it’s icon.

You can also double-click in a blank area of the BDF to open the Symbol dialog box

Libraries:
= B Project

: 'E]' simplecounter

@ £ c:faltera12.0/quartus libraries/

--------------- +— - CLOCK 50 counter out[34 Ofgmm.cco0ddndsn sl g

Lot | e e b

ST R R e e S e M N s e A S

Esimple_counter |E] e

[] Repeat-insert mode e
[] Insert symbol as block e

nomit el ol e Y

[ MegaWizard Plug-n Vrager... Ditriiiianiaiiiniiin i e e

Figure 3-6 Adding the Symbol to the BDF

16. Click OK.
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17.  Move the cursor to the BDF grid; the symbol image moves with the cursor. Click to place the
simple_counter symbol onto the BDF. You can move the block after placing it by simply clicking

and dragging it to where you want it and releasing the mouse button to place it. See Figure 3-7.

4, Quartus IT 32-bit — E:/Hy_design/my first fpga/my first fpga — my first fpga

File Edit Wiew Project Assignments Processing Tools Window Help & E
D@ & & BE o oy fst o Y S8 E T r W HH EE &8 5
|Praject Navigator @8 x| I ﬁ my_first_fpga.bdf* B8 3@0 simple_counter.v 3¢
| Entity [ E REAOADSZ-O71TANNS{OO N ™ =
. Cyclane IV GX: EPACGX150DF31C7 | e eiiiLiiiililiiiiliiiiiiiiiiiiiiiiiiiciiiiiiiiiiocsos g
| > my_first_fpga ﬁEEI I :
| R
K | 5 (|-
e | s ~ : Lt t[21..0f
£ Hierarchy | Files | of Design Units | e e
[Tasks eax|[: % 2
Flow: |compdaton % E e e -
| B Nl it il
|
| = ® Compile Design | = ‘
| = P Analysis & Synthesis | y
| - [ Edit Settings
| - B view Report
| -~ P Analysis & Elaboration |
| (- P Partition Merge | e e iR
1= | | @ 5
X' X |F c<Searchs» LV
& L : |
QE!I Type Message A||
| I [ j‘JZ:.-fe: Quartus IT 32-bit Create Symbol File was successful. 0 errors, 0 warnings \-fli
|
gl — ' 3 |
=\ _System /\_Processing (4) /\_Extra Info_/\_Info (4) /\_Warning J\_Critical Warning f\_Error /%_Suppressed /\_Flag / i
WA N e PA— A A=
%iirLDEaiic-r:: | Locate
36, 55 100% 00:00:08

Figure 3-7 Placing the simple_counter symbol

18.  Press the Esc key or click an empty place on the schematic grid to cancel placing further

instances of this symbol.
19.  Save your project regularly.
Using Quartus Add a PLL Megafunction

Megafunctions, such as the ones available in the LPM, are pre-designed modules that you can use in
FPGA designs. These Altera-provided megafunctions are optimized for speed, area, and device

family. You can increase

Efficiency by using a megafunction instead of writing the function yourself. Altera also provides

more complex functions, called MegaCore functions, which you can evaluate for free but require a

license file for use in production designs. This tutorial design uses a PLL clock source to drive a

simple counter. A PLL uses the on-board oscillator (DE2i-150 Board is 50 MHz) to create a

constant clock frequency as the input to the counter. To create the clock source, you will add a
17
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pre-built LPM megafunction named ALTPLL.
1. Choose Edit > Insert Symbol or click Add Symbol on the toolbar---

2. Click Megawizard Plug-in Manager. The MegaWizard® Plug-In Manager appears (see Figure
3-8).

4 NegaWizard Plug—In Nanager [page 11

The MegaWizard Flug-In Manager helps you create or modify design files that contain custom variations of
megafunctions.

\ Which action do you want to perfarm?

@ iCreate a new custom megafunction variation |

() Edit an existing custom megafunction variation

O Copy an existing custom megafunction variation

Copyright {C) 1991-2012 Altera Corporation

Figure 3-8 Mega Wizard Plug-In Manager
3. Click Next.
4. In MegaWizard Plug-In Manager [page 2a], specify the following selections (see Figure 3-9):
a. Choose I/0 > ALTPLL.

b.  Under Which device family will you be using? Choose the Cyclone IV GX for DE2i-150
development board.

c. Under Which type of output file do you want to create? Choose Verilog HDL.

d. Under What name do you want for the output file? Type pll at the end of the already
created directory name.

€. Click Next.

18
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# NegaWizard Plug—TIn Nanager [page 2al

Which megafunction would you like to customize?
Select a megafunction from the list below

|4 X|
P *{ ALTDQ_DQS2 v12.0 #
P ¥ ALTEK
l . ¥} ALTGX_RECONFIG

*3, ALTINT_O5C
¥ ALTIOBUF
| C ¥ ALTLVDS_RX
©ob ¥ AITIVDS TX
*{, ALTMEMPHY
i, ALTOCT
W ALTRLL
¥ ALTPLL_RECONFIG
*{, ALTREMOTE_UPDATE
*§ ALTTEMP_SENSE
¥, Altera CRCERROR Verify v12
\ Altera PLL Reconfig w12.0
*§, Altera PLL viZ.0 v

Which device family will you be using? |C1,-'|:I|:|ne IV GX v|
Which type of output file do you want to create?

O aHoL

{7 yHOL

{) Verilog HOL

What name do you want for the output file?

| E:/My_design/my_first_fpaa/pll.v| |B

Output files will be generated using the dassic file structure

[] Return to thiz page for anather create operation

Mote: To compile a project successfully in the Quartus II software, your design
files must be in the project directary, in a library spedified in the Libraries page of
the Options dialog box {Tools menu), or a library spedfied in the Libraries page
of the Settings dialog box {Assignments menu).

Your current user library directories are:

[ Cancel ][ < Back ][ Mext = Finish

Figure 3-9 MegaWizard Plug-In Manager [page 2a] Selections

5. In the MegaWizard Plug-In Manager [page 3 of 14] window, make the following selections

(see Figure 3-10).

a. Confirm that the Currently selected device family option shows the device family that

corresponds to the development board you are using.

b. The device speed grade choose 6 for DE2i-150.

c. Set the frequency of the inclockO input 50 MHz.

d. Click Next.

Www. LErasIc. com
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NegaWizard Plug—In Manager [page 3 of 14] E]EJ

[t J[gsmmmotr]

arameter
Settings

-
General Modes i J .~ Clock switchover

Currently selected device family: i":'v'fJDﬂE IV.GY |

Match project/default

Able to implement the requested PLL

General

Which device speed grade will you be using? 6 |

Uze military temperature range devices only

What is the frequency of the indk0 input? | |MHz v|
Setup PLL in LVDS mode Data rates t Available | Mbips
PLL Type
Which PLL type will you be using?
FastPLL Enhanced PLL (#) select the PLL type automatically
Operation Mode
Howe will the PLL outputs be generated?
(%) Use the feedback path inside the PLL
(&) In normal mode
) In source-synchronous compensation Mode
() In zero delay buffer mode
Connect the fhmimic port (bidirectional)
) With no compensation
Create an 'fhin' input for an external feedback (External Feedback Mode)
Which output dock will be compensated for? o v|
| Cancel | | < Back | | MNext = | | Finish |

Figure 3-10 MegaWizard Plug-In Manager [page 3 of 14] Selections

6. Turn off all options on MegaWizard page 4. As you turn them off, pins disappear from the PLL

block’s graphical preview. See Figure 3-11 for an example.
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7.

Parameter

Nega¥Wizard Plug—In Manager [page 4 of 14]

Settings

jss > Clock switchover

GeneralModes

Able to implement the requested PLL

Cptional Inputs
Create an ‘pllena" input to selectively enable the PLL

[] create an 'areset’ input to asynchronously reset the PLL
[[] create an 'pfdena’ input to selectively enable the phase/frequency detector

Lock Qutput
[ Create locked" output

[1 Enable selfreset on loss lock

Advanced Parameters
Using these parameters is recommended for advanced users anly

[ create output file(s) using the ‘Advanced' PLL parameters

- Configurations with output dock(s) that use cascade counters are not supported

| Cancel || < Back || Mext = || Einish |

Www. LErasIc. com

Figure 3-11 MegaWizard Plug-In Manager [page 4 of 14] Selections

Click Next four times, In the MegaWizard Plug-In Manager [page 8 of 14] window, make the
following selections (see Figure 3-12).

Clock Division Settings  input 10
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NegaWizard Plug—In Nanager [page 8 of 14]

*

c0 - Core/External Output Clock

Able to implemant the requested PLL

Use this dock
Clock Tap Settings

() Enter output dock frequency:
(%) Enter output dock parameters:

Requested Settings Actual Settings

| 00.00000000 [MHz - | [s.000000 |

i [E |

Clock multiplication factor

P I o DTE—
Clock division factor |10 ] << cony | |10 |
Clork phase shift .00 (%] [deg % [o.00 |
Clock duty cydle (%) |50.00 [ |50.00 |
Description Val, ™

Mote: The displayed internal settings of the ripary; Hodi VOG- e guency (VHz) |8...
PLL is recommended for use by advanced Modulus for M counter |12 o
users only < Ll F s . | -) —

Per Clock Feasibility Indicators
@ ¢l &2 3 od

| Canicel || < Back || Mext = || Firish |

Figure 3-12 MegaWizard Plug-In Manager [page 8 of 14] Selections
9.  Click Next.

10. The wizard displays a summary of the files it creates (see Figure 3-13). Click Finish .
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Nega¥Wizard Plug—In Nanager [page 14 of 14]

-

E Summary

Turn on the files you wish to generate. A gray checkmark indicates a file thatis automatically generated, and a
green checkmark indicates an optional file, Click Finish to generate the selected files. The state of each

pl checkbox is maintained in subsequent MegaWizard Plug-In Manager sessions.
The MegaWizard Plug-In Manager creates the selected files in the following directory:
L e E:My_design\my_first_fpgal
el File Description
pll.v Yariatien file )
pll.ppf | PinPlanner ports PPF file
[pl.inc | AHDL Include file
[Ipll.cmp | YHOL component decdaration file
'| pllbsf | Quartus 11 symbol file
it inst.v Instantiation template file
pll_bb.v “ierilog HOL black-box file

[ | [ | [5es |[E ],

Figure 3-13 Wizard-Created Files

The Symbol window opens, showing the newly created PLL megafunction. See Figure 3-14.
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Libraries: e

e 0 0 0 0 0 [
7T T e s

# 1 cfaltera/12.0/quartus braries| =

............... inclkd SyEge i clf- -

Mame:

! simple _counter

[ ] Repeat-insert mode
[] tnsert symbol as block

Launch MegaWizard Plug-In

E MegaWizard Plug-In Manager. ..

[ OK J[ Cancel J

Figure 3-14 PLL Symbol

11. Click OK and place the pll symbol onto the BDF to the left of the simple_counter symbol. You
can move the symbols around by holding down the left mouse button, helping you ensure that they

line up properly. See Figure 3-15.
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4 Quartus II 32-bit — E:/Ny_design/my first fpga/my first fpga — my first fpga

File Edit Wiew Project Assignments FProcessing Tools Window Help & | T
DSEGP S % RE o | |yt o VX% @G T rW sHET B 4 0
|Project Navigator ©8x|| fa myfrstpoabd B | $  smpecountery [

BRACADL-OITANNNDTON 4]

Entity
Cyclone IV GX: EP4CGX 1500F31C7
W my_first_fpga ﬁTEl

< 2|
&y Hierarchy | Files | of Design Units | ]
= = S 3 inc iz —i counter_out[31..0]
[Tasks @8 x| : or :
Flow: iCompiIah’on v| [Customize...J

Task & Time ™
| & P Compile Design
. B P Analysis & Synthesis
[ Edit settings
=] View Report
i P Analysis & Elaboration

v
< | b
=zl 1 -
Xl x 'Y <«Search=> v |
= L |
@ |‘1‘y‘pe Message ﬁll
= |
@3 Info: Quartus II 32-bit Create Symbol File was successful. 0 errors, 0 warnings ;'l
RS | > |‘
o
2\ System Processing {4 Extra Info f\_Info (4 f\_Warning /\_Critical Warning /% _Error /\_Suppressed /\ Flag /
R L 8 R R - e e S WS
| gE!Lc-catlm: Locate

Saves all open files 45, 559 100% 00:00:08

Figure 3-15 Place the PLL Symbol

12.  Move the mouse so that the cursor (also called the selection tool) is over the pll symbol’s cO
output pin. The orthogonal node tool (cross-hair) icon appears.

13.  Click and drag a bus line from the cO output to the simple_counter clock input. This action
ties the pll output to the simple_counter input (see Figure 3-16).

CLOCK_50 Counter_out]31..0] qem— < - - -

........ inclkD e 1 =

Figure 3-16 Draw a Bus Line connect pll cO port to simple_counter CLOCK_50 port

14.  Add an input pin and an output bus with the following steps:
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a. Choose Edit > Insert Symbol.
b. Under Libraries, select quartus/libraries > primitives > pin >input. See Figure 3-17
c. Click OK

If you need more room to place symbols, you can use the vertical and horizontal scroll bars at the

edges of the BDF window to view more drawing space.

& Syahol

s S
‘B & cfalteraf12.0/quartus/ibraries/ E AR A A R A A A A SRR RN A

#- £ megafunctions
- 21 others
=& primitives
lE 23 buffer
23 logic
¥ 1 ather
& pin
& bidir
g
- £} output

(L1 5 mbmrmmm

Name:

Einput

[] Repeat-insert mode
Inzert symbol &= blodk

Launch MegaiWizard Plug-In

[ MegaWizard Flug-In Manaaer. ..

(o (o=

Figure 3-17 Input pin symbol
d. Place the new pin onto the BDF so that it is touching the input to the pll symbol.

e. Use the mouse to click and drag the new input pin to the left; notice that the ports remain

connectedasshowninFigure

C o |inekn

counter_out]31..0]

Figure 3-18 Connecting the PLL symbol and Input port
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f.  Change the pin name by double-clicking pin_name and typing CLOCK_50 (see Figure 3-19).

This name correlates to the oscillator clock that is connected to the FPGA.

g.  Using the Orthogonal Bus tool, draw a bus line connected on one side to the simple_counter
output port, and leave the other end unconnected at about 4 to 8 grid spaces to the right of the

simple_counter.

% Pin Properties

General | Format
To create multiple pins, enter a name in AHDL bus notation
(For example: "name[3..0]7), or enter a comma-seperated list of names.
Pinname(s): | cLOCK_s0| |
Default value: |'I.I'CC V|
[ (0]4 l [ Cancel ] [ Help

Figure 3-19 Change the input port name
h.  Right-click the new output bus line and choose Properties.

i.  Using the Orthogonal Bus tool, draw a bus line connected on one side to the simple_counter
output port, and leave the other end unconnected at about 6 to 8 grid spaces to the right of the

simple_counter.

J.- Type counter [31..0] as the bus name (see Figure 3-20). The notation [X ..Y] is the Quartus II
method for specifying the bus width in BDF schematics, where X is the most significant bit (MSB)
and Y is the least significant bit (LSB).

k. Click OK. Figure 3-21 shows the BDF.
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bus Froperties r‘>_(

General lFl:-nt ] Format ]

M ame: ||:|:|unter[3'l ]

[ Hide name in block. dezign file

fifE Hif

Figure 3-20 Change the output BUS name

4 Quartus II 32-bit — E:/My_design/my first fpga/my first fpga — my first fpga

File Edit View Project Assignments Wagie=cio@ Tools Window Help &) Search a!-tera.:c-m l.
DEHE S s BB oo [rishe VMY s @RS T P eHEY 80 A 0O
|Project Navigator @A x| | 2 my_first_fpga. bdf= B { £ simple_counter.v [5¢]
= EHEBEADADL-O1TINANSOO S as £ d S| sBR o o
Ay Cydone TV GX: EPACGX150DF31CT e
> mv_ﬁrst_FpgaéTE i
|
& | > ol
&y Hisrarchy | Fles | dP Designunits | 3 P
Tasks @8 x| [ D—Q@Qﬂ b £LOCK 20 counter_out21 0]
Flows iComp\Iahon V| [Cusmmize‘..] S
Tack & Time & et
= P Compile Design 3 inst1 Cyclor
= P Analysis & Synthesis
- [0 Edit Settings 3
=2} View Report |
P Analysis & Elaboration » S
& | B | |z i
Xl x 1? <<Search>5 W
a L
|
@ “l'ype Message _.I
B yIr;fc: Quartus II 32-bit Create Symbol File was successful. 0 errors, 0 warnings :l
T 3|
System Processin Extra Info /\_Info (4) /\ Warning S\ Critical Warning /\_Error f\ Suppressed /\ Flag /
Ei|Locat|Dn: Locate
185; 4 100% 00:00:08

Figure 3-21 BDF
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3.2 Add a Multiplexer

This design uses a multiplexer to route the simple_counter output to the LED pins on the DE2i-150
development board. You will use the MegaWizard Plug-In Manager to add the multiplexer,
Ipm_mux. The design multiplexes two variations of the counter bus to four LEDs on the DE2i-150

development board.

1. Choose Edit > Insert Symbol.

2. Click Megawizard Plug-in Manager.

3. Click Next.

4. Choose Installed Plug-Ins > Gates > LPM_MUX.

5. Choose the device family that corresponds to the device on the development board you are
using, choose Verilog HDL as the output file type, and name the output file counter_bus_mux.v (see
Figure 3-22).

6. Click Next.
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NezaWizard Plug—In Nanager [page 2al

Which megafunction would you ke to customize?  yhich device family will you be using? !Cydane IV GX V|
[ | Select a megafunction from the list below
| ™, | Which type of output file do vou want to create?
“u
- ) AHDL
= i% Installed Plug-Ins
3, Altera SOPC Builder © yHOL
B 1 Arithmetic i®) Verilog HOL
o _—
If' | Comipreabins What name do you want for the output file?
# [ psp ,
=- 3 Gates |E:,."I'dy_|:|E5|gn,."mv_ﬁrst_fpga,."cu:uunter_l:uus_mux.v| |[E
£ 1‘-}\ LPM_CLSHIFT Output files will be generated using the dassic file structure
g ::\ LPM_CONSTANT [] Return to this page for another create operation
: - #4 LPM_DECODE ! . i :
i 5t Mote: To compile a project successfully in the Quartus II software, your design
: ~ LPM_MUX files must be in the project directory, in a library specified in the Libraries page of
B 2] Ijo the Options dialog box {Tools menu), or a library specified in the Libraries page
- [l Tk of the Settings dialog box {Assignments menu).
® [ ITAG-accessible Extensions Your current user library directories are:
=3 Memory Compiler
(] click to Open IP MegaStore
[ Cancel ] [ < Back ] [ Mext = Finish

Figure 3-22 Selecting Ipm_mux
7.  Under How many ‘data’ inputs do you want? Select 2 inputs (default).

8. Under How ‘wide’ should the data input and result output be? Select 4 (see Figure 3-23).
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[ svout | [eocumentaton

=

Currently selected device family: |cydane 1v o

datatx3..0] Match project/default

datalx][3..0] =

Haow many 'data’ inputs do you want? | i LY

How wide should the 'data’ input and [ —I i

the 'result’ output buses be? H—v_ bits
Do you want to pipeline the multiplexer?

%) Mo
{7) Yes, I want an output latency of |1 ] clock cydes
LA
Create an asynchronous Clear input

Create a Clock Enable input

Rezource Uzage

1 Ipm_mux | Cancel || < Back || Next » || Einish |

Figure 3-23 Ipm_mux settings
9. Click Next.

10. Click Finish twice. The Symbol window appears (see Figure 3-24 for an example).
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Libraries: ..............................................................

= & Project Rt e st R e e bh b e s b e
© - EF counter_bus_mux e
- &l i SRS e e b
- B simple_counter s S D R e e b e
# O cfaltera/12.0/quartus/ibraries/ S SEntnmmTEnmamnEa
counter_bus_mux
..................... dﬂtﬂ1x[3u'. .
..................... rt?ru.l
..................... dﬂtﬂ.ﬁx[:!vﬂ" I%;
MName:

1
counter bus_mux

[T] Repeat-insert mode

["] Insert symbol as block

Launch MegaWizard Plug-In

[ MeagaWizard Plug-In Manager. ..

Figure 3-24 Ipm_mux Symbol
11. Click OK

12. Place the counter_bus_mux symbol below the existing symbols on the BDF. See Figure 3-25

CLOCK_ED counter_out[31..0]

............................................... EDL”'Iter_hus_n]ux :

s datat3. ] o
............................................... BBOT - o
............................................... data[lx[&.[l]_'resu
............................................... T T T I

e P

Figure 3-25 Place the Ipm_mux symbol

13.  Add input buses and output pins to the counter_bus_mux symbol as follows:

32

tcrm www.terasic.com

Www. LErasIc. com




maslc

a.  Using the Orthogonal Bus tool, draw bus lines from the datalx[3..0] and dataOx[3..0]
Input ports to about 8 to 12 grid spaces to the left of counter_bus_mux.

b. Draw a bus line from the result [3..0] output port to about 4 to 8 grid spaces to the right of

counter_bus_mux.

c.  Right-click the bus line connected to datalx[3..0] and choose Properties.

d. Name the bus counter[26..23], which selects only those counter output bits to connect to
the four bits of the datalx input.

Because the input busses to counter_bus_mux have the same names as the output bus from

simple_counter, (counter[x .. y]) the Quartus II software knows to connect these busses.
e. Click OK.
f.  Right-click the bus line connected to dataOx[3..0] and choose Properties.

g.  Name the bus counter [24..21], which selects only those counter output bits to connect to the

four bits of the datalx input.

h. Click OK. Figure 3-26 shows the renamed buses.

| counterbus_mux oo
g il 111 swats ™) Joo
....... e . a result(3. 07 - - rEsetEOL L L
.......“..-_-_ = e N datal=[2..0]| [ : »® -
L Y— ’FJ I
........................ nstl

Figure 3-26 Renamed counter_bus_mux Bus Lines
If you have not done so already, save your project file before continuing.
14. Choose Edit > Insert Symbol.

15. Under Libraries, double-click quartus/libraries/ > primitives > pin > output (see Figure 3-27).
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Libraries:

05 megafunctions ;|

-2 others

= B primitives
-2 buffer
- 23 logic

E 23 other
= & pin
i & bidir
ool input
- €1 storage 5,
Mame:
(output [
[] Repeat-insert mode
Insert symbol as blodk
Laurch MegaWizard Plug-In
MegaWizard Plug-In Manager... J

Figure 3-27 choose an output pin

16. Click OK.

17.

18.

19.

Place this output pin so that it connects to the counter_bus_mux result [3..0] bus output line.

Rename the output pin as LEDG [3..0] as described in steps 13 ¢ and d. (see Figure 3-28).

counter_bus_mux
dataix[2.0 5
alalx] ]\l result[3..01y - - -

datal=[2..0]] _¢
['¥] H
nstl /fJ :

Figure 3-28 Rename the output pin
Attach an input pin to the multiplexer select line using an input pin:
Choose Edit > Insert Symbol.
Under Libraries, double-click quartus/libraries/ > primitives > pin > input.

Click OK.
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20. Place this input pin below counter_bus_mux.
21. Connect the input pin to the counter_bus_mux sel pin.

22. Rename the input pin as KEY [0] (see Figure 3-29).

counter_out[31..0] 4

counter_bus_mux

- | data1=]3..0]
datalx=]3..0]

result[?-..B'i - result3.0]

Figure 3-29 Adding the KEY [0] Input Pin

You have finished adding symbols to your design. You can add notes or information to the project
as text using the Text tool on the toolbar (indicated with the A symbol). For example, you can add
the label “OFF = SLOW, ON = FAST” to the KEY [0] input pin and add a project description, such
as “My First FPGA Project.”

3.3 Assign the Pins

In this section, you will make pin assignments. Before making pin assignments, perform the

following steps:

1. Choose Processing > Start > Start Analysis & Elaboration in preparation for assigning pin

locations.
2. Click OK in the message window that appears after analysis and elaboration completes.

To make pin assignments that correlate to the KEY [0] and CLOCK_50 input pins and LEDG[3..0]

output pin, perform the following steps:

1. Choose Assignments > Pins, which opens the Pin Planner, a spreadsheet-like table of specific

pin assignments. The Pin Planner shows the design’s six pins. See Figure 3-30
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File Edit View Processing Tools Window Help &

LEX

Search altera.com | 0

= |'___",__f'
— = [ Early Pin #%
B ] ,E! Crez
1] —— e
& v [E) Edit: 3¢ /| |Filter:{Pins: al v
@ | Direction Location If0 Bank WREF Group Ij0 Standard Reserved
:Ec Input 2.5V {default)
| Input 2.5V {default)
o &P LEDG[3] Dutput 2.5V (default)
£ LEDG[Z] Output 2.5V {default) =
e Ll LepGl) Output 2,5V {default)
| &|| € LEDG[0] Output 2.5 {default) ¥
g L=l a8 |

0% 00:00:00

Figure 3-30 Pin Planner Example

2. In the Location column next to each of the six node names, add the coordinates (pin numbers)

as shown in Table 3-1 for the actual values to use with your DE2i-150 board.

Table 3-1 Pin Information Setting

Pin Name FPGA Pin Location
KEY[0] AA26

LEDG[3] F26

LEDG[2] F27

LEDG [1] AB25

LEDG [0] AA25

CLOCK_50 AJ16

Double-click in the Location column for any of the six pins to open a drop-down list and type the
location shown in the table alternatively, you can select the pin from a drop-down list. For example,
if you type F1 and press the Enter key, the Quartus II software fills in the full PIN_F1 location name
for you. The software also keeps track of corresponding FPGA data such as the I/O bank and VREF

Group. Each bank has a distinct color, which corresponds to the top-view wire bond drawing in the

upper right window. See Figure 3-31.
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=S

Fle Edit WView Processing Tools Window Help & [search altera.com | @
= [Tasks @8 x|
= I:IEarIyPinf_i
g Doy
(e |
|%—|f J= v Edit - [PIN_AAZS | Fitter:{Pins:
@, | ;I Named:| v| Editz 3 ||~ |[PIN_ | Filter:|Pins: all ¥
@ ;E# Node Name Direction Location IjO Bank VREF Group 1/0 Standard Reserved
B il ||m* cLock 50 Input PIN_AJ1G 4 B4 N2 2.5 Y (default)
|| || kEYO] Input PIN_AAZS 5 B5 N2 2.5y {default)
& & LEDG[3] | Qutput PIN_F26 6 B6_NO | 2,5V (default)
£ LEDG[Z] Cutput PIN_F27 & B&_MNO 2.5 {default) =
kX w2 LEDG[1] Output PIN_AB25 5 B5 N2 2.5V {default)
§| L LEDG[]] Output PIN_AAZS 5 B5_N2 2.5V {default) b
¥ =] | | bd
0% 00:00:00

Figure 3-31 Completed Pin Planning Example

Now, you are finished creating your Quartus II design!

3.4 Create a Default TimeQuest SDC File

Timing settings are critically important for a successful design. For this tutorial you will create a
basic Synopsys Design Constraints File (.sdc) that the Quartus II TimeQuest Timing Analyzer uses
during design compilation. For more complex designs, you will need to consider the timing

requirements more carefully.

To create an SDC, perform the following steps:

1.  Open the TimeQuest Timing Analyzer by choosing Tools > TimeQuest Timing Analyzer.
2. Choose File > New SDC file. The SDC editor opens.

3. Type the following code into the editor:

create_clock -name "CLOCK_50" -period 20.000ns [get_ports { CLOCK_50}]
derive_pll_clocks

derive_clock_uncertainty

4. Save this file as my_first_fpga.sdc (see Figure 3-32)
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4 Quartus II 32-bit — E:/Hy_design/my first fpga/my first fpga — my first fpga |L“|:|”§|
Fle Edit WView Project Assignments Processing  Tools  Window Help & ISearch I — |°
: — T ™ e S - TR - b= — 2]
DzEa@ & & 2@ © o |nyfst e MY s EREG T r W sH M &8 5 09
Erpjggt__ﬁa_iigghgr eax | a@c s " % my_first_fpga.bdf*= [0 | a@c my_first_fpoa.sde [E3 |
o 1= 3
CydoneI\n'GX: EP4CGX 1500F31CT 1 create clock -name "CLOCK 50" —perind 20.000ns [get_ports {CLOCK 50}1
=) ;% my_ﬁrst_fpgaﬁTEI 2 der:!.ve_pll_clc:cks -
T 2 B 3 derive clock uncertainty
- Rt simple_counter:inst 4 i s
r: plhinst1
%, counter_bus_mucinst3
2] il | >
&y Hierarchy | Files || o Design Units |
Tasks o8 x|
Flow: iCOmpiIah’on V_| [Cushomjze... ]
@ ~
oo:
fo iew Repor
ER view Report
4 i P Analysis & Elaboration v
< j | B | = 5
..... -
g X |V «<Search>> ~
£ Type Message ]
\i') Info (293000): Quartus II Full Compilation was successful. 0 errors, 5 warnings 7
i€ - | il
%\Mng (131) f\_ExtraInfo f\_Info {126) /\_Warning (2) J/\_Critical Warning (3) /\_Error /\_Suppressed (8) /% Flag /
B : e R RS
%{{Lc-catlon: Locate
100% 00:01:13

Figure 3-32 Default SDC

Naming the SDC with the same name as the top-level file except for the .sdc extension causes the
Quartus II software to using this timing analysis file automatically by default. If you used another
name, you would need to add the SDC to the assignments file list.
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Chapter 4

Compile and Verify Your Design

After creating your design you must compile it. Compilation converts the design into a bitstream
that can be downloaded into the FPGA. The most important output of compilation is an SRAM
Object File (.sof), which you use to program the device. The software also generates other report

files that provide information about your code as it compiles.

4.1 Compile Your Design

If you want to store .SOF in memory device (such as flash or EEPROMs), you must first convert

the SOF to a file type specifically for the targeted memory device.

Now that you have created a complete Quartus II project and entered all assignments, you can

compile the design.
In the Processing menu, choose Start Compilation or click the Play button on the toolbar.
If you are asked to save changes to your BDF, click Yes.

While compiling your design, the Quartus II software provides useful information about the

compilation (see Figure 4-1).
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4 Quartus II 32-bit — E:/Hy_design/my first fpga/my first fpga — my first fpga
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d . Embedded Multiplier 9-bit elements 0
Fadk &~ '~ Total GXB Receiver Channel PCS 0
- . — i - Total GXB Receiver Channel PMA 1]
2% | 'El P Compile Design | DO:E . Total G¥B Transmitter Channel PCS 0
|V’ | i B P Analysis & Synthesis |00:¢ Total GXB Transmitter Channel PMA 0
| [F 7k ] Edit Settings . " Total PLLs 1
| i BB Wiew Report |
e . P Analysis & Elaboration | b
T
s ' 2 < - 3% - | &
X x iY <<Search>> AV
&
@ Type Message o
s 3Warning (15714) : Some pins have incomplete I/0Q assignments. Refer to the I/0 Assignment Warnings report for det,ai.';
g % | 3 |
a1\ System /\_Processing (39) /\ Extra Info /\_Info (38) /\ Warning (1) J\_Critical Warning /%\_Error /\_Suppressed J\ Flag /
@l s A s A
2L acation: ! Locate

22% 3 00:00:11

Figure 4-1 Compilation Message for project

When compilation is complete, the Quartus II software displays a message. Click OK to close the

message box.

The Quartus II Messages window displays many messages during compilation. It should not display
any critical warnings; it may display a few warnings that indicate that the device timing information
is preliminary or that some parameters on the I/O pins used for the LEDs were not set. The software

provides the compilation results in the Compilation Report tab as shown in Figure 4-2.
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Flow Status Successful - Fri Aug 17 12:52;25 2012
Quartus II 32-bit Version 12,0 Build 232 07/05/2012 5P 1 5] Full Yersion
Revision Mame my_first_fpga

Top-evel Entity Mame my_first_fpga

Family Cydone IV GX

Device EP4CGX150DF31C7

Timing Models Final

Total logic elements
Total combinational functions
Dedicated logic registers
Total registers
Total pins
Total virtual pins
Total memory bits
Embedded Multiplier 9-bit elements
Total GXB Receiver Channel PCS
Total GXB Receiver Channel PMA
Total GXB Transmitter Channel PCS
Total GXB Transmitter Channel PMA
Total PLLs

31/149,760 (< 1%)
31/149,760 ( < 1%)
27 149,760 { < 1 %)
27

6 /508 (1%)

0

0 /86,635,520 (0 %)
0/720 (0 %)
0/8(0%)
0/8(0%)
0/8(0%)
0/8(0%)
1/8(13%)

Figure 4-2 Compilation Report Example

4.2 Program the FPGA Device

After compiling and verifying your design you are ready to program the FPGA on the development
board. You download the SOF you just created into the FPGA using the USB-Blaster circuitry on

the board. Set up your hardware for programming using the following steps:
a) Connect the power supply cable to your board and to a power outlet.

b) For the DE2i-150 board, connect the USB-Blaster (included in your development kit) to J9 and
the USB cable to the USB-Blaster. Connect the other end of the USB cable to the host computer.

Refer to the getting started user guide for detailed instructions on how to connect the cables.
¢) Turn the DE2i-150 board on using the on/off switch.
Program the FPGA using the following steps.

1. Choose Tools > Programmer. The Programmer window opens. See Figure 4-3.
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Fle Edit Yiew Processing Tools Window Help &

B

oo, Hardware Seh.lr:l...l IUSB-EIaster [UsE-0]

| Mode: |TTAG

b

Wi Start
ml stop
et Auto Detect
< Delete

2 add File...

= Change File...
B save Fite
22 Add Device. ..
| 4 p
ﬁﬂ Down

I [] Enable real-time ISP to allow background programming (for MAX IT and MAX V devices)

Progress: l

File

my_first_fpoa.sof

EP4CGX150DF31

Dewice

Checksum

007240DES

Usercode

FFFFFFFF

Program/ Verify
Configure

Blank-
Check

Examine

4

IALTERN

—

L4

2.

3.

Click Hardware Setup.

hardware. See Figure 4-4.

Figure 4-3 Programmer Window

If it is not already turned on, turn on the USB-Blaster [USB-0] option under currently selected

{'{")‘ Hardware 5Setup

Hardware Settings ITAG Settings |
Select a programming hardware setup to use when programming devices. This programming
hardware setup applies only to the current programmer windowe.
Currently selected hardware:
Available hardware items
Hardware Server Port Add Hardware. .. |
USE-Blaster Local UsBE-0
Remowve Hardware
Figure 4-4 Hardware Setting
4. Click Close.
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5. If the file name in the Programmer does not show my_first_fpga.sof, click Add File.

6. Select the my_first_fpga.sof file from the project directory (see Figure 4-5).

> Programmer — E:/Hy design/my first fpga/my first fpga — my first fpga — [my first fpe... E”EJ@
Fle FEdit ¥ew Processing Tools Window Help 3 |Searcl'; FrT—— |@

[G:; Hardware 5et|..||:l...] !USB—BIaster [usB-a] | Mode: !JTAG VI Progress: ’ 100%: (Su&:cassﬁii'; j]

["] Enable real-time ISP to allow background programming {for MAX II and MAX V devices)

File Device Checksum Usercode Program/ Verify Blank- Examine ‘

Wi Start Configure Check |
= my_ first fogs.sof EPACGX150DF31  O00774DE5  FFFFFFEF |
e ]n]

et Auto Detect
X Delete

Gl Add File...

B8 change File... -
Ll
@ Save File A

(& add Device...

FMagdaeaaaas

oty PRy
ﬁ" Bai L’ i: ’ H j

Figure 4-5 Downloading Complete

Congratulations, you have created, compiled, and programmed your first FPGA design! The
compiled SRAM Object File (.sof) is loaded onto the FPGA on the development board and the
design should be running.

4.3 Verify The Hardware

When you verify the design in hardware, you observe the runtime behavior of the FPGA hardware

design and ensure that it is functioning appropriately.
Verify the design by performing the following steps:

1. Observe that the four development board LEDs appear to be advancing slowly in a binary

count pattern, which is driven by the simple_counter bits [26..23].
The LEDs are active low, therefore, when counting begins all LEDs are turned on (the 0000 state).

2. Press and hold KEY [0] on the development board and observe that the LEDs advance more

quickly. Pressing this KEY causes the design to multiplex using the faster advancing part of the
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counter (bits [24..21]).

3. If other LEDs emit faintness light, Choose Assignments > Device. Click Device and Options.
See Figure 4-6.

Wi +
&, Dewice

Select the family and device you want to target for compilation.

Device family Show in '&vailable devices' list
Farnily: !Cydone IV GX vi Package: iAny’ v|
Devices: |.-!I.II | Pin count: gAny v|
Speed grade: |Any vl
Target device =
Mame filter: | [

() Auto device selected by the Fitter

(%) Spedific device selected in ‘Available devices' list P BT e PRLIGODY compativie By

Qther: n/a [QEViI.'.E and Pin Options.. J

Available devices:

Mame Core Voltage LEs User1/0s GXB Transmitter Channel PMA GXB Receiver Chan ™
EP4CGXN110DF31CE | L2V | 109424 | 508 8 8
EP4CGX110DF3117 | 1.2V | 109424 | 508 8 8
EP4CGX150CF23CT 1.2V | 149760 | 287 4 4
EP4CGX150CF23C3 | 1.2V | 149760 287 |4 4
EP4CGK150CF23I7 | 1.2V | 1497850 | 287 4 4
EP4CGX150DF27CT | 1.2V | 143760 | 425 8 B
EP4CGX150DF27C8 | 1.2V | 149760 | 426 8 s
EP4CGX150DF27T7 | L2V 199760 (426 i3 |8
EP4CGEX 1500F31C7 | 1.2V 149750 | 508 s 8 =
EP4CGX150DF31C8 | 1.2V | 149750 | 508 8 8 E
EPACGX150DF31I7 | 1.2V 149750 |508 8 8 ¥
< | >|

Migration compatibility Companion device

[ Migration Devices. .. J HardCopy! |

0 migration devices selected Limit DSP & RAM to HardCopy device resolrces

[ QK J ’ Cancel J [ Help J :

Figure 4-6 Device and Options

Choose unused pins. Reserve all unused pins: Choose the As input tri-stated option. See Figure 4-7.
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& Device and Pin Optionz — my first fpga

Category:
“General
Configuration
- Programming Files Spedify device-wide options for reserving all unused pins on the device. To reserve individual dual-
Unused Pins : purpose configuration pins, go to the Dual-Purpose Pins tab. To reserve other pins individually, use
-~ Dual-Purpose Pins the Assignment Editor.
i Capadtive Loading =
"~ Board Trace Model ; ; : I
- 1/O Tiing Reserve all unused pins: | LEAige il ==ty w
“Voltage
i~ Pin Placement
~Errar Detection CR.C
CwP Settings
Description:
Reserves all unused pins on the target device in one of 5 states: as inputs that are tri-stated, as
outputs that drive ground, as outputs that drive an unspecdified signal, as input tri-stated with bus-
hold, or as input tri-stated with weak pull-up.
[ oK J [ Cancel l [ Help ]
Figure 4-7 Setting unused pins
Click twice OK.

4. In the Processing menu, choose Start Compilation. After the compile, Choose Tools >

Programmer. Select the my_first_fpga.sof file from the project directory. Click Start. At this time
you could find the other LEDs are unlighted.
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Chapter 5

DEZI-150 System Builder

5.1 Headquarter & Branches

o Tel : +886-3-5508800

e Fax @ +886-3-5502860

e Add : No.356, Sec. 1, Fusing E. Rd., JhuBei City , HsinChu County Taiwan
302-64

e Email : sales@terasic.com / support@terasic.com
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