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Evaluating the ADPD103 Photometric Front End

FEATURES GENERAL DESCRIPTION
Supports the detection of UART The EVAL-ADPD103Z-GEN evaluation board provides the
UDP transfer capability user with a simple means of connecting their own optics to the
ADPD103 full configuration ADPD103 photometric front end to evaluate the ADPD103 in a
Register level number of different applications, from vital signs monitoring to
Pa ran?eter level industrial sensing. The evaluation board includes the OpenMarket
Gra!)h view WaveTool graphical user interface (GUI) that provides the user
Time graph with low level and high level configurability, real-time frequency
Frequency graph . . .
and time domain analysis, and User Datagram Protocol (UDP)
EVALUATION KIT CONTENTS transfer capability so that the evaluation board can easily interface
EVAL-ADPD103Z-GEN evaluation board to the user’s development system.
Mini USB cable The USB port powers the EVAL-ADPD103Z-GEN. On-board
ADDITIONAL EQUIPMENT NEEDED voltage regulators provide voltage supplies for the ADPD103,

ADuCM360, and FTDI Chip FI232. There are on-board regulators
that provide 3.3 V and 4.3 V LED supplies, as well as a selectable
ADDITIONAL SOFTWARE NEEDED option to add an external LED supply. The evaluation board
provides an LED and photodiode (PD) for a finger photo-

PC running Windows 7 operating system

.NetFramework 4.0

plethysmography (PPG) measurement that is useful for a quick
ONLINE RESOURCES functionality check of the evaluation system.
ADPD103 data sheet

The schematic and board layout, as well as the board itself,
indicate signal names for easy identification. For additional
information on the functionality of the ADPD103, refer to the
ADPDI103 datasheet.
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Figure 1. EVAL-ADPD103Z-GEN Evaluation Board
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INSTALLATION

INSTALL WAVETOOL

Download the ADPD103 OpenMarket WaveTool software
package from the EVAL-ADPD103Z-GEN page on analog.com.
Unzip the folder and run the ADPD103_OpenMarket_
WaveTool_Setup.exe file found in the WaveTool_x_x_x folder,
following the prompts for software installation.

F=men ===

Welcome to the ADPD103
OpenMarket WaveTool v1.4.2
Setup Wizard

D ADPD103 OpenMarket WaveTool v14.2 Setup

This wizard will guide you through the installation of
ADPD10Z Opentarket WaveTool v1.4.2 |

It iz recommended that you close all other applications
before starting Setup. This will make it possible to update
relevant system files without having to reboot your
computar,

Click Mext to continue.

[ext = Cancel

14321-002

Figure 2. WaveTool Setup

CHECKING THE USB SERIAL CONNECTION IN
WINDOWS 7

Connect the USB cable to the EVAL-ADPD103Z-GEN
evaluation board. Ensure that the COM port driver is installed
correctly. To verify proper installation, go to Control Panel >
All Control Panel Items > System > Device Manager, as
shown in Figure 3. In this case, the proper COM Port selection
is USB Serial Port (COM16).

The EVAL-ADPD103Z-GEN evaluation board uses an FT-232R
USB UART IC. If the USB driver installation does not install
propetly, refer to the FTDI Driver Installation guide found on
the FTDI website.

= Device Mansger 5 =%~ |
File. Acion  View Help

(7

Figure 3. USB-COM Port in Windows® 7

Rev. 0| Page 3 of 23
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RUNNING THE TOOL
To start the WaveTool application, navigate to the ADPD103 USB UART CONNECTION

OpenMarket WaveTool from the Start menu and click After the application opens, select File > Connect (see Figure 6)

ADPD103_Tool and from the drop-down menu, select either Auto Connect or

| Analog Devices Select Port, depending on whether specific COM port selection

I ADPD103 OpenMarket WaveTool

is necessary.

= = = =
[3 ADPD103 OpenMarket WaveTor

) AP0
(3 ADPD103_Tool File | View Tools Help
=7 R a | Connect 4 || Autg.Connect | -
| Documentation % Disconnect  Ctri+D se|e._£’t"p0,t 12
i Register Dump
Figure 4. Navigate to ADPD103_Tool from Start Menu
L . Load Cfg Ctrl+L
At startup, the application automatically checks whether the - s S bt R
installed WaveTool version is up to date. If there is a newer - .
. . . ApPply Lonrig

version available, the user is prompted to download the new P = Ll
version, as shown in Figure 5. I Byt g

Register View

Figure 6. UART Connect

MName Walue
Register Field Vie, If a specific COM port selection is not needed, select Auto
Connect to automatically connect the WaveTool to the device.
Choose Select Port to connect the WaveTool to the device via a
UpdateStatus

particular COM port as shown in Figure 7.

A new version is available. 1

* Woul_d you like to update? m
Ill Version - 1.4.2 - Connect \El

Update Cancel
l:] Connect

Single Register '

Register A L
Register Yal § COM23
,—; § COmB

Figure 5. Automatic Version Update Prompt

14321-007

Figure 7. Port Selection
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MAIN SCREEN

The main screen is divided into two different modes: register
level and parameter level/high level.

The register level configuration is used to access each register or
to load a complete list of registers that are already stored in a
configuration file on the PC.

The parameter level/high level configuration performs a high
level configuration of the device without the need for individual
register writes. The high level configuration screen is used to
setup parameters such as LED current, number of LED pulses,
AFE integration time, and so forth.

USING THE REGISTER VIEW CONFIGURATION

Figure 8 shows the ADPD configuration window in Register
View. The following controls and descriptions are listed in the
configuration window:

e  Firmware Version—shows the firmware version.
¢  Config File in Use—information about the configuration
file that is in use.

3 ADPD103 OpenMarket WaveT ool

Register View shows the current register values of the
device. Change register values by entering a hexadecimal
value and then the Enter key on the keyboard.

Register Field View shows how the register is subdivided
into fields that determine how each bit field is used. For
example, in Figure 8 it shows that the PAD_IO_CTRL
Register 0x02 is composed of the bit fields INT_POL,
INT_DRYV, and INT_ENA to configure the operation of the
INT pin.

The Single Register Control allows reading and writing of
individual registers.

Load a configuration file (.dcfg) by choosing File >
LoadCfg and selecting a .dcfg file that came with the
software installation or a custom .dcfg file developed by the
user for a desired configuration.

Save a configuration file (.dcfg) by choosing File > SaveCfg.
The Go to High Level button switches to the High Level
Control view.

File Wiew Tools Help

Register View

’ Go o HighlLevel ‘

Firmware Yersion MName Walue -
1.8 INT_STATUS (00) [ox0000
INT_MASK (m) | nennEFE Register Field View
Al ( |0x0005 Mame Yalue
Conlfig File in Use FIFO_LENGTH (D8} Ox0F0T mmm_
MO3_103_GGRI_Dafaul deig CHIPID (08) |0x0415 INT_DR (1:1) ;D
12C5_I0 (09) Ox00C8 INT_EMA (2:1) 1
0532M_CAL_OUT (04) 007 CA | RESERVED (3:13) 0
OP_MODE (10) |oxo000 1= '
OP_MODE_CFG (11) (o311
SAMPLING_FREC! (12) 00014
PD_SELECT (14) |0xo55E
INT_AVG_MODE (15) 00220
CHI_OFFSET_A(18) [ox1EDD
CHZ2_OFFSET A (18) Ox1E00
CH3_OFFSET_A (1A) |Ox1E0D Single Register Control
CH4_OFFSET_A (1E) Ox1E00
CH1_OFFSET_EB (1E) Ox1E0D Fegister Address [x
CHZ2_OFFSET_B (1F) [ox1E00
CH3_OFFSET_E (20) |0x1EnD L
CH4_OFFSET_E (21) |ox1E00
LEDT_DRV (23) 03037 ‘ s ‘
LED3_DRY (22) Ox103F
LEDZ_DRY (24) [ox1032
LED_TRiIM (25) 0x02CC ‘ Write Register ‘
PULSE_OFFSET_A (30) :EleIST 9
Clll ©F DEEIMM (214 N ikl

UART Bridge

14321-008

Figure 8. Main Screen Register Level View
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Register View

To view the registers of the device, select Register View, shown
in Figure 8. The Name column is the register name as defined
by the register map, followed by (in parentheses) the address in
abbreviated hexadecimal format (see Figure 9). The Value
column shows the register value of the corresponding register in
full hexadecimal format.

Register View

Name Walue -
INT_STATUS (00) D000
INT_MASK (01) DOFF
PAD_IO_CTRL {02) <0005
FIFO_LENGTH (D) <0000 3
CHIPID (08) L0416
[2CS_1D (09) =<00CE
OS32M_CAL_OUT (DA) 07EE I
OF_MODE (10} <0000

OP_MODE_CFG (1) 3011
SAMPLING_FREQ (12) | 0x0014
PD_SELECT (14) [e055E
INT_AVG_MODE (15) (0220
CH1_OFFSET_A (18) e 1E0D
CH2_OFFSET_A(19) L 1E0D
CH3_OFFSET_A(1A) L1E0D
CH4_OFFSET_A(18) e1E0D
CH1_OFFSET_B (1E) Le1E00

14321-009

Figure 9. Register View

Clicking any register in the Register View fields reveals the
register categories in the Register Field View, as shown in
Figure 10. The Register Field View is read only.

Name Value
RESERVED (0:5) 0
SLOTA_INT_STATUS (5:1)
SLOTB_INT_STATUS (6:1)
RESERVED (7:1)
FIFO_STATUS (8:81)

0
0
0
0

14321-010

Figure 10. Register View Showing Operation Control Registers

Enter data in cells in the Value column of the Register View in
either hexadecimal or decimal format. A hexadecimal number is
entered with a 0x prefix to the number, whereas a decimal
number does not include these prefix characters. For example,
entering OXFF (hexadecimal) or 255 (decimal), results in the
same value written to the register.

Hovering over a cell in the Value column shows the delineation
of the register fields for the current value (see Figure 11),
whereas hovering over a cell in the Name column shows a
description of the corresponding register.

INT_MASK (01) LIS | [sLoTa NT_mask sy [
PAD_I0_CTRL (12} 30005 INT_MASK @ 05

12C5_CTL_MATCH (06) | eOF 0T o nopp

CHIPID (08) 00416 Ficld ) Value
RESERVED 1

12C5_ID (03} ODIC 51 oTA_INT_MASK 1

OSI2M_CAL OUT(08) | 00707 SLOTBINT_MASK 1
RESERVED 1 -

SW_RESET (OF) OO0 FiEoy INT_MASK 0 3

OF_MODE (10) RESERVED 0 g

Figure 11. Register Value Field Delineation on Hover

The Register View has a context sensitive window exposed by
right-clicking the mouse anywhere on the grid, as shown in
Figure 12.

Refresh Selected
Refresh All Fa

Show Hex

Figure 12. Register View Context Menu

14321-012

By using this menu, it is possible to refresh the selected register,
refresh all registers, or select whether the selected register
displays in hexadecimal or decimal format. The selection of
hexadecimal vs. decimal is persistent across opening and
closing of the tool.

For example, in Figure 13, the Time Slot B offset registers
(CHx_OFFSET_B) display in decimal format but others, such
as LED drive settings (LEDx_DRYV), display in hexadecimal
format.

CH1_OFFSET_E (1E) 7660
CHZ_OFFSET_B (1F) 7680
CH3_OFFSET_E (207 7660
CH4_OFFSET B (21] 7680
LEDT DRV (23) %3037
LEDS_DRY (22) Ox103F
LEDZ_DRY [24) 01032
LED_TRiM (25) 0x0200

Figure 13. Register Values in Decimal and Hexadecimal Format
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Register Field View

The Register Field View is a read-only view to see specific
register field value(s). It automatically tracks the currently
selected register in Register View.

The Register Field View is composed of two columns as shown
in Figure 14.

Register Field View

Mame Value
ReEEo 0
SLOTA_INT_STATUS (&:1) |0
SLOTE_INT_STATUS {&:1) | D
RESERVED (7:1) 1]
FIFO_STATUS (8:2r) 0

14321-014

Figure 14. Register Field View

The Register Field View section shows each register field,
where the Name column consists of the field name (start bit:
length in bits), and the Value column provides the hexadecimal
value (without the prefix characters, 0x) of that field .

Single Register Control

The Single Register Control section includes controls to read
or write an individual register.

The Read Register button reads and displays the value of the
register entered in the Register Address field.

The Write Register button writes the register with the value
entered in the Register Value field.

Single Register Control

Register Address|x A

Register Value |* O7E3

‘ Read Register ‘

‘ ‘wirite Register ‘

14321-015

Figure 15. Single Register Control

Rev. 0| Page 7 of 23




UG-947

PARAMETER LEVEL (HIGH LEVEL)

Figure 16 shows the ADPD103 high level configuration window.
This window offers an entire set of high level parameter
controls. The configurable parameters are as follows:

e  Sampling Frequency—adjusts the sampling rate.

e Internal Average (identical for both slots)—controls the
output data rate, which is equal to the sampling frequency
divided by the internal average. For example, a sampling
frequency of 400 Hz and an internal average setting of 4, as
shown in Figure 16, results in an output data rate of 100 Hz.

e ADPD Slot Mode—specifies all the ADPD slot modes.

¢ Slot A Control and Slot B Control
¢ LED Control

e  LED-—selects the specific LED from a drop-down
menu.
e  LED Status—specifies the status of the LED,
whether it is in the on or off state.
e Number Of Pulses—sets the number of LED
pulses.
e  TIA Gain—sets the gain of the TIA via a drop-down
menu.
¢ Timing Control—see the ADPD103 datasheet for
detailed descriptions of the timing controls.

| 3 ADPD103 OpenMarket WaveToo

3 LED's High Level Control

Sampling Frequency 400

SLOT ACONTROL
LED Cortrol Timing Control

LED AFE Vfidth (us) 4

LED 2 b
LED ON -

Number Of Pulses 2

LED Status Pulse \idth (us) 13

125 2]

Pulse Offset (us)

AFE Offset(us) 15

oy AFE Fine Offset (ns)/843.75

LED1 LED2

-

135.9476

g

Final |_LED mé Final |_LED 2295523

Intemal Average

SLOT BCONTROL

-

mé

e AFE Width—sets the AFE integration time in

microseconds.

e Pulse Width—sets the LED pulse width in
microseconds.

e Pulse Offset—sets the LED pulse offset in
microseconds.

e  AFE Offset—sets the coarse AFE integration offset
in microseconds.

e AFE Fine Offset—sets the fine AFE integration
offset in nanoseconds.

e LED1,LED 2, LED 3 current controls

e I _LED Coarse—coarse setting for the LED current
via a drop-down menu.

e Scale Factor—100% or 40% scale factor applied to
the coarse LED current setting.

e  Final I LED—this is controlled by applying a fine
tuning value by using the slider. The Final I_LED
current displays in mA.

To switch to the register level configuration, click the Go to

RegisterLevel button.

Go to RegisterLevel

ADPD Slot Mode | Slot A 16-Bits -

LED Cortrol Timing Cortrol

LED AFEWidth (us) 4

LED 3 -
LEDON >

it s

Do Pulse Width (us) 3

Number Of Pulses Pulse Offset (us) 32

AFEOfset(us) 15

Rl AFE Fine Offset (ns) 843.75

LED 3

—_—

Final |_LED 738116 mé

Apply

UART Bridge

14321-016

Figure 16. Main Screen High Level View
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ADPD SLOT MODE

The ADPD slot mode contains Slot A, Slot B, and their sum and
digital integration modes.

ADPD Slot Mode  |Slot A 16-Bits -

Slot A 16-Bits
Slot B 16-Bits
L Slot AB 16-Bits
- Slot A 32-Bits
Slot B 32-Bits
! Slot AB 32-Bits
E03 Slot A Sum 16-Bits
@ ISlot B Sum ‘IS-Bits_
Slot AB Sum 16-Bits
g8 2 I Slot A Sum 32-Bits
Slot B Sum 32-Bits
Slot AB Sum 32-Bits
100k jSIotADig-Intj 16-Bits
Slot B Dig-Int_1 16-Bits
Slot AB Dig-Int_1 16-Bits
Slot A Dig-Int_1 32-Bits
Slot B Dig-Int_1 32-Bits
Slot AB Dig-Int_1 32-Bits

SlotA Dig-nt_2 16-Bits
carse | 250 Slot B Dig-int_2 16-Bits

- Slot AB Dig-Int_2 16-Bits
sctor|40% Slot A Dig-int_2 32-Bits
Slot B Dig-nt_2 32-Bits

Slot AB Dig-Int_2 32-Bits

14321-017

Figure 17. ADPD Slot Mode

Slot A (16 Bits)

The 4-channel, 16-bit data displays in the Time View for Time
Slot A only. Selected channel data in the Channel Select drop-
down box displays in FFT view.

Slot B (16 Bits)

The 4-channel, 16-bit data displays in the Time View for Time
Slot B only. Selected channel data in the Channel Select drop-
down box displays in FFT view.

Slot AB (16 Bits)

The 4-channel, 16-bit data displays in the Time View for both
Time Slot A and Time Slot B. Selected channel data in the
Channel Select drop-down box displays in FFT view.

Slot A (32 Bits)

The 4-channel, 32-bit data displays in the Time View for Time
Slot A only. Selected channel data in the Channel Select drop-
down box displays in FFT view.

Slot B (32 Bits)

The 4-channel, 32-bit data displays in the Time View for Time
Slot B only. Selected channel data in the Channel Select drop-
down box displays in FFT view.

Slot AB (32 Bits)

The 4-channel, 32-bit data displays in the Time View for both
Time Slot A and Time Slot B. Selected channel data in the
Channel Select drop-down box displays in FFT view.

Slot A Sum (16 Bits)

The sum of 4-channel, 16-bit data displays in the Time View for
Time Slot A only. Selected summation sample data in the
Channel Select drop-down box displays in FFT view.

Slot B Sum (16 Bits)

The sum of 4-channel, 16-bit data displays in the Time View for
Time Slot B only. Selected summation sample data in the
Channel Select drop-down box displays in FFT view.

Slot AB Sum (16 Bits)

The sum of 4-channel, 16-bit data displays in the Time View for
both Time Slot A and Time Slot B. Selected summation sample
data in the Channel Select drop-down box displays in FFT
view.

Slot A Sum (32 Bits)

The sum of 4-channel, 32-bit data displays in the time view for
Time Slot A only. Selected summation sample data in the Channel
Select drop-down box displays in FFT view.

Slot B Sum (32 Bits)

The sum of 4-channel, 32-bit data displays in the Time View for
Time Slot B only. Selected summation sample data in the Channel
Select drop-down box displays in FFT view.

Slot AB Sum (32 Bits)

The sum of 4-channel, 32-bit data displays in the Time View for
both Time Slot A and Time Slot B. Selected summation sample
data in the Channel Select drop-down box displays in FFT
view.

Slot A Dig Int-1 (16-Bits)

16-bit digital integrated sample data displays in the Time View
for Time Slot A only. Selected sample data in the Channel Select
drop-down box displays in FFT view.

Slot B Dig Int-1 (16 Bits)

16-bit digital integrated sample data displays in the Time View
for Time Slot B only. Selected sample data in the Channel Select
drop-down box displays in FFT view.

Slot AB Dig Int-1 (16 Bits)

16-bit digital integrated sample data displays in the Time View
for Time Slot A and Time Slot B. Selected sample data in the
Channel Select drop-down box displays in FFT view.

Slot A Dig Int-2 (16 Bits)
16-bit digital integrated sample and background data displays in
the Time View for Time Slot A only. Selected sample or back-

ground data in the Channel Select drop-down box displays in
FFT view.

Rev. 0| Page 9 of 23
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Slot B Dig Int-2 (16-Bits)

16-bit digital integrated sample and background data displays in
the Time View for Time Slot B only. Selected sample or back-
ground data in the Channel Select drop-down box displays in
FFT view.

Slot AB Dig Int-2 (16 Bits)

16-bit digital integrated sample and background data displays in
the Time View for Time Slot A and Time Slot B. Selected sample or
background data in the Channel Select drop-down box displays
in FFT view.

Slot A Dig Int-1 (32 Bits)

32-bit digital integrated sample data displays in the Time View
for Time Slot A only. Selected sample data in the Channel Select
drop-down box displays in the FFT view.

Slot B Dig Int-1 32 Bits:

32-bit digital integrated sample data displays in the Time View
for Time Slot B only. Selected sample data in the Channel Select
drop-down box displays in the FFT view.

Slot AB Dig Int-1 (32 Bits)

32-bit digital integrated sample data displays in the Time View
for Time Slot A and Time Slot B. Selected sample data in the
Channel Select drop-down box displays in the FFT view.

Slot A Dig Int-2 (32 Bits)

32-bit digital integrated sample and background data display in
the Time View for Time Slot A only. Selected sample or back-
ground data in the Channel Select drop-down box display in
the FFT view.

Slot B Dig Int-2 (32 Bits)

32-bit digital integrated sample and background data display in
the Time View for Time Slot B only. Selected sample or back-
ground data in the Channel Select drop-down box display in
the FFT view.

Slot AB Dig Int-2 (32 Bits)

32-bit digital integrated sample and background data display in
the Time View for Time Slot A and Time Slot B. Selected sample or
background data in the Channel Select drop-down box display
in the FFT view.

LOAD AND SAVING CONFIGURATIONS

To load and save device configuration files use File > Load Cfg
and File > Save Cfg, respectively, as shown in Figure 18 and
Figure 19. Load configuration (Load Cfg) loads the set of
registers mentioned in the user selected .dcfg file to ADPD103.
Save configuration (Save Cfg) saves all writable registers of
ADPD103 to a .dcfg file via the Open file dialog box.

Find sample configuration files installed with the WaveTool
application in the SampleCfgs folder.

File | View Tools Help

Connect

Disconnect  Ctrl+D

Register Durnp

Load Cfg  ~ Ctrl+L
Save Cfg bs Ctrl+5

Apply Config

Exit

14321-018

Figure 18. Load Configuration

File | View Tools Help

Connect

Disconnect  Ctrl+D

Register Dump

Load Cfg Ctrl+L
Save CFQ Ctrl+5
Apply tﬁ nfig

Exit

14321-019

Figure 19. Save Configuration

Selecting Load Cfg opens up a file dialog window. Device
configuration files have the extension .dcfg. Once loaded, the
configuration file used by the evaluation board is indicated in
the main window, as shown in Figure 20. The full path of
the .dcfg file is shown when the mouse hovers over the file
name. If no file is loaded, then it is indicated as None.

Config File in Use
Finger_FPPG_default.dcfg

Full Path
C:\Program Files (x86)\An

14321-020

Figure 20. Configuration File in Use

A configuration file uses the following format:

Address Data # (comment optional)

Where the address can be an in 8-bit or 16-bit format and the
data must be in 16-bit format, as follows:

14 0555 #setup input PD configuration

15 0220 #number of averages = 4

18 1F80 #slot A channel 1 ADC offset

19 1F80 #slot A channel 2 ADC offset

Rev. 0| Page 10 of 23
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APPLY CONFIGURATION

A previously loaded configuration remains in the memory of
the tool until overwritten by a new load configuration
(LoadCfg). Therefore, to return to a loaded configuration
quickly, it is not necessary to reload the configuration, instead
select File > Apply Config.

File | View Tools Help

Connect

Disconnect  Ctrl+D
Register Dump

Load Cfg Ctrl+L
Save Cfg Ctrl+5

Apply Config
g

Exit

14321-021

Figure 21. Apply Configuration

DUMP REGISTERS

With the tool, it is possible to dump all the registers to a single
file by selecting File > Register Dump, as shown in Figure 22.

File | View Tools Help

Connect

Disconnect  Ctrl+D

| Register Dump

Ly
Load Cfg Ctrl+L
Save Cfg Ctrl+5
Apply Config

Exit

14321-022

Figure 22. Dump Register

Registers are dumped into a text file with a filename given by
the user upon opening the File dialog box, a window that
prompts the user to save the file to a specific location with a
specific name.

The following is an example of a register dump:

PD_SELECT (14) 0555

INT_AVG_MODE (15) 0220

CH1_OFFSET_A (18) 1F80

CH2_OFFSET_A (19) 1F80

Note that, the register is listed by name (address in hexadecimal
value).

Rev.0|Page 11 of 23
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GRAPH VIEW

Use Graph View or real-time frequency and time domain
analysis of the ADPD103 raw data. Access Graph View from the
main window via the View menu tab, as shown in Figure 23.

| View | Tools

Help

When the Graph View opens, it defaults to the time domain z
8
g
view (Time View) as shown in Figure 24. There is also a
. . . Figure 23. View Menu
Frequency View tab for frequency domain analysis.
Graph View \
H > m ChannelCalibration Target 400
Time View | Fraquency Yiew |
7] LUDF Transfer [| Save Raw Data WeAois Sample Counts - 250
Raw Data Channels
18
T T A
BB it 15 ST . SIS ISR R ) ESIRE A GRS [ eSSt g
515 =+ . - ¥ g T RN T
_ B4
s
= :
bl Bc I SR SEEESEUTES [ ERRRREES? SRR EEUTURTERS f ERTE CARPPEREE SERFERE [EFISRRTY STRR: RETTREEERSY S-SR (FFERERTE SYREPREEE (EER-EN URTETEREE) ERRERRT: REPRTERS EERTEE SRS
==}
i
| :
(N O OO O SO | SO SO0 RN O O TOI IJOUNG . SRS OO OO -SRI = C OO O | SN I NI | O N SO . .. <. S .
611 1
E‘] D = £ T R P R P B b i el R S o P T D P T R B P
(i TR R U SRR L U AU SO - NURE: UL S SO NN ORI SRR SRR SR NP SN SRR L S SN )
i : : : : ; : ] : : ]
60 270 280 290 300 310 320 330 340 380 360 0 30 300 400 410 420 430 440 450 460 470 480 490 500
Sample (Index)
Slot A : . Slot A
- || AutoScaleEnable =
‘!\L Chanrel 1-Blue Channel 1-SkyBlue [¥] Avg_Ch1:81373 W] 8D chi: 1748 By Chl - SD_Ch1: -
Channel 2-Gi ' . i
| Chieninie | 2-Giren Channel 2-Magenta Min |0 [¥] Awg Ch2 O W] s ch2: 00 Aug_CnZ ;- 5D Ch2:
[T channel 3-Fed Channel 3-Orange i [T [¥] Avg_Ch3: 0 ¥ S0 _ch3: 0.0 Avg_Ch3 - 5D Chd .-
[] channel 4-Black Channel 4-Maroon [Ed| Ay Ché 0 ™ SD_Ch4 : 0.0 By Che: - SO Chd : -
[T Slat & Surn - Violet Slot B Surn - Brown O g SUM - - O SD_SUM - - A SUM - - SD_SUM: —

Figure 24. Time View
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Time View

Time View displays the raw data from the sensor in time
domain format. Plot or send the raw data through the UDP
protocol to the host system that is controlled by a checkbox in
the Time View, which has three controls:

e  UDP on/plot off, where the UDP Transfer checkbox is
checked (see Figure 25).

UDP Transfer

14321-024

Figure 25. UDP On/Plot Off Mode

e UDP off/plot on, where the UDP Transfer checkbox is not
selected (see Figure 26).

[ UDP Transfer

14321-025

Figure 26. UDP Off/Plot On Mode

e  UDP on/plot on, where the UDP Transfer checkbox fill is
solid (see Figure 27).

UDP Transfer

14321-026

Figure 27. UDP On/Plot On Mode
In UDP on mode, the data is sent through UDP and does not
display in the graph panel.
In UDP off/plot on mode, the data displays in the graph panel
but is not sent through the UDP.
In UDP on/plot on mode, the data is sent through UDP and
also displays in the graph panel.

The UDP Transfer Tool, a separate executable within the
WaveTool package, receives the data from WaveTool and
transfers the data to the assigned UDP port.

To save the raw data into a file, check the Save Raw Data
checkbox, as shown in Figure 28. When the box is checked, the
user is prompted to save the file.

[7] Save Raw Data

Figure 28. Checkbox to Save Sensor Raw Data to a File

Slot A
Avg_Chl: — SD_Ch1: -
fwg_Ch2 : - SD_Ch2: -
dovg_Ch3: - SD_Ch3: -
forg Chd : - SD_Ch4 : --

Configure the x-axis sample count for graph plotting through
the X-Axis Sample Counts field (see Figure 29).

-

¥-Axis Sample Counts ; (100 =

14321-028

Figure 29. X-Axis Sample Count Configuration

Note that, the minimum value for sample count is limited to
100. If it is assigned with values smaller than 100, it
automatically corrects to 100.

Time View shows the raw data graph that plots Sample (index)
vs. LSBs data.

The plot of each individual channel is controlled using the
checkboxes as shown in Figure 30.

Slot A Slot B

Channel 1-Blue Channel 1-SkyBlue
Channel 2-Green Channel 2-Magenta
Channel 3-Red Channel 3-Orange
Channel £-Black Channel 4-Maroon

14321-029

Figure 30. Channel Display Control

By clicking the checkbox the corresponding channel data is
plotted with the specified color in the Raw Data graph.

The auto scaling of the time graph view can be enabled/disabled
by a checkbox present at the bottom of the time graph. Also the
minimum and maximum scale range can be adjusted while the
auto scale option is disabled.

LutoScaleEnable
Min |0 <

Max |10000 =

-

14321-030

Figure 31. Auto Scale Control and Scale Range Setting

The average and standard deviation for every channel and sum
of all channels are displayed along the bottom of the time graph
view. These statistics are enabled or disabled by the checkbox
preceded by each label as shown in Figure 32.

Slot B

Avg_Ch1: - SO_Ch1: -
Avg_Ch2: - SD_Ch2 : -
Avg_Ch3: - SD_Ch3 : —
Avg_Chd : — SO_Chd : -

14321-031

Figure 32. Average and Standard Deviation Display
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General Controls S OTA CH
Ch | Select: - %
Using standard controls, the user can start (see Figure 33), stop anne
the current mode and return to idle mode (see Figure 34), and SLOTA-CH 2
pause the device in its current operating state (see Figure 35) SLOTA-CH3
— 5LOTA-CH4

whereby graphs are no longer updated but data is still retrieved

>

Figure 33. Start Icon

Figure 34. Stop and Return to Idle Icon Ko S T, 11 St 20

14321-035

from the device.
Figure 38. Slot A Channels

14321-133

The linear scale of the FFT graph is shown in Figure 39 and the

14321-134

1 Chiset Sebees SUOTASEA T

0
8
o Spéctrum
b
2

Figure 35. Pause and Resume Icon o+ gEm

FREQUENCY VIEW

Frequency View shows the fast fourier transform (FFT) of the
raw data in the form of a graph that plots amplitude vs. N
frequency (Hz). The user can select the x-axis scale type as R | |

linear or logarithmic in the X Axis Scale Type drop-down list, _' l!_[fil

as shown in Figure 36. o P ) ) &

Hlxis Scale Type: |Linsar =

14321-036

Figure 39. Linear FFT Graph

14321-033

[
Logarithmic |—
-

Figure 36. X-Axis Scale Type D0 M >N CuomstnTaaen

The FFT Samples field provides the number of samples used to Tmmhrmfmt o] e B Ouses (BINGD
calculate the FFT. I - A

FFT Samples : [100

Ak
14321-034

Figure 37. FFT Samples || l

Note: The minimum value for sample count is limited to 50 : ]

samples. If it is assigned with values smaller than 50, it i 1

automatically corrects to 50. "3 RO V i

The Frequency View displays any one of the enabled channels i _

from the Channel Select drop-down list. For example, if Slot A
is enabled, the user can select any one channel of Slot A, as

14321-037

hown in Figure 38.
show gure 38 Figure 40. Logarithmic FFT Graph

Rev. 0| Page 14 of 23




UG-947

TOOLS

OPTIONS

The Options selection from the Tools drop-down menu shows
the general board settings as well as the UDP configuration.

General

The General tab contains information about the device, the

platform, and the firmware version.

Firmware Version

3 UDP Configuration
Board Settings
Device ADPD103
Platform M360

16

ok

==

UDP Configuration

The UDP Configuration tab allows the user to configure the
port numbers for UDP communication. The UDP transfer tool
sends the raw data to the client via the specified port numbers.
The IP address field should be filled with the IP address in

which the UDP transfer tool is running.

Use the Raw Data Transfer Port field to assign the port number
for sending raw data from WaveTool to the data transfer tool.

Figure 41. Options Window: General

Enter UDP Transfer Tool IP Address:

Port Number Configuration

Raw Data Transfer Port: 50007

172.16.7.124

Figure 42. Options Window: UDP Configuration

AUTOMATIC UPDATE
The Tools > Auto Update function enables/disables the

Tools | Help

Options i

l. AutE Update
Check For Updates

Firmware Update

14321-040

Figure 43. Auto Update

CHECK FOR UPDATES

Use the Tools > Check For Updates function to manually check
for the availability of a new software update.

Tools | Help

Opticns i

Auto Update

| Check For Updates

Firmware Update

14321-038

14321-041

Figure 44. Check for Update

FIRMWARE UPDATE

Note: The WaveTool must be connected with the target board to
perform the firmware update; otherwise, the WaveTool shows a
disconnect message (see Figure 45).

Target(M360) is not connected with Wavetool
Please connect and proceed for firmware updaticon

14321-045

Figure 45. Connection Status for Firmware Update

Use the Tools > Firmware Update function to start the
firmware update process.

Tools | Help

Opticns

Auto Update

Check For Updates

Firmware Update

14321-039

14321-042

Figure 46. Firmware update

automatic software update functionality at the time of tool start.

When Auto Update is enabled, it checks for the availability of a When Firmware Update is selected, the CM3WSD firmware
new WaveTool update and prompts the user to update the tool flashing tool opens.

with the latest version.
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To flash the firmware, the user must ensure that the correct SEND REPORT

path and filename are selected in the file dialog box, as shown If the software update failed for ten times continuously, it opens

in Figure 47. the pop-up window shown in Figure 49.

¥ CMaWsSD [ @ =]
File to download

‘)evu:es\ADPDT 03 OpenMarket WaveToolhADPD1 034 M360Frmware\ADPD103hex  Browse

Serial Port Baudrate
|comz6 (UsE Serial Por) ~| [isa00 ~|

<
Flash Action <
‘Prugram and Verify ﬂ 3
[~ Autorun [ Autoflash )
Monitor Status Figure 49. Report Alert

D o oM AR o When the user clicks Yes, another window appears (see Figure 50).

Enter Your Details to Send Update Request to Analog Devices. Inc.

Enter Your Name :

Enter Your Email 1D : ||

| 1 =N E=mpes|
Figure 47. Firmware Flashing Tool Figure 50. Email Window
With the correct path/filename entered and the correct USB Enter your name in the Enter Your Name field and your user
serial port selected, click Start. The user is then prompted to email ID (this is the email address you used when registering to
pulse the Reset button while holding down the Download receive the software package) in the Enter Your Email ID field.
button on the evaluation board (circled in Figure 48). The After entering your user name and email ID, click Send to
firmware download starts when this step is completed. initiate the report to Analog Devices.

14321-044

Figure 48. Serial Download and Reset Buttons to Flash Firmware

When the firmware download has completed, click Reset in the
CM3WSD window and then Exit. The user can now return to
the WaveTool and reconnect the device via File > Connect to
commence testing with the updated firmware.
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EXITING APPLICATION 2. Exit via File > Exit, as shown in Figure 52.

There is a two-step process to exit the application.

File | View Tools Help

1. Disconnect the device via File > Disconnect Ctrl+D, as
Connect

shown in Figure 51. .
Disconnect  Ctrl+D

File | View Toeols Help

Register Dump
Connect

| [Tc;con nect  Ctrl+D
Log

Load Cfg Ctrl+L

Save Cfg Ctrl+5
Register Dump .
| Apply Config
Load Cfg Ctrl+L

Exit
Save Cfg Ctrl+5 m
Figure 52. Exit

14321-049

Apply Config

‘ Exit

14321-048

Figure 51. Disconnect
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UDP TRANSFER TOOL

This section explains the raw data reception and its data format for 1. Enter the file name to save the raw data from WaveTool
and press enter.

various modes from the UDP transfer tool over UDP protocol.

UDP TRANSFER TOOL SETUP
To setup the UDP transfer tool, follow these steps:

1.  Open WaveTool and go to Tools > Options > UDP
Configuration. Enter the IP address of the remote
machine where the UDP transfer tool is running.

COptions =D
General | UDP Configuration
Enter UDF Transfer Tool IP Address: 10.66.100.69

Figure 53. UDP Configuration

2. Connect the hardware (File > Connect > Auto Connect or
File > Connect > Select Port) using the UART bridge on

the host machine.

File | View Toels Help

Connect 3 Auto Connect E
Disconnect  Ctrl+D SelectVort

Register Dump -
Load Cfg  Ctrl+L ¥

Figure 54. Connection

3. Open Graph View and check the UDP Transfer box in the current file.

Time View tab.

Time Yiew | Frequency View

| UDF Transter Save Raw Data

14321-052

Figure 55. Enable UDP Transfer

4.  Click the play button to send the raw data through the
UDP protocol.
To save the raw data being transferred via UDP to a data file,

14321-054

Figure 57. Decision to Continue or Stop

14321-050

2. The received packet count is continuously displayed in the
tool and the raw data is stored in the file.

14321-055

Figure 58. Receiving Raw Data

3. Press the ESC key to stop receiving the data and close the

14321-056

Figure 59. Closing the File

open the receiver tool (UDPTransferTool.exe) and enter the IP RAW DATA FORMAT

address of the system.

Figure 56. UDP Receiver Tool

Before using the UDP transfer tool, ensure that WaveTool is
opened and running with UDP transfer enabled. See Figure 60
for an example of stored sample raw data.

14321-053
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') data 14 18 25 PM - Notepad [=[@] = | Figure 60. Sample Data
File Edit Format View Help
393 3676 3636 4070 14:26:19 P - The sample data transmits in the form of ASCII bytes. The
géég §§§‘g gégé %ggé g %Eg m sample data format is as follows:
7 2% m
Jo02  3os1  Jeaz 4o laizeie F0136CFC0000000FE90000105000000EA000000FCC
3962 3685 3637 4083 14:26:19 PM
3972 3678 3638 407_5' 14 26519 PM
3% Jers 335 dors  1aiseita m e The first two characters (FO) represent sync.
3959 3677 3634 4077 14:26:19 PM
o s N e mBEm A e  Next two characters (13) represent size.
3980 36§2 353‘3 40?3 14 25519 PM
oS O P S 1% e Next two characters (6C) represent sequence number.
3953 3685 3636 4078 14:26:19 Pm .
EE I R R O b e Next four characters (FC00) represent time stamp.
§§§§ gggé gggg %Ei ﬁ géié EE e  The remaining characters represent the hexadecimal
996 Jom  do33  igrs 14izeiia mi channel raw data and its count (based on the slot modes of
3970 3684 3640 4084 14:26:19 PM
203 I Za3s  ioss  lsispira m the WaveTool).
3947 3679 3634 4083 14:26:19 PM
3960 3683 3638 4085 14:26:19 PM ~
3985 3679 3634 4088 14:26:19 PM g
3970 3678 3627 4077 14:26:19 PM - K:
Table 1. UDP Data Format
FO 13 6C FC00 00000FE9 0000105000000EA000000FCC
Sync (2) Size (2) Sequence number (2) | Time stamp (4) Raw data
Table 2. UDP Data Count for Various Modes
Slot Mode Data Format Data Count
Slot A Sum, 16 Bits 00000FE9 1
Slot B Sum, 16 Bits
Slot A Sum, 32 Bits
Slot B Sum, 32 Bits
Slot A Dig Int, 16 Bits
Slot B Dig Int, 16 Bits
Slot AB Sum, 32 Bits 00000FE9 00001050 2
Slot A Dig Int, 32 Bits
Slot B Dig Int, 32 Bits
Slot A, 16 Bits 00000FE9 00001050 00000EAO 00000FCC 4
Slot B, 16 Bits
Slot A, 32 Bits
Slot B, 32 Bits
Slot AB, 16 Bits 00000F7E 0000105C 00000EA8 00000FCC 00000FE9 00001064 00000EAD 00000FCE 8

Rev. 0| Page 19 of 23




UG-947

UDP CONTROLLER TOOL

Open the UDP controller tool (see Figure 61) and complete the
Enter your Host IP Address field. This is the IP address of the
system where the WaveTool is running.

After entering the corresponding IP address, the user can send and
receive commands between the controller and the WaveTool.

#  UDPControllertool

UDP CONTROLLER TOOL

[COMMAND PORT NUMBER : 58881
[RESPONSE PORT NUMBER : 58082
: 8.1

Ex:8n @08
Ex:0B 08

OpenlUiew: Ex:0C 08

LoadGonfig: Ex:8D 08
<{reg address> Ex:00 @1 48
<reg address> <Value> Ex:01 B3 41 88 81
Ex:82 08
Ex:03 08
ICLOCK CALIE: Ex:04 08
OFFSET CALIB: Ex:85 08
RAW DATA:= 81 <ON/OFF> Ex:06 01 91 <or> B6 01 0@

Enter your Host IP Address: .

Figure 61. UDP Controller

UDP CONTROLLER APPLICATION TESTING

PROCEDURE
Port Connection

To use the read register or write register functions, the port
must be connected in the OpenMarket WaveTool. Connect the
port using the following steps:

1. Open the ADPD103 OpenMarket WaveTool application.
2. Connect the port. From File > Connect select either
a.  Auto Connect (to automatically select the port) or
b. Select Port (to manually select the port).
3. Ensure the UDP control IP address is assigned correctly.

Read Register

After connecting to the port, send the register read command as
00 01 <reg address>, for example, send as 00 01 01 to read from
register 0x01.

00 = register read command
01 = number of parameters

14321-058

01 = register address

The response is received with the register value.

1" DAUDPControl.exe

B8 81 {re
a1 @3
B2 @a
B3 o8
B4 @@
OFFSET CALIB: 85 8@
B6 @1 (ON/OFF>

Enter your Host IP Address: 172.16.6.72

onmand, = B8 81 81
a : 8@ B0 B2 @8 FF

x:06 B1 B1 ) B6 B Hame Value

A1 48

ix:B1 B3 41 @8 81
x:02 B9
ix:03 88
x:B4 BB

ix:05 88 Register View

INT §

14321-059

Figure 62. Read Register Operation

Rev.
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Write Register

After connecting the port following the instructions in the Port

Connection section, send the register write command as 00 03
<reg address> <Value>, for example, send as 00 03 01 00 01,

where

00 = register write command
03 = number of parameters
01 = register address

00 01 = register value

The response is received with the register value.

1" DAUDPControl.exe
B @3 ¢
02 6@
83 68
CLOCK CALIB: B4 o8

OFFSET CALIB: B85 6@

A\ DATA: 86 B1 {ON/OFF>

¢ your Host IP Adde
your command : B8 81 B1
Data H

¢ your command = @1 B3 A1 88 A1
: 81 66 88

¢ your command :

Ex:82 @8
Ex:83 @8
Ex:04 B8

Ex:05 08

Ex:86 81 81 (or) 86 B1 B4

(Value> Ex:B1 B3 41 68 81

Register View

FFOLENGTH(S) O

14321-060

Figure 63. Write Register Operation
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Run

Open the ADPD103 OpenMarket WaveTool application and
connect the port (see the Port Connection section). If bridge is
connected, then open the graph view: View > Graph.

Next, send the play command as 02 00, where

02 = play command
00 = number of parameters

Stop

Open the ADPD103 OpenMarket WaveTool application and
connect the port (see the Port Connection section). If bridge is
connected, then open the graph view: View > Graph.

Next, send the stop command as 03 00, where

03 = stop command
00 = number of parameters

Load Configuration
Open the ADPD103 OpenMarket WaveTool application and

connect the port (see the Port Connection section). If bridge is

Table 3. Commands Summary

connected, then a command can be sent to WaveTool through
the UDP.

Next, send the load configuration file command as 0D 00,
which gives a list of available configuration file names as shown
in Figure 64.

Select the particular configuration file using the following
command, based upon which configuration from the list is to
be loaded. For example, 0D 01 (01/02/03....... 107).

Likewise, commands can be given for connect, disconnect,
open view, and raw data by referring to the command list in
Table 3.

COMMANDS SUMMARY

Table 3 summarizes the list of commands, command code and
example formats for various functions that are currently
available in the WaveTool.

Command Command Code' Example
Connect 0A 00 0A 00
Disconnect 0B 00 0B 00
Open View 0C 00 0C 00
Load Configuration (Load Cfg) 0D 00 0D 00
Read 0001 000140
<reg address>
Write 0103 0103410001
<reg address> <Value>
Run 0200 0200
Stop 0300 0300
Raw Data 06 01 <ON/OFF> 060101 (or) 06 01 00

' See Figure 61.
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8 files/{/Fy/Backup/Mar. 21/UDPContralTool V_0.1/UDPControl/bin/Debug/UDPControlEXE || (5
Ex:00 01 40
B3 <reg address» <Ualue> Ex:8i 83 41 @88 81
08 Ex:02 88
a0 Ex:63 68
CALIB: a0 Ex:04 88
CALIB: 00 Ex:85 88
IR DATA: 81 <ON/OFF> Ex:06 81 01 Cor) 86 91 00

iEnter your Host IP Address: 172.16.7.37
Enter ynl.u'k:nmmand : @D a8

Lizt of Configuration Files :

1 >dgdg.dcfg

2 »Finger PPG_820%916 .dcfyg

3 2Finger PPG_default.dcfg

1 dgfg.dcfyg

5 dhfhghghg _dcfyg

6 *hjhgj.dcfg

7 YMB3_183_GGRI_Default.dcfyg

Enter load config command with any of above choice as shown below..

h Eg..8D 81 <B1-82-83...)choice

Figure 64. List of .dcfg Files Available in WaveTool Configuration Directory

ESD Caution
\ ESD (electrostatic discharge) sensitive device. Charged devices and circuit boards can discharge without detection. Although this product features patented or proprietary protection
m circuitry, damage may occur on devices subjected to high energy ESD. Therefore, proper ESD precautions should be taken to avoid performance degradation or loss of functionality.

Legal Terms and Conditions

By using the evaluation board discussed herein (together with any tools, components documentation or support materials, the “Evaluation Board”), you are agreeing to be bound by the terms and conditions
set forth below ("Agreement”) unless you have purchased the Evaluation Board, in which case the Analog Devices Standard Terms and Conditions of Sale shall govern. Do not use the Evaluation Board until you
have read and agreed to the Agreement. Your use of the Evaluation Board shall signify your acceptance of the Agreement. This Agreement is made by and between you (“Customer”) and Analog Devices, Inc.
("ADI"), with its principal place of business at One Technology Way, Norwood, MA 02062, USA. Subject to the terms and conditions of the Agreement, ADI hereby grants to Customer a free, limited, personal,
temporary, non-exclusive, non-sublicensable, non-transferable license to use the Evaluation Board FOR EVALUATION PURPOSES ONLY. Customer understands and agrees that the Evaluation Board is provided
for the sole and exclusive purpose referenced above, and agrees not to use the Evaluation Board for any other purpose. Furthermore, the license granted is expressly made subject to the following additional
limitations: Customer shall not (i) rent, lease, display, sell, transfer, assign, sublicense, or distribute the Evaluation Board; and (i) permit any Third Party to access the Evaluation Board. As used herein, the term
“Third Party” includes any entity other than ADI, Customer, their employees, affiliates and in-house consultants. The Evaluation Board is NOT sold to Customer; all rights not expressly granted herein, including
ownership of the Evaluation Board, are reserved by ADI. CONFIDENTIALITY. This Agreement and the Evaluation Board shall all be considered the confidential and proprietary information of ADI. Customer may
not disclose or transfer any portion of the Evaluation Board to any other party for any reason. Upon discontinuation of use of the Evaluation Board or termination of this Agreement, Customer agrees to promptly
return the Evaluation Board to ADI. ADDITIONAL RESTRICTIONS. Customer may not disassemble, decompile or reverse engineer chips on the Evaluation Board. Customer shall inform ADI of any occurred
damages or any modifications or alterations it makes to the Evaluation Board, including but not limited to soldering or any other activity that affects the material content of the Evaluation Board. Modifications to
the Evaluation Board must comply with applicable law, including but not limited to the RoHS Directive. TERMINATION. ADI may terminate this Agreement at any time upon giving written notice to Customer.
Customer agrees to return to ADI the Evaluation Board at that time. LIMITATION OF LIABILITY. THE EVALUATION BOARD PROVIDED HEREUNDER IS PROVIDED “AS IS” AND ADI MAKES NO WARRANTIES OR
REPRESENTATIONS OF ANY KIND WITH RESPECT TO IT. ADI SPECIFICALLY DISCLAIMS ANY REPRESENTATIONS, ENDORSEMENTS, GUARANTEES, OR WARRANTIES, EXPRESS OR IMPLIED, RELATED TO THE
EVALUATION BOARD INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTY OF MERCHANTABILITY, TITLE, FITNESS FOR A PARTICULAR PURPOSE OR NONINFRINGEMENT OF INTELLECTUAL PROPERTY
RIGHTS. IN NO EVENT WILL ADI AND ITS LICENSORS BE LIABLE FOR ANY INCIDENTAL, SPECIAL, INDIRECT, OR CONSEQUENTIAL DAMAGES RESULTING FROM CUSTOMER'S POSSESSION OR USE OF THE
EVALUATION BOARD, INCLUDING BUT NOT LIMITED TO LOST PROFITS, DELAY COSTS, LABOR COSTS OR LOSS OF GOODWILL. ADI'S TOTAL LIABILITY FROM ANY AND ALL CAUSES SHALL BE LIMITED TO THE
AMOUNT OF ONE HUNDRED US DOLLARS ($100.00). EXPORT. Customer agrees that it will not directly or indirectly export the Evaluation Board to another country, and that it will comply with all applicable
United States federal laws and regulations relating to exports. GOVERNING LAW. This Agreement shall be governed by and construed in accordance with the substantive laws of the Commonwealth of
Massachusetts (excluding conflict of law rules). Any legal action regarding this Agreement will be heard in the state or federal courts having jurisdiction in Suffolk County, Massachusetts, and Customer hereby
submits to the personal jurisdiction and venue of such courts. The United Nations Convention on Contracts for the International Sale of Goods shall not apply to this Agreement and is expressly disclaimed.
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