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LIFE SUPPORT POLICY 

ZILOG’S PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL COMPO- 
NENTS IN LIFE SUPPORT DEVICES OR SYSTEMS WITHOUT THE EXPRESS 
PRIOR WRITTEN APPROVAL OF THE PRESIDENT AND GENERAL COUNSEL OF 
ZILOG CORPORATION. 

 

As used herein 

Life support devices or systems are devices which (a) are intended for surgical implant into 
the body, or (b) support or sustain life and whose failure to perform when properly used in 
accordance with instructions for use provided in the labelling can be reasonably expected 
to result in a significant injury to the user. A critical component is any component in a life 
support device or system whose failure to perform can be reasonably expected to cause 
the failure of the life support device or system or to affect its safety or effectiveness. 

 

Document Disclaimer 

©2021 Zilog, Inc. All rights reserved. Information in this publication concerning the devices, 
applications, or technology described is intended to suggest possible uses and may be 
superseded. ZILOG, INC. DOES NOT ASSUME LIABILITY FOR OR PROVIDE A 
REPRESENTATION OF ACCURACY OF THE INFORMATION, DEVICES, OR 
TECHNOLOGY DESCRIBED IN THIS DOCUMENT. ZILOG ALSO DOES NOT ASSUME 
LIABILITY FOR INTELLECTUAL PROPERTY INFRINGEMENT RELATED IN ANY 
MANNER TO USE OF INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED 
HEREIN OR OTHERWISE. The information contained within this document has been 
verified according to the general principles of electrical and mechanical engineering. 

Z8 Encore!, Z8 Encore! XP, ZMOTION, eZ80Acclaim! and ZNEO are trademarks or 
registered trademarks of Zilog, Inc. All other product or service names are the property of 
their respective owners. 

  

Warning: DO NOT USE THIS PRODUCT IN LIFE SUPPORT SYSTEMS. 
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Overview 

This document describes the features of the Z8 Encore! XP F3224 Series Development Kit 
(Z8F32240100ZCOG) and provides instructions to setup the hardware and to install the software drivers 
and development tools needed to start building applications.    
 
The development board features the Z8F3224 MCU with 32KB internal Flash in a 44-pin QFN package 
operating at 20MHz.  Z8F3224 serial peripheral devices (SPI, I2C, UART) can be used to interface with 
the 64Mb serial Flash (SPI) and optical sensor (I2C) available on the development board, or external 

devices (header pins).  Refer to the Z8 Encore! XP® F3224 Series Product Specification (PS0381) 

available for download at www.zilog.com for information on these and other F3224 peripheral 

devices.  
 
Subsequent sections of this document guide you through the following tasks: 
 

• Download and Install the ZDS II Software and Documentation – see page 4 

− Installing the Encore! Smart Cable Driver – see Appendix B. Installing the Encore! Smart 
Cable Driver on page 16 

• Connect F3224 Series Dev Board to PC – see page 5 

• Start Z8F3224 Demonstration Program – see page 7 
   
Further details, including memory configurations, jumper settings, and a listing of sample projects can be 
found in the Z8F3224 Sample Projects section on page 12. 
 
Figure 1 shows an image of the F3224 Series Development Kit. 
 

https://www.zilog.com/docs/ps0381.pdf
https://www.zilog.com/index.php
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Figure 1. The F3224 Series Development Kit 
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Kit Contents 

Table 1 lists the contents of the F3224 Series Development Kit. 

 

Table 1. Z8F32240100ZCOG Contents 

Item Description Quantity 

1 F3224 Series Development Board 1 

2 Encore! Smart Cable 1 

3 6-wire ribbon cable 1 

4 A (male) to Mini-B USB cable 2 

5 F3224 Series Development Kit Flyer (FL0193) 1 

 

Kit Features 

The key features of the F3224 Series Development Kit are: 

• F3224 Series Development Board, which includes: 

− Z8F3224QN020XK MCU in 44-pin QFN package operating at 20 MHz  

− UART port J3 

− Test points and headers  

− Four LEDs (Power and Port Display) 

− Two pushbuttons (Reset and Test)  

− Smart Cable Debug Interface J5 

• Encore! Smart Cable (ESC) 

• ZDS II development tools, sample projects, and documentation available free for download 
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System Requirements 

The F3224 Series Development Board supports the following operating systems: 

• Microsoft Windows 7, (32-bit/64-bit) 

• Microsoft Windows 8 (32-bit/64-bit) 

• Microsoft Windows 10 (32-bit/64-bit) 

Download and Install ZDSII SW and Docs 

Observe the following steps to install ZDS II software and documentation. 
 

Note:  If you have already downloaded and installed the ZDS II – Z8 Encore! <version> development tools and 
documentation by following the procedure on the paper insert in your kit (FL0193), then you’re ready for 
Appendix B. Installing the Encore! Smart Cable Driver on page 16.  

 

 

1. Prior to connecting the Z8 Encore! XP F3224 Series Development Board to your development 
PC, download ZDS II for Z8 Encore! v5.6.0 (or later) from the Zilog Software Downloads 
category in the Zilog website. 

2. When your download is complete, unzip the file to your local drive, then double-click the 
installation file named ZDS2_Z8Encore!_<version>.exe, and follow the on-screen 

instructions. 

3. When the ZDS II installation is complete, click the supporting documentation link on Zilog Software 
Downloads. This will download the documentation installer as a ZIP file. Unzip and double click on 
docs_Z8Encore!_<version>.exe and follow the on-screen instructions. 

 

 

 

 

 

 

 

 

https://www.zilog.com/index.php?option=com_zcm&task=view&soft_id=42&Itemid=74
https://www.zilog.com/index.php?option=com_zcm&task=view&soft_id=42&Itemid=74
https://www.zilog.com/index.php?option=com_zcm&task=view&soft_id=42&Itemid=74
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Connect F3224 Series Dev Board to PC 

Observe the following procedure to connect the F3224 Series Development Board to your PC. 

 

Caution: The USB Smart Cable can be configured to supply power to the F3224 Series Development Board, 
or an external power source may be used to power the board.  When external power is used, be 
sure to disconnect or turn off the external power source before connecting or disconnecting the 
Encore! Smart Cable from the development board.  

  

1. Connect one end of the ribbon cable to the Encore! Smart Cable ensuring the ridge on the 
ribbon cable’s female connector is aligned with the notch in the shrouded male connector on 
the Smart Cable as shown in Figure 2. 

 

 Figure 2. Connecting the 6-Circuit Ribbon Cable to the Encore! SmartCable 

 

2. Connect the other end of the ribbon cable to Debug Connector J5 on the Development Board. 
Ensure that Pin 1 on the ribbon cable (red stripe) is aligned with Pin 1 on the target connector 
(square pad), as highlighted in Figure 3. 
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    Figure 3. Debug Connector J5 

 
 

 

 

  



  Z8 Encore! XP® F3224 Series Development Kit  

 

 

 

 UM029101-0421  START Z8F3224 DEMONSTRATION PROGRAM 

User Manual 

7 

Start Z8F3224 Demonstration Program 

The F3224 Series Development Kit includes a sample program that demonstrates a blinking LED 

application with a UART console. An optional terminal emulation program and a 3rd Party USB to TTL 

Serial converter (not supplied) maybe used to display the messages and send characters to the 

application.  In this instance, the terminal program must be configured for 57600-8-N-1 with no flow 

control, as described in the Terminal Emulation Configuration section on page 10. To get started with the 

Z8F3224 demonstration, observe the following procedure. 

1. Launch ZDS II by navigating from the Windows Start menu to Programs → Zilog ZDS II – Z8 

Encore! <version> → ZDS II – Z8 Encore! <version>. 

2. From the File menu in ZDS II, select Open Project and navigate to the following folder: 

<ZDS Install>\samples\XP_F3224\XP_F3224_LedBlink_C 

3. Select the ledblink.zdsproj project from within the XP_F3224_LedBlink_C folder and click 

Open. 

4. From the Build menu, select Set Active Configuration to open the Select Configuration dialog 

box. 

5. Select Debug, then click OK to close the Select Configuration dialog box. 

6. From the Project menu in ZDS II, select Settings to open the Project Settings dialog box. In the 

Project Settings dialog box, click the Debugger tab. 

7. On the Debugger page, select Z8F32240100ZCOG from the Target list, then select 

EncoreSmartCable from the Debug Tool drop-down menu, as shown in Figure 4. 
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 Figure 4. Select Z8F32240100ZCOG and EncoreSmartCable 

8. Click Setup on Figure 5 below to open the Setup USB Communication dialog. 

 

 

  Figure 5. Setup EncoreSmartCable 

 

9. Verify that a Serial Number is displayed in the Setup USB Communication dialog as shown in 

Figure 6. If multiple Encore! Smart Cables are connected to the PC, click the chevron to display 

the serial number of each Smart Cables and select which to use when programming or 

debugging the target. If no serial numbers are displayed, verify that the Encore! Smart Cable is 

attached to the PC and see Appendix B. Installing the Encore! Smart Cable Driver for instructions on 

installing the necessary device drivers. 
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    Figure 6. Setup USB Communication 

10. Click OK on the Setup USB Communication above and on the Project Settings dialog box. 

11. If you are prompted to rebuild any affected files, click Yes. Otherwise, choose Build from the 

menu bar, then click Rebuild All. 

12. To run the application, select Go from the Debug menu. As a result, LEDs D3, D4, and D5 will 

blink in sequence. 

13. After the application has started, UART output should be visible in the terminal application 

program, as shown in Figure 7. 

 

 

   Figure 7. UART Output Using Terminal Application program 

 



  Z8 Encore! XP® F3224 Series Development Kit  

 

 

 

 UM029101-0421  TERMINAL EMULATION CONFIGURATION 

User Manual 

10 

Terminal Emulation Configuration  

A communications program such as HyperTerminal or TeraTerm can be used on Windows systems to view 
messages from the F3224 Series Development Board. The following procedure examines how to configure 
TeraTerm for the Z8F3224 demonstration project. 

1. Connect a 3rd Party USB to TTL Serial converter to J3 on the Development Board using the 

following connections.  

  Table 2. USB to TTL Serial converter connection 

Z8F3224 Board USB to TTL Serial Converter 

J3-1 VCC 3.3V 

J3-2 RXD TXD 

J3-3 TXD RXD 

J3-4 GND GND 

 

2. Connect the other end to your PC. 

3. In TeraTerm, choose Setup >Serial Port then, if your PC has a serial interface, select the COM 
port assigned to your serial port. If you do not have a serial port on your PC, use a USB-to-serial 
adapter (not included in the kit). 

4. From the Windows Control Panel, navigate via the Device Manager to Ports (COM & LPT) to 
determine the correct COM port assigned to your adapter. Configure this port to reflect the following 
settings: 

– 57600 bps  
– 8 data bits  
– No parity  
– 1 stop bit  
– No flow control 

5. In TeraTerm, click the New Setting button to connect to the F3224 Series Development Board. 
When connected, you should be able to see the demonstration program menu shown in Figure 7. 
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ZDSII Flash Loader Utility  

A Flash Loader utility can be accessed from the Tools menu in Zilog Developer Studio. With the Flash 
Loader, you can program the Z8F3224 MCU directly using the hex code generated from the ZDS II IDE 
Figure 8 presents an example. 

 

   Figure 8. An Example Flash Loader Screen 
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Z8F3224 Sample Projects  
A number of sample projects are included with the ZDS II – Z8 Encore! v5.6.0 software, which can be 
downloaded for free from the Zilog website. These sample projects will be accessible upon installation of 
ZDS II – Z8 Encore! v5.6.0; their locations are listed in Table 3. 

  

    Table 3. Z8F3224 MCU Sample Projects 

   

 

 

 

F3224 Series Dev Kit Documentation  

There is an LED on the top side of the ESC enclosure. When ESC is powered up, it shines steady yellow 
light to indicate that power is on and that the device was recognised by USB host and enabled to be used 
as USB device. If host was unable to enumerate the ESC the LED will stay off. 

  Table 4. F3224 Series Development Kit Documentation 

Description 
Document 
ID 

Installed Location 

F3224 Series Product Specification PS0381 
Documentation\Chip_Documentation 

F3224 Series Development Kit User Manual UM0291 Documentation\Tools_Documentation 

eZ8 CPU User Manual UM0128 Documentation\Chip_Documentation 

Z8 Encore! Design for Debug TN0036 Documentation\Tools_Documentation 

Encore! Smart Cable User Manual UM0294 Documentation\Tools_Documentation 

USB SmartCable User Manual UM0181 Documentation\Tools_Documentation 

Opto-Isolated USB SmartCable User Manual UM0195 
Documentation\Tools_Documentation 

Ethernet SmartCable User Manual UM0207 Documentation\Tools_Documentation 

 

 

 

Description Installed Location 

ledblink 
\samples\XP_F3224\XP_F3224_LedBlink_C 

\samples\XP_F3224\XP_F3224_LedBlink_asm 

SerialFlash \samples\XP_F3224\XP_F3224_SerialFlash 

https://www.zilog.com/index.php?option=com_zcm&task=sdlp&Itemid=74
https://www.zilog.com/docs/ps0381.pdf
http://www.zilog.com/docs/devtools/um0291.pdf
http://www.zilog.com/docs/UM0128.pdf
http://www.zilog.com/docs/z8encore/appnotes/TN0036.pdf
http://www.zilog.com/docs/devtools/um0294.pdf
http://www.zilog.com/docs/devtools/um0181.pdf
http://www.zilog.com/docs/z8encoremc/devtools/UM0195.pdf
http://www.zilog.com/docs/devtools/UM0207.pdf
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Appendix A 
Schematic Diagrams 

Figures 9 through 10 present schematic diagrams of the F3224 Series Development Board. 
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Appendix B 

Installing the Encore! SmartCable Driver 
 

Note:  You might have done the driver installation on ZDSII – Z8 Encore! 5.6.0 installation, when the     
check box is selected on below screen shot and clicked Finish. If so, you don’t need to do the 
following below steps, but there is no harm proceeding 

 

  

 
1. Navigate to Start >All Programs >ZiLOG ZDSII – Z8 Encore! 5.6.0 

2. Right click on Install Encore! SmartCable Driver and select Run as  administrator 

3. Click on Yes button on the User Account Control prompt that appears 

4. Click on Yes button on the Encore! SmartCable Driver Installation prompt to  install 
the driver software 

5. Select Next button that appears 

6. Select the Finish button 
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Revision History 

Each instance in this document’s revision history reflects a change from its previous edition. For more 
details, refer to the corresponding page(s) or appropriate links furnished in the table below. 

Date 

Revision 

Level Description Page 

Apr 2021 01 Original issue. All 

Customer Support 

To share comments, get your technical questions answered, or report issues you may be experiencing 
with our products, please visit Zilog’s Technical Support page at support.zilog.com. 

To learn more about this product, find additional documentation, or to discover other facets about 
Zilog product offerings, please visit the Zilog Knowledge Base. 

This publication is subject to replacement by a later edition. To determine whether a later edition 
exists, please visit the Zilog website at www.zilog.com. 

 

https://zilog.com/index.php?option=com_product&task=tech_support&Itemid=88
http://www.zilog.com/kb
https://www.zilog.com/index.php?option=com_tech&task=kb&Itemid=84
http://www.zilog.com/
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