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Welcome to the SparkFun Inventor’s Guide

The SparkFun Inventor's Guide is your map for navigating the
waters of beginning embedded electronics. This booklet contains
all the information you will need to explore the 16 circuits of the
SparkFun Inventor's Kit for Educators. At the center of this
manual is one core philosophy - that anyone can (and should)
play around with electronics. When you're done with this guide,
you'll have the know-how to start creating your own projects and
experiments. Now enough talking - let's get inventing!

www.sparkfun.com
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The DIY Revolution

We live in a unique time where we have access to resources
that allow us to create our own solutions and inventions. The
DIY revolution is composed of hobbyists, tinkerers and
inventors who would rather craft their own projects than let
someone do it for them.

www.sparkfun.com

A Computer for the Physical World

The RedBoard in your hand (or on your desk) is your
development platform. At its roots, the RedBoard is
essentially a small portable computer. It is capable of
taking inputs (such as the push of a button or a reading
from a light sensor) and interpreting that information to
control various outputs (like a blinking LED light or an
electric motor).

‘That's where the term "physical computing” is born -
this board is capable of taking the world of electronics
and relating it to the physical world in a real and tangible
way. Trust us - this will all make more sense soon.

RedBoard

// SparkFun RedBoard

The SparkFun RedBoard is one of a multitude of
development boards based on the ATmega328. It has 14
digital input/output pins (6 of which can be PWM
outputs), 6 analog inputs, a 16 MHz crystal oscillator, a
USB connection, a power jack, an ISP header, and a reset
button. Don’t worry, you’ll learn about all these later.

OO CRCIRCI
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Download the Arduino IDE (integrated Development Environment)

Access the Internet

In order to get your RedBoard up and running, you'll need to

download the newest version of the Arduino software first from
f- | ‘ www.arduino.cc (it's free!). This software, known as the Arduino
4 IDE, will allow you to program the board to do exactly what you
2 want. It’s like a word processor for writing programs. With an
‘ internet-capable computer, open up your favorite browser and
A type in the following URL into the address bar:

m arduino.cc/en/main/software

( )
Click on your appropriate computer

Download operating system next to the “ + ” sign.

+ Windows
+ MacOS X
4+ Linux: 32 bit, 64 bit

+ source

ARDUINO =

Dumnloas the Arduine Sofware

0 Choose the appropriate Operating System installation package for your computer.
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// Connect your RedBoard to your Computer

Use the USB cable provided in the SIK kit to connect the RedBoard to
one of your computer’s USB inputs.

// Install Arduino Drivers

Depending on your computer’s operating system, you will need to follow specific
instructions. Please go to www.sparkfun.com/FTDI for specific instructions on how to
install the FTDI drivers onto your RedBoard.
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// Open the Arduino IDE:

Open the Arduino IDE software on your computer. Poke around and get to know
the interface. We aren’t going to code right away, this is just an introduction. This
step is to set your IDE to identify your RedBoard.
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GU' (Graphical User Interface)

1 Verify: Compiles and approves your code. It will catch errors in syntax (like missing semi-colons or parenthesis).  See Diagram Below

ou should see the lights on your board blink rapidt:

. This button will let you open up an existing sketc See Diagram Below
5  Save: This saves the currently active sketch.
6 Serial Monitor: This will open a window that displays any serial information your RedBoard is transmitting. It is very useful for debugging.
7 = Sketch Name: This shows the name of the sketch you are currently working on.
8 Code Area: This is the area where you compose the code for your sketch.

9 Message Area: This is where the IDE tells you if there were any errors in your code.

1/ The three most important commands for this guide are seen below:

Open

Verify

Upload
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// Select your Serial Device

Page 8

// Select your board: Arduino Uno

Auto Format

Archive Sketch

Fix Encoding & Reload
Serial Monitor

Serial Port

Programmer
Burn Bootloader

Note:
Your SparkFun RedBoard and the
Arduino UNO are interchangeable

but you won't find the RedBoard
listed in the Arduino Software.
Select “Arduino UNO” instead.

, > kTR

Select the serial device of the RedBoard from the Tools |
Serial Port menu. This is likely to be com3 or higher
(COM1 and COM2 are usually reserved for hardware
serial ports). To find out, you can disconnect your
RedBoard and re-open the menu; the entry that
disappears should be the RedBoard. Reconnect the
board and select that serial port.

|
4
\ 4

Select the serial device of the RedBoard from the Tools
> Serial Port menu. On the Mac, this should be
something with /dev/tty.usbmodem or
/dev/tty.usbserial in it.

> Arduino Duemilanove w/ ATmega328]

Arduino Diecimila or Duemilanove w/ ATmega168
Arduino Nano w/ ATmega328

Arduino Nano w/ ATmega168

Arduino Mega 2560 or Mega ADK

Arduino Mega (ATmega1280)

Arduino Mini

Arduino Mini w/ATmega168

Arduino Ethernet

Arduino Fio

Arduino BT w/ ATmega328

Arduino BT w/ATmega168

LilyPad Arduino w/ ATmega328

LilyPad Arduino w/ ATmega168

Arduino Pro or Pro Mini (5V, 16 MHz) w/ATmega328
Arduino Pro or Pro Mini (5V, 16 MHz) w/ATmega168
Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ATmega328
Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ATmega168
Arduino NG or older w/ ATmega168

Arduino NG or older w/ ATmega8

Auto Format

Archive Sketch

Fix Encoding & Reload
Serial Monitor

Board »
com 12
Programmer
Burn Bootloader
v gl Tools W
Auto Format
Archive Sketch
Fix Encoding & Reload
Serial Monitor
Board »
/dev/cu.usbmodem262471
Programmer /dev/tty.Bluetooth-Modem

Burn Bootloader /dev/cu.Bluetooth-Modem

/dev/tty FireFly-7256-SPP
/dev/cu.FireFly-7256-SPP
/dev/tty.tiPhone-WirelessiAP-1
/dev/cu.tiPhone-WirelessiAP-1
/dev/tty.Bluetooth-PDA-Sync
/dev/cu.Bluetooth-PDA-Sync

hetp://www.arduino.cc/playground/Learning/Linux



Download Arduino Code (For use with the circuits in this guide)

Type in the following URL to download the code:

sparkfun.com/sikcode

I 3 ‘ (© start —>» [ Programs —» ([ arduino —» [ examples

-

Unzip the file “SIK Guide Code”. It

should be located in your browser’s « . » . .
Copy the “SIK Guide Code” fold Ard
“Downloads” folder. Right click the opy the e ode fowder Tt Ao s

zipped folder and choose “unzip”.

folder named “examples”.

— [ Contents
=
e, '
[ Resources
Find “Arduino” in your applications *
folder. Right click(ctrl + click) on Iave
“Arduino”. Select “Show Package Dy
Unzip the file “SIK Guide Code”. It Conrents”. \
should be loacted in your brovs{ser’s [ examples
“Downloads” folder. Right click the Arduino
ipped folder and choose “unzip”. Open
APPSR SC s S el Copy the “SIK Guide Code” folder into
Move to Trash Arduino’s folder named “examples”.

// Copy “SIK Guide Gode” into “Examples” library in Arduino folder

A hetp://www.arduino.cc/playground/Learning/Linux

WHAT’S NEXT? Read on to learn more about getting started with circuits. Then you can start on your first circuit on page 17!
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Getting Started with Circuits

What is an Electrical Circuit?

A circuit is basically an electrical loop with a starting point and an
ending point - with any number of components in between.
Circuits can include resistors, diodes, inductors, sensors of all sizes
and shapes, motors, and any other handful of hundreds of
thousands of components.

Circuits are usually divided into three categories - analog circuits,
digital circuits, or mixed-signal circuits. In this guide, you will
explore all three sets of circuits.

The World Runs on Circuits:

Everywhere you look, you'll find circuits. The cell
phone in your pocket, the computer that controls
your car's emissions system, your video game

console - all these things are chock full of circuits.
In this guide, you'll experiment with some simple
circuits and learn the gist of the world of embedded
electronics.

. A + | abcde||fghij ‘+ -
// Simple and Complex Circuits o ammae | | ndeem | gy
B | npaan g
. . . . . . 3
In this guide, you will be primarily exploring 00| | EHEEE go
simple circuits - but that doesn't mean you can't EL et BH
do amazing things with simple tools! When you've a= gt B aa
finished the SIK, your knowledge of circuits will B M=r EE
enable you to explore amazing projects and oo| | 2¥ER E[E
. . . BER]

unleash the power of your imagination. EllAbET i om
BB |jsofugo | | o B
om| |(*ERHEE pui BE
BE| |\vofugo | |o B

LE=D i J= =i
BE BE

B =
BE BE
) e e
o0& glg BE

B||E
BE ==

8=
EE B |E EE
+ =[] 2z HE
= BE B E BE

8| =

+ - K + -
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Inventory of Parts

Jumper Wire
Various Colors

/

LED (5mm)
(Light Emitting Diode)

33092 Resistor

&

* ACTUAL SIZE

10KQ Resistor

* ACTUAL SIZE

Potentiometer

¢

Diode
(1N4148)

* ACTUAL SIZE

Photo Resistor

Piezo Buzzer

Temp. Sensor

(TMP36)
%éé// x1

Transistor
(P2N2222AG)

DC Motor

Kl o)
(o) o)
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Flex Sensor SparkFun RedBoard

x1

Soft Potentiometer

= I0REF
 RESET

x1

NI H0TYNY

x1
Breadboard
Standard Solderless (Color may vary)
x1

+ =| abcde fghij |+ -
. g, | BODED | | DEDDE | o
Relay Integrated Circuit om||;BEEEE | | BHERE? |gg
(Ic) 00| | poooo | | oooom 4| |20
28| sooneE | | oooEms||EE

sHEOHE | | EEEEE ¢
gml||’DEDED | | BEEOE7||gg
ool |{DEDED | | DEEOE¢| |55
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x1

Page 13



Page 14

B I0REF
 RESET
® 3.3V
m 5V
GND ©
- (=]
®GND =
m
mVIN 3

B A0
B Al
B A2
= A3
m Ad
m A5

NI 90TYNY

(C

1)

ds XL

“Unjyiec
o




SparkFun RedBoard

Power In (Barrel Jack) - Can be used with either a 9V or 12V wall-wart or battery.

Power In (USB Port) - Provides power and communicates with your board when plugged into your computer via USB.

LED (RX: Receiving) - This shows when the FTDI chip is receiving data bits from the microcontroller. This happens when the microcontroller is
sending data bits back to the computer.

LED (TX: Transmitting) - This shows when the FTDI chip is transmitting data bits to the microcontroller. This happens when the
microcontroller is receiving this data from the computer.

LED (Pin 13: Troubleshooting) - This LED is incorporated into your sketch to show if your program is running properly.

Pins (ARef, Ground, Digital, Rx, Tx) - These various pins can be used for inputs, outputs, power, and ground.  See Diagram Below

LED (indicates RedBoard is ON) - This is a simple power indicator LED.

Reset Button - This is a way to manually reset your RedBoard, which makes your code restart.

ICSP Pins (Uploading Code without Bootioader) - This is for "In-Gircuit Serial Programming," used if you want to bypass the bootloader.
Pins (Analog In, Power In, Ground, Power Out, Reset) - These various pins can be used for inputs, outputs, power, and ground. ~ See Diagram

RFU - This pin is reserved for future use.

// Pins Diagram

S L

The header pins are one of the most important parts for putting our
0 example circuits together. Take a moment and locate the inp tp
ports of your RedBoard.
st |
SDA
AREF ARef
GND Ground
@
— 13 Digital
IOREF .
12 Digital
Reset RESET
~11 Digital
Power Out 3.3v
~10 Digital
Power Out 5v
~9 Digital
Ground GND iai
o 8 Digital
Ground GND g
@ Power In VIN 3 7 Digital
g ~6 Digital
L)
Analog A0 E ~5 Digital
Analog Al g 4 Digital
> 2 G
Analog A2 § s -3 Digital
Analog A3 5 E 2 Digital
Analog A4 ; ™>1 - Out
Analog \AS O O RX <0 RX-In

o~ =PWM/Analog out compatible (i.e.~3)
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Breadboard

1 Vertical Connection (+ Power and - Ground) - Power bus ~ See Diagram Bell

2 Horizontal Connection (a-e & f-j) ~See Diagram Below]
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How It Works:

2 WRITE 3 UPLOAD

1 ASSEMBLE

+ Connect the USB cable.

+ Peel sticker off back of

+ Make sure the text on the RedBoard and

breadboard are facing up so you can read them.

+ Screw the RedBoard down and into place.

breadboard and stick into place.

Your RedBoard runs on 5V. This is the power that will be supplied from your computer via USB and

will be the driving force behind any components you use in your circuits. By plugging your RedBoard

into your computer, you are supplying it with just the right voltage it needs to thrive! 5V can’t hurt you,

t be afraid to touch anything in your circuit. You can also power the RedBoard through the

>

so don

barrel jack. The on-board voltage regulator can handle anything from 7 to 15VDC.
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PIN 13] RedBoard Blinking an LED

LED LEDs (light-emitting diodes) are small, powerful lights
XZ (Light-Emitting Diode) that are used in many different applications. To start off
the SIK, we will work on blinking an LED. That's right
- it's as simple as turning a light on and off. It might
not seem like much, but establishing this important
baseline will give you a solid foundation as we work
toward more complex experiments.

A\

§ Resistor (330 ohm)
(Orange-Orange-Brown)

+ Each circuit begins with a brief description
_1  GND of the what you are putting together and
(Ground) the expected result.

+ This is a schematic of your circuit. ]

LED 330Q Wire
/ Resistor
x1 x1 x3< + This section lists the parts you

will need to complete the circuit.

+ This is an illustration of how the
completed circuit should look. It is not
necessary to use the black holder for the
RedBoard and breadboard, but we
recommend it for the first time inventor!

+ Components like resistors need to have
their legs bent into 90° angles in order to
correctly fit the breadboard sockets. You
can also cut the legs shorter to make them
easier to work with on the breadboard.
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Open Up the Arduino IDE software on your computer. Coding in the Arduino
language will control your circuit. Open the code for Circuit 1 by accessing the “SIK
Guide Code” you downloaded and placed into your “Examples” folder earlier.

.. [N Edit Sketch Tools  Help

New
Open...
Sketchbook »
1.Basics »
Close 2.Digital >
Save 3.Analog >
Save As... 4.Communication | 4
Upload 5.Control | 4
Upload Using Progammer 6.Sensors >
7.Displays >
Page Setup 8.Strings »
Print ArduinolSP
Circuit #2
EEPROM Circuit #3
Ethernet Circuit #4
Firmata Circuit #5
Liquid Crystal Circuit #6
SD Circuit #7
Servo Circuit #8
SoftwareSerial Circuit #9
SPI Circuit #10
Stepper Circuit #11
Wire Circuit #12
Circuit #13
Circuit #14
Circuit #15
Circuit #16
// Circuit #1

00

Circuit #1

Y

Elink

Turns on an LED on _tur one
then off for one

This example code is in the public domain.

void P+|1p() {
/¢ indt e the digital pin as an outp
A Pin 13 h:- an LED connected on most Ardvino boards:
) pintlode(13, OUTPFUT);
void loop() §
digitalWrite(13, HIGH); set the LED
delay(10007; mait for a d
AigitalTribe(13, LOW); set the LED
) delay(10007; mait for a second
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N

This compiles your code. The IDE changes it from text into instructions the computer

can understand.

J Verify

This sends the instructions via the USB cable to the computer chip on the RedBoard. The

RedBoard will then begin running your code automatically.

Upload

>

t with correct code after verified and uploaded.

ul

// The result of a completed circ.
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+ This is where you will find the
Arduino code for each circuit.

| , wJ Open Arduino IDE // File > Examples > SIK Guide > Circuit # 1
Code to Note: + Remember to Verify and >° °

Upload your code.

+ Begin to understand how the
Arduino code works. See below.

Before you can use one of the RedBoard's pins, you need to tell the
pinMode(13, OUTPUT); :> RedBoard whether it is an INPUT or OUTPUT. We use a built-in
"function” called pinMode() to do this.

digitalWrite(13, HIGH); :> When you're using a pin as an OUTPUT, you can command it to be
) ’ ’ HIGH (output 5 volts), or LOW (output 0 volts).

What you Should see. + See if your circuit is complete

and working in this section.

You should see your LED blink on and off. If
itisn't, make sure you have assembled the

circuit correctly and verified and uploaded the
code to your board or see the troubleshooting
tips below.

+ Here you will find examples of the circuit
you just completed in the real world.

Many of the theories in these circuits are

used in things you use everyday!

+ This is a section dedicated to the most
common mistakes made while assembling
the circuit.

Troubleshooting: Real World Application:

LED Not Lighting Up? Almost all modern flat screen televisions and monitors
LEDs will only work in one direction. Try taking it out and have LED indicator lights to show they are on or off.
twisting it 180 degrees (no need to worry, installing it

backward does no permanent harm).

Program Not Uploading

This happens sometimes, the most likely cause is a confused
serial port, you can change this in tools>serial port>

Still No Success?
A broken circuit is no fun, send us an e-mail and we will get
back to you as soon as we can: techsupport@sparkfun.com
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Potentiometer

PIN 13|RedBoard

In this circuit you'll work with a potentiometer.

5 volt A potentiometer is also known as a variable resistor.
LED When it’s connected with 5 volts across its two outer
(Light-Emitting Diode) pins, the middle pin outputs a voltage between 0 and
5, depending on the position of the knob on the
potentiometer. A potentiometer is a perfect
Potentiometer § PIN AQ demonstration of a variable voltage divider circuit.
RedBoard The voltage is divided proportionate to the resistance
Resistor (330 ohm) between the middle pin and the ground pin. In this
(Orange-Orange-Brown) A s .
circuit, you'll learn how to use a potentiometer to
control the brightness of an LED.
1w
= (Ground)
Potentiometer LED 330Q Wire

Resistor

Page 25



Circuit 2: Potentiometer
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‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 2

00

A “variable” is a stored value you've given a name to. You must introduce,
. r lare" variables before yt hem; her I larin, riabl
int sensorValue; :> or "declare" variables befo e you use them; here we e declaring a variable
called sensorValue, of type "int" (integer). Don't forget that variable names
are case-sensitive!

We use the analogRead() function to read the value on an analog
. 0 analooRes ’ - analoo pi 5
sensorValue = ana ll()gRea d (sensorI’m); :> pin. analogRead() takes one parameter, the analog pin you want
to use ("sensorPin"), and returns a number ("sensorValue")
between 0 (0 volts) and 1023 (5 volts).

The Arduino is very very fast, capable of running thousands of lines of code
:> each second. To slow it down so that we can see what it's doing, we'll often

delay(sensorValue);
insert delays into the code. delay() counts in milliseconds; there are 1000 ms

in one second.

What you Should See:

You should see the LED blink faster
or slower in accordance with your
potentiometer. Ifit isn't working,
make sure you have assembled the
circuit correctly and verified and
uploaded the code to your board or
see the troubleshooting tips below.

Troubleshooting: Real World Application:

Sporadically Working Most traditional volume knobs employ a potentiometer.
'This is most likely due to a slightly dodgy connection
with the potentiometer's pins. This can usually be
conquered by holding the potentiometer down.

Not Working

Make sure you haven’t accidentally connected the
wiper, the resistive element in the potentiometer, to
digital pin 0 rather than analog pin 0. (the row of pins
beneath the power pins).

LED Not Lighting Up?

LEDs will only work in one direction. Tty taking it out and
twisting it 180 degrees (no need to worry, installing it
backward does no permanent harm).
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RGB LED
RedBoard You know what’s even more fun than a blinking

LED? Changing colors with one LED. RGB, or
red-green-blue, LEDs have three different color-emit-
ting diodes that can be combined to create all sorts of
Resistors (330 ohm) colors. In this circuit, you'll learn how to use an RGB
(Orange-Orange-Brown) LED to create unique color combinations.
Depending on how bright each diode s, nearly any
color is possible!

B LED
(Light-Emitting Diode)

(Ground)

N LED 330Q Wire
% Resistor
x1 x3 x6
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Circuit 3: RGB LED
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‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 3

00

A for() loop is used to step a number across a range, and repeatedly runs

??f (x = 0; x < 768; x++) :> code within the brackets {}. Here the variable "x" starts a 0, ends at 767,
§

and increases by one each time ("x++").

if (x <= 255) "If / else" statements are used to make choices in your programs. The statement
{3 :> within the parenthesis () is evaluated; if it's true, the code within the first brackets {}
else will run. If it's not true, the code within the second brackets {} will run.
The RedBoard is very very fast, capable of running thousands of lines of
code each second. To slow it down so that we can see what it's doing,
delay(sensorValue); . ) ; S
we'll often insert delays into the code. delay() counts in milliseconds;

there are 1000 ms in one second.

What you Should See:

You should see your LED turn on,

but this time in new, crazy colors! If it
isn't, make sure you have assembled
the circuit correctly and verified and
uploaded the code to your board or
see the troubleshooting tips below.

Troubleshooting: Real World Application:

LED Remains Dark or Shows Incorrect Color Many electronics such as

With the four pins of the LED so close together, it’s videogame consoles use RGB

sometimes easy to misplace one. Double check each LED:s to have the versatility

pin is where it should be. to show different colors in
the same area. Often times

Secing Red the diffent colors represent

'The red diode within the RGB LED may be a bit brighter different states of working

than the other two. To make your colors more balanced, condition.

use a higher Ohm resistor. Or adjust in code.

analogWrite(RED_PIN, redIntensity);

o

analogWrite(RED_PIN, redIntensity/3);
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CIRCUIT #4

RedBoard

LEDs
(Light-Emitting Diodes)

Resistors (330 ohm)
(Orange-Orange-Brown)

AW
WW-

AW
WW-

A
WW-

‘TL GND (Ground)
RedBoard
IEE

PIN 8

LEDs
(Light-Emitting Diodes)

Resistors (330 ohm)
(Orange-Orange-Brown)

AW
WW-

L GND (Ground)

330Q Wire
Resistor
x8 x10

Multiple LEDs

So you have gotten one LED to blink on and off —
fantastic! Now it's time to up the stakes a little bit — by
connecting EIGHT LEDS AT ONCE. We'll also give
our RedBoard a little test by creating various lighting
sequences. This circuit is a great setup to start practicing
writing your own programs and getting a feel for the
way RedBoard works.

Along with controlling the LEDs, you'll learn about a
couple programming tricks that keep your code neat

and tidy:

for() loops - used when you want to run a piece of
code several times

arrays| ] - used to make managing variables easier by
grouping them together

Page 33



Circuit 4: Multiple LEDs

o
-3
«Q
]
W
'y

+ EEEEE HOEEER HEEEEE EEEET @@@@@+

|
OEEEE DOEEEE EEEEE HEDEE  EEEEE

—N®m T ONO®DOS

IS B g e i)
_@@@@@@E@@@@@@@@@
=

I@I

RESET

am 13

4T
amp T SPATKIUN

()

www% ﬂ” R@@Boanl

((-l (1]] .
" [[LEARN. SHARE. HACK. | = »
1Z=}
- |
[ —
ISP
()

ANALOG IN

®
<<



—— — au soduny QD sy coee | &
— — p— I.&\\ D J——
— — o E§\ CID s oge
— — — Iﬂ&\\ CID s oge
— — p— =§\\ CID s oge
— — T %§ —— W wwan
— —— au sacune E§ ,\——E W wwam
—— —— aap odwing %§ s—D V  wwsgn
—— —— aap Jadwing %§ s ) V  wwdgq
oo (o) 7 == |V e
Jo151S0Y T0EE %§ y—— WV g
—— —— S——— ——




‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 4

00

When you have to manage a lot of variables, an "array" is

int ledPins[] = {2,3,4,5,6,7,8,9% :> a handy way to group them together. Here we're creating
an array of integers, called ledPins, with eight elements.

You refer to the elements in an array by their position.
The first element is at position 0, the second is at position

digitalWrite(ledPins[0], HIGH); :> 1, etc. You refer to an element using "ledPins[x]" where x
is the position. Here we're making digital pin 2 HIGH,
since the array element at position 0 is "2".

Computers like to do the same things each time they run. But sometimes
index = random(8); :> you want to do ‘thin'gs randomly, such as .simulating the roll of a dice. The

random() function is a great way to do this.

See http://arduino.cc/en/reference/random for more information.

What you Should See:

"This is similar to circuit number one, but
instead of one LED, you should sece all the
LED:s blink. If they aren't, make sure you
have assembled the circuit correctly and
verified and uploaded the code to your board
or see the troubleshooting tips below. »

Troubleshooting: Real World Application:

Some LEDs Fail to Light Scrolling marquee displays are generally used to spread
It is easy to insert an LED backwards. Check the LEDs short segments of important information. They are built
that aren't working and ensure they the right way out of many LEDs.

around.

Operating out of sequence

With eight wires it's easy to cross a couple. Double check

that the first LED is plugged into pin 2 and each pin o e ses s o ses s e ses ses s e n
s | BEEPEEREREL S Y
Starting Afresh

Its easy to accidentally misplace a wire without noticing.
Pulling everything out and starting with a fresh slate is
often easier than trying to track down the problem.
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Push Buttons

5 volt Up until now, we've focused solely on outputs. Now
we're going to go to the other end of spectrum and
play around with inputs. In this circuit, we’ll be
looking at one of the most common and simple
inputs — a push button. The way a push button works
with RedBoard is that when the button is pushed, the
voltage goes LOW. The RedBoard reads this and
reacts accordingly. In this circuit, you will also use a
pull-up resistor, which keeps the voltage HIGH when

?0922190;'3 O(Ea?logshg:())wn) you're not pressing the button.

Resistors (10K ohm)

RedBoard (Brown-Black-Orange)

LED
(Light-Emitting Diode)

Buttons

1

= GND
(Ground)

Push Button LED 10KQ 330Q Wire
/ Resistor Resistor
x2 x1 x2 x1 x7
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Circuit 5: Push Buttons
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‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 5

00

The digital pins can be used as inputs as well as outputs.
pinMode(button2Pin, INPUT); :> Before you do either, you need to tell the RedBoard

which direction you're going.

To read a digital input, you use the digitalRead()
button1State = digitalRead(button1Pin); :>

function. It will return HIGH if there's 5V present at the
pin, or LOW if there's OV present at the pin.

Because we've connected the button to GND, it will read LOW when
if (button1State == LOW) it's being pressed. Here we're using the "equivalence” operator ("==")

to see if the button is being pressed.

What You Should See:

You should see the LED turn on
if you press either button, and off
if you press both buttons. (See the
code to find out why!) If it isn't
working, make sure you have
assembled the circuit correctly
and verified and uploaded the
code to your board or see the
troubleshooting tips below.

Troubleshooting:

Light Not Turning On 'The buttons we used here are similar to the buttons in
'The pushbutton is square, and because of this it is easy to most video game controllers.

put it in the wrong way. Give it a 90 degree twist and see

if it starts working.

Underwhelmed

No worries, these circuits are all super stripped down to
make playing with the components easy, but once you
throw them together the sky is the limit.
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CIRCUIT #6

LED
(Light-Emitting Diode)

Resistor (330 ohm)
(Orange-Orange-Brown)

5 volt

Photocell
(Light Sensitive Resistor)

[PINAO] RedBoard

Resistor (10K ohm)
(Brown-Black-Orange)

(Ground)

=

x1

Photo Resistor LED

x1

Photo Resistor

So you've already played with a potentiometer, which
varies resistance based on the twisting of a knob. In
this circuit, you'll be using a photo resistor, which
changes resistance based on how much light the
sensor receives. Since the RedBoard can’t directly
interpret resistance (rather, it reads voltage), we use a
voltage divider to use our photo resistor. This voltage
divider will output a high voltage when it is getting a
lot of light and a low voltage when it is not.

330Q Wire 10KQ
Resistor Resistor
x1 x6 x1
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Circuit 6 : Photo Resistor
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‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 6

lightLevel = map(lightLevel, 0, 1023, 0, 255); |:>
Parameters
map(value, fromLow, fromHigh, toLow, toHigh)

value: the number to map

fromLow: the lower bound of the value's current range
fromHigh: the upper bound of the value's current range
toLow: the lower bound of the value's target range
toHigh: the upper bound of the value's target range

lightLevel = constrain(lightLevel, 0, 255);

Parameters
constrain(x, a, b)
x: the number to constrain, all data types

a: the lower end of the range, all data types
b: the upper end of the range, all data types

What You Should See:

You should see the LED grow brighter
or dimmer in accordance with how
much light your photoresistor is
reading. Ifit isn't working, make sure
you have assembled the circuit
correctly and verified and uploaded
the code to your board or see the
troubleshooting tips below.

Troubleshooting:

LED Remains Dark

This is a mistake we continue to make time and time
again, if only they could make an LED that worked both
ways. Pull it up and give it a twist.

It Isn't Responding to Changes in Light
Given that the spacing of the wires on the photo-resistor
is not standard, it is easy to misplace it. Double check it’s

in the right place.

Still Not Quite Working

You may be in a room which is either too bright or dark.
Try turning the lights on or off to see if this helps. Or if
you have a flashlight near by give that a try.

Page 44
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When we read an analog signal using analogRead(), it will be
a number from 0 to 1023. But when we want to drive a
PWM pin using analogWrite(), it wants a number from 0 to
255. We can "squeeze” the larger range into the smaller range
using the map() function.

See http://arduino.cc/en/reference/map for more info.

Because map() could still return numbers outside the "to"
range, we'll also use a function called constrain() that will
"clip" numbers into a range. If the number is outside the
range, it will make it the largest or smallest number. If it is

within the range, it will stay the same.

See http://arduino.cc/en/reference/constrain for more info.

Real World Application:

A street lamp uses a light sensor to detect when to turn

the lights on at night.

M



5 volt
TMP36
11 vee
VouT |2
ST
_ 1 _ GND
—  (Ground)
Wire
x1 x5

(Precision Temperature Sensor)

PIN AO
RedBoard

Temperature Sensor

A temperature sensor is exactly what it sounds like —a
sensor used to measure ambient temperature. This
particular sensor has three pins — a positive, a ground,
and a signal. This is a linear temperature sensor. A
change in temperature of one degree centigrade is equal
to a change of 10 millivolts at the sensor output. The
TMP36 sensor has a nominal 750 mV at 25°C (about
room temperature). In this circuit, you'll learn how to
integrate the temperature sensor with your RedBoard,
and use the Arduino IDE’s serial monitor to display the
temperature.

When you’re building the circuit be careful not
to mix up the transistor and the temperature
sensor, they’re almost identical. Look for
“TMP” on the body of the temperature sensor.

GND
SIGNAL
+V

R
SIGNAL
GND
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Circuit 7: Temperature Sensor
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‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 7

Serial.begin(9600);

Serial.print(degreesC);

Serial.println(degreesF);

=

=

=

(V1)
Before using the serial monitor, you must call Serial.begin() to
initialize it. 9600 is the "baud rate", or communications speed. When
two devices are communicating with each other, both must be set to
the same speed.

The Serial.print() command is very smart. It can print out almost
anything you can throw at it, including variables of all types,
quoted text (AKA "strings"), etc.

See http://arduino.cc/en/serial/print for more info.

Serial.print() will print everything on the same line. Serial.printIn() will
move to the next line. By using both of these commands together, you

can create easy-to-read printouts of text and data.

What You Should See:

You should be able to read the
temperature your temperature
sensor is detecting on the serial
monitor in the Arduino IDE. If it
isn't working, make sure you have
assembled the circuit correctly and
verified and uploaded the code to
your board or see the troubleshoot-
ing tips below.

Troubleshooting:

Nothing Seems to Happen

# Autoscroll Mo line ending T8 (9600 baud_

voltage: 0.73 deg C: 23.24 deg F: 73.84
voltage: 0.73 deg C: 23.24 deg F: 73.84
voltage: 0.73 deg C: 23.24 deg F: 73.84
voltage: 0.73 deg C: 22.75 deg F: 72.96
voltage: 0.73 deg C: 23.24 deg F: 73.84
voltage: 0.73 deg C: 23.24 deg F:73.84
voltage: 0.73 deg C: 23.24 deg F: 73.84
voltage: 0.73 deg C: 22.75 deg F:
voltage: 0.73 deg C: 23.24 deg F:
voltage: 0.73 deg C: 22.75 deg F: 72.96
voltage: 0.73 deg C: 22.75 deg F: 72.96
voltage: 0.73 deg C: 23.24 deg F:73.84
voltage: 0.73 deg C: 22.75 deg F: 72.96
voltage: 0.73 deg C: 23.24 deg F: 73.84

\\ AN

Real World Application:

Building climate control systems use a temperature sensor

'This program has no outward indication it is working. To
see the results you must open the Arduino IDE's serial
monitor (instructions on previous page).

Gibberish is Displayed

'This happens because the serial monitor is receiving data at
a different speed than expected. To fix this, click the
pull-down box that reads "*** baud" and change it to
"9600 baud".

Temperature Value is Unchanging

Try pinching the sensor with your fingers to heat it up or
pressing a bag of ice against it to cool it down.
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CIRCUIT #8

ingle Servo

AS

Servos are ideal for embedded electronics applications

because they do one thing very well that motors cannot —

No junction dot means no connection

they can move to a position accurately. By varying the
pulse width of the output voltage to a servo, you can move

5 volt

a servo to a specific position. For example, a pulse of 1.5
milliseconds will move the servo 90 degrees. In this circuit,

you'll learn how to use PWM (pulse width modulation)

to CODU'Ol and rotate a servo.

=)
IS
=] =
o| O o3
= © = =
= @ GRS
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|
2| x| o
S o+ O
s = =
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Circuit 8: A Single Servo
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‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 8

00

#include is a special "preprocessor” command that inserts a library (or any

#include <Servo.h> :>

Setvo servol;

servol.attach(9);

other file) into your sketch. You can type this command yourself, or
choose an installed library from the "sketch / import library" menu.

The servo library adds new commands that let you control a servo. To

:> prepare the Arduino to control a servo, you must first create a Servo
"object" for each servo (here we've named it "servol"), and then "attach" it
to a digital pin (here we're using pin 9).

The servos in this kit don't spin all the way around, but they can be commanded

servol.write(180); |:>

to move to a specific position. We use the servo library's write() command to

move a servo to a specified number of degrees(0 to 180). Remember that the

servo requires time to move, so give it a short delay() if necessary.

What You Should See:

You should see your servo motor move to
various locations at several speeds. If the
motor doesn't move, check your
connections and make sure you have
verified and uploaded the code, or see the
troubleshooting tips below.

Troubleshooting:

Servo Not Twisting
Even with colored wires it is still shockingly easy to pluga
servo in backward. This might be the case.

Still Not Working

A mistake we made a time or two was simply forgetting
to connect the power (red and brown wires) to +5 volts
and ground.

Fits and Starts

If the servo begins moving then twitches, and there's a
flashing light on your RedBoard, the power supply you
are using is not quite up to the challenge. Using a wall
adapter instead of USB should solve this problem.
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Real World Application:

Robotic arms you might see in an assembly line or sci-fi
movie probably have servos in them.




CIRCUIT #9

5volt

= Resistor (10K ohm)
T (Brown-Black-Orange)

A

PIN A
RedBoard <
< Flex Sensor
L aND
~ (Ground)

MM Flex Sensor

10KQ Wire
Resistor
x1 x11

Flex Sensor

In this circuit, we will use a flex sensor to measure,
well, flex! A flex sensor uses carbon on a strip of
plastic to act like a variable resistor, but instead of
changing the resistance by turning a knob, you
change it by flexing (bending) the component. We
use a "voltage divider" again to detect this change in
resistance. The sensor bends in one direction and the
more it bends, the higher the resistance gets; it has a
range from about 10K ohm to 35K ohm. In this
circuit we will use the amount of bend of the flex
sensor to control the position of a servo.
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Circuit 9: Flex Sensor
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‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 9

00

Because the flex sensor / resistor combination won't give us a
setvoposition = map(flexposition, 600, 900, 0, 180); full 0 to 5 volt range, we're using the map() function as a
map(value, fromLow, fromHigh, toLow, toHigh) handy way to reduce that range. Here we've told it to only

expect values from 600 to 900, rather than 0 to 1023.

Because map() could still return numbers outside the "to"
. . . range, we'll also use a function called constrain() that will
servoposition = constrain(servoposition, 0, 180);

i "clip" numbers into a range. If the number is outside the
constrain(x, a, b)

range, it will make it the largest or smallest number. If it is

within the range, it will stay the same.

What You Should See:

You should see the servo motor move in
accordance with how much you are
flexing the flex sensor. If it isn't
working, make sure you have assembled
the circuit correctly and verified and
uploaded the code to your board or see
the troubleshooting tips below.

Troubleshooting: Real World Application:

Servo Not Twisting Controller accessories for video game consoles like

Even with colored wires it is still shockingly easy to plug a Nintendo’s “Power Glove” use flex-sensing technology. It

servo in backwards. This might be the case. was the first video game controller attempting to mimic
hand movement on a screen in real time.

Servo Not Moving as Expected

'The sensor is only designed to work in one direction. Try

flexing it the other way (where the striped side faces

out on a convex CUIVC).

Servo Doesn’t Move very Far
You need to modify the range of values in the call to the
map() function.
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CIRCUIT #10

Soft Potentiometer

RedBoard T . .
In this circuit, we are going to use yet another kind of

variable resistor — this time, a soft potentiometer (or
soft pot). This is a thin and flexible strip that can

5 volt
detect where pressure is being applied. By pressing
Resistors (330 ohm) down on various parts of the strip, you can vary the
RedBoard SoftPot L (Orange-Orange-Brown) resistance from 100 to 10K ohms. You can use this

ability to track movement on the soft pot, or simply
as a button. In this circuit, we’ll get the soft pot up
and running to control an RGB LED.

Resistor (10K ohm)
(Brown-Black-Orange)

[ GND
= (Ground)

LED Soft Potentiometer ~ Wire 330Q 10KQ
% # Resistor Resistor
x1 x1 x9 x3 x1
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Circuit 10: Soft Potentiometer
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‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 10
Code to Note: o °

|:> These big, scary functions take a single

redValue = constrain(map(RGBposition, 0, 341, 255, 0), 0, 255) Value (RGBposition) and calculate the

+ constrain(map(RGBposition, 682, 1023, 0, 255), 0, 255); three RGB values necessary to create a

rainbow of color. The functions create
three "peaks" for the red, green, and

greenValue = constrain(map(RGBposition, 0, 341, 0, 255), 0, 255) blue values, which overlap to mix and

~req ~ l . h ~ f
- constrain(map(RGBposition, 341, 682, 0,255), 0, 255); create new colors. See the code for more

information! Even if you're not 100%
clear how it works, you can copy and

aste thi F: function int:
blueValue = constrain(map(RGBposition, 341, 682, 0, 255), 0, 255) paste this (or any) function into your

- constrain(map(RGBposition, 682, 1023, 0, 255), 0, 255); own code and use it yourself. If you

want to know more about creating your

own functions - take a look at circuit
#11.

What You Should See:

You should see the RGB LED change
colors in accordance with how you
interact with the soft potentiometer.
If it isn't working, make sure you
have assembled the circuit correctly
and verified and uploaded the code to
your board, or see the
troubleshooting tips below.

Troubleshooting: Real World Application:

LED Remains Dark or Shows Incorrect Color ‘The knobs found on many objects, like a radio for
With the four pins of the LED so close together, it’s instance, are using similar concepts to the one you just
sometimes easy to misplace one. Try double checking each completed for this circuit.

pin is where it should be.

Bizarre Results

‘The most likely cause of this is if you're pressing the
potentiometer in more than one position. This is normal
and can actually be used to create some neat results.

888
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Piezo Buzzer

[+

RedBoard

L GND
(Ground)

Piezo Buzzer Wire

Piezo Buzzer

In this circuit, we'll again bridge the gap between the
digital world and the analog world. We'll be using a
buzzer that makes a small "click" when you apply
voltage to it (try it!). By itself that isn't terribly
exciting, but if you turn the voltage on and off
hundreds of times a second, the buzzer will produce a
tone. And if you string a bunch of tones together,
you've got music! This circuit and sketch will play a
classic tune. We'll never let you down!

+ If the buzzer doesn't easily fit
into the holes on the breadboard,

try rotating it slightly.
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‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 11

char notes[] = "cdfda ag cdfdg gf "";

=

char names[] = {'c','d",'¢",'f",'g",'a’','b",'C'};

tone(pin, frequency, duration); :>

What You Should See:

You should see - well, nothing!
But you should be able to hear a
song. If it isn't working, make
sure you have assembled the
circuit correctly and verified and
uploaded the code to your board
or see the troubleshooting tips
below.

IXLINy

Troubleshooting:

No Sound
Given the size and shape of the piezo buzzer it is easy to
miss the right holes on the breadboard. Try double

checking its placement.

Can't Think While the Melody is Playing
Just pull up the piezo buzzer whilst you think, upload
your program then plug it back in.

Feeling Let Down and Deserted

'The code is written so you can easily add your own songs.

Page 64

00

Up until now we've been working solely with numerical data, but
the Arduino can also work with text. Characters (single, printable,
letters, numbers and other symbols) have their own type, called
"char". When you have an array of characters, it can be defined
between double-quotes (also called a "string"), OR as a list of

single-quoted characters.

One of Arduino's many useful built-in commands is the tone()
function. This function drives an output pin at a certain
frequency, making it perfect for driving buzzers and speakers. If
you give it a duration (in milliseconds), it will play the tone then

stop. If you don't give it a duration, it will kee aying the tone
top. If you don't give it a duration, it will keep playing the ¢

forever (but you can stop it with another function, noTone() ).

Real World Application:

Many modern megaphones have settings that use a loud
amplified buzzer. They are usually very loud and quite
good at getting people’s attention.

. (CXEXE)



Spinning a Motor

5volt

Remember before when you played around with a servo
motor? Now we are going to tackle spinning a motor.
"This requires the use of a transistor, which can switch a
DC Motor larger amount of current than the RedBoard can. When
using a transistor, you just need to make sure its
maximum specs are high enough for your use. The
transistor we are using for this circuit is rated at 40V max
and 200 milliamps max — perfect for our toy motor!
Transistor When the motor is spinning and suddenly turned off; the
(P2N2222AG) magnetic field inside it collapses, generating a voltage
spike. This can damage the transistor. To prevent this, we
use a "flyback diode", which diverts the voltage spike
GND around the transistor.

Diode
(1N4148)

RedBoard

Resistor (330 ohm)
(Orange-Orange-Brown)

(Ground) When you’re building the circuit be careful not
I to mix up the transistor and the temperature
= sensor, they’re almost identical. Look for

“P2N2222A” on the body of the transistor.

Transistor Diode DC Motor Wire 330Q
P2N2222AG 1N4148 Resistor
x1 x1 x6 x1

x1
7\

EMITTER
BASE
COLLECTOR

FRONT

COLLECTOR
BASE
EMITTER
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‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 12

00

‘The RedBoard's serial port can be used to receive as well as send data.
Because data could arrive at any time, the RedBoard stores, or
: . : "buffers” data coming into the port until you're rez se it. Thy
while (Serial.available() > 0) :> buffers" data coming into the port until you're ready to use it. The
Serial.available() command returns the number of characters that the
port has received, but haven't been used by your sketch yet. Zero

means no data has arrived.

If the port has data waiting for you, there are a number of ways for
) g for) Y

you to use it. Since we're typing numbers into the port, we can
speed = Serial.parselnt(); :> use the handy Serial.parselnt() command to extract, or "parse”

integer numbers from the characters it's received. If you type "1"

"0" "0" to the port, this function will return the number 100.

What You Should See:

The DC Motor should spin if you have
assembled the circuit’s components correctly,
and also verified/uploaded the correct code. If
your circuit is not working check the
troubleshooting section below.

Troubleshooting: Real World Application:

Motor Not Spinning Radio Controlled(RC) cars use Direct Current(DC)
If you sourced your own transistor, double check with motors to turn the wheels for propulsion.

the data sheet that the pinout is compatible with a
P2N2222AG (many are reversed).

Still No Luck

If you sourced your own motor, double check that it will
work with 5 volts and that it does not draw too much
power.

Still Not Working

Sometimes the RedBoard will disconnect from the
computer. Try un-plugging and then re-plugging it into
your USB port.
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Relays

In this circuit, we are going to use some of the lessons we
5 volt learned in circuit 12 to control a relay. A relay is basically
Resistor (330 ohm) : H H :
o o) an electrically controlled mechanical switch. Inside that
harmless looking plastic box is an electromagnet that,

when it gets a jolt of energy, causes a switch to trip. In
5'33;8) this circuit, you'll learn how to control a relay like a pro
T — giving your RedBoard even more powerful abilities!
SPDT Relay LEDs
fedBoard Transistor éSZ éSZ(L\qthm\mr\q Diodes)

(P2N2222AG)
Resistor (330 ohm)
(Orange-Orange-Brown)

When the relay is off, the COM (common)
pin will be connected to the NC (Normally
Closed) pin. When the relay is on, the COM
(common) pin will be connected to the NO
(Normally Open) pin.

I

GND
(Ground)

P2N2222AG 1N4148 Resistor

Relay Transistor Diode 330Q LED/ Wire
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Circuit 13: Relays
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‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 13

digitalWrite(relayPin, HIGH);

=

digitalWrite(relayPin, LOW);

What You Should See:

You should be able to hear the
relay contacts click, and see the
two LED:s alternate illuminating
at 1-second intervals. If you
don't, double-check that you
have assembled the circuit
correctly, and uploaded the
correct sketch to the board. Also,
see the troubleshooting tips below.

Troubleshooting:

LED:s Not Lighting
Double-check that you've plugged them in correctly. The
longer lead (and non-flat edge of the plastic flange) is the

positive lead.

No Clicking Sound
'The transistor or coil portion of the circuit isn't quite
working. Check the transistor is plugged in the right way.

Not Quite Working

'The included relays are designed to be soldered rather than
used in a breadboard. As such you may need to press it in
to ensure it works (and it may pop out occasionally).
When you're building the circuit be careful not to mix up
the temperature sensor and the transistor, they’re almost
identical.
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When we turn on the transistor, which in turn energizes the
relay’s coil, the relay's switch contacts are closed. This connects the
relay's COM pin to the NO (Normally Open) pin. Whatever
you've connected using these pins will turn on. (Here we're using

LEDs, but this could be almost anything,)

The relay has an additional contact called NC (Normally Closed).
‘The NC pin is connected to the COM pin when the relay is OFF.
You can use cither pin depending on whether something should
be normally on or normally off. You can also use both pins to

alternate power to two devices, much like railroad crossing

warning lights.
g o

Real World Application:

Garage door openers use relays to operate. You might be
able to hear the clicking if you listen closely.




CIRCUIT #14

Shift Register

5ol Now we are going to step into the world of ICs (integrated
circuits). In this circuit, you'll learn all about using a shift
Resistors (330 ohi . . .
iR T (Orne. O Brown register (also called a serial-to-parallel converter). The shift
° o 15 Sl MM . 1 . .. .
B bo o W 2 register will give your RedBoard an addmox.lal .elghF outp}m,
g —0 s e e {>\%\ AW, using only three pins on your board. For this circuit, you'll
o Qo . . . . .
L : ::: Bt AW practice by using the shift register to control eight LEDs.
oF N\
—2g o gs & S‘ A:A:A:A: {>\i AW
—— oo o l(’\
LED:
74HC595 (Lxg:t-Emmmg Diodes)
= tGGr\:gund) *Do not connect pin 9 Q
5
DC
q,
Q.
Q.
QG
QN
GND
LED 330Q Wire .
. Align notch on top,
Resistor ; GBEN and HEN
inbetween “e5” and “f5” on
x1 x8 x8 x19 the breadboard. The notch
N indicates where pin 1 is. /
S ' <
Bend legs to 90° angle.
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‘ , ! Open Arduino IDE // File > Examples > SIK Guide > Circuit # 14

00

:> You'll communicate with the shift register (and a lot of other parts) using an
interface called SPI, or Serial Peripheral Interface. This interface uses a data
shiftOut(datapin, ClOCk‘pin, MSBFIRST, data); line and a separate clock line that work together to move data in or out of
the RedBoard at high speed. The MSBFIRST parameter specifies the order
in which to send the individual bits, in this case we're sending the Most

Significant Bit first.

:> Bits are the smallest possible piece of memory in a computer; each one can
store cithera "1" ora "0". Larger numbers are stored as arrays of bits.

. . . ) . Sometimes we want to manipulate these bits directly, for example now when

bitWrite(byteVar, desiredBit, desiredState);

we're sending eight bits to the shift register and we want to make them 1 or 0

to turn the LEDs on or off. The RedBoard has several commands, such as

bitWrite(), that make this easy to do.

What You Should See:

You should see the LEDs light up
similarly to circuit 4 (but this
time, you're using a shift register).
If they aren't, make sure you have
assembled the circuit correctly
and verified and uploaded the
code to your board. See the
troubleshooting tips below.

Troubleshooting: Real World Application:

The RedBoard's power LED goes out Similar to circuit #4, a scrolling marquee display delivers
This happened to us a couple of times, it happens when a message with multiple LEDs. Essentially the same task
the chip is inserted backward. If you fix it quickly the shift register achieves here in Circuit #14.

nothing will break.

Not Quite Working

Sorry to sound like a broken record but it is probably
something as simple as a crossed wire.

Frustration

Shoot us an e-mail, this circuit is both simple and
complex at the same time. We want to hear about
problems you have so we can address them in future

editions: techsupport@sparkfun.com
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- all depending on how you

you'll learn about how to use an LCD.

or liquid crystal display, is a simple screen

that can display commands, bits of information, or

readings from your sensor

program your board. In this circuit, you'll learn the
baslcs Of mcorporatmg an LCD into your proJeCt
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Circuit 15: LCD
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|_ , “ Open Arduino IDE // File > Examples > SIK Guide > Circuit # 15

00

This bit of code tells your Arduino IDE to include the library for a
#include <LiquidCrystal.h> simple LCD display. Without it, none of the commands will work,
so make sure you include it!

This is the first time you'll fire something up on your screen. You
Ied.print(“hello, world!”); :> may need to adjust the contrast to make it visible. Twist the
potentiometer until you can clearly see the text!

What you Should See:

Initially, you should see the
words “hello, world!” pop up
on your LCD. Remember you
can adjust the contrast using
the potentiometer if you can’t
make out the words clearly. If
you have any issues, make sure
your code is correct and
double-check your

connections.

Troubleshooting: Real World Application:

The Screen is Blank or Completely Lit? LCD:s are everywhere! From advanced LCD:s like your
Fiddle with the contrast by twisting the potentiometer. If television, to simple notification screens, this is a very
it's incorrectly adjusted, you won’t be able to read the common and useful display!

text.

Not Working At All?

Double check the code, specifically that you include the

LCD library. j j E@?F

Screen Is Flickering DD DQ o DQ DD
Double check your connections to your breadboard and N
Arduino. AN
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CIRCUIT #16

PARTS

EDs
(Light-Emitting Diodes)

GND

(Ground)

Push Button

<.

Simon Says

Now that we've learned all the basics behind the
components in the SIK, let's put them together and
have some fun. This circuit will show you how to
create your own Simon Says game. Using some LEDs,
some buttons, a buzzer and some resistors, you can
create this and other exciting games with your SIK.

Piezo Element Wire

x1 x16
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|_ , “ Open Arduino IDE // File > Examples > SIK Guide > Circuit #16

00

The #define statement is used to create constants in your code. Constants are variables that
will likely only have one value during the lifespan of your code. Thus, you can assign

#define :> constants a value, and then use them throughout your code wherever you need them.
Then, if you need to change that value, you only have to change one line instead of going
through all the code to find every instance of that variable.

Bytes are another variable type. In the world of computing, a byte is a chunk of space that
byte :> contains 8 bits, and a bit is a single binary value. Binary is another way of counting and uses
: only 1'sand 0's. So a byte can hold all 1's: 11111111, all 0's: 00000000, or a combination of
the two: 10010110.

What You Should See:

With the circuit complete,
plug the Arduino in to a
power source. Once powered,
the buzzer will beep a few times,
and all four LEDs should begin blinking.
‘The game begins once you press any of the
four buttons. Once the game has been started, a
random LED will blink. Press the button
associated with that color LED to replicate the
pattern. With a successful guess, the pattern will
repeat, this time adding another random LED. The
player is to follow the pattern for as long as possible,
with each successful guess resulting in an additional
layer of complexity added to the original pattern.

Troubleshooting: Real World Application:

Only half the circuit works Toys and games, such as the original Simon from Milton
If only half of your circuit is working, make sure you added the Bradley, have relied on electronics to provide fun and
additional wire from one ground rail to the other. Remember that
breadboards have two power rails on each side and that these can
be connected, or bussed, together to provide the power to both
sides of the same circuit.

entertainment to children across the world.

No sound

Once the buzzer is in the breadboard, it's hard to see the legs and
which row they are connected to. If you aren't hearing any sound,
make sure your wires are on the same row as the buzzer legs.

Game is not working

If everything starts up ok, but you're having trouble when it comes
time to play the game, you may have a button or two misplaced.
Pay close attention to which pin is connected to each button, as it
matters which button is pressed when a particular color lights up.
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Learning More

Visit us Online:

This is just the beginning of your exploration into embedded
electronics and coding. Our website has a wealth of tutorials to
whet your appetite for more knowledge. We also host a
community of hackers, engineers, DIYers, etc. in our forums. So
log on to our website for more information about Arduino, or to
plan ahead for your next project!

€ ) www.sparkfun.com




Begin y()ur Joumey N The SparkFun Inventor’s Kit

teaches basic programming,

into Electronics for which you will need both

This kit will guide you through a computer and an internet connection.

experiments of varying difficulty
as you learn all about embedded

systems, physical computing, You will also learn to assemble 16
programming and more! This kit basic physical electronic circuits, but
is perfect for anyone who wants no soldering is required. No

to explore the power of the previous experience is necessary!
RedBoard platform.

KIT INCLUDES

L
\ B o
‘ . i
SparkFun RedBoard RGB LED Photo Resistor 330 ohm resistors
Breadboard Temperature sensor Transistors Piezo buzzer
Instruction booklet DC motor Jumper wires Flex sensor
Sealed relay 8-bit shift register USB cable Soft potentiometer
Small servo Push button switches  Signal diodes Baseplate
LEDs Potentiometer 10k ohm resistors LCD

© SparkFun Electronics, inc. All rights reserved. The SparkFun Inventor’s kit for the SparkFun RedBoard features, specifications, system
requirements and availability are subject to change without notice. All other trademarks contained herein are the property of their respective owners.

The SIK Guide for the SparkFun Inventor’s Kit for the SparkFun RedBoard is licensed under
the Creative Commons Attribution Share-Alike 3.0 Unported License

To view a copy of this license visit: http://creativecommons.org/by-sa/3.0/
Or write: Creative Commons;. 171 Second Street, Suite 300, San Francisco, CA 94105, USA.
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