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DISCLAIMERDISCLAIMER

© 2017 Olimex Ltd. Olimex®, logo and combina琀椀ons thereof, are registered trademarks of Olimex Ltd.

Other product names may be trademarks of others and the rights belong to their respec琀椀ve owners.

The informa琀椀on in this document is provided in connec琀椀on with Olimex products.  No license, express or

implied or otherwise, to any intellectual property right is granted by this document or in connec琀椀on with

the sale of Olimex products.

The hardware designs of the development boards men琀椀oned in this guide (ESP8266-EVB; ESP8266-EVB-

BAT; ESP8266-EVB-BAT-BOX) are considered open source. Anyone can download the original schema琀椀cs

and board design 昀椀les. The 昀椀les describing the hardware are made with CadSo昀琀's EAGLE PCB design

so昀琀ware – the so昀琀ware has a free version suitable for studying any board schema琀椀c or board design.

The part  of  the so昀琀ware wri琀琀en by Olimex is  released under  GPL.  However,  the examples that  we

distribute are based on the SDK libraries and projects released by Espressif Systems. Make sure that you

are acquainted with Espressif Systems’ license agreement before using, publishing, or distribu琀椀ng any

code based on our so昀琀ware.

It is possible that the pictures in this manual di昀昀er from the latest revision of the board. 

The products described in this document are subject to con琀椀nuous development and improvements. All

par琀椀culars of the products and their use contained in this document are given by OLIMEX in good faith.

However,  all  warran琀椀es  implied  or  expressed,  including  but  not  limited  to,  implied  warran琀椀es  of

merchantability or 昀椀tness for purpose, are excluded. This document is intended only to assist the reader

in the use of the products. Olime Ltd. shall not be liable for any loss or damage arising from the use of

any informa琀椀on in this document or any error or omission in such informa琀椀on or any incorrect use of the

product.

These evalua琀椀on boards are intended for use in engineering development, demonstra琀椀on, or evalua琀椀on

purposes only and are not considered by Olimex to be a 昀椀nished end-product 昀椀t for general consumer

use.  Persons  handling  the  products  must  have  electronics  training  and  observe  good  engineering

prac琀椀ce standards.  As such, the goods being provided are not intended to be complete in terms of

required design-, marke琀椀ng-, and/or manufacturing-related protec琀椀ve considera琀椀ons, including product

safety and environmental measures typically found in end products that incorporate such semiconductor

components or circuit boards.

Olimex currently deals with a variety of customers for products, and therefore our arrangement with the

user is not exclusive. Olimex assumes no liability for applica琀椀ons assistance, customer product design,

so昀琀ware performance, or infringement of patents or services described herein.
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CHAPTER 1: PURPOSE OF THIS DOCUMENTCHAPTER 1: PURPOSE OF THIS DOCUMENT

This document aims to assist beginners in the 昀椀rst-琀椀me programming of ESP8266-EVB, ESP8266-EVB-

BAT, or ESP8266-EVB-BAT-BOX, via Arduino IDE. Experienced ESP8266 users would probably 昀椀nd this 

document redundant.

The document structure is as follows:

• All the required hardware and so昀琀ware for a basic setup is listed in “CHAPTER 2: 

REQUIREMENTS”.

• In “CHAPTER 3: SETUP” there are speci昀椀c details on how to set everything together. 

• “CHAPTER 4: UPLOADING BLINKING LED” shows how to upload a simple blinking LED example to 

the board.

• “CHAPTER 5: FURTHER READING” provides links to more ESP8266-related resources.

• The document's revision and ordering informa琀椀on are available in “CHAPTER 6: ORDERING 

CODES AND DOCUMENT REVISION”.
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CHAPTER 2: REQUIREMENTSCHAPTER 2: REQUIREMENTS

The minimal connec琀椀on requires several prerequisites.

2.1 Hardware requirements2.1 Hardware requirements

Note that you might already own all the necessary hardware listed below. For example, as long as you 

have a 昀椀琀�ng 5V power supply unit or USB<->serial cable there is no need to purchase new ones.

2.1.1 ESP8266 board2.1.1 ESP8266 board

The main component of the setup. You need one of the following three boards, which are suitable for 

beginners:

• ESP8266-EVB

• ESP8266-EVB-BAT

• ESP8266-EVB-BAT-BOX

MOD-WIFI-ESP8266-DEV and MOD-WIFI-ESP8266 are not suitable for beginners with ESP8266. The main di昀케culty if you use 

one of those two boards would be changing the boot mode of the board. This would require cu琀�ng and soldering of SMT 

jumpers (or shortening pins via wires).

2.1.2 Power supply adapter2.1.2 Power supply adapter

The ESP8266-EVB board gets powered via the barrel power jack named “PWR”. You need to apply exactly

5V DC. 

The corresponding power supply plug (or female jack) that 昀椀ts the DC barrel has 2.1mm inner diameter 

and 5.5mm outer diameter. The length of the male plug should be between 10mm and 14mm.

We distribute a昀昀ordable 220V<->5V adapters that 昀椀t the board's barrel jack. Search our web-shop for SY0605E and SY0605E-

CHINA.

2.1.3 USB <-> serial cable2.1.3 USB <-> serial cable

You might already have such a cable. In case you don't, you would need to get such an adapter cable due

to a couple of reasons:

• the voltage levels of board's RXD and TXD are lower than the voltage levels of computer's TXD 

and RXD (even if your computer has a na琀椀ve serial port). The adapter takes care of the level 

adjustment;

• most modern computers lack serial port.

The are two very important considera琀椀ons to make, when selec琀椀ng the cable that would work for you:

Page 5 of 15



OLIMEX© 2017 ESP8266 with Arduino IDE

• the cable needs to 昀椀t the pins of UEXT connector of the board – if it has free female leads, for 

example;

• the cable has the proper driver support for the opera琀椀ng system of your personal computer.

We distribute a昀昀ordable USB to serial adapter cables with female leads. Search our web-shop for USB-SERIAL-CABLE-F and 

BB-CH340T.

2.1.4 Personal computer2.1.4 Personal computer

In order to install the Arduino IDE you need a computer which is able to:

• run Arduino IDE;

• work properly with your serial cable;

• access the Internet.

2.2 Software requirements2.2 Software requirements

2.2.1 Driver for the USB<->serial cable2.2.1 Driver for the USB<->serial cable

Contact the supplier of your USB to serial adapter cable for such drivers. A昀琀er the drivers are installed 

make sure the cable is properly recognized by the opera琀椀ng system.

A properly installed serial cable should be listed as a COM port by the opera琀椀ng system. 

For example, under Windows, in “Windows Device Manager” a properly installed cable gets listed like 

this:

2.2.2 Arduino IDE2.2.2 Arduino IDE

Download and install Arduino IDE from the o昀케cial web-site of Arduino.

Get a version 1.6.4 or newer. It is important that the Arduino IDE version that you get has the addi琀椀onal 

boards manager.

We used Arduino 1.6.6 during the prepara琀椀on of this document. If you want to have the exact same 

behavior as us, use Arduino 1.6.6.
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CHAPTER 3: SETUPCHAPTER 3: SETUP

Now that we have all the prerequisites ready we need to set everything together.

3.1 Hardware setup3.1 Hardware setup

The layout hardware connec琀椀ons that we are interested can be found on the next page.

The hardest part of the connec琀椀on is probably connec琀椀ng the USB<->serial cable to the UEXT connector 

of ESP8266-EVB. The important part here is to connect the GND of the cable to the GND pin (#2) of the 

UEXT connector. Then TXD of the cable to RXD of the UEXT (#4). Finally, RXD of the cable to TXD of the 

UEXT (#3). 

For connec琀椀ng the USB<->serial cable we are interested only in pins #2, #3 and #4.
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3.2 Software setup3.2 Software setup

Before we are able to compile and upload a demo example, we need to prepare Arduino IDE to work 

with ESP8266 boards.

This is rela琀椀vely simple. Follow the steps below:

• Start Arduino.

• Select File → Preferences as shown below:

• A dialog window would pop-up.

• The only thing we need to edit here is the 昀椀eld called “Addi琀椀onal Boards Manager URLs:”. In the 

blank space we need to provide a link to the .json 昀椀le which would add ESP8266 support to 

Arduino. By the 琀椀me of wri琀椀ng the correct address is:

h琀琀p://arduino.esp8266.com/stable/package_esp8266com_index.json

The 昀椀eld should look similar to this: 

• Click “OK” to apply the changes and close the dialog window

• Navigate to Tools → Board → Boards Manager… and install the esp8266 pla琀昀orm. A properly 

installed library should show similar to this:

http://arduino.esp8266.com/stable/package_esp8266com_index.json
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• Now at the bo琀琀om of the selector Tools → Board you should see di昀昀erent ESP8266 boards 

available. This is shown below:

At this point we have a properly con昀椀gured setup. Now we can proceed to upload a simple blinking LED 

example (the “Hello, World!” of electronics).
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CHAPTER 4: UPLOADING BLINKING LEDCHAPTER 4: UPLOADING BLINKING LED

We need a properly con昀椀gured hardware and so昀琀ware setup as described previously in chapters 2 and 

3. Then we proceed as follows:

• Start Arduino IDE.

• Load the blinking LED example. Navigate to File → Examples → 01.Basics → Blink and click on it. 

This is shown below:

• A new window with code would open. Edit the code in order to re昀氀ect the hardware of ESP8266-

EVB boards. By default, the example assumes the LED is connected to digital pin #13  (like in most

Arduino boards). In our case the relay that has a LED is connected to digital pin #5. This 

informa琀椀on can be acquired from the schema琀椀c of the board. Replace all occurrences of  “13” 

with “5”. The code should look as follows:

void setup() {

// ini琀椀alize digital pin 5 as an output.

pinMode(5, OUTPUT);

}

// the loop func琀椀on runs over and over again forever

void loop() {

digitalWrite(5, HIGH);   // turn the LED on (HIGH is the voltage level)

  delay(1000);              // wait for a second

  digitalWrite(5, LOW);    // turn the LED o昀昀 by making the voltage LOW

  delay(1000);              // wait for a second

}
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• Save the edited code.

• Connect the board to the serial cable, and the cable to the USB of the computer (this is detailed 

in chapter 3 above).

• Iden琀椀fy the serial port number which the cable created in your personal computer. 

• In Arduino IDE select “Generic ESP8266 Module” board. This is done from Tools → Board → 

Generic ESP8266 Module.

• Edit the se琀�ngs for upload! Navigate to Tools and edit the se琀�ngs as show below (except for the 

COM port number which you iden琀椀昀椀ed previously; use the COMx number of your setup):

The important se琀�ngs (speci昀椀c for Olimex ESP8266-EVB boards) are:

◦ Board: “Generic ESP8266 Module”

◦ Flash Mode: “QIO”

◦ Flash Size: “2M (1M SPIFFS)”

◦ Upload Speed: “57600”

◦ Port: “COMx”
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• Enter bootloader mode and power the board. How to do it: press and hold the bu琀琀on of the 

ESP8266-EVB board; apply 5V of power to the PWR jack; release the bu琀琀on.

You need to perform the above sequence every 琀椀me before uploading new code to the board.

• In Arduino IDE compile and upload the example to the board. Simply click bu琀琀on “Upload”.

• If everything goes smooth you will also hear that our blinking LED example goes an extra mile 

and also switches the relay.
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CHAPTER 5: FURTHER READINGCHAPTER 5: FURTHER READING

In this chapter you would 昀椀nd links to places with useful informa琀椀on.

• The best loca琀椀on for ESP8266-related informa琀椀on is the o昀케cial Espressif Systems' forum here:

h琀琀p://bbs.espressif.com/

• The best place to read more about the ESP8266 support for Arduino IDE is this one:

h琀琀ps://github.com/esp8266/Arduino

• The custom ESP8266 昀椀rmware and examples provided by Olimex can be found here:

h琀琀ps://github.com/OLIMEX/ESP8266

• The link to the o昀케cial web-site of Olimex is here:

h琀琀ps://www.olimex.com
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CHAPTER 6: ORDERING CODES AND DOCUMENT REVISIONCHAPTER 6: ORDERING CODES AND DOCUMENT REVISION

6.1 Ordering codes6.1 Ordering codes

The exact names of some products men琀椀oned in this guide can be found below. The products can be 

found in our web-shop with these speci昀椀c product names:

ESP8266-EVB – evalua琀椀on board for ESP8266 with relay, bu琀琀on, UEXT, all GPIOs available on 0.1" header

ESP8266-EVB-BAT – evalua琀椀on board for ESP8266 with relay, bu琀琀on, UEXT, Li-Po ba琀琀ery connector with 

charger and all GPIOs available on boxed connector

ESP8266-EVB-BAT-BOX – evalua琀椀on board for ESP8266 with relay, bu琀琀on, UEXT, Li-Po ba琀琀ery connector 

with charger; all GPIOs available on boxed connector and Hammond box

USB-SERIAL-CABLE-F – a昀昀ordable serial to USB cable with female leads

BB-CH340T – a昀昀ordable serial to USB cable (remember to get female-female jumper cables with it)

SY0605E – a昀昀ordable power supply adapter 5V/1A 50Hz/220V(suitable for most European countries)

You can also 昀椀nd a big number of extension boards that can be connected to the UEXT of the board and 

also some of the components (if damage occurs and you want to replace the part yourself). Make sure to

use the search box.

You can purchase directly from our online shop or from any of our distributors. Note that usually it is 

faster and cheaper to purchase Olimex products from our distributors. List of con昀椀rmed Olimex LTD 

distributors and resellers: h琀琀ps://www.olimex.com/Distributors. 

Please visit h琀琀ps://www.olimex.com/ for more info.

6.26.2  DDocument revisionocument revision

Document revision Changes Modified page

A, 22.12.15 Initial document release All

B, 13.02.17
Corrected “hardware pin” mentions to 

“digital pin”.
11
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