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Chapter 1

Introduction

The DEO-Nano board introduces a compact-sized FPGA development platform suited for to a wide
range of portable design projects, such as robots and mobile projects.

The DEO-Nano is ideal for use with embedded soft processors—it features a powerful Altera Cyclone
IV FPGA (with 22,320 logic elements), 32 MB of SDRAM, 2 Kb EEPROM, and a 64 Mb serial
configuration memory device. For connecting to real-world sensors the DEO-Nano includes a
National Semiconductor 8-channel 12-bit A/D converter, and it also features an Analog Devices
13-bit, 3-axis accelerometer device.

The DEO-Nano board includes a built-in USB Blaster for FPGA programming, and the board can be
powered either from this USB port or by an external power source. The board includes expansion

headers that can be used to attach various Terasic daughter cards or other devices, such as motors
and actuators. Inputs and outputs include 2 pushbuttons, 8 user LEDs and a set of 4 dip-switches.

1.1 Features

Figure 1-1 shows a photograph of the DEO-Nano Board.

Figure 1-1 The DEO-Nano Board
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The key features of the board are listed below:

e Featured device
o Altera Cyclone® IV EP4CE22F17C6N FPGA

o 153 maximum FPGA I/O pins

¢ Configuration status and set-up elements
o On-board USB-Blaster circuit for programming

o Spansion EPCS64

e Expansion header

o Two 40-pin Headers (GPIOs) provide 72 1/O pins, 5V power pins, two 3.3V power pins and

four ground pins

e Memory devices
o 32MB SDRAM
o 2Kb I2C EEPROM

e General user input/output
o 8 green LEDs
o 2 debounced pushbuttons
o 4-position DIP switch

o (-Sensor
o ADI ADXL345, 3-axis accelerometer with high resolution (13-bit)

e A/D Converter
o NS ADC128S022, 8-Channel, 12-bit A/D Converter

o 50 Ksps to 200 Ksps

e Clock system
o On-board 5S0MHz clock oscillator

e Power Supply
o USB Type mini-AB port (5V)
o DC 5V pin for each GPIO header (2 DC 5V pins)

o 2-pin external power header (3.6-5.7V)

www.terasic.com
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1.2 About the KIT

The kit comes with the following contents:

DEO-Nano board

Quick Start Guide

USB Cable

CD (Download from Terasic Web)

The system CD contains technical documents for the DEO-Nano board, which includes component
datasheets, demonstrations, schematic, and user manual. User can download this System CD from the
web: http://de0-nano.terasic.com/cd.

Figure 1-2 shows the photograph of the DEO-Nano kit contents.

(1]
@ Altera DEO-Nano Board

® USB Mini-B Cable
® DEO-Nano Quick Start Guide

Figure 1-2 DEO-Nano kit package contents

1.3 Getting Help

Here is information of how to get help if you encounter any problem:

e Terasic Technologies
o Tel: +886-3-575-0880
e Email: support@terasic.com

Altera Corporation
Email: university @altera.com
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Chapter 2
DEO-Nano Board Architecture

This chapter describes the architecture of the DE(O-Nano board including block diagram and
components.

2.1 Layout and Components

The picture of the DEO-Nano board is shown in Figure 2-1 and Figure 2-2. It depicts the layout of
the board and indicates the locations of the connectors and key components.

FPGA Serial Configuration Device (EPCS)

8 Creen LEDs 32 MB SDRAM 40-pin GPIO Header
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Figure 2-1 The DEO-Nano Board PCB and component diagram (top view)
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Figure 2-2 The DEO-Nano Board PCB and component diagram (bottom view)

2.2 Block Diagram of the DEO-Nano Board

Figure 2-3 shows the block diagram of the DEO-Nano board. To provide maximum flexibility for
the user, all connections are made through the Cyclone IV FPGA device. Thus, the user can
configure the FPGA to implement any system design.

12C
EEPROM
(2Kbit)

> 40-pin GPIO
Header
B Xx72
— 40-pin GPIO
/NETERA. —
525“734 — Cyclonet1v
Ll X16 2X13
—> -
Pin Header
X1 X8 X2
I l X4
S

50 MHz

Figure 2-3 Block diagram of DEO-Nano Board
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2.3 Power-up the DEO-Nano Board

The DEO-Nano board comes with a preloaded configuration bit stream to demonstrate some
features of the board. This allows users to see quickly if the board is working properly. To power-up
the board two options are available which are described below:

1. Connect a USB Mini-B cable between a USB (Type A) host port and the board. For
communication between the host and the DEO-Nano board, it is necessary to install the Altera USB
Blaster driver software.

2. Alternatively, users can power-up the DEO-Nano board by supplying 5V to the two DC +5
(VCCS) pins of the GPIO headers or supplying (3.6-5.7V) to the 2-pin header.

At this point you should observe flashing LEDs on the board.

10
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Chapter 3
Using the DEO-Nano Board

This chapter gives instructions for using the DEO-Nano board and describes in detail its components
and connectors, along with the required pin assignments.

3.1 Configuring the Cyclone IV FPGA

The DEO-Nano board contains a Cyclone IV E FPGA which can be programmed using JTAG
programming. This allows users to configure the FPGA with a specified design using Quartus II
software. The programmed design will remain functional on the FPGA as long as the board is
powered on, or until the device is reprogrammed. The configuration information will be lost when
the power is turned off.

To download a configuration bit stream file using JTAG Programming into the Cyclone IV FPGA,
perform the following steps:

1. Connect a USB Mini-B cable between a host computer and the DEO-Nano.

2. The FPGA can now be programmed through the Quartus II Programmer by selecting a
configuration bit stream file with the .sof filename extension.

B Configuring the Spansion EPCS64 device

The DEO-Nano board contains a Spansion EPCS64 serial configuration device. This device
provides non-volatile storage of the configuration bit-stream, so that the information is retained
even when the power supply to the DEO-Nano board is turned off. When the board’s power is
turned on, the configuration data in the EPCS64 device is automatically loaded into the Cyclone IV
E FPGA.

The Cyclone IV E device supports in-system programming of a serial configuration device using
the JTAG interface via the serial flash loader design. The serial flash loader is a bridge design for
the Cyclone IV E device that uses its JTAG interface to access the EPCS jic file and then uses the
AS interface to program the EPCS device. Figure 3-1 illustrates the programming method when
adopting a serial flash loader solution. Chapter 9 of this document describes how to load a circuit to
the serial configuration device.

11
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Serial
Configuration

QUARTUS"II

Figure 3-1 Programming a serial configuration device with serial flash loader solution

B JTAG Chain on DEO-Nano Board

The JTAG Chain on the DE(O-Nano board is connected to a host computer using an on-board
USB-blaster. The USB-blaster consists of a USB Mini-B connector, a FTDI USB 2.0 Controller,

and an Altera MAX II CPLD.

Figure 3-2 illustrates the JTAG configuration setup.

USB
Connector

1

Figure 3-2 JTAG Chain

3.2 General User Input/Output

B Pushbuttons

The DEO-Nano board contains two pushbuttons shown in Figure 3-3. Each pushbutton is
debounced using a Schmitt Trigger circuit, as indicated in Figure 3-4. The two outputs called KEYO,
and KEY'1 of the Schmitt Trigger devices are connected directly to the Cyclone IV E FPGA. Each
pushbutton provides a high logic level when it is not pressed, and provides a low logic level when
pressed. Since the pushbuttons are debounced, they are appropriate for using as clock or reset

inputs.

12
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VCC2P5

—O H. O ——————» E1
KEYO SN74AUC17
oW O I T Cyclone,gwIV

Figure 3-3 Connections between the push-buttons and Cyclone IV FPGA

lPushbutton depressed lPushbutton released
Before

Debouncing ||||||||| |||||||
Schmitt Trigger

Debounced

v

A

Figure 3-4 Pushbuttons debouncing

B LEDs

There are 8 green user-controllable LEDs on the DEO-Nano board. The eight LEDs, which are
presented in Figure 3-4, allow users to display status and debugging information. Each LED is
driven directly by the Cyclone IV E FPGA. Each LED is driven directly by a pin on the Cyclone IV
E FPGA; driving its associated pin to a high logic level turns the LED on, and driving the pin low

turns it off.

13
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| el
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Figure 3-5 Connections between the LEDs and Cyclone IV FPGA

B DIP Switch

The DEO-Nano board contains a 4 dip switches. A DIP switch provides, to the FPGA, a high logic
level when it is in the DOWN position, and a low logic level when in the UPPER position.

Table 3-1 Pin Assignments for Push-buttons

Signal Name FPGA Pin No.  Description I/O Standard
KEY[0] PIN_J15 Push-button[0] 3.3v
KEY[1] PIN_E1 Push-button[1] 3.3V

Table 3-2 Pin Assignments for LEDs

Signal Name FPGA Pin No.  Description I/O Standard
LEDIO] PIN_A15 LED Green[0] 3.3V
LED[1] PIN_A13 LED Green[1] 3.3V
LED[2] PIN_B13 LED Green[2] 3.3V
LEDI3] PIN_A11 LED Green[3] 3.3V
LED[4] PIN_D1 LED Green[4] 3.3V
LEDI5] PIN_F3 LED Green[5] 3.3V
LEDI6] PIN_B1 LED Green[6] 3.3V
LEDI[7] PIN_L3 LED Green[7] 3.3V

14
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Table 3-3 Pin Assignments for DIP Switches

Signal Name FPGA Pin No.  Description I/O Standard
DIP Switch[0] PIN_MH1 DIP Switch[0] 3.3V
DIP Switch[1] PIN_T8 DIP Switch[1] 3.3V
DIP Switch[2] PIN_B9 DIP Switch[2] 3.3V
DIP Switch[3] PIN_M15 DIP Switch[3] 3.3V

3.3 SDRAM Memory

The board features a Synchronous Dynamic Random Access Memory (SDRAM) device providing
32MB with a 16-bit data lines connected to the FPGA. The chip uses 3.3V LVCMOS signaling
standard. All signals are registered on the positive edge of the clock signal, DRAM_CLK.
Connections between the FPGA and SDRAM chips are shown in Figure 3-6.

DRAM_DQ[15..0]
DRAM_ADDR[12..0]
DRAM_DQM[1..0]

A DYA DRAM_CLK
= DRAM CKE
DRAM_WE N
Cyclone,ngV DRAM_CAS N
DRAM_RAS_N SDRAM 16MX16
DRAM CS N
DRAM_BAO
DRAM_BA1

Figure 3-6 Connections between FPGA and SDRAM

Table 3-4 SDRAM Pin Assignments

Signal Name FPGA Pin No. Description I/O Standard
DRAM_ADDRI0] PIN_P2 SDRAM Address[0] 3.3V
DRAM_ADDRIJ1] PIN_N5 SDRAM Address[1] 3.3v
DRAM_ADDR]J2] PIN_N6 SDRAM Address[2] 3.3V
DRAM_ADDRIJ3] PIN_M8 SDRAM Address[3] 3.3V
DRAM_ADDRJ4] PIN_P8 SDRAM Address[4] 3.3v
DRAM_ADDRI5] PIN_T7 SDRAM Address[5] 3.3V
DRAM_ADDRI6] PIN_N8 SDRAM Address[6] 3.3v
DRAM_ADDR]7] PIN_T6 SDRAM Address[7] 3.3V
DRAM_ADDRI8] PIN_R1 SDRAM Address[8] 3.3V
DRAM_ADDRJ9] PIN_P1 SDRAM Address[9] 3.3V
DRAM_ADDRJ[10] PIN_N2 SDRAM Address[10] 3.3v
DRAM_ADDRJ[11] PIN_N1 SDRAM Address[11] 3.3V
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DRAM_ADDR[12] PIN_L4 SDRAM Address[12] 3.3V
DRAM_DQJ[0] PIN_G2 SDRAM Data[0] 3.3V
DRAM_DQJ[1] PIN_G1 SDRAM Data[1] 3.3v
DRAM_DQJ[2] PIN_L8 SDRAM Data[2] 3.3V
DRAM_DQI3] PIN_K5 SDRAM Data[3] 3.3V
DRAM_DQJ[4] PIN_K2 SDRAM Data[4] 3.3V
DRAM_DQJ[5] PIN_J2 SDRAM Data[5] 3.3V
DRAM_DQI[6] PIN_J1 SDRAM Data[6] 3.3V
DRAM_DQ][7] PIN_R7 SDRAM Data[7] 3.3V
DRAM_DQI8] PIN_T4 SDRAM Data[8] 3.3V
DRAM_DQJ[9] PIN_T2 SDRAM Data[9] 3.3V
DRAM_DQ[10] PIN_T3 SDRAM Data[10] 3.3V
DRAM_DQJ[11] PIN_R3 SDRAM Data[11] 3.3v
DRAM_DQ[12] PIN_R5 SDRAM Data[12] 3.3V
DRAM_DQ[13] PIN_P3 SDRAM Data[13] 3.3v
DRAM_DQJ[14] PIN_N3 SDRAM Data[14] 3.3V
DRAM_DQJ[15] PIN_K1 SDRAM Data[15] 3.3V
DRAM_BA[0] PIN_M7 SDRAM Bank Address[0] 3.3V
DRAM_BA[1] PIN_M6 SDRAM Bank Address[1] 3.3V
DRAM_DQM][0] PIN_R6 SDRAM byte Data Mask[0] 3.3V
DRAM_DQM]J1] PIN_T5 SDRAM byte Data Mask[1] 3.3V
DRAM_RAS_N PIN_L2 SDRAM Row Address Strobe 3.3V
DRAM_CAS_N PIN_LA1 SDRAM Column Address Strobe 3.3V
DRAM_CKE PIN_L7 SDRAM Clock Enable 3.3V
DRAM_CLK PIN_R4 SDRAM Clock 3.3V
DRAM_WE_N PIN_C2 SDRAM Write Enable 3.3V
DRAM_CS N PIN_P6 SDRAM Chip Select 3.3V

3.4 12C Serial EEPROM

The DEO-Nano contains a 2Kbit Electrically Erasable PROM (EEPROM). The EEPROM is
configured through a 2-wire I2C serial interface. The device is organized as one block of 256 x 8-bit
memory. The 12C write and read address are 0xAO and OxA1, respectively. Figure 3-7 illustrates its
connections with the Cyclone IV FPGA.

16
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Signal Name
12C_SCLK
12C_SDAT

/AVO[S RVAN,

FPGA Pin No.

PIN_F2
PIN_F1

EEPROM
vcc —O
I2C_SCLK scL A0 . A
I2C_SDAT Al —/"NV NV
- SDA  m2 b —AAN—
VSS
WP
Figure 3-7 Connections between FPGA and EEPROM
Table 3-5 Pin Assignments for I12C Serial EEPROM
Description I/O Standard
EEPROM clock 3.3V
EEPROM data 3.3V

VCC3P3

3.5 Expansion Headers

The DEO-Nano board provides two 40-pin expansion headers. Each header connects directly to 36
pins of the Cyclone IV E FPGA, and also provides DC +5V (VCCS5), DC +3.3V (VCC33), and two
GND pins. Figure 3-8 shows the 1/0 distribution of the GPIO connectors.

17
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GPIO-1
JP2

GPIO_0_INO GPIO_00 GPIO_1_INO 2  GPIO_10

GPIO_0_INT GPIO_01 GPIO_1_IN1 4 GPIO_11

GPIO_02 GPIO_03 GPIO_12 6 GPIO 13

GPIO_04 GPIO_05 GPIO_14 8 GPIO 15

GPIO_06 GPIO_07 GPIO_16 10 GPIO_17

1

vee_sysO GPIO_08 GPIO 09 vee_sysO GPIO 18 1 GPIO_19
GPIO_010 GPIO_011 GPIO_110 GPIO_111
GPIO_012 GPIO_013 GPIO_112 17 18 | GPIO_113
GPIO_014 GPIO_015 GPIO_114 19 20 | GPIO_115
GPIO 016 GPIO 017 GPIO 116 21 22 | GPIO 117
GPIO 018 GPIO 019 GPIO 118 23 24 | GPIO 119
GPIO_020 GPIO_021 GPIO_120 25 26 | GPIO_121
GPIO_022 GPIO_023 GPIO_122 28 | GPIO 123

29

veesPsO GPIO 024 | GPIO 025 VeesP3O GPIO 124 31 | GPIO 125
GPIO_026 GPIO_027 GPIO 126 33 34 | GPIO_127
GPIO 028 GPIO 029 GPIO 128 35 36 | GPIO 129
GPIO 030 GPIO 031 GPIO 130 37 38 | GPIO 131
GPIO 032 GPIO 033 GPIO 132 40 | GPIO 133

Figure 3-8 Pin arrangement of the GPIO expansion headers

The pictures below indicate the pin 1 location of the expansion headers.

he aaamesssnpesnsasm®e sl

A

AamADanmneeadnde @@ RH2E0

D0 HNano,

Figure 3-9 Pin1 locations of the GPIO expansion headers

Table 3-6 GPIO-0 Pin Assignments

Signal Name FPGA Pin No. Description I/O Standard
GPIO_0_INO PIN_AS8 GPIO Connection DATA 3.3V
GPIO_00 PIN_D3 GPIO Connection DATA 3.3v
GPIO_0_IN1 PIN_BS8 GPIO Connection DATA 3.3V
GPIO_01 PIN_C3 GPIO Connection DATA 3.3v
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GPIO_02 PIN_A2 GPIO Connection DATA 3.3V
GPIO_03 PIN_A3 GPIO Connection DATA 3.3V
GPIO_04 PIN_B3 GPIO Connection DATA 3.3V
GPIO_05 PIN_B4 GPIO Connection DATA 3.3V
GPIO_06 PIN_A4 GPIO Connection DATA 3.3V
GPIO_07 PIN_B5 GPIO Connection DATA 3.3V
GPIO_08 PIN_A5 GPIO Connection DATA 3.3V
GPIO_09 PIN_D5 GPIO Connection DATA 3.3v
GPIO_010 PIN_B6 GPIO Connection DATA 3.3v
GPIO_011 PIN_A6 GPIO Connection DATA 3.3V
GPIO_012 PIN_B7 GPIO Connection DATA 3.3v
GPIO_013 PIN_D6 GPIO Connection DATA 3.3V
GPIO_014 PIN_A7 GPIO Connection DATA 3.3v
GPIO_015 PIN_C6 GPIO Connection DATA 3.3V
GPIO_016 PIN_C8 GPIO Connection DATA 3.3V
GPIO_017 PIN_EG6 GPIO Connection DATA 3.3V
GPIO_018 PIN_E7 GPIO Connection DATA 3.3V
GPIO_019 PIN_D8 GPIO Connection DATA 3.3V
GPIO_020 PIN_ES8 GPIO Connection DATA 3.3V
GPIO_021 PIN_F8 GPIO Connection DATA 3.3V
GPIO_022 PIN_F9 GPIO Connection DATA 3.3V
GPIO_023 PIN_E9 GPIO Connection DATA 3.3V
GPIO_024 PIN_C9 GPIO Connection DATA 3.3v
GPIO_025 PIN_D9 GPIO Connection DATA 3.3V
GPIO_026 PIN_E11 GPIO Connection DATA 3.3V
GPIO_027 PIN_E10 GPIO Connection DATA 3.3V
GPIO_028 PIN_C11 GPIO Connection DATA 3.3V
GPIO_029 PIN_B11 GPIO Connection DATA 3.3V
GPIO_030 PIN_A12 GPIO Connection DATA 3.3V
GPIO_031 PIN_D11 GPIO Connection DATA 3.3V
GPIO_032 PIN_D12 GPIO Connection DATA 3.3V
GPIO 033 PIN_B12 GPIO Connection DATA 3.3v
Table 3-7 GPIO-1 Pin Assignments
Signal Name FPGA Pin No. Description I/O Standard
GPIO_1_INO PIN_T9 GPIO Connection DATA 3.3V
GPIO_10 PIN_F13 GPIO Connection DATA 3.3V
GPIO_1_IN1 PIN_R9 GPIO Connection DATA 3.3V
GPIO_11 PIN_T15 GPIO Connection DATA 3.3V
GPIO_12 PIN_T14 GPIO Connection DATA 3.3v
GPIO_13 PIN_T13 GPIO Connection DATA 3.3v
GPIO_14 PIN_R13 GPIO Connection DATA 3.3v
GPIO_15 PIN_T12 GPIO Connection DATA 3.3v

wwwwwwwwwww
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GPIO_16 PIN_R12 GPIO Connection DATA 3.3v
GPIO_17 PIN_T11 GPIO Connection DATA 3.3V
GPIO_18 PIN_T10 GPIO Connection DATA 3.3V
GPIO_19 PIN_R11 GPIO Connection DATA 3.3V
GPIO_110 PIN_P11 GPIO Connection DATA 3.3V
GPIO_111 PIN_R10 GPIO Connection DATA 3.3V
GPIO_112 PIN_N12 GPIO Connection DATA 3.3V
GPIO_113 PIN_P9 GPIO Connection DATA 3.3v
GPIO_114 PIN_N9 GPIO Connection DATA 3.3v
GPIO_115 PIN_N11 GPIO Connection DATA 3.3v
GPIO_116 PIN_L16 GPIO Connection DATA 3.3v
GPIO_117 PIN_K16 GPIO Connection DATA 3.3v
GPIO_118 PIN_R16 GPIO Connection DATA 3.3v
GPIO_119 PIN_L15 GPIO Connection DATA 3.3V
GPIO_120 PIN_P15 GPIO Connection DATA 3.3V
GPIO_121 PIN_P16 GPIO Connection DATA 3.3V
GPIO_122 PIN_R14 GPIO Connection DATA 3.3V
GPIO_123 PIN_N16 GPIO Connection DATA 3.3V
GPIO_124 PIN_N15 GPIO Connection DATA 3.3V
GPIO_125 PIN_P14 GPIO Connection DATA 3.3v
GPIO_126 PIN_L14 GPIO Connection DATA 3.3v
GPIO_127 PIN_N14 GPIO Connection DATA 3.3v
GPIO_128 PIN_M10 GPIO Connection DATA 3.3v
GPIO_129 PIN_L13 GPIO Connection DATA 3.3v
GPIO_130 PIN_J16 GPIO Connection DATA 3.3v
GPIO_131 PIN_K15 GPIO Connection DATA 3.3V
GPIO_132 PIN_J13 GPIO Connection DATA 3.3V
GPIO_133 PIN_J14 GPIO Connection DATA 3.3V

3.6 A/D Converter and 2x13 Header

The DEO-Nano contains an ADCI128S022 lower power, eight-channel CMOS 12-bit
analog-to-digital converter. This A-to-D provides conversion throughput rates of 50 ksps to 200
ksps. It can be configured to accept up to eight input signals at inputs INO through IN7. This eight
input signals are connected to the 2x13 header, as shown in Figure 3-10. The remaining I/Os of the
2x13 header are a DC +3.3V (VCC33), a GND and 13 pins, which are connect directly to the
Cyclone IV E device.

For more detailed information on the A/D converter chip, please refer to its datasheet which is
available on manufacturer’s website or under the /datasheet folder of the system CD.
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2X13 HEADER

Figure 3-10 Pin distribution of the 2x13 Header

Figure 3-11 shows the connections on the 2x13 header, A/D converter and Cyclone IV device.

P GPIO_2[12..0] =
GPIO_2_IN[2..0] _
/AYO[S RYA)
2X13 Header \
INO Cyclone,@lv
IN1
i3 5. 1 be ADC_CS_N
ADC_SADDR
IN3 DIN f¢——= . T
ADC_SDAT
Analog_In[7 0= . PouT )
nalog_In[7..0] ADC_SCLK
IN5 SCLK 1
IN6
IN7

ADC1285022CIMTX

Figure 3-11 Wiring for 2x13 header and A/D converter

The pictures below indicate the pin 1 location of the 2x13 header.
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Figure 3-12 Pin1 locations of the 2x13 header

Table 3-8 Pin Assignments for 2x13 Header

Signal Name FPGA Pin No. Description I/O Standard
GPIO_2[0] PIN_A14 GPIO Connection DATA[O0] 3.3V
GPIO_2[1] PIN_B16 GPIO Connection DATA[1] 3.3V
GPIO_2[2] PIN_C14 GPIO Connection DATA[2] 3.3V
GPIO_2[3] PIN_C16 GPIO Connection DATA[3] 3.3V
GPIO_2[4] PIN_C15 GPIO Connection DATA[4] 3.3V
GPIO_2[5] PIN_D16 GPIO Connection DATA[5] 3.3V
GPIO_2[6] PIN_D15 GPIO Connection DATA[6] 3.3V
GPIO_2[7] PIN_D14 GPIO Connection DATA[7] 3.3V
GPIO_2[8] PIN_F15 GPIO Connection DATA[8] 3.3V
GPIO_2[9] PIN_F16 GPIO Connection DATA[9] 3.3V
GPIO_2[10] PIN_F14 GPIO Connection DATA[10] 3.3V
GPIO_2[11] PIN_G16 GPIO Connection DATA[11] 3.3V
GPIO_2[12] PIN_G15 GPIO Connection DATA[12] 3.3V
GPIO_2_IN[0] PIN_E15 GPIO Input 3.3V
GPIO_2_IN[1] PIN_E16 GPIO Input 3.3V
GPIO_2_IN[2] PIN_M16 GPIO Input 3.3V

Table 3-9 Pin Assignments for ADC

Signal Name FPGA Pin No. Description I/O Standard
ADC_CS N PIN_A10 Chip select 3.3V
ADC_SADDR PIN_B10 Digital data input 3.3V
ADC_SDAT PIN_A9 Digital data output 3.3V
ADC_SCLK PIN_B14 Digital clock input 3.3V
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3.7 Digital Accelerometer

The ADXL345 is a small, thin, ultralow power, 3-axis accelerometer with high resolution
measurement. This digital accelerometer can be accessed through a SPI 3-wire digital interface or
12C 2-wire digital interface. Main applications include medical instrumentation, industrial
instrumentation, personal electronic aid and hard disk drive protection etc. Some of the key features
of this device are listed below. For more detailed information, please refer to its datasheet which is
available on manufacturer’s website or under the /datasheet folder of the system CD.

e Up to 13-bit resolution at +/- 16g
e SPI(3- wire) or I2C (2-wire) digital interface

e Flexible interrupts modes

Figure 3-13 shows the connections between the ADXL345 and the Cyclone IV E device.

VeLaPy ADXL345
12C_SCLK 1 N——
MR SDA_SDI_SDIO
/ANO[S RYA\ A/\—— SDO_ALT_ADDRESS

G_SENSOR_CS_N

A\ 4

CS_n

ENSOR_INT
G SENSOR, INT1

He—AN—INT2

A

Figure 3-13 Wiring between the ADXL345 and the Cyclone IV E device

Table 3-10 Pin Assignments for Digital Accelerometer

Signal Name FPGA Pin No. Description I/O Standard
12C_SCLK PIN_F2 EEPROM clock 3.3V
12C_SDAT PIN_F1 EEPROM data 3.3V
G_SENSOR_INT PIN_M2 G_Sensor Interrupt 3.3v
G_SENSOR _CS N PIN_G5 G_Sensor chip select 3.3v

3.8 Clock Circuitry

The DEO-Nano board includes a 50 MHz oscillator. The oscillator is connected directly to a
dedicated clock input pin of the Cyclone IV E FPGA. The S0MHz clock input can be used as a
source clock to drive the phase lock loops (PLL) circuit. The clock distribution on the DEO-Nano
board is shown in Figure 3-14.
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Figure 3-14 Block diagram of the clock distribution

3.9 Power Supply

The DEO-Nano board’s power is provided through the USB 5V power, the 5V VCC pins on the two
40-pin headers or the 2-pin power header. The DC voltage is then stepped down to various required
voltages. For portable project applications, connect a battery power supply (3.6~5.7V) to the 2-pin
external power header shown in Figure 3-15.

&
R4y S'ElF-l
‘ O'EEJ Y2 24MH: LEOTLEDSLEDSLEDA LEDILEDZ LEDILEDD e
— 2 BENEE g
& — s - (- i
i | .
L 1iiHe
-

AL N AN N »

r

3TT3
SW[3:.0]
R 1" BEEYe w1
s e

C- - SSRGS 4

¥
ol
N
s |
|
.o

Figure 3-15 Portable Battery Connection
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B Power Distribution System

Figure 3-16 shows the power distribution system on the DEO-Nano board.
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5V power pins
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il USB 5V P 05;/A — On two 40-pin
ower ]
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N J
5V VCC pins on two 40-pin
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\s Y, 0.025A —» FT245BL
N .
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5 \J 002A —> - % 24LC02B
Regulator
3.3V VCCIO
LP385005D-ADJ
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i ’—l 33V e /| vDD &VvDDQ
0.292A —» 2 N SDRAM
3.3V VCCINT & VCCIO
01A —» MAX || EPM240
3.3V s “ | ADXL345 &
0.00014A —» - N VDDIO
3.3V power
3.3V pins
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-
a R
Regulator W VCCINT
LP385005D-ADJ 1.2V o
(Max. 1.5A output)J 0654A —> EP4CE22
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Figure 3-16 DEO0-Nano Power Distribution System
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Chapter 4
DEO-Nano Control Panel

The DEO-Nano board comes with a Control Panel facility that allows users to access various
components on the board from a host computer. The host computer communicates with the board
through a USB connection. The facility can be used to verify the functionality of components on the
board or be used as a debug tool while developing RTL code.

This chapter first presents some basic functions of the Control Panel, then describes its structure in
block diagram form, and finally describes its capabilities.

4.1 Control Panel Setup

The Control Panel Software Utility is located in the directory “tools/DEO_NANO_ControlPanel” in
the DE0-Nano System CD. It's free of installation, just copy the whole folder to your host computer
and launch the control panel by executing the “DE0_NANO_ControlPanel.exe”.

When Control Panel starts it will attempt to download a configuration file onto the DEO-Nano board.
The configuration file contains a design that communicates with the peripheral devices on the board
that are attached to the FPGA device. Perform the following steps to ensure that the control panel
starts up successfully:

1. Make sure Quartus II 10.0 or later version is installed successfully on your PC.
2. Connect a USB A to Mini-B cable to a USB (Type A) host port and to the board.

3. Start the executable DEO_NANO_ControlPanel.exe on the host computer. The Control Panel
user interface shown in Figure 4-1 will appear.

5. The DEO_NANO_ControlPanel.sof bit stream is loaded automatically as soon as the
DEO_NANO_ControlPanel.exe is launched.

6. In case the connection is disconnected, click on CONNECT where the .sof will be re-loaded
onto the board.

Note: the Control Panel will occupy the USB port until you choose to close the program or
disconnect it from the board by clicking the Disconnect button. While the Control Panel is
connected to the board, you will be unable to use Quartus Il to download a configuration file into
the FPGA.
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8. The Control Panel is now ready for use; experience it by setting the ON/OFF status for some
LEDs and observing the result on the DEO-Nano board.

Eaca

Figure 4-1 The DEO-Nano Control Panel

The concept of the DEO-Nano Control Panel is illustrated in Figure 4-2. The “Control Circuit” that
performs the control functions is implemented in the FPGA board. It communicates with the
Control Panel window, which is active on the host computer, via the USB Blaster link. The
graphical interface is used to issue commands to the control circuit. It handles all requests and
performs data transfers between the computer and the DEO-Nano board.

+—> Accelerometer

G ADC
USB Blaster _ | Control

Circuit
— Button/ Switch
e 4 SDRAM/ EEPROM/ EPCS

Figure 4-2 The DEO-Nano Control Panel concept
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The DEO-Nano Control Panel can be used to light up LEDs, change the buttons/switches status,
read/write to SDRAM Memory, read ADC channels, and display the Accelerometer information.

4.2 Controlling the LEDs

A simple function of the Control Panel is to allow setting the values displayed on LEDs. Choosing
the LED tab displays the window in Figure 4-3. Here, you can directly turn the LEDs on or off
individually or by clicking “Light All” or “Unlight All”.

Figure 4-3 Controlling LEDs

4.3 Switches and Pushbuttons

Choosing the Switches tab displays the window in Figure 4-4. The function is designed to monitor
the status of slide switches and pushbuttons in real time and show the status in a graphical user
interface. It can be used to verify the functionality of the slide switches and pushbuttons.
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Memory

Figure 4-4 Monitoring switches and buttons

The ability to check the status of pushbutton and slider switches is not needed in typical design
activities. However, it provides a simple mechanism for verifying if the buttons and switches are
functioning correctly. Thus, it can be used for troubleshooting purposes.

4.4 Memory Controller

The Control Panel can be used to write/read data to/from the SDRAM/EEPROM/EPCS on the
DEO-Nano board. As an example, we will describe how the SDRAM may be accessed; the same
approach is used to access the EEPROM and EPCS. Click on the Memory tab and select “SDRAM”
to reach the window in Figure 4-5.
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Figure 4-5 Accessing the SDRAM

A 16-bit word can be written into the SDRAM by entering the address of the desired location,
specifying the data to be written, and pressing the Write button. Contents of the location can be read
by pressing the Read button. Figure 4-5 depicts the result of writing the hexadecimal value 06CA
into offset address 200, followed by reading the same location.

The Sequential Write function of the Control Panel is used to write the contents of a file into the
SDRAM as follows:
1. Specify the starting address in the Address box.

2. Specity the number of bytes to be written in the Length box. If the entire file is to be loaded,
then a checkmark may be placed in the File Length box instead of giving the number of bytes.

3. To initiate the writing process, click on the Write a File to Memory button.

4.  When the Control Panel responds with the standard Windows dialog box asking for the source
file, specify the desired file in the usual manner.

The Control Panel also supports loading files with a .hex extension. Files with a .hex extension are
ASCII text files that specify memory values using ASCII characters to represent hexadecimal
values. For example, a file containing the line

0123456789 ABCDEF

defines eight 8-bit values: 01, 23, 45, 67, 89, AB, CD, EF. These values will be loaded
consecutively into the memory.

The Sequential Read function is used to read the contents of the SDRAM and fill them into a file as
follows:
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1. Specify the starting address in the Address box.

2. Specify the number of bytes to be copied into the file in the Length box. If the entire contents
of the SDRAM are to be copied (which involves all 32 Mbytes), then place a checkmark in the
Entire Memory box.

3. Press Load Memory Content to a File button.

4. When the Control Panel responds with the standard Windows dialog box asking for the
destination file, specify the desired file in the usual manner.

Users can use the similar way to access the EEPROM and EPCS. Please note that users need to
erase the EPCS before writing data to it.

4.5 Digital Accelerometer

The Control Panel can be used to display the status of the Digital Accelerometer where it measures
the output of its 3-axis (X, Y, Z). The measurement range and resolution is set to default value +2g
(acceleration of gravity) and 10bit twos complement respectively. Figure 4-6 shows the current
digital accelerometer status of the DEO-Nano when Accelerometer tab is clicked. The units that are
displayed are the raw register values converted to decimal. The value in parentheses is the
gravitational acceleration values (mg) calculated from the register values according the formula.
Table 4-1 shows the rule.

Table 4-1 acceleration values convert rule

Register Value *Formula Result (mg)
0 0/511*2 0

1 1/511*2 3.9

2 2/511*2 6.8

17 17/511*2 66.4

511 511/511*2 2000
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17 (66.4mg)
24 (93.8mg)
229 (894.5mg)

Figure 4-6 Digital Accelerometer status

4.6 ADC

From the Control Panel, users are able to view the eight-channel 12-bit analog-to-digital converter
reading. The values shown are the ADC register outputs from all of the eight separate channels. The
voltage shown is the voltage reading from the separate pins on the extension header. Figure 4-7
shows the ADC readings when the ADC tab is chosen.

Figure 4-7 ADC Readings
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4.7 Overall Structure of the DEO-Nano Control Panel

The DEO-Nano Control Panel is based on a Nios II SOPC system instantiated in the Cyclone IV E
FPGA with software running on the on-chip memory. The software part is implemented in C code;
the hardware part is implemented in Verilog HDL code with SOPC builder. The source code is not
available on the DEO-Nano System CD.

To run the Control Panel, users should make the configuration according to Section 4.1. Figure 4-8
depicts the structure of the Control Panel. Each input/output device is controlled by the Nios II
Processor instantiated in the FPGA chip. The communication with the PC is done via the USB

Blaster link. The Nios II interprets the commands sent from the PC and performs the corresponding
actions.

FPGA/ SOPC

ADC

JTAG Blaster
Hardware

Accelerometer

LED/ Button/ Switch

SDRAM

EEPROM

olqe 4 }08UU0oIBIU| WS)SAS

EPCS

Figure 4-8 The block diagram of the DE0O-Nano Control Panel
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Chapter 5
DEO-Nano System Builder

This chapter describes how users can create a custom design project on the DEO-Nano board by
using DEO-Nano Tool — DEO-Nano System Builder.

5.1 Introduction

The DEO-Nano System Builder is a Windows based software utility, designed to assist users in
creating a Quartus II project for the DEO-Nano board within minutes. The generated Quartus II
project files include:

Quartus II Project File (.qpf)

Quartus II Setting File (.qsf)
Top-Level Design File (.v)

Synopsys Design Constraints file (.sdc)
Pin Assignment Document (.htm)

By providing the above files, DEO-Nano System Builder helps to prevents occurrence of situations
that are prone to errors when users manually edit the top-level design file or place pin assignments.
The common mistakes that users encounter are the following:

1. Board damaged for wrong pin/bank voltage assignments.

2. Board malfunction caused by wrong device connections or missing pin counts for connected
ends.

3. Performance degeneration because of improper pin assignments.

5.2 General Design Flow

This section will introduce the general design flow to build a project for the DEO-Nano board via
the DEO-Nano System Builder. The general design flow is illustrated in Figure 5-1.

To create a new system using the DEO-Nano System Builder, begin by launching the DEO-Nano
System Builder software. The software will then prompt you to specify the name of the project you
wish to create, as well as the components on the DEO-Nano board you wish to you. Once your
specification is complete, you can generate the system.
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The generated system is described using several files. In particular, there is the project file (.qpf),
the top-level Verilog wrapper file (.v) that describes the I/O pins you will use in your design, and
the Quartus II settings file (.gsf) that specifies which pin on the FPGA each I/O in your design
should connect to. A Synopsys Design Constraints (.sdc) file with timing constraints and an HTML
file with pin descriptions will be generated as well.

To proceed with your design, open the Quartus II CAD software and open your newly-created
project. You will now be able to implement the logic of your design by describing your design in a
hardware description language, and connecting it to I/Os in the top-level wrapper file. Once your
design is complete, compile the design using Quartus II, and then use the Quartus II Programmer
tool to configure the FPGA on the DEO-Nano board, using the JTAG programming mode.

Start

' I

Launch DEO-Nano
System Builder

!

Launch Quartus Il
and Open Project

!

Create New
DEO-Nano System Builder Add User Design/ Logic
Project
Generate

Quartus Il Project
and Document

!

Compile to generate.SOF

!

.QPF HTM
.QSF .SDC Configure FPGA
V

!

End

Figure 5-1 The general design flow of building a design
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5.3 Using DEO-Nano System Builder

This section provides the detailed procedures on how the to use the DEO-Nano System Builder.

B Install and launch the DE(O-Nano System Builder

The DEO-Nano System Builder is located in the directory: "Tools\DEO_NANO_SystemBuilder" on
the DEO-Nano System CD. Users can copy the whole folder to a host computer without installing
the utility. Launch the DEO-Nano System Builder by executing the DEO_NANO_SystemBuilder.exe
on the host computer and the GUI window will appear as shown in Figure 5-2.

Terasic DEO-Nano System Builder ¥1.0.0 O X
System Configuration

UNIVERSITY Project Name:
LINIVERSITY |l e TG
DEO-Nano FPGA Board CLOCK LED X8
B Button x 2 Dip Switch x 4

VI SDRAM, 32MB MaADC
¥l EEPROM, 2Kb M EPCS
Accelerometer 2x13 Pin Header

GPIO-0 Header
None

| [

Prefix Name: ]

GPIO-1 Header
Generate l None v

[ Load Setting

I l Prefix N
refix Name:
[ Save Setting l t Exit J SIREMS: |

Figure 5-2 The DEO-Nano System Builder window

B Input Project Name

Input project name as show in Figure 5-3.

Project Name: Type in an appropriate name here, it will automatically be assigned as the name of
your top-level design entity.
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Terasic DEO-Nano System Builder ¥1.0.0

= System Configuration
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UNIVERSITY Project Nam.e:

B &

PROGRAM Wwwterasic.com

ﬂDEO_NANo

CLOCK

Button x 2
SDRAM, 32MB
EEPROM, 2Kb
M Accelerometer

GPIO-0 Header

LEDx 8

Dip Switch x 4
ADC

EPCS

2x13 Pin Header

iNone

Prefix Name: ‘

GPIO-1 Header
|None

[ Load Setting

Generate l

|
|

[ Save Setting Exit

Prefix Name: ‘ '

Figure 5-3 The DEO-Nano Board Type and Project Name

B System Configuration

Under System Configuration users are given the flexibility of enabling their choice of included
components on the DEO-Nano as shown in Figure 5-4. Each component of the DEO-Nano is listed
where users can enable or disable a component according to their design by simply marking a check
or removing the check in the field provided. If the component is enabled, the DEO-Nano System

Builder will automatically generate the associated pin assignments
location, pin direction, and I/O standard.

including the pin name, pin

Terasic DEO-Nano System Builder ¥1.0.0 e X
System Configuration

AIERA .

AR

PROGRAM ‘DEO_NANO

DEO-Nano FPGA Board CLOCK LEDx 8

o Buttonx 2 Dip Switch x 4

I SDRAM, 32MB MADC
[ EEPROM, 2Kb M EPCS

Accelerometer

2%13 Pin Header

GPI0-0 Header

None

Prefix Name:

GPIO-1 Header

‘None

l Load Setting [ Generate l

|
[ Save Setting ] | Exit

Prefix Name: ‘

Figure 5-4 System Configuration Group

B GPIO Expansion
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Users can connect GPIO expansion card onto GPIO header located on the DEO-Nano board as
shown in Figure 5-5. Select the appropriate daughter card you wish to include in your design from
the drop-down menu. The system builder will automatically generate the associated pin assignments
including the pin name, pin location, pin direction, and IO standard.

If a customized daughter board is used, users can select “GPIO Default” followed by changing the
pin name and pin direction according to the specification of the customized daughter board.

Terasic DEO-Nano System Builder ¥1.0.0 E]E] @
System Configuration
ALIERAY .
UNIVERSITY wmm — Project Name:
Frecmam DEO_NANO
DEO-Nano FPGA Board CLOCK LEDx8
| . Button x 2 Dip Switch x 4

¥ SDRAM, 32MB MADC
[¥] EEPROM, 2Kb M EPCS
Accelerometer 2%13 Pin Header

GPIO-0 Header

apaspsesassonssseonsonss '77":\
Prefix Name: | ‘

GPIO-1 Header
[ Load Setling l [ Generate ] :None 7;
[ Save Setting ‘ [ Exit l Prefix Name: |

Figure 5-5 GPIO Expansion Group

The “Prefix Name” is an optional feature which denotes the prefix pin name of the daughter card
assigned in your design. Users may leave this field empty.

B Project Setting Management

The DEO-Nano System Builder also provides functions to restore default setting, loading a setting,
and saving users’ board configuration file shown in Figure 5-6. Users can save the current board
configuration information into a .cfg file and load it to the DEO-Nano System Builder.
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Terasic DEO-Nano System Builder ¥1.0.0 Cfe X
System Configuration

ABERA 7 .
UNIVERSITY Mra, o Project Name:
PROGRAM ‘DEO_NANO
DEO-Nano FPGA Board cLOCK LEDxS8
Button x 2 Dip Switch x 4

M SDRAM, 32MB MADC
[¥] EEPROM, 2Kb M EPCS
Accelerometer 2%13 Pin Header

Prefix Name: N g

GPIO-1 Header

l Load Setting ‘ l Generate l ‘None v
Prefix Name: ‘—

[ Save Setting ] [ Exit

Figure 5-6 Project Settings

B Project Generation

When users press the Generate button, the DEO-Nano System Builder will generate the
corresponding Quartus II files and documents as listed in the Table 5-1:

Table 5-1 The files generated by DE(O-Nano System Builder

No. | Filename Description

1 <Project names.v Top level Verilog HDL file for Quartus I

2 <Project name>.qpf Quartus Il Project File

3 <Project names.qsf Quartus Il Setting File

4 <Project name>.sdc Synopsys Design Constraints file for Quartus Il
5 <Project name>.htm Pin Assighment Document

Users can use Quartus II software to add custom logic into the project and compile the project to
generate the SRAM Object File (.sof).
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Chapter 6

Tutorial: Creating an FPGA Project

This tutorial provides comprehensive information for understanding how to create a FPGA design
and run it on the DEO-Nano development and education board. The following sections provide a
quick overview of the design flow, explaining what is needed to get started, and describe what is
taught in this tutorial.

6.1 Design Flow

Figure 6-1shows a block diagram of the FPGA design flow.

The first step in the FPGA design flow starts is design entry. The standard design entry methods are
using schematics or a hardware description language (HDL), such as Verilog HDL or VHDL. The
design entry step is where the designer creates the digital circuit to be implemented inside the
FPGA. The flow then proceeds through compilation, simulation, programming, and verification in
the FPGA hardware.

Dgsii_n — 5 Compile ——»| Simulatt —» Pﬁ m — H?ifdwl ia_'e

|

This tutorial describes all of the steps except for simulation. Although it is not covered in this
document, simulation is very important to learn. There are two types of simulation, Functional and
Timing Functional simulation allows you to verify that your hardware is performing the desired
functionality. Timing (or post place-and-route) simulation verifies that the design meets timing and
functions appropriately in the device. Simulation tutorials can be found on the Altera University
Program website at http://university.altera.com.

Figure 6-1 Design Flow
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6.2 Before You Begin

This tutorial assumes the following prerequisites

B You have a general understanding of FPGAs. This tutorial does not explain the basic concepts
of programmable logic.

B You are somewhat familiar with digital circuit design and electronic design automation (EDA)
tools.

B You have installed the Altera Quartus II 10.1 software on your computer. If you do not have the
Quartus II software, you can download it from the Altera web site at www.altera.com/download.

B You have a DEO-Nano Development Board on which you will test your project. Using a
development board helps you to verify whether your design is really working.

B You have gone through the quick start guide and/or the getting started user guide for your
development kit. These documents ensure that you have:

e Installed the required software.
e Determined that the development board functions properly and is connected to your computer.

Next step is to install the USB-Blaster driver, if not already done. To install the driver, connect a
USB cable between the DEO-Nano board and a USB port on a computer that is running the Quartus
II software.

The computer will recognize the new hardware connected to its USB port, but it will be unable to
proceed if it does not have the required driver already installed. If the USB-Blaster driver is not
already installed, the New Hardware Wizard in Figure 6-2 will appear.
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Welcome to the Found New
Hardware Wizard

Windows will search for current and updated software by
looking on your computer, on the hardware installation CD, or on
the Windows Update Web site [with your permission).

Read our privacy policy

Can Windows connect to Windows Update to search for
software?

O Yes, this time only
(O Yes, now and every time | connect a device
() No, not this time

Click Next to continue.

[ Next > ][ Cancel ]

Figure 6-2 Found New Hardware Wizard

The desired driver is not available on the Windows Update Web site, therefore select “No, not this
time” and click Next. This leads to the window in Figure 6-3.

Hardware Update Wizard

Welcome to the Hardware Update
Wizard

Thiz wizard helps pau install software far:

|1SB-Blaster

\) If your hardware came with an installation CD
‘-‘.{ﬁh or floppy dizk, insert it now.

“what do you want the wizard to do’?

) Install the software automatically [Fecommended)
() Inztall fram a list or specific location [Advanced)

Click Mexst to continue.

[ Mewt = ][ Cancel

Figure 6-3 The driver is found in a specific location
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The driver is available within the Quartus II software. Hence, select “Install from a list or specific
location” and click Next to get to Figure 6-4.

Found Mew Hardware Wizard

Pleasze choose your zearch and inztallation options.

(%) Search for the best driver in these locations.,

Uz the check bares belaw ta limit or expand the default search, which includes lacal
pathz and removable media. The best diver found will be inzstalled.

Search removable media [loppy, CD-ROM. )

Include this location in the gearch:
C:Aakkerat 10,1 hquartuzhdrivershuzb-blaster w

() Don't zearch. | will choose the driver ta install

Choosge thiz option to zelect the device driver from a lizt. Windows does not guarantee that
the driver vau chaoose will be the best match far paur hardware.

[ < Back ” Mest » l[ Cancel

Figure 6-4 Specify the location of the driver

Now, select “Search for the best driver in these locations” and click Browse to get to the pop-up
dialog box in Figure 6-5 Find the desired driver, which is at location
C:\altera\10.1\quartus\drivers\usb-blaster. Click OK and then upon returning to Figure 6-4 click
Next. At this point the installation will commence, but a dialog box in Figure 6-6 will appear
indicating that the driver has not passed the Windows Logo testing. Click Continue Anyway.
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Browse For, Folder

Select the Folder that contains drivers Faor your hardware,

=I5 101 -
I installer
= ip
=) nioszeds
= 15 quartus
I bim
I binge
I comman
IS0 cusp
= I drivers
I 386
I sentinel
EREY sb-blaster
[
I w64
I dsp_builder
F 7= eda X

To view any subfaolders, click a plus sign abowve.,

[ Ok, l [ Cancel

Figure 6-5 Browse to find the location

Hardware Installation

L] "_\ The zoftware pou are installing for this hardware:
[ ]
Altera LISE-Blazter

has not paszed Windows Logao kesting ta werify ite compatibility
with "Windows =P, [Tell me why this testing is imporkank. |

Continuing your installation of thiz software may impair
or destabilize the correct operation of your spstem
either immediately or in the future. Microzoft strongly
recommends that you stop thiz installation now and
contact the hardware vendor for zoftware that has
pazzed Windows Logo testing.

Continue Anyaay ] [ STOPR Installation

Figure 6-6 There is no need to test the driver
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The driver will now be installed as indicated in Figure 6-7. Click Finish and you can start using the
DEO-Nano board.

Found Hew Hardware Wizard

Completing the Found New
Hardware Wizard

The wizard hasz finizhed instaling the saftware for:

% Altera USE-Blaster

Click Finizh to cloze the wizard.

Figure 6-7 The driver is installed

6.3 What You Will Learn

In this tutorial you will perform the following tasks:

Create a design that causes LEDs on the development board to blink at two distinct rates. This
design is easy to create and gives you visual feedback that the design works. Of course, you can use
your DEO-Nano board to run other designs as well. For the LED design, you will write Verilog HDL
code for a simple 32-bit counter, add a phase-locked loop (PLL) megafunction as the clock source,
and add a 2-input multiplexer megafunction. When the design is running on the board, you can
press an input switch to multiplex the counter bits that drive the output LEDs.

6.4 Assign The Device

Begin this tutorial by creating a new Quartus II project. A project is a set of files that maintain
information about your FPGA design. The Quartus II Settings File (.qsf) and Quartus II Project File
(.gpf) files are the primary files in a Quartus II project. To compile a design or make pin
assignments, you must first create a project. The steps used to create a project are:
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1. In the Quartus II software, select File > New Project Wizard. The Introduction page opens, as
shown in Figure 6-8.

4 New Project Wizard

Introduction

The MNew Project Wizard helps you create a new project and preliminary project settings, incuding the following:

Project name and directory

Mame of the topdevel design entity
Project files and libraries

Target device family and device
EDA tool settings

‘fou can change the settings for an existing project and specify additional project-wide settings with the Settings command (Assignments menu). You can use
the various pages of the Settings dialog box to add functionality to the project.

LE R R R J

[]:Don't show me this introduction again ;

< Back Einish Cancel ] [ Help

Figure 6-8 New Project Wizard introduction

2. Click Next.

3. Enter the following information about your project: (Note: File names, project names, and
directories in the Quartus II software cannot contain spaces.)

a. What is the working directory for this project? Enter a directory in which you will store your
Quartus II project files for this design. For example, E:\My_design\my_first_fpga.

b. What is the name of this project? Type my_first_fpga.

c.  What is the name of the top-level design entity for this project? Type my_first_fpga. See
Figure 6-9.
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! New Project Wizard

Directory, Name, Top-Level Entity [page 1 of 5]

What is the working directory far this project?

| E:\y_designimy_first_fpga |E]
What is the name of this project?

| my_first_fpga |E]
What is the name of the top-level design entity For this project? This name is case sensitive and must exactly match the entity name in the design file.

| my_first_fpga |E]

[Use Existing Project Settings. ..

[ < Back ]L Pt = J[ Finish H Caniel H Help

Figure 6-9 Project information

d. Click Next.

e. In the next dialog box, you will assign a specific FPGA device to the design. Select the
EP4CE22F17C6 device, as it is the FPGA on the DEO-Nano, as shown in Figure 6-10.
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¥ New Project Wizard

Family & Device Settings [page 3 of 5]

Select the family and device you want to target for compilation.

Device family Show in 'Available devices' list
Eamily: !Cydone IVE "I Package: !Any V|
Devices: |All | Pin count: IAny v|
Target device Speed grade: |Aﬂy ¥
(O Auto device selected by the Fitter Show advanced devices
(%) Specific device selected in 'Available devices' list HardCopy compatible anly
Other: nfa

Available devices:

Name Core Voltage LEs User I/0s HMemory Bits Embedded multiplier 9-bit elements PLL ™
EP4CEZZEZ2TT 1.2V 22320 80 6082586 132 G 20
EP4CE22E2218L | 1.0V 22320 80 608256 132 4 20
EP4CE22F17A7 | 1.2V 22320 154 1608255 132 4 20

| EpaceazFi7ce 154 132 4 o)
EP4CE22F17C7 1.2V 22320 154 608256 132 % 0
EP4CE2IF17CE 1.2y 22320 154 608258 132 4 20
EP4CEZ22F17C3L 1.0V 22320 154 608256 132 4 20 o

: =
Caompanion device
HardCopy: |
Limit D5P &RAM to HardCopy device resources
[ < Back ] [ Mext = ] [ Einish ] ’ Cancel ] [ Help ]

Figure 6-10 Specify the Device Example

f.  Click Finish.

4.  When prompted, select Yes to create the my_first fpga project directory. You just created your
Quartus IT FPGA project. Your project is now open in Quartus II, as shown in Figure 6-11.
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¥ Quartuzs II — E:/By desien/my first fpga/my first fpga — my first fpea
FEile Edit View Project Assignments Processing Tools  Window  Help

DEEHD S BB o s VY /EVG TP 0D OV AL e
Project Mavigator & x|
- IN\IERA
& Cydone s acep e = .
* my_first_fpga Eﬁﬂ
QUARTUS II Q
2] 1l | &*
Hierarchy | Files ” ¥ Designdi b
Tasks 8 x| /E = nYA
Flow: |comﬂaﬁon "| [Cusmmize... ] = Ia
Task il

& P Compile Design
| B P Analysis BSynthesis
| G P Fitter (Place &Route)
@ W Assembler (Generate pi
- @ P TimeQuestTiming Analy —
H B EDANeflistWriter

a— a4 AR e

Type Message

QUARTUSII C

) View Quartus Il
Information

E \ system /\_Processing /\ ExtraInfo /\ Info /\ Warning /\_Critical Warning /\_ Error /\ Suppressed /\ Flag /

o - 4

EHMessage: ‘B | 9 |Locati0n: Locate

| 0% 00:00:00 .:

Figure 6-11 my_first_fpga project

6.5 Creating an FPGA design

This section describes how to create an FPGA design. This includes creating the top-level design,
adding components (in Verilog HDL and using the megafunctions), adding pins and interconnecting
all the components and pins.

First, create a top-level module. In this tutorial, you will use schematic entry, via a Block Design
File (.bdf). Alternatively, you could use Verilog HDL or VHDL for the top-level module. The
following steps describe how to create the top-level schematic.

1. Select File > New > Block Diagram/Schematic File (see Figure 6-12 to create a new file,
Block1.bdf, which you will save as the top-level design.

49
t‘"m Terasic DEO-Nano User Manual www.terasic.com

Www. Lerasic. com,




2. Click OK.

Mew Quartus II Project
SOPC Builder System
[=} Design Files
AHOL File
Blodk Diagram/Schematic File
EDIF File
Qsys System File
State Machine File
SystemVerilog HDL File
Td Script File
VHDL File
Verilog HOL File
[=} Memary Files
Hexadedmal (Intel-Format) File
Memory Initialization File
[= Verification/Debugging Files

In-System Sources and Probes File

Logic Analyzer Interface File

SignalTap II Logic Analyzer File
= Other Files

AHDL Indude File

Block Symbal File

Chain Description File

Synopsys Design Constraints File

Text File

[ Ok H Cancel ][

Help

Figure 6-12 New BDF

3. Select File > Save As and enter the following information.

e File name: my_first_fpga

e Save as type: Block Diagram/Schematic File (*.bdf)

4. Click Save. The new design file appears in the Block Editor (see Figure 6-13).
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o
File Edit View Project Assignments FProcessing Tools Window Help

DSHE@ S % D@ 2 o |i[ny st ose XY s 2RS TrY D O Y 2A 0~
Project Navigator ax| 1 my_frst_fpga bef 8| - _
Eatity BRAOADL-O07172NNNO0 N > H5age

Cyclone IV E: EP4CE22F17CE
- my first fpga eﬁil

£ | *

Hierarchl,r | Files " o Designd) b

Tasks & x|

T 1
Flaw: iCompiIation V| [Cusmmize... ]

Task A:
= P Compile Design
e Analysis & Synthesis
i P Fitter (Place & Route)
[+ #  Assembler (Generate pi
i W TimeQuest Timing Analy —
;:«a P EDANetistWriter

< | 2/

| Tvpe| Message

o x|

%E'\ System /\_Processing [\ ExtraInfo /\ Info /\_Warning /\_Critical Warning /\_Error /\ Suppressed /\ Flag /
%_@]MESS«EQE: 4+ & |Lc-catic|n: Locate
538, 218 | 0% 00:00:00
Figure 6-13 Bank BDF
B Adding a Verilog HDL to the Schematic
1. Add HDL code to the blank block diagram by choosing File > New > Verilog HDL File.
2. Select Verilog HDL File in the tree and Click OK.
3. Save the newly created file, by selecting File > Save As and entering the following information
(see Figure 6-14).

e File name: simple_counter.v
e Save as type: Verilog HDL File (*.v, *.vlg, *.verilog)

Terasic DEO-Nano User Manual
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Save fs

Sawve in: ||;i' my_first_fpga j I:j( T

1 IChdb
Lﬁ" [Charevbox_tmp

My Recent IChincremental_db

Documents counter_bus_mu v
@ counter_bus_mux_bb,y
pll.w
Desktop pll_bb,v
. simple_counter v

7

ty Documents

My Computer
My Metwark  File name: |$imp|e_|:l:nunter.v ﬂ \il

Placez
Save as type: |"-.-"E[i|l:|g| HOL Files [*.w * vlg ™ verlog) j m

[v Add file to current project

Figure 6-14 Saving the Verilog HDL file
The resulting empty file is ready for you to enter the Verilog HDL code.

4. Type the following Verilog HDL code into the blank simple_counter.v file, as shown in Figure
6-15.

/1t has a single clock input and a 32-bit output port
module simple_counter (
CLOCK_5,

counter_out

input CLOCK_5;
output [31:0] counter_out;

reg [31:0] counter_out;
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always @ (posedge CLOCK_5) // on positive clock edge
begin

counter_out <= counter_out + 1;// increment counter

end

endmodule // end of module counter

1 F/It has a single clock input and a 32-bit output port

2 EHmodule Simple counter |

3 CLOCE 5,

4 COUnter out

5 B )i

& input CLOCE 5 »

7 output [31:0] COUnter out:

8 reg [31:0] COUnter out:

9

10 alwavs B (posedoge CLOCE_5) S5 on pogitive clock edge
11 & begin

1z COUnter out <= counter out + 1; SS increment counter

13 - end

14 = endmodule S/ end of module counter
15

Figure 6-15 The Verilog File of simple_counter.v

5. Save the file by choosing File > Save, pressing Ctrl + S, or by clicking the floppy disk icon.

6. Select File > Create/Update > Create Symbol Files for Current File to convert the
simple_counter.v file to a Symbol File (.sym). You will use this Symbol File to add the HDL code
to your schematic.

The Quartus II software creates a Symbol File and displays a message (see Figure 6-16).

# Quartus IT

\i\r) Create Symbol File was successful

Figure 6-16 Create Symbol File was Successful

7. Click OK.

8. To add the simple_counter.v symbol to the top-level design, click the my_first_fpga.bdf tab.
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9. Right click in the blank area of the BDF file, and select Insert > Symbol.
10. Double-click the Project directory to expand it.
11. Select the newly created simple_counter symbol by clicking its icon.

7 Symbol X]

Libraries:

21 Project
£3 d:/altera/10. 1/quartusfibraries,

............... _ CLOCK 5 counter_out[31..0] ._ B

Mame:

|sim|:||e_::ounter |E]
[] Repeat-insert mode

[] tnsert symbal as blodk e

Launch MegaWizard Plug-In e

[ MegaWizard Plug-In Manager... il

OK ] [ Cancel

Figure 6-17 Adding the Symbol to the BDF

12.  Click OK.

13. Move the cursor to the BDF grid; the symbol image moves with the cursor. Click to place the
simple_counter symbol onto the BDF. You can move the block after placing it by simply clicking
and dragging it to where you want it and releasing the mouse button to place it. See Figure 6-18.

. simple_counter

— CLOCK_5  counter_out[31..0] —
inst

Figure 6-18 Placing the simple_counter symbol
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14.  Press the Esc key or click an empty place on the schematic grid to cancel placing further
instances of this symbol.

15.  Save your project regularly.

B Adding a Megafunction to the Schematic

Megafunctions, such as the ones available in the LPM, are pre-designed modules that you can use in
FPGA designs. These Altera-provided megafunctions are optimized for speed, area, and device
family. You can increase efficiency by using a megafunction instead of writing the function yourself.
Altera also provides more complex functions, called MegaCore functions, which you can evaluate
for free but require a license file for use in production designs. This tutorial design uses a PLL clock
source to drive a simple counter. A PLL uses the on-board oscillator (DEO-Nano Board is 50 MHz)
to create a constant clock frequency as the input to the counter. To create the clock source, you will
add a pre-built LPM megafunction named ALTPLL.

1. Right click in the blank space in the BDF and select Insert > Symbol or click the Add Symbol
icon on the toolbar.

2. Click the Megawizard Plug-in Manager button. The MegaWizard® Plug-In Manager appears,
as shown in Figure 6-19.

4 NegaWizard Plug-In Nanager [page 1]

The MegaWizard Plug-In Manager helps you create ar modify design files that contain custom variations of
megafunctions.

Which action do you want to perform?

@ {Create a new custom megafunction variation |

() Edit an existing custom megafunction variation

(:} Copy an existing custom megafunction variation

Copyright (C) 1991-2010 Altera Corporation

Figure 6-19 Mega Wizard Plug-In Manager

1]
Fal
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3. Click Next.
4. In MegaWizard Plug-In Manager [page 2a], specify the following selections (see Figure 6-20):
a. Select /O > ALTPLL.

b. Under “Which device family will you be using?” select the Cyclone IV E for DEO-Nano
development board.

c.  Under “Which type of output file do you want to create?” select Verilog HDL.

d. Under “What name do you want for the output file?” type pll at the end of the already created
directory name.

e. Click Next.

W NegaWizard Plug—In Nanager [page 2al

Which megafunction would you like to customize?  yyhich device family will you be using? ECydonE IVE Vi
Select a megafunction from the list below

*{ ALTDDIO_IN

=l Which type of output file do you want to create?

4 ALTDDIO_OUT 1O ao

« ALTDLL 3 vHOL

“a ALTD

:: ALTDES () Verilog HOL

», ALTDQ DOS What name do you want for the output file?

“o ALTDO DGS2 w10, 1 _—

v ALTGX [E:/My_designimy_first_fogapl.v L]

¥§, ALTGX_RECONFIG

:+.+ T [] Return to this page for another create operation

*& ALTLVDS RX

‘*"{ ALTLVDS TX MNate: To compile & project successfully in the Quartus IT software, your design

1*-:;. ALTMEMEHY filez must be in the project directory, in a library specified in the Libraries page of

Y ALTOCT the Options dialog box (Tools menu), or a library spedfied in the Libraries page
—— of the Settings dialog box (Assignments menu).

:"{. ALTPLL_RECONFIG Your current user library directories are:

“% ALTREMOTE_UPDATE
“§, ALTTEMP_SENSE

“o Altera PLL v10,1

4, MAX TI/MAX V oscillator

Iz

s

[ Cancel ][ < Back ][ Mext = Finish

Figure 6-20 MegaWizard Plug-In Manager [page 2a] Selections
5. In the MegaWizard Plug-In Manager [page 3 of 14] window, make the following selections
(see Figure 6-21).
a. Confirm that the currently selected device family option is set to Cyclone IV E.
b. For device speed grade choose 6 for DEO-Nano.
c. Set the frequency of the inclockO input 50 MHz.
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d. Click Next.

Nega¥izard Plug—In Hanager [page 3 of 14]

[ st Jlzomison

Clodk switchover

Currently selected device family: oy cope 1y £

Match project/default

Able to implement the requested PLL

General
y . : - = ]
Which device speed grade will you be using? 5 ns
Use military temperature range devices only
What is the freguency of the indk0 input? | iMHz T|
Setup PLL in LYDS mode Mbps
PLL Type
Which PLL type will you be using?
Fast PLL Enhanced PLL (%) Select the PLL type automatically
Operation Mods
Howe will the PLL outputs be generated?
(%) Use the feedback path inside the PLL
() In source-synchronous compensation Mode
() In zero delay buffer mode
Connect the fomimic port (bidirectional)
() With no compensation
Create an 'fhin' input for an external feedback (External Feedback Mode)
Which output dock will be compensated for? IcU b
| Cancel | | < Back | | Mext = | | Einish |

Figure 6-21 MegaWizard Plug-In Manager [page 3 of 14] Selections

6. Unselect all options on MegaWizard page 4. As you turn them off, pins disappear from the PLL
block’s graphical preview. See Figure 6-22 for an example.
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Nega¥izard Plug—In Manager [page 4 of 14]

Clock switchover

Able to implement the requested PLL

Optional Inputs

Create an 'pliens’ input to selectively enable the PLL

[JiCreate an ‘areset input to asynchronously reset the PLL

] create an 'pfdena’ input to selectively enable the phaseffrequency detector

Lok Output
[] Create "locked' output
[] Enable self-reset on loss lock

Advanced Parameters

Lsing these parameters is recommended for advanced users only

[] create output file{s) using the ‘Advanced’ PLL parameters

- Configurations with output dock(s) that use cascade counters are not supported

| Cancel || < Back || MNext = || Finish |

Figure 6-22 MegaWizard Plug-In Manager [page 4 of 14] Selections

7. Click Next four times to get to page 8.

8. Set the Clock division factor to 10, as shown in Figure 6-23.
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c0 - Core/External Qutput Clock

Able to implement the requested PLL

Use this clock
Clock Tap Settings

Requested Settings Actual Settings
© Enter output dock frequency: | 100.00005000 | Mz ~| [s.000000 |
® {Enter output dock parameters: |

Clodk multiplication factor 1 | | | E_l |
= —
Clack division factor 10 [E {10 |
Clock phase shift 0.00 | % i |deg Vi !0.00 |
Clack duty cyde (%) 50.00 ] [som0 |
Description Value o !
Primary clock VCO frequency (MHz) &00,000 i
Mote: The displayed internal Modulus for M counter 12 =1
settings of the PLL is recommended Mol for N caanter 1
fo by ad d |
e bt SR s Sl Initial YCO phase cydes for M counter
VCO phase tap for M counter 0 |
Per Clock Feasibility Indicators
ol 1 2
| Cancel | | < Back | | MNext = | | Finish |

Figure 6-23 MegaWizard Plug-In Manager [page 8 of 14] Selections

9.  Click Next and then click Finish.

10. The wizard displays a summary of the files it creates (see Figure 6-24). Select the pll.bsf
option and click Finish again.
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Nega¥izard Plug—In Manager [page 12 of 12]

E Summary

The MegaWizard Flug-In Manager creates the selected files in the following directory:
E:\WMy_design'my_first_fpga),

Turn on the files you wish to generate. A gray checkmark indicates a file that is automatically generated, and & green
checkmark indicates an optional file. Click Finish to generate the selected files. The state of each checkbox is
maintained in subsequent MegaWizard Plug-In Manager sessions.

| File
[Vinly
pll.ppf
ph.inc
[pll.cmp
pll.bsf
[pll_inst.v
pll_bb.v

Description

Varigtion file

PinPlanner ports PPF file

AHDL Indude file

VHOL component dedlaration file
Quartus II symbol file
Instantiation template file
Verilog HOL black-box file

Figure 6-24 Wizard-Created Files

The Symbol window opens, showing the newly created PLL megafunction,a s shown in Figure

6-25.
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Libraries: S S S

= Project S S S

£} counter_bus_mux S S S

£ simpls_counter S S S

-3 Fifquartus10. 1 jguartus/libraries/ R S

SREEEEEREERES pl SEEEEESEERESEE

Crirrirrnr ek bk frequency: 50,000 MHz L

O Opertion hode: Normal CLLLLILiiiiin

S [k [Ratio[Ph rdgi] D (4] S

............... (oo {10 ] oo | socn |

llarne; O CLLLLILiiiiin

............... inst Cyclone W E

el B L A NS L

[ Repestinert made e EEEEEEEEEEEEEEEEE N EE

[ Insert symbal as black S S S

Launch Megaizard Plug-In O O

[ Megawizard Plug-In Manager .. A A A SN
Ok ][ Cancel

Figure 6-25 PLL Symbol

11. Click OK and place the pll symbol onto the BDF to the left of the simple_counter symbol. You
can drag and drop the symbols, if you need to rearrange them. See Figure 6-26.

inclki ] . cl
kD fre

counter_out[31..0] -— :

Figure 6-26 Place the PLL Symbol

12.  Move the mouse so that the cursor (also called the selection tool) is over the pll symbol’s cO
output pin. The orthogonal node tool (cross-hair) icon appears.

13. Click and drag a bus line from the cO output to the simple_counter clock input. This action ties
the pll output to the simple_counter input (see Figure 6-27).
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inclko -
nclkd frequency: #0.000 MHz - CLOCH_& counter_out[31..0]) p—
Dperation Mode: Norma L
Clk | Ratio| Ph {dg){ OC oLl
= IRl BRS R= Ry N -
nsti Cyclens IV E L

Figure 6-27 Draw a Bus Line connect pll c0 port to simple_counter CLOCK_5 port

B Adding an Input pin to the Schematic

The following steps describe how to add an input pin to the schematic.

1. Right click in the blank area of the BDF and select Insert > Symbol.

2. Under Libraries, select quartus/libraries > primitives > pin >input. See Figure 6-28

3. Click OK

If you need more room to place symbols, you can use the vertical and horizontal scroll bars at the
edges of the BDF window to view more drawing space.

& Symbol

Libraries:

£} simple_counter
= & d:/faltera/10. 1fquartus/libraries/
£ megafunctions
others
primitives
1 buffer
23 logic
£ other
E pin
1 bidir
L input
it output
23 storage

[TH

i e O

Marme:

[] repeat-insert mode
Insert symbol as block

Launch MegaWizard Plug-In

[nput L]

x)

[ MegaWizard Plug-in Manager... R LR RN REE
OK H Cancel
Figure 6-28 Input pin symbol
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4. Place the new pin onto the BDF so that it is touching the input to the pll symbol.

5. Use the mouse to click and drag the new input pin to the left; notice that the ports remain
connected as shown in Figure 6-29.

Ll pll

..................... o ek o o cl : ) P
[ k:i,_, - nclkd frequency: 50.000 MHz ; CLOCHK_S counter_out[31. 0] —
T Operation Mode: Mormal | 1 ool :
SRR Cik | Ratol P (43)| DC i

N =l -

Sl t Cyclone IV E LIl

Figure 6-29 Connecting the PLL symbol and Input port

6. Change the pin name by double-clicking pin_name and typing CLOCK_50 (see Figure 6-30).
This name correlates to the oscillator clock that is connected to the FPGA.

B Adding an Output bus to the Schematic

The following steps describe how to add an output bus to the schematic.

1. Using the Orthogonal Bus tool, draw a bus line connected on one side to the simple_counter
output port, and leave the other end unconnected at about 4 to 8 grid spaces to the right of the
simple_counter.
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E Fin Properties

General | Format
To create multiple pins, enter a name in AHOL bus notation
{(For example: “name[3..0]7), or enter a comma-seperated list of names,
Pinname(s): | CLOCK_50 |
Default value: |'|.|'CC vl
[ QK l [ Cancel ] [ Help

Figure 6-30 Change the input port name

2. Right-click the new output bus line and select Properties.

3. Type counter [31..0] as the bus name (see Figure 6-31). The notation [X ..Y] is the Quartus II
method for specifying the bus width in BDF schematics, where X is the most significant bit (MSB)
and Y is the least significant bit (LSB).

4. Click OK. Figure 6-32 shows the BDF.
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| Font Format

Mame: | counter[31..0] |

[] Hide name in block design file.,

[ K H Cancel H Help

Figure 6-31 Change the output BUS name

Climewo [ | el :
clkD freguency: 50.000 MHz

CLOCH_5 counter_owt[31..0]

Figure 6-32 Circuit schematic (BDF)

B Adding a Multiplexer to the Schematic

This design uses a multiplexer to route the simple_counter output to the LED pins on the DEO-Nano
development board. You will use the MegaWizard Plug-In Manager to add the multiplexer,
Ipm_mux. The design multiplexes two portions of the counter bus to four LEDs on the DEO-Nano
board. The following steps describe how to add a multiplexer to the schematic.
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1. Right click in the blank area of the BDF and select Insert > Symbol.
2. Click Megawizard Plug-in Manager.

3. Click Next.

4. Select Installed Plug-Ins > Gates > LPM_MUX.

5

. Select the Cyclone IV E device family, Verilog HDL as the output file type, and name the
output file counter_bus_mux.v, as shown in Figure 6-33.

6. Click Next.

' WegaWizard Plug—In Nanager [page 2al

Which megafunction would you ke to customize?  \yhich device family will vou be using? i_C:}EnnE IVE __V:|
Select a megafunction from the list below

= ﬁ Installed Plug-Ins

Which type of output file do you want to create?

¥4 Altera SOPC Buider O anoL
e I;I Arithmetic {7 VHOL
[+ || Communications
#-[ ] psp {*) Verilog HOL
= ] Gates What name do you want for the gutput file?
“§ LPM_CLSHIFT ——
:+.'i LPM CONSTANT IE:,."My___c!es:gnfmy_ﬁr_st___f'p_lga,.’munter_bus_mux.u |E]
i LPM_DECODE
; ; [] Return to this page for another create operation
B 1o
#- ] Interfaces Mote: To compile 3 project successfully in the Quartus II software, your design
#- ] ITAG-accessible Extensions files must be in the project directory, in a library specified in the Libraries page of

the Options dislog box (Tools menu), or a library specified in the Libraries page
of the Settings dialog box (Assignments menu).

Bt

-] Memary Compiler

Your current user library directories are:

[ Cancel H < Back H Mext = Finish

Figure 6-33 Selecting I[pm_mux

7. Under “How many ‘data’ inputs do you want?” select 2 inputs (default).

8. Under “How wide should the ‘data’ input and the ‘result’ output buses be?” select 4, as shown
in Figure 6-34.
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counter_bus_mux

el
| datalx=[3..0]

Currently selected device family: ii'-r":'D"lE' WE

How many 'data’ inputs do you want? ' 2

s 1:'!9'-[
[ oo Jamenotn

Match project/default

adl|
e 143, 0] Haw wide should the 'data’ input and & B i
the 'result’ output buses be? L |
Do you want to pipeline the multiplexer?
©@ito,
) Yes, I want an output latency of -1 _: dock cydes
Create an asynchronous Clear input
Crieate a Clock Enable input
Re=ource Usage
1 Ipm_mux | Cancel | | < Back | | Mext = | | Finish |

Figure 6-34 Ipm_mux settings

9. Click Next.
10. Click Next.

11. Select the counter_bus_mux.bsf option.

12.
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Click Finish. The Symbol window appears (see Figure 6-35 for an example).
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& Symbol

Libraries:

X

= & Project

EF
Lt pl
¥ simple_counter
23 d:/faltera/10. 1/quartuslibraries/

Mame:

| counter_bus_mux

[] repeat-insert mode
[] insert symbol as block

Launch MegaWizard Flug-In

[ MeagaWizard Plug-In Manager. ..

counter_bus_muzx

zel result]3..0]
datalx[3..0) ]
datal1x=[3..0]

OK l [ Cancel

13. Click OK

Figure 6-35 Ipm_mux Symbol

14. Place the counter_bus_mux symbol below the existing symbols on the BDF, as shown in

Figure 6-36.

CLOCK_& counter_owt[31..0]

counter_bus_mux

- | dataoxqz.q) resutt[3.0]{ - - -
datalx[3..0] :
ze|

Figure 6-36 Place the Ipm_mux symbol
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15. Add input buses and output pins to the counter_bus_mux symbol as follows:

a. Using the Orthogonal Bus tool, draw bus lines from the datalx[3..0] and dataOx[3..0] input
ports to about 8 to 12 grid spaces to the left of counter_bus_mux.

b. Draw a bus line from the result [3..0] output port to about 6 to 8 grid spaces to the right of
counter_bus_mux.

c. Right-click the bus line connected to datalx[3..0] and select Properties.

d. Name the bus counter[26..23], which selects only those counter output bits to connect to the
four bits of the datalx input.

Because the input busses to counter_bus_mux have the same names as the output bus from
simple_counter, (counter[x .. y]) the Quartus II software knows to connect these busses.

e. Click OK.
f.  Right-click the bus line connected to data0x[3..0] and select Properties.

g. Name the bus counter [24..21], which selects only those counter output bits to connect to the
four bits of the datalx input.

h. Click OK. Figure 6-37 shows the renamed buses.

SESEES RS SRR counter_bus_mux o
:*::‘:._'—:'5-1;24:.2-;::::: datalx]3. 0] resun[g__c-;:-:-'s'_:'_z'..'__:::::::’:t:'
:..3:—-"!:5':_.’_:...’_:_..... data1x[3..0]
* o
I I
I 1 LTI

Figure 6-37 Renamed counter_bus_mux Bus Lines
If you have not done so already, you may want to save your project file before continuing.

16. Right click in the blank area of the BDF and select Insert > Symbol.

17. Under Libraries, select quartus/libraries > primitives > pin >output, as shown in Figure 6-38.
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Libraries:

tF simple_counter
= & d:faltera/10. 1/quartus libraries/

[+ 21 megafunctions
[+ 3 others
= & primitives

F 21 buffer

& 23 logic

[+ €3 other

= & pin
£ bidir
£ input
| ﬂ' output
# 3 storage
!
Mame:
!ou'q:-ut

[ Repeat-nsert mode
Inzert symbol as block

Launch MegaWizard Plug-In

[ MegaWizard Plug-In Manager. ..

18. Click OK.

Figure 6-38 Choose output pin

19. Place this output pin so that it connects to the counter_bus_mux’s result [3..0] bus output line.

20. Rename the output pin as LED [3..0]. (see Figure 6-39).

. .counter[24 . 21]

A% nunter|28. 29 . . . .

coutter_bus_mux IESIEIESIAEEEEEREEE AR AN b
data0x[3. 0] result[a__[]]? resultf30]. ... L L. BB CEBTE D]
dataix[3 0] T e
sel :

Figure 6-39 Rename the output pin

21. Attach an input pin to the multiplexer select line using an input pin:

a. Right click in the blank area of the BDF and select Insert > Symbol.

b. Under Libraries, double-click quartus/libraries/ > primitives > pin > input.

c. Click OK.

22. Place this input pin below counter_bus_mux.

23. Connect the input pin to the counter_bus_mux sel pin.

24. Rename the input pin as KEY [0] (see Figure 6-40).
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pll

I LoD TEmple seunter T Ll

o L P
- linclko c0d- - A .counter[31..0] . . . ORI

i CLOCK 50 | inclk0 frequency: 50.000 MHz CLOCK.S  counter_out[31.0] fe—¢.
Operation Mode: Mormal

3

counter_bus_mux

data0x[3. 0] resuft[3 0] -resutld. ol S
ldatatxzop | | o

Slsel

Figure 6-40 Adding the KEY [0] Input Pin

You have finished adding all required components of the circuit to your design. You can add notes
or information to the project as text using the Text tool on the toolbar (indicated with the A symbol).
For example, you can add the label “OFF = SLOW, ON = FAST” to the KEY [0] input pin and add
a project description, such as “DE(O-Nano Tutorial Project.”

6.6 Assign the Pins

In this section, you will make pin assignments. Before making pin assignments, perform the
following steps:

1. Select Processing > Start > Start Analysis & Elaboration in preparation for assigning pin
locations.

2. Click OK in the message window that appears after analysis and elaboration completes.

To make pin assignments to the KEY [0] and CLOCK_50 input pins and to the LED[3..0] output
pins, perform the following steps:

1. Select Assignments > Pin Planner, which opens the Pin Planner, a spreadsheet-like table of
specific pin assignments. The Pin Planner shows the design’s six pins. See Figure 6-41
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& Pin Planner — E:/Ny design/ay first fpga/my first fpga — my first fpea El@”§|
File Edit View Processing Tools Window
o |Groves 8 x| i
——(Named:| * b
;nt] 1: Mode Mame Direction Location
= i R KEY[D..0] Input Group
|5 | @ & epp.0) Output Group
<<new group>>
O e | 3
B x| Named:% * "i Edit:| 3¢ || v | gFiIter:iPim': all v
g e
&7 | Mode Mame Direction Location 1/0 Bank VREF Group 1/0 Standard Reserved
i B CLOCK_50 Input 2,5V (default)
1B KEY[O] Input 2.5V (default)
€ LED[3] Output 2,5V (default)
43 LED[2] Dutput 2.5 (default)
o LED[1] Output 2,5 Y (default)
=" |4k LED[O] Output 2,5V (default)
ﬁﬁ | <<new node >3
= -
T
% J=|
0% 00:00:00

Figure 6-41 Pin Planner Example

2. In the Location column next to each of the six node names, add the coordinates (pin numbers)
as shown in Table 6-1 for the actual values to use with your DEO-Nano board.

Table 6-1 Pin Information Setting

Pin Name FPGA Pin Location
KEY[0] J15

LED[3] A1l

LED[2] B13

LED [1] A13

LED [0] A15

CLOCK_50 R8

Double-click in the Location column for any of the six pins to open a drop-down list and type the
location shown in the table. Alternatively, you can select the pin from a drop-down list. For example,
if you type F1 and press the Enter key, the Quartus II software fills in the full PIN_F1 location
name for you. The software also keeps track of corresponding FPGA data such as the I/0O bank and
VREF Group. Each bank has a distinct color, which corresponds to the top-view wire bond drawing
in the upper right window, as shown in Figure 6-42.
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& Pin Planner — E:/Ny design/ay first fpga/my first fpga — my first fpea El@[§|
File Edit View Processing Tools Window
| Groups g x|
@ B ol e =
—{Named:| = |
;nt] E Mode Mame Direction Locati #* !
= i @ LED[Z] Output PNB1Z |
[ B | €% LED[]] Output PIN.ALZ ||
J @ LED[0] Output PIN ALS |
|, <smeworoin> el
O ¢ i i 8 |
B x| Mamed:| = "i Edit:| 3¢ || v | !Filter:IPim': all v
o et
L] Mode Mame Direction Location 1/0 Bank VREF Group 1/0 Standard Reserved
u I8 CLOCK_50 Tnput PIN_R3 3 B3_NO 2.5V (default)
15" KEY[O] Input PIN_J15 5 B5_NO 2.5 (default)
« LED[3] Output PIN_A11 7 B7_NO 2.5V (default)
£ |ED[2] Output PIN_E13 7 B7_NO 2.5 (default)
£ LED[1] Output PIMN_A13 7 B7 MO 2.5V (default)
= || ep[o] Output PIN_A15 7 B7_NO 2,5V (default)
ﬁﬂ_ || < <new node >
= -
|
v =
0%  00:00:00

Figure 6-42 Completed Pin Planning Example

Now, you are finished creating your Quartus II design!

6.7 Create a Default TimeQuest SDC File

Timing settings are critically important for a successful design. For this tutorial you will create a
basic Synopsys Design Constraints File (.sdc) that the Quartus II TimeQuest Timing Analyzer uses
during design compilation. For more complex designs, you will need to consider the timing
requirements more carefully.

To create an SDC, perform the following steps:

1. Open the TimeQuest Timing Analyzer by choosing Tools > TimeQuest Timing Analyzer.
2. Select File > New SDC file. The SDC editor opens.

3. Type the following code into the editor:
create_clock -period 20.000 -name CLOCK_50
derive_pll_clocks

derive_clock_uncertainty

4. Save this file as my_first_fpga.sdc (see Figure 6-43)
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¥ Quartuzs II — E:/By desien/my first fpga/my first fpga — my first fpea

File Edit View Project Assignments FProcessing Tools Window Help

DEEg & + Ba@|@m o o~ ;_my_ﬁrs{:__fpga - v]|§°4 4’@@@ I PE'@@@@ H t’!)»
Project Mavigator g )_(: first_fpaa.bdf [ | abc simple_counter.v || @ Compilation Report | abc my _first_fpga.sdc [:] 4
A% %% 00 R (g | =22

Cydlone IV E: EP4CE2IE 1766 ~Greate clock -pericd 20.000 —name CLOCE 50

| Entity | Fh - L ﬁ"“ [0

i
= 2 my fist fogs Sf 2 derlve_pll_clocks
b0 cimple counter:inst 3 derive_clock_uncertaintyi
*3 pll:inst2 4
I# “s, counter_bus_muxinst3 |
kel |
&y Hierarchy Files | of Design Units
Tasks g x|
Flow: ;Compilation i
| Task |
l = e
| [+
| & |
| & 3
| ! |
| = 2|
(5 ) & g >
oty = ~

il Type | Mesasage
I+ \i,) Info: Worat-case minimam pulse width sliack is 85.584
\i.J Info: Writing out detailed assembly data for power analysis
\i,J Info: Assemblier is generating dewice programming files
\i,J Info: Design is not fully constrained for setup reguirements P

A
[1

\ System \_Processing (117) /\, Extra Info j\ Info {113) S\ Warring (1) S\ Critical Warning (3) /\_Error /\_Suppressed (5} /\ _Flag /
]Message 0of 310 4+ & _I:t cation: Locate

Messages

66, 231 | 100% 00:01:23

Figure 6-43 Default SDC

Naming the SDC with the same name as the top-level file causes the Quartus II software to use this
timing analysis file automatically by default. If you used another name, you would need to add the
SDC to the Quartus II assignments file.

6.8 Compile Your Design

After creating your design you must compile it. Compilation converts the design into a bitstream
that can be downloaded into the FPGA. The most important output of compilation is an SRAM
Object File (.sof), which you use to program the device. Also, the software generates report files
that provide information about your circuit as it compiles.

Now that you have created a complete Quartus II project and entered all assignments, you can
compile the design.

In the Processing menu, select Start Compilation or click the Play button on the toolbar.
If you are asked to save changes to your BDF, click Yes.

While compiling your design, the Quartus II software provides useful information about the
compilation, as shown in Figure 6-44.
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4 Quartus II — E:/By design/ay first fpga/my first fpea

— my firzst fpga

FEile Edit View Project Assignments Processing Tools  Window  Help
~ = {= T - " .
DEE@d & & BER o o |iny fist o X% s SRS B PV 'shH P LA 9>
Project Navigator B X first_foga.bdf (21 | 4 simple_counter.y [ | @)Compilation Report (£ | 3B my_first_fpga.sdc [ (4P
. Table of Contents o] Flow Summar
Sl E Flow Summary Flow Status In progress - Fri Jan 14 17:42:11 2011
Cyclone IV E: EP4CE22F17CH : Quartus II Version 10,1 Build 153 11/29/2010 51 Full Versior}
T ER Flow Settings Rt first
= 2 my_first fpga eﬁil ; evision Name my_first_fpga
Lot e counterinek EE Flow Non-Default Global Settings Topdevel Entity Name my_first_fpoa
o o pll'inst_z = ER Flow Elapsed Time Family Cycdone TVE
& "'} co;.mher bus_muinst3 ES Flow 055 ik
e S Flow Lo
g
< | b [ ] Analysis & Synthesis
& Hierarchy | B Fies | P DesignUnits |
Tasks 8 X
Flow: |C0mpilahon | Customize. ..
Task
- Con
- .
- >
- >
-
b - £ |
T
; TIype | Mes=sage i
{Ex \i',) Info: 5 registers last a2l their fanouts during nerlist optimizations. The first 5 are displayed below
B \i..) Info: Generating hard biock partition "nard blocki:auto generated inst”
= \i,J Info: Implemented 38 dewvice resources after synthesis — the final resocurce count might be different
= j,) Info: Quartus II Analysis & Synthesis was successful. 0 errors, 0 warnings ;;
@ | < [ | >
gi\, System J\_Processing (27) [\ Extra Info /\_Info (27) J\_Warning /\_Critical Warning J/\_Error f\ Suppressed /\ Flag /
£ |Message: 0 of 107 4+ | ¥ |location: | Locate
86,231 | 24% 2. 00:00:13

Figure 6-44 Compilation Message for project

When compilation is complete, the Quartus II software displays a message. Click OK to close the
message box.

The Quartus II Messages window displays many messages during compilation. It should not display
any critical warnings; it may display a few warnings that indicate that the device timing information
is preliminary or that some parameters on the I/O pins used for the LEDs were not set. The software
provides the compilation results in the Compilation Report tab as shown in Figure 6-45.
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AVOTS RYA),

{Flow Status:

Quartus II Version

Revision Mame

Topdevel Entity Mame

Family

Device

Timing Models

Total logic elements
Total combinational functions
Dedicated logic reqgisters

Total registers

Total pins

Total virtual pins

Total memary bits

Embedded Multiplier 9-hit elements

Total PLLs

my_first_fpga
my_first_fpaa
Cydone IV E
EPACE22F17Co

Final

31/22,320( < 1%)
31/22,320( < 1%)
27/22,320 (< 1%)
27

6/154(4%)

0

0 /608,256 (0 %)
0/132(0 %)
1/4(25%)

Successful - Fri Jan 14 17:42:39 2011
10.1 Build 153 11/29,/2010 51 Full Version

Figure 6-45 Compilation Report Example

6.9 Program the FPGA Device

After compiling and verifying your design you are ready to program the FPGA on the development
board. You download the SOF you just created into the FPGA using the USB-Blaster circuitry on

the board. Set up your hardware for programming using the following steps:

First, connect the USB cable, which was included in your development kit, between the DEO-Nano
and the host computer. Refer to the getting started user guide for detailed instructions on how to

connect the cables.

Refer to the getting started user guide for detailed instructions on how to connect the cables.

Program the FPGA using the following steps.

1. Select Tools > Programmer. The Programmer window opens, as shown in Figure 6-46.
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File Edit View Processing Tools Window

s

é_—,,, Hardware Semp...] |USB—BIaster [usE-0] | Mode: EJTAG Vl Progress: ] ‘

[ ] Enable real-time ISP to allow backaround programming {for MAX IT and MAX V devices)

. File Device Checksum Usercode Program/ Verify Blank-
P start Configure Check

EP4CE22F17 00133380 FFFFFFFF
mi Stop
a Auto Detect
X Delete
¥ add File...
B Change File. ..
¢ >
m’ Save File =

B2 add Device. .,

. T OaEREEEAE"

A up ] ABTEEE, i
™ T
ﬁ“ Do ) . > =
i ai
i m! —
|_FEEmsEEES |
EP4CEZF 1T
TDO e

Figure 6-46 Programmer Window

2. Click Hardware Setup.

3. [If it is not already turned on, turn on the USB-Blaster [USB-0] option under currently selected
hardware, as shown in Figure 6-47.
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‘}.'.'") Hardware S5S5etup

Hardware Settings | JTAG Settings |

3

Currently selected hardware:

Available hardware items

Select a programming hardware setup to use when programming devices, This programming
hardware setup applies only to the current programmer window,

USB-Blaster [USB-0]

Mo Hardware

IUSB-Blaster [USE-0]

Hardware SErver Port Add Hardware. .. |
|JSB-Blaster Local LISB-0
Femove Hardware
Figure 6-47 Hardware Setting
Click Close.

N o vk

Click the Start button.
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03 Programmer - D:/Home/User/Desktop/allen/my_first_fpgalmy._first_fpga - my_first_fpga - [my_... E|@|Pz|

File Edit “iew Processing Tools  ‘Window

’é;, Hardware Setup.. l |

| Mode: |JTAG V| Progress: l 100%: (SuccessFul) l]

[] Enable real-time ISP ta allow background programming (For Ma3 11 and Max ¥ devices)

File Device Checksum Usercode Praogram) Werify Elal
Wb ssrt Configure Chi

rvy_First_fpaa.saf EP4CEZ2F17 00137C0E FFFFFFFF

il Stop
# Auto Detect
W Delete
(2 Add File...
= Change File. ..
Save File ~
&2 ndd Device...
2 t
-ﬁ" Doy

Figure 6-48 Downloading Complete

Congratulations, you have created, compiled, and programmed your first FPGA design! The
compiled SRAM Object File (.sof) is loaded onto the FPGA on the development board and the
design should be running.

6.10 Verify The Hardware

When you verify the design in hardware, you observe the runtime behavior of the FPGA hardware
design and ensure that it is functioning appropriately.

Verify the design by performing the following steps:

1. Observe that the four development board LEDs appear to be advancing slowly in a binary count
pattern, which is driven by the simple_counter bits [26..23].

The LEDs are active low, therefore, when counting begins all LEDs are turned on (the 0000 state).

2. Press and hold KEY [0] on the development board and observe that the LEDs advance more
quickly. Pressing this KEY causes the design to multiplex using the faster advancing part of the
counter (bits [24..21]).

3. If other LEDs emit faintness light, select Assignments > Device. Click Device and Options. See
Figure 6-49.
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Device family

Select the family and device you want to target for compilation.

Show in 'Available devices' list

Eamily: iCydone IVE

Devmes:|ﬂh

| Pin count:

Target device

Other: nfa

Available devices:

() Auto device selected by the Fitter

{#) Specific device selected in ‘Available devices' list

bl | Package:

|any ¥|
\Any "|
1

Speed grade: |Any
Show advanced devices

HardCopy compatible only

[Qevice and Pin Opfions. . ]

EP4CEZ2E22C9L | 1.0V
EP4CE22E2217 12V
rEP-’ICEZZEZ?_IBL 1.0v
'EP4CE}‘_2‘F 1I7AY | L2V

EP4CE22F17CY 1.2V
EP4CE22F17CE | 1.2V
EP4CE22F17CEL | 1.0V
EP4CEZIFIFCOL | 1.0V
EP4CE22F 1717 12V
EP4CE22F17I8L | 1.0V
FDAFEIN 11417 | 1 W

2RI 184

Hame Core Voltage LEs User If0s
22320 30 B0E256
22320 B0 608258
22320 80 608256
608256
. 608256
1549 603256
22320 154 508258
22320 159 608256
22320 154 B08256
22320 154 608256
22320 154 608256
anRIsA

Memory Bits

Embedded multiplier 9-bit elements

132
132
132

132
132
132

132
137

Migration compatibility

Companion device

[ Migration Devices...

J HardCopy:

0 migration devices selected

Limit DSP- & RAM to HardCopy device resources

QK ][ Cancel ]I_ Help ]

Figure 6-49 Device and Options

Select unused pins. Reserve all unused pins: select the As input tri-stated option. See Figure 6-50.
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¥ Device and Pin Options — my first fpga

Category:
Configuration i 1
Programming Files Specify device-wide options for reserving all unused pins on the devica. To reserve
Unused Pins : individual dual-purpose configuration pins, go to the Dual-Purpose Pins tab. To reserve
Dual-Purpose Pins other pins individually, use the Assignment Editor,
Capacditive Loading
Board Ti Model T T
I,."?Zla[ﬁmi;?;m mes Reserve all unused pins: As input tri-stated bl
Voltage
Fin Placement
Error Detection CR.C
CvPCle Settings
Description:
Reserves all unused pins on the target device in one of 5 states; as inputs that are tri-
stated, as outputs that drive ground, as outputs that drive an unspecdified signal, as
input tri-stated with bus-hold, or as input tri-stated with weak pull-up.
[ 0K ] [ Cancel ] [ Help ]
Figure 6-50 Setting unused pins
Click twice OK.

4. In the Processing menu, choose Start Compilation. After the compile, select Tools >
Programmer. Select the my_first_fpga.sof file from the project directory. Click Start. At this time
you could find the other LEDs are off.
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Chapter 7

Tutorial: Creating a Nios I] Project

This tutorial provides comprehensive information that will help you understand how to create a
microprocessor system on your FPGA development board and run software on it. This system will
be based on the Altera Nios II processor.

7.1 Required Features

This tutorial requires the Quartus II and Nios II EDS software to be installed. The tutorial was
written for version 10.1 of those software packages. If you are using a different version, there may
be some difference in the flow. Also, this tutorial requires the DEO-Nano board.

7.2 Creation of Hardware Design

This section describes the flow of how to create a hardware system including a Nios II processor.

1. Launch Quartus II then select File > New Project Wizard, start to create a new project. See
Figure 7-1and Figure 7-2.
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Assignments

Project

View
Hew. . . Ctrl1+H
Open. .. Ctr1+0

i
=
@ Hew Froject Wizard ..
E? Open Froject. .. Cirl+T

0

o

Create ; Update >

Conwert Programming Files. . .

[ ]
Recent Files L3
Recent Frojects 4
Exit A ++F4

Figure 7-1 Start to Create a New Project

¥. New Project Wizard

Directory, Name, Top-Level Entity [page 1 of 5]

What is the working directory for this project?

| D:'Home\User\Desktop |E]
What is the name of this project?
What is the name of the topevel design entity for this project? This name is case sensitive and must exactly match the entity name in the design file.
[gse Existing Project Settings. . ]
[ < Back ] [ Mext = ] [ Finish ] [ Cancel ] [ Help

Figure 7-2 New Project Wizard

2. Select a working directory for this project, type project name and top-level entity name as shown

in Figure 7-3. Then click Next, you will see a window as shown in Figure 7-4.
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4 HNew Project Wizard

Directory, Name, Top-Level Entity [page 1 of 5]
What is the working directory for this project?
| D: fmyfirst_niosii| |E]
What is the name of this project?
| myfirst_niosit |E]
What is the name of the topewvel design entity for this project? This name is case sensitive and must exactly match the entity name in the design file.
| myfirst_niosii |E]
[gse Existing Project Settings...

< Back [ MNext = ] [ Finish ] [ Cancel ] [ Help ]

Figure 7-3 Input the working directory, the name of project, top-level design entity

NHew Project Wizard

Add Files [page 2 of 5]
Select the design files you want to indude in the project. Click Add All to add all design files in the project directory to the project,
Mote: you can always add design files to the project later.
File name: | |E] Add
File Hame Type Library | Design EntrwdSymthesiz Tool HOL Yersion
Bemove
Lp
Down
Properties
Specify the path names of any non-defauit libraries.
[ = Back ] [ Mext = ] [ Finish ] [ Cancel ] [ Help ]

Figure 7-4 New Project Wizard: Add Files [page 2 of 5]

3. Click Next to skip in Add Files window. In the Family & Device Settings window, we will
choose device family and device settings appropriate for the DEO-Nano board. You should choose
settings the same, as shown in Figure 7-5. Then click Next to get to the window as shown in

Figure 7-6.
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4 New Project Wizard

Family & Device Settings [page 3 of 5]
Select the family and device you want to target for compilation.
Device family Shaw in "Available devices' list
Eamily: !Cydone WE V| Package: |An\-’ "i
Devices: Al | Pin count: |Ar|\f "|
Target device Speed grade; |'°'“Y v|
() Auto device selected by the Fitter Show advanced devices
() Sperific device selected in "Available devices' list HardCopy compatible only
COiher: nfa
Available devices:
Hame Core ¥oltage LEc User If0x Hemory Bits Embedded multiplier 9-bit elements
EP4CE2_2E_2218L Lo _22320 0] BOGZSE 132
EP4CEZEFITAT 1z 22320 154 BOGZSE 132
EF4 1706 1, BO5256
EP4CE2_2F_1'TCT I 154 B052568 132 -
EP4CE2.2F.1"|'C8 I | 154 B05256 132
EP4CE2.2F.1"|'CBL ooy .22320 154 BO052568 132
EP4CEZEF1TCOL ooy | 2z3z 154 E05256 132
EP4CEZZFITIT ey 22320 154 BOS256 132 bt
£ I 3
Companion device
HardCopy:
Limit DSP & RAM to HardCopy device resources
[ < Back ] [ Mext = J [ Einish ] [ Cancel ] [ Help

Figure 7-5 New Project Wizard: Family & Device Settings [page 3 of 5]

4. Click Next and will see a window as shown in Figure 7-7. Figure 7-7 is a summary about the
new project. Click Finish to complete the New Project Wizard. Figure 7-8 show the new project.
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¥ New Project

EDA Tool Settings [page 4 of 5]

Specify the other EDA tools used with the Quartus II software to develop your project.

Board-Lewel Timing .<None>
Symbol <Mone >
Signal Integrity <Mone >
Boundary Scan <Mone>

LS

EDA tools:
Tool Type Tool Fame Format (=) Fun Tool Automatically
Design Entrs/Syme- { <Monex || <MNone > Run this tool automatically to synthesize the current design
Simalation <Mone> » || <Mone= Rur gateevel simulation automatic after compilation
Timing Analysis :N_Dl_ﬂne> ([ <MNone > Run this tool automatically after compilation
Formal Verificat-- | <Hone>

[ < Back ][ Mext =

Cancel ] [ Help ]

Figure 7-6 New Project Wizard: EDA Tool Settings [page 4 of 5]

Project

Summary [page 5 of 5]

Project directory:

Project name:

Top-level design entity:
Mumber of files added:

Mumber of user libraries added:

Device assignments:
Family name:
Dewice:
EDA tools:
Design entry fsynthesis:
Simulation:
Timing analysis:
Operating conditions:
YWCCINT voltage:

Junction temperature range:

When vou dick Finish, the project will be created with the following settings:

O frvyfirst_niosii
myfirst_niosii
myfirst_niosii

i

4]

Cyclone IV E

EPACEZ22F17C6

<Mone= {<Mone =)

<Mone= {<Mone =)

<Mone = {<Mone =)

1.2v

0-85 *C

Mext

Cancel ] [ Help J

Figure 7-7 New Project Wizard: Summary [page 5 of 5]
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File Edit VYiew Project Assiznments Processing Tools Window Help
DEEd & s+ BR « o
[myfrst o VY s @0 T rW oD @ ® AA O
Project Mavigator 8 X
Entity
dyiCyclone IV E: EPACEZZFITCE
- W myfirst_nioesii
Hierard'n.I | Files || 8P Design Units |
Status F X
Module 7 Progress ® Time
® View New Quartus Il
Information
® Documentation
o .
; Type Message
B
g \_System f\_Processing /% Extra Info /Y Info /\ Warning S\ Critical Warning /\_Error /% Suppressed /% Flag /
2 |Message: ‘E ; |Locaﬁon: Locate
0% 00:00:00

Figure 7-8 A New Complete Project

5. Select Tools > SOPC Builder to open SOPC Builder, the Altera
shown in Figure 7-9.

system generation tool, as

Window Help

Furn EDA Simulatieon Tool L4
Fun EDA Timing Analys=sis Tool

Launch ETA Simulation Library Compiler
Launch Dezizgn Space Explorer

TimeQueszt Timing Analyrer

Advizors L2

Chip Flanmer (Floorplan and Chip Editor)
Desizn Partition Flanmer

Hetlist ¥iewers *

SignalTap IT Logic Analyrer
In—Sw=tem Memory Content Editor
Logic Analyzer Interface Editor
In—Sw=stem Scources and Probesz Editor
SignalFrobe Fins. . .

Frozrammer

JTA5 Chain Debugzer

Transceiwer Toollit

External Memory Interface Toolkit

vERE Emin &6 R

Exd

e

Mezafizard FluzIn Manager
il der

B=3= (Beta)
Tel Seripts. ..

/ﬂa.

Customize. ..
Options. ..

License Setup. ..

N

Figure 7-9 SOPC Builder Menu
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Fie Edit Module System View Toole Help

System Contents | System Gemraﬁnni

Component Library Target Clock Settings

Device Famiy) Cyclone WE  » Name Source MHz

=
|

[#-Avalon Verification Suite
[#-Bridges and Adapters
[#-Interface Protocols

[#-Legacy Components
[#-Memaries and Memory Contro =
[#-Merlin Components

™ Create New System - Clock Base End

System Name: |

[#-Peripherals

EPLL Target HDL: (3) Verilog

[#-Processor Additions ) VHDL

[+ -Processors

#-5LS @ Info: Specify a new system name.

[#-University Program
[+-Vides and Imaoe Processing

=
"

el
4| | %

Edit Add Remove Edit = rs b = [A.clnjrmsh!ap ] [Eﬂers._. ]

oo et ] (o]

Figure 7-10 Create New SOPC System [0]

6. Rename System Name as shown in Figure 7-10 and Figure 7-11. Click OK and your will see a
window as shown in Figure 7-12.

= Create New System

Syatem Name:|DEEI_N.&NO_SOPC|

Target HOL: (%) “erilog
() WHDL

L I J[ Cancel ]

Figure 7-11 Create New System [1]
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" Altera SOPC Builder (=1E3
Fie Edit Module System View Tools Help

—————
System Contents | System Generation|

Component Library Target Clock Settings
Project - Device Family: Cyclone WE % Name Source MHz
o — el ||
"I New component... clk_0 External 50.0 ——
Library Remove

t-Avalon Verification Suite
(+!-Bridges and Adapters
[+ Interface Protocols
-Legacy Components Use C.. Module Description Clock Base End
-Memories and Memory Contro -
--Merfin Components
-Peripherals
-PLL
it-Processor Additions
+!-Processors
tt-University Program

w

+-Video and Imaoe Processing =
) ?

B8 o BB o R - R 1]
1 e e

P

| %

y =

< | »

Edi = & v = [Adresswap. | [Fters. | Fiter:Defaut

4 Frav [ Next |+ ] [ Generate ]

Figure 7-12 Create New System[2]

7. Click the clk_0 name in the Clock Settings table to rename clk_0 to clk_50. Press Enter to
complete the update, as shown in Figure 7-13.

W Altera SOPC Builder

Fie Edit Module System WView Toolk Help

System Contents | System Generation|

Component Library Target Clock Seftings
Project A| | Device Famiy|cycone VE | | Name Source MHz
I3 New component... clk_50 External 50.0 —
Library Remove

[*-Avalon Verification Suite
[#-Bridges and Adapters
@---Interfaoe Protocols
@---Legacy Components Use | C..| Module Description Clock Base End
@---Memuries and Memory Contro —
@---Merlin Components
[#-Peripherals

-PLL

Figure 7-13 Rename Clock Name

8. In the left hand-side Component Library tree, select Library > Processors > Nios II Processor
and click the Add... button to open the Nios I component wizard, as shown in Figure 7-14 and
Figure 7-15.
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W Altera S0PC Builder
File [Edit Module System View Took

System Contents | System Generation

Component Library

Fl

E-E-E-E-E-E-E-E-E

Project

Library

lg New component...

-Avalon Verification Suite
-Bridges and Adapters
~Interface Protocols
-Legacy Components
-Memories and Memory Controliers
-Merlin Components
-Peripherale
-PLL
~Processor Additions
~Processors

LN lios Il Processor
-aLS
~University Program
-Wideo and Image Processing

[

Figure 7-14 Add NIOS Il Processor
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%]

™ Nios IT Processor — cpu 0

Nios II Processor

Core Mios IT Caches and Memory Interfaces ustom Instructions
rCore Nios Il
Select a Nios ll core:
2 = |
O Nios lli/e O Nios II/s =
& RISC RISC
Nios Il 132-bit 32-bit
Selector Guide Instruction Cache Instruction Cache
Family: Cyclone IV E ‘Branch Prediction ‘Branch Prediction
'Hardware Multiply Hardware Muttiply =
foystem: 50.0 MHz |Hardware Divide ‘Hardware Divide
cpuid: 0 |
Performance at 50.0 MHz Up to 8 DMIPS ‘Up to 32 DMIPS =
Logic Usage 600-700 LE= j12cm-14ﬂn LE= 2|
Hardware Multiply: | Embedded Muttipliers b | [] Hardware Divide
Reset Vector: Memory: | o |0ffset ||jx[| |
Exception Vector: Memory: | I | Offzet: |ngg |
[] inciude MMU
Only include the MMU when using an operating system that explicitly =upports an MMU
Fast TLB Mizs Exception Vector: Memory: Off=zet: |60
[] include MPU

", Warning: Reset vector and Exception vector cannot be set until memory devices are connected to the Nios |l processor

ancel Back

(]

Figure 7-15 Nios Il Processor

9. Click Finish to return to main window as shown in Figure 7-16.
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™ Altera S50PC Builder

File Edit Module System WView Tools Niosll Help

—————
System Contents | System Generation|

Component Library Target Clock Settings
Project Device Famiy;{ Cyclone VE % | Name Source MHz
l}é few component.... =
Library Remove
[ -Avalon Verification Suite
[+-Bridges and Adapters
[#-Interface Protocols
[#-Legacy Components Use  Conn.. Wodule Description Clock Base End
[#-Memories and Memory Controllers B cpu 0 Hios Il Processor [k
e Hesdn Components. instruction_master | Avalon Memory Mapped Master clk_50
&-Peripherals 5 data_master Avalon Memory Mapped Master o] IRQ o
Be-PLL tag_debug_module Avalon Memory Mapped Slave [clk] 0x00000800 |0200000£1E
[#-Processor Additions
[=-Processors
@515
[#-University Program
#-Video and Image Processing
< | ¥
2 | . - I "

Edit. = s v X Address Map... ] ’Eﬁters... ] Fitter: Default

7 To Do: cpu_0; No reset vector has been specified for this CPU. Please parameterize the CPU o resolve this issue
27 1o Do: cpu_0: No exception vector has been specified for this CPU. Please parameterize the CPU to resolve this issue
‘4, Warning: cpu_0: Reset vector and Exception vector cannot be set until memory devices are connected to the Nios Il processor

Help 4 Pre [ Next ] ’ Generate ]

Figure 7-16 Add Nios Il CPU completely

10. Select the cpu_0 component and right-click then select rename, after this, you can update
cpu_0 to cpu, as shown in Figure 7-17 and Figure 7-18.
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W Altera 50PC Builder

File Edit Module System View Tools Niosll Help

System Contents | System Generation

Target Clock Settings:

. -
Device Family: Cyclone W E | Name Source MHz |

#-Awalon Verification Suite
+-Bridges and Adapters
[#-Interface Protocols
#--Legacy Components:
#--Memories and Memory Controflers
[=--Merlin Components
#-Peripherals
A1 | Mapped Slave
#-Processor Additions | ahOWEonneckd
=)-Processors v Default
W Nio= 1| Processor Al
H-5LS
Clocks
-University Program
F-Video and Image Processing Avalon-MM
Awvalon-5T
£ Il | B | Edit Crl+E
Rename rl+R
1% e | Rename _____ctrs | | =
1 Remove
[‘“‘m ] [ Remove ] [E‘ﬂ ] | Details » Address Map.. ] [Eﬂters ] Fitter: Default

Show Arbitration

& To Do: cpu_0: No reset vector has been specified for this CPU. PlBB’
= To Do: cpu_0: No exception vector has been specified for this CPU.! . = Ad -+ 1 |olve this issue
‘4, Warning: cpu_0: Reset vector and Exception vector cannot be st qu fto the Nios Il processor

_|this issue

1
|_ Me_x{_b%_] Generate

Figure 7-17 Rename the CPU (1)

I Altera S50PC Builder |’L“E|g|

File Edit Modwle System View Tools Niosil Help

System Contents | System Generationl

Component Library Target Clock Settings

S e e ER
Device Famiy: Cycione VE | | Name Source MHz
i — -~ L)

Library
“Awalon Verification Suite

L

-Bridges and Adapters
-Interface Protocols

Pt o B o

-Legacy Components Use Conn..., Module Description Clock Base End
Memories and Memory Controller:

‘Meriin Components instruction_master Awalon Memory Mapped Master cik_50
Peripherals

data_master /Avalon Memory Mapped Master k] IR O
PLL jtag_debug_module /Avalon Memory Mapped Slave cki 0x00000800 |0xCO0000EEE
Processor Additions

Processors

515

-University Program

-Wideo and Image Processing

Fru 8 zu R ca 8 - 8 a8 101

i g

il

-
b

&
i)

. o | >

[ Add... ] [ Remove ] [ Edit... ] = || al||[lw | = Address Map... ] [ Fiters. . ] Fitter: Default

=7 To Do: cpu: No reset vector has been specified for this CPU. Please parameterize the CPU to resolve this issue
C7 To Do: epu: No exception vector has been specified for this CPU. Please parameterize the CPU to resolive this issue
‘1., Warning: cpu: Reset vector and Exception vector cannot be set until memory devices are connected to the Nios Il processor

Figure 7-18 Rename the CPU (2)
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11. Add a second component by selecting Library > Interface Protocols > Serial > JTAG UART
and clicking the Add... button, as shown in Figure 7-19 and Figure 7-20.

B Altera S0PC Builder

Fie Edit Module System View To

System Contents | System Generation

Component Library

Project

e ﬂg New component...

Library

---Avah:m Werification Suite

---Eri:lges and Adapters

-Interface Protocols

- AS]

Ethernat

High Speed

Interlaken

&-PCl

S0

= Serial W
- ® Avalon-ST JTAG

[ >

@ Awvalon-5T Serial
» SPI(3 Wire Serial
+ UART (R5-232 S«

t-Legacy Components bt
£ | >

Bl

Figure 7-19 Add the JTAG UART component
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I JTTAG TAET — jtag uart 0

JTAG UART

Megaters'  alftera_avalon_jtag_uart

|"' Block Diagram

jtag_uart_0
clock B=clk ire = interrupl
reset ™roset

avalon ™= avglon_jtag_slave

'~ Write FIFO (Data from Avalon to JTAG)

Buffer depth (bytes): | ga !
IRQ threshold: s '

|:| Con=truct using registers instead of memory blocks

'~ Read FIFO (Data from JTAG to Avalon)

Buffer depth (bytes): (g4 w |
IRQ threshold: |3 |

|:| Construct uging registers instead of memory blocks

|"' Simulated input character stream
Contents:

|" Prepare interactive windows
Options: INTERACTIVE_ASCH OUTPUT |»

| cancel || Fmsn |

Figure 7-20 JTAG UART’s add wizard

12. We are going to use the default settings for this component, so click Finish to close the wizard
and return to the window as shown in Figure 7-21.
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™ Altera S0PC Builder

Fie Edit Module System View Tools HNiosll Help

Component Library Target Clock Settings

5 ;IO ||
Project ~ Device Family: Cyclone WE & | Name Source MHz

-5 New component. . = External
Library

#i--Awvalon Verification Suite
#-Bridges and Adapters
=l-interface Protocols

G-AS : Uze | Conn.. Module Description Clock Base End
[-Ethernet
EJH'gh Speed inetruction_master Avalon Memory Mapped Master clk_50
- interiaken data_master Avalon Memory Mapped Master [clk] IRQ ©
-PCl jtag debug_module  |Avalon Memory Mapped Slave [cik] 0x00000800  |0xO0000£EE
B B jag_uart 0 JTAG UART [clk
avalon_jtag_slave Avalon Memory Mapped Slave clk_50
' Avalon-5T JTAG

' Awvalon-5T Serial
+ SP (3 Wire Serial
- @ UART (R5-232 S«
#-Legacy Components |
< Al | 2|

| %

| »
[ Address Map... ] [ Filters... ] Filter; Default

£ To Do: cpu: No reset vector has been specified for this CPU. Please parameterize the CPU to resolve this issue
= ToDo: cpu: No exception vector has been specified for this CPU. Please parameterize the CPU to resolve this issue
‘4 Warning: cpu: Reset vector and Exception vector cannot be set until memory devices are connected to the Nios |l processor

(Add._ | | [Remove |[Eit. | = | a

drev [ Neth | [ Generate |

Figure 7-21 JTAG UART

13. Select the jtag_uart_0 component and rename it to jtag_uart as shown in Figure 7-22.
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™ Altera S0PC Builder

B
Fie Edit Module System View Tools HNiosll Help

&
P

Component Library Target Clock Settings
: o T 1|
Project 4| | DeviceFamiy:Cycione VE v | | Name Source MHz |
Library Remov

£--Awvalon Verification Suite
#-Bridges and Adapters
=l-interface Protocols

E;J--ASI Usze | Conn.. Module De=cription Clock Base End
G- Ethemet = cpu Nios Il Processor ekl
(+-High Speed instruction_master Avalon Memory Mapped Master clk_50
(-Interiaken data_master Avalon Memory Mapped Master [clk] IRQ ©
-PCl g jftag_debug_module  |Avalon Memory Mapped Slave [cik] 0X000CO800 |0x00000£EE
&S0l H i JTAG UART g
avalon_jtag_slave Avalon Memory Mapped Slave clk_50 0x 00000000 |0z00000007
Avalan-5T JTAG
@ Avalon-ST Serial
:
3 SPI (3 Wire Serial
L@ UART (RS-232 S
#-Legacy Components s
< Al | 2|
g | | %

2t |

Edi. (Add._ | | [ Removs | [ Edt. ] E v | = [AddessMap_ | [Fiers. | Fier; Defaut

£ To Do: cpu: No reset vector has been specified for this CPU. Please parameterize the CPU to resolve this issue
= ToDo: cpu: No exception vector has been specified for this CPU. Please parameterize the CPU to resolve this issue
‘4 Warning: cpu: Reset vector and Exception vector cannot be set until memory devices are connected to the Nios |l processor

o | ] [oomoe ]

Figure 7-22 Rename JTAG UART

15. Add the Library > Memories and Memory Controllers > On-Chip > On-Chip Memory
(RAM or ROM) component to system, as shown in Figure 7-23 and Figure 7-24.

97
Terasic DEO-Nano User Manual

Www. Lerasic. com,

www.terasic.com




B Altera SOPC Builder

File Edit Module System View Toole Niosll Help

System Contents | System Generation

Cormponent Library

[#-Avalon Verification Suite
Bridges and Adapters
Interface Protocolz
Legacy Components
I_i—_l---!.'lernnriﬁs and Memory Controliers
- @ DDR2 SDRAM Controller with UniPHY (New!)
- @ DDR3 SDRAM Controller with UniPHY (New!)
- @ QDR land QDR I+ SRAN Controller with UniPHY
- @ RLDRAM Il Controller with UniPHY
- @ Traffic Generator and BIST Engine (New!)
[#-DMA
[+}-Flash
[=+-On-Chip
- ® Avalon-ST Dual Clock FIFO
o Avalon-5T Multi-Channel Shared Memaory FIFO
@ Avalon-5T Round Robin Scheduler
o Avalon-5T Single Clock FIFO
i @ 0On-Chip FIFO Memory
N (- Chip Memory (RAM or ROM)
[+ SDRA A

[ >

Figure 7-23 Add On-Chip Memory
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® On—Chip Nemory (EAN or RON) — onchip memory? 0

On-Chip Memory (RAM or ROM)

MagoCors” altera_avalon_onchip_memory2

|" Block Diagram

onchip_memory2 0
clock ™=clk1

avalon ¥=s
tecet ™= rosot

|"' Memory type
Type: |F|AI'|'I (Writable) %

[ ] Duakport access
Read During Write Mode:
Block type:

|" Size

Data width:

Total memory size:

™ Read latency
Slave =1 Latency:

Slave =2 Latency:

|"' Memory inttialization
initiglize memory content

| cancel || Finish ]

Figure 7-24 On-Chip Memory Box

16. Modify Total memory size setting to 26000 as shown in Figure 7-25. Click Finish to return to
the window as in Figure 7-26.
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® On—Chip Nemory (EAN or REON) - onchip_memory? 0

On-Chip Memory (RAM or ROM)

Megatars’ altera_avalon_onchip_memory2

S
Docurmentation

7

4

|"' Block Diagram

ionchip_memory2_0
clock ™=clki

avalon #s
tecet™rocatl

|' Memory type

Type: | RAM (Writable) |+

[ ] Dual-port access
Read During Write Mode: ONT_CARE

Block type: | Auto | v |

-~ Size

Data width: |32_ v|

Total memory size: | ZEU.D[]{

~ Read latency

Slave =1 Latency: 1 v|

Slave =2 Latency:

'~ Memory initialization

Initialize memory content

| cancel || Finisn |

Figure 7-25 Update Total memory size
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™ pltera SOPC Builder =]
Fie Edit Module System View Tool Niosll Help

System Contents | System Generaton|

Component Library Target Clock Settings
[#--Avalon Verification Suite -~ Device Famﬂyi Cyclone W E I Name Source MHz m
-Bridges and Adapters = ' =
H-Interface Protocolz &
H-Legacy Components
=-Memories and Memory Controllers
@ DDR2 SDRAM Controller with UniPHY {Newl)
~ @ DDR3 SDRAM Controller with UniPHY {Mew!) Use Conn.... Module Description Clock Base
4 QDR Il and QDR ll+ SRAM Controller with UniPHY o epu Nios 1 Processor k]
=W HLDEAN N Controller with UanH.Y instruction_master Awvalon Memory Mapped Master clk_50
- @ Traffic Generator and BIST Engine (New!) ey Pt Avalon Memory Mapped Master Tchk]
:. ?::n [— jtag_debug_module Avalon Memory Mapped Slave [ck] Oz 000
EOn-Chip avalon_jtag_slave Avalon Memory Mapped Slave clk_50 0z 000
Anminn ST Ol Cack FEO == Bl onchip_memory2_0 On-Chip Memory (RAM or ROM) ek
Awvalon-ST Mutti-Channel Shared Memory FIFO =1 Avalon Memory Mapped Slave ok 50 000
Awalon-ST Round Robin Scheduler -
Awvalon-ST Single Clock FIFO
On-Chip FIFO Memory
On-Chip Memory (RAM or ROM)
- SDRAM et
2 | % |l i | 5
E Remeve | [0t | [ = ] [ ][=] [aduessmep. | [Eers.. | Fiter Detaut
3 Error: cpu.instruction_master: onchip_memory2_0.s1 cannot be at 0x2000 (0x0 or 010000 are acceplable)
Q Error: cpu.data_master: onchip_memeory2_0.s1 cannot be at 0x2000 (0x0 or 0x10000 are acceptable)
=7 To Do: cpu: No reset vector has been specified for this CPU. Please parameterize the CPU to resolve this issue
2 Yo Do cpu: No exception vector has been specified for this CPU. Please parameterize the CPU to resolve this issue

4 Prev [ Next [p ] [ Generate J

Figure 7-26 Add On-Chip memory

17. Rename onchip_memory2_0 to onchip_memory2 as shown in Figure 7-27.

= Altera SOPC Builder

Fie Edt Module System View Tools Niosll Help

System Contents | System Generation

Component Library Target Clock Setlings:
~ Device Famﬂy;{ Cyclone WE | » ‘ Name ‘Source MHz |
cik_50 External 50.0 -
+-Legacy Componenis
= Memories and Memory Controllers
DDR2 SDRAM Controller with UniPHY (New!)
DDR3 SDRAM Controller with UniPHY (New!) Use Conn... Module Description Clock Base
QDR Il and QDR I+ SRAM Controller with UniPHY = — . oKl
REDECAM § Controfier with Uiy instruction_master |Avalon Memory Mapped Master cik_50
@ Traffic Generator and BIST Engine (New!} LS ki Wy W Wisietos -
B O, - jtag_debug_module \Avalon Memory Mapped Slave =] ox00C
E-Flash B jtag_uart UTAG UART [ek]
[_}--Drpcrup avalon_jtag_slave \Avalon Memory Mapped Slave clk_50 o0x00(
o Auside ST NG Clock FIEG = i On_Chip Memory (RAM or ROM)
® Awalon-ST Multi-Channel Shared Memory FIFO s = A MEeoEy NS == e
@ Awalon-ST Round Robin Scheduler o=
Avalon-ST Single Clock FIFO
On-Chip FIFO Memory
Dn-Chip Memory (RAM or ROM)
-
[% g i | >
. [Adga. | | [ Remove | [Edt. | [E] v |[[= [(Adoressmap | [Fiers. | Fiter Defaut

3 Error: cpu.instruction_master: onchip_memory2.s1 cannot be at 0x2000 (0x0 or 0x10000 are acceptable)
E3 Error: cpu.data_master: onchip_memory2.s1 cannot be at 0x2000 (0x0 or 0x10000 are acceptable)

To Do: cpu: No reset vector has been specified for this CPU. Please parameterize the CPU to resolve this issue

To Do: cpu: No exception vector has been specified for this CPU. Please parameterize the CPU to resolve this issue

Figure 7-27 Rename On-Chip memory

Cren b ] [oowme |

18. Right click on the cpu component table and select Edit... from the list. Update the Reset Vector
and Exception Vector as shown in Figure 7-28. Then, click Finish to return to the window as
shown Figure 7-29.
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I Nios II Processor — cpu [g|

Nios II Processor

MM and MPU Setting 2 TTAG Debug Module 2 Custom Instruction
Core Nios Il
Select a Nios ll core:
: > < |
ONios Ilfe ONios ll/s =
. RISC RISC
Nios Il 32-bit 32-bit
Selector Guide Instruction Cache Instruction Cache
Family: Cyclone IV E \Branch Prediction Branch Prediction
Hardware Multiply ‘Hardware Multiply =
Teystem: 50.0 MHz Hardware Divide Hardware Divide
couid: 0 Barrel Shifter
Performance at 50.0 MHz Up to & DMIPS :Up to 32 DMIPS =
Logic Usage /600-700 LEs 1200-1400 LE= 1400-1800 LE= |
Hardware Multiply: | Embedded Multipliers “ | [] Hardware Divide
ResetVector  Memory:| onchip_memory2 | Offset: 0x0 |0x00002000
Exception Wector: Memory: | onchip_memory2 v | Offset: |Clx2El |ﬂxﬂDDﬂ2ﬂf-.‘ﬂ
[] include MU
Only include the MMU when using an operating system that explicithy supports an MMU
Fast TLB Miss Exception Vector: Memory: Off=zet: |04
[] include MPU

Figure 7-28 Update CPU settings
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W Altera SOPC Builder EJ@[X]

File Edit Module System Wiew Tools Niosll Help

System Contents | System Generation|
Component Library Target BRI

Z
1=
g
5
=
£
i
5
7]
E
&
|

-Bridge=s and Adapters

-Interface Protocols

-Legacy Components

- Memories and Memory Controllers

- @ DDR2 SDRAM Controller with UniPHY (New!)
DDR3 SDRAM Controller with UniPHY (New?) Use Conn... Module Diescription Clock Base
QDR Il and QDR I+ SRAM Controller with UniPHY Nios Il Processor

HEDRAM N Confroder with Ling iy - instruction_master Avalon Memory Magped Master clk_50
@ Traffic Generator and BIST Engine (New!) data_master Avalon Memory Mapped Master [clk]

- DMA jtag_debug_module Awvalon Memory Mapped Slave [cik] 0x00(
i-Flash g B jtag_uart JTAG UART [elk]
=+ 0n-Chip avalon_jtag_slave Avalon Memory Mapped Slave clk_50 0x00(
% Asions3) el Sock EHO — B onchip_memory2 On-Chip Memary (RAM or ROM) [clk1]

o Awvalon-ST Multi-Channel Shared Memory FIFO =1 Avalon Memory Mapped Slave clk_50 ox00C
Awvalon-5T Round Robin Scheduler

@ Avalon-5T Single Clock FIFO
On-Chip FIFO Memory

On-Chip Memory (RAM or ROM)

+-SORAM w

Device Famiﬂ Cyclone WE w Name Source MHz |

o

1% g | >

Edi. [Am...] [Rer_mve”gnu... ] = || - E [Aﬂdress Map... ] [fiaers... ] Fiter: Defautt

e Error: cpu.instruction_master: onchip_memory2.s1 cannot be at 0x2000 (0x0 or 0x10000 are acceptable)
e Error: cpu.data_master: onchip_memory2.s1 cannot be at 0x2000 (0x0 or 0x10000 are acceptable)

Help 4 Frev [ Next |» ] [ Generate ]

Figure 7-29 Updated CPU settings

19. Add the Library > Peripherals > Microcontroller Peripherals >PIO (Parallel 1/0)
component to the system, as shown in Figure 7-30 and Figure 7-31.
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B Altera S50PC Builder

File Edit Module System View Toole HNiosll

System Content® | System Generation

Cormponent Library

Project

. g New component...
Library

[#--Avalon Verification Suite
[#/--Bridge= and Adapters
[#--Interface Protocolz
=
[
[

H-Legacy Components

H-Merlin Components
[=-Peripheralz

--Del:rug and Performance
- Display

[+-FPGA Peripherals
E}--Micrucuntrull&r Peripherals
. o Interval Timer

-0 (Parallel 10)

[#-PLL
[#-Processor Additions
[#-Processors

H-Memories and Memory Controllers

--Murtiprul:»&ssur Coordination

[

Figure 7-30 Add PIO
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™ P10 (Parallel I/0) — pio 0

PIO (Parallel I/O)

Megotors altera_avalon_pio

|"' Block Diagram

clock ®=elk
recet®™reset
avalon ™51
conduit ™ esternal_connection

|' -Basic Settings
Width {1-32 bit=): ig

Direction: {::, Bidir
) Input
{:} InCut

(%) Output
Output Port Reset Value: |uxuuuuuuuuuuuuuuuu

'~ Output Register

|:| Enable individual bit 2etting/clearing

|' Edge capture register

Synchronoushly capt

Edge Type:

| cancel || Fimisn |

Figure 7-31 Add PIO

20. Click Finish to use the default settings for this component. This closes the PIO wizard and
returns to the window shown in Figure 7-32.
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= Altera SOPC Builder

File Edit Module Swystem View Tools Niosll Help

—
System Contents | System Generation |

Component Library Target Cleck Settings
Project -~ Device Family] Cyclone W E | v Name Source MHz
1 New component... —_——— “Jic
Library
[#-Avalon Verification Suite
[#-Bridges and Adapters
[#}-interface Protocols
#-Legacy Components
[+ Memaories and Memory Controllers TR T
- lerhn Companents. = instruction_master Avalon Memory Mapped Master clk_50
=-Peripherals data_master Avalon Memory Mapped Master ik
G-Debug and Performance ftag_debug_module Avalon Memory Mapped Slave [cik] Ox000]
E-Display Bl jtag_vart ITAG UART [cik]
- FPGA Peripherals avalon_jtag_slave Avalon Memory Mapped Slave clk_50 Ox 000
j:Micxoconiroties Berpherni El onchip_memory2 On-Chip Memory (RAM or ROM) k1]
i Interval Timer =1 Avalon Memory Mapped Slave clk_50 Ox000]
- Bl pio_0 PIO (Paraliel 1O} [cik]
- Multiprocessor Coordination B =1 Avalon Memory Mapped Slave clk_50 0x000]
-PLL
- Processor Additions
[ -Processors »
2 | | ¢ = | >
[Aga. | | [remove |[Ear. | | = | = [ Addressmap... | [ Eiters.. | Fiter Deraur

Q Error: cpu.instruction_master: onchip_memory2.s1 cannot be at 0x2000 (0x0 or 0x10000 are acceptable)
Q Error: cpu.data_master: onchip_memory2.s1 cannot be at 0x2000 (0=0 or 0x10000 are acceptable)

4 7= [ netp | [ cenerats

Figure 7-32 PIO

21. Rename pio_0 to pio_led as shown in Figure 7-33.

I Altera 50PC Builder

Fie Edit Module System View Tools HNiosll Help

Component Library Target Clock Settings
Project ~ Device Fami}d CycloneWE | v Name Source MHz |
Library
#-Avalon Verification Sutte
[#-Bridges and Adapters
[#-Interface Protocols
- Legacy Components Use | Conn.. Module Description Clock Base
[*-Memories and Memory Controflers B cpu Mios Il Processor [cik]
d-Merin Components: instruction_master Avalon Memory Mapped Master clk_50
=-Peripherals data_master Avalon Memory Mapped Master [clk]
* Debug and Performance f jtag_debug_module Avalon Memory Mapped Slave [clk] 0x 00
G- Display B jtag_uart ITAG UART [ck]
:ﬁJFPGA Peripherals ) avalon_jtag_slave Avalon Memory Mapped Slave clk_50 0x00(
k- Micenconkroler Perinherals Bl onchip_memory2 On-Chip Memory (RAM or ROM) [ck1]
interval Timer f* =1 Avalon Memory Mapped Slave cik_50 0x00(
PIC {Parallel IO} PIO {Paraliel VO)
[+ Multiprocessor Coordination o
E-PLL
[#-Processor Additions
#-Processors et
- | x & IfiTE i b3
[Aﬂﬁ...] [Rer_nuve J [ Ed... ] v || = [Andrass Wap... ] [Emers... ] Filter: Defautt
0 Error: cpu.instruction_master: onchip_memory2.e1 cannot be at 0x2000 (0x0 or Ox10000 are acceptable)
9 Error: cpu.data_master: onchip_memory2.s1 cannot be at 02000 (0=0 or 0:x10000 are acceptable)
[ next b | [ cenerte
Figure 7-33 Rename PIO
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22. Select System > Auto-Assign Base Addresses as shown in Figure 7-34. Then, select File >

Refresh System. After that you will find that there is no error in the message window as shown in
Figure 7-35.

| = sltera SOPC Builder =13

ile it jodule BSE=ull View Tools Niosll Help

System Contents Auto-Assign Base Addresses

Auto-Assign IRQs

Clock Settings
Insert Avalon-ST Adapters vl
| Show Transformed System £ Device Fa'm'ﬂy.! Cyclone VE &
“o=m
t-Awalon Verification Suite
|-Bridges and Adapters
Interface Protocols
|-Legacy Components Use Conn... Module Description Clock Base
Memories and Memory Controllers B cpu Nios Il Processor [clk]
Mer.lin Components ingtruction_master Avalon Memory Mapped Master clk_50
ripherals data_master Avalon Memory Mapped Master [cik]
+-Debug and Performance f jtag_debug_module Avalon Memory Mapped Slave [cik] 0x00C
[#- Display B jtag_uart JTAG UART [cik]
[#-FPGA Peripherals avalon_jtag_slave Avalon Memory Mapped Slave clk_50 0x00C
-Microcontroller Peripherais El onchip_memory2 On-Chip Memory (RAM or ROM) [cik1]
I @ Interval Timer fe =1 Avalon Memory Mapped Slave clk_50 0x00C
M PO (Parallel VO) PIO (Paraliel O ]
Muttiprocessor Coordination | =1 |Avalon Memory Mapped Slave |etk_50 oxood
~
| % = | >
[Aga. ] | [ Remove | [ gar. | v || = Address Map.. | [ Eiters. | Fiter: Defaut
Q Error: cpu.instruction_master: onchip_memory2.s1 cannot be at 0x2000 (0x0 or 0x10000 are acceptable)
e Error: cpu.data_master: onchip_memory2.s1 cannot be at 0x2000 (0x0 or 0x10000 are acceptable)
Help 4 [ Next [ ] [ Generate ]

Figure 7-34 Auto-Assign Base Addresses

™ Altera S0PC Builder [:“E”zl

File Edit Module System Wiew Tools Niosll Help

System Contents | System Generation

Component Library Target Clock Settings
Project "~ Device Family: Cyclone WE % Name Source MH=
o New component.. — =7 clk_50 External 50.0
Library
Awalon Verification Suite
Bridges and Adapters
Interface Protocols =
Legacy Components: Use Conn.... Module Des=scription Clock Base
Memories and Memory Controllers: B cpu Mios || Processor [clk]
@ DDH2 SDRAM Controfler with Uni instruction_master avalon Memory Mapped Master cik_50
DO SREUAM Contiolir Wil data_master Avalon Memory Mapped Master Iclk] IRQ O
QDR Nl and QDR I+ SRAM Controi= ftag_debug_module Avalon Memory Mapped Siave [ck] 0x 00010800 |
RLDRAM Il Controller with UniPH B jtag_uart ITAG UART okl
» Traffic Generator and BIST Engir avalon_jtag_slave Avalon Memory Mapped Slave clk_50 ' 0x00011010 |C
DMA, E onchip_memory2 On-Chip Memory (RAM or ROM) [chki]
Fiash =1 Axalon Memory Mapped Stave clk_50 0x 00008000 (g
On-Chip = pio_led PIO (Paraliel 10} i)
SDRAM =1 Awalon Memory Mapped Slave clk_50 © Oox 00011000 |
- SRAM
[&-Meriin Components e
< I >
o | | x a | >
Ed = i v = [ Address Map... ] [ Filters... J Fitter: Default

4 Warning: cpu: Custom Instruction components can be edited through the Component Editor. |

* Warning: cpu: Disabling the assign CPUID control register value manually will no longer auto-assigns unique control register value. This option will always be turned on with default|]

£l i | »

o |Cmr ] (oo

Figure 7-35 No errors or warnings
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23. Click the Generate button, which will pop up a window, as shown in Figure 7-36. Click Save,
which bring up the window in Figure 7-37. Input the name, DEO_NANO_SOPC, and click the
save button. The compilation will automatically start. If there are no errors in the generation, the
window will show a message of success, as shown in Figure 7-38.

Save changes?

\::) Save changes to unnamed?

|1 Save ,I [Ill:-n’ £ Sa?e] [ Cancel ]

Figure 7-36 Generate SOPC

= Save E

Save in; ||ﬁ tryfirat_miosii v| _ﬁ‘ PEE
[ I =opc_builder
L I=) b
My Recent
Docurnents
@
Deskkop

My Docurments
L

My Computer

Nl
A File niame: DE0_MANO_SOPC| | [ save |
Ml Mebwiork,
Places Files of type: | SOPC Buider System Files (*.50pc) v| Cancel

Figure 7-37 Generate SOPC
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= Altera SOPC Builder - DEO_NANO_SOPC.sopc (D:\myﬁrst_niosii\DEﬂ_N.ﬁNO_SOPCksopc]
File Edit Module System “iew Toolz Nios il Help »

I_| System Contents [

Options -
System module logic will be created in Yerilog.

|:| Simulation. Creste project simulstor files, Run Simulator

Mioz Il Taols

[ Mios || Software Build Tools for Eclipse J

#2011 .02.24 13:23:09 (*) Generating Guartus symbol for top level: DEO_MANO_SOPC

[

#2011.02.24 13:23:09 (*) Generating Symbol 0 dnyfirst_niosi/DED_NANG _SOPC bef
#2011 .02.24 13:23:09 (*) Creating command-line system-generation script: Dumyfirst_niosi/DED_MANO_SOPC_generstion_script
#2011 .02.24 13:23:09 (*) Running setup for HOL simulstor: modelsim
#2011.02.24 132310 (*) Completed generation for system: DED_NAND_SCOPC.
#2011.02.24 13:23:10 (*) THE FOLLCWING SY'STEM ITEMS HANE BEEM GENERATED:
SOPC Builder databasze : Domyfirst_niosiDED_MAND _SOPC ptf
System HOL Model : D:hnyfirst_niosiDED_MAMD _SOPC .y
System Generation Script : Domyfirst _niosiiDED_NANG_SOPC_generation_script

#2011.02.24 13:23:10 (%) SUCCESS: SY'STEM GENERATION COMPLETED.
£ [l

15 [

o Warning: epu: Custom Instruction components can be edited through the Component Editor.

o Warning: epu: Disabling the assign CPUID cortrol register value manually swill no longer auto-assigns unigue contral register value. Thiz aption will abways be turned on with defa

< 1]
[ Exit ] [ Help ] [ 4 Prev J Mext P |

Figure 7-38 SOPC Builder generation successful

24. Click Exit to exit the SOPC Builder and return to the window as shown in Figure 7-39

Quartus IT — D:fayfirst niosziifayfirst_nios

Fle Edit Mew Project Assignments Processing Tools Window Help

DEHG & $B@ o~
myfist_iosi V3N s SRS TR BOH S L EL 0D

Project Mavigator & X

Entity
Cydlane IV E: EP4CE22F 1705

Fies | & Design Units |

Status g x|
Module 7 Progress & Time
@ View New Quartus II
Information
Documentation
- /I . T
; Type Message

\_System /\_Processing J\_Extra Info J/\_Info J/\ Warning f\_Critical Warnina /%\_Error /% Suppressed [\ _Flag [
IMEssage.' t 1 9 |Locaticn: Locate

0% 00:00:00

| Messages

Figure 7-39 Return to Quartus Il after exiting SOPC Builder
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25. Create a new Verilog HDL file, by selecting File > New, Verilog HDL File and click OK, as
shown in Figure 7-40 and Figure 7-41.

Quartus IT — D:/ayfirst_niozii/my

Edit View Project Assignments  Processing

i Mew... Cirl+N x

& open... Ctrl+0

@ Mew Project Wizard. ..
E? Open Project... Ctrl+
Save Project

Close Project -
=

E save al Ctrl45hift+5

Create [ Update 4

Convert Programming Files. ..

o) B

Recent Files k
Recent Projects 4
Exit Alt+F4

Figure 7-40 New Verilog file

Mew Quartus II Project
SOPC Builder System

=} Design Files
AHDL File
Block Diagram/Schematic File
EDIF File
Qsys System File
State Machine File
SystemVerilog HDL File
T Script File
WHDL File

= Memory Files
Hexadecimal {Intel-Format) File
Memory Initialization File

=)+ VYerification/Debugging Files
In-System Sources and Probes File
Logic Analyzer Interface File
SignalTap II Logic Analyzer File

= Other Files
AHDL Incude File
Block Symbal File
Chain Description File
Synopsys Design Constraints File
Text File

[ QK ] [ Cancel ] [ Help ]

Figure 7-41 New Verilog File
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33. Figure 7-42 show a blank Verilog file.

2 Quartus IL — D:/myfirst niosii/myfirst niosii — myfirst niosii

_E_il_e__ g_d_it Miew Project Assignments  Processing Tools Window Help

T hheEdag & & B 0 o

myfrstoos VMY RS T > TO Y aaA e D
 Project Navigator —— 5x‘| £ verilog Ly B | o

A% %% 0 T K Rl | 2E -

Entity
Cyclone IV E: EP4CEZ3F 17C6 1 |
- = myfirst_niosi .{ﬁﬂ

&y tierarchy | B Files | & Design Units |

Status g x|
Module ¥ Progress & Time
< | >
—
| 2<
E’E Tvpe Message
|

@

il

g: \_System /\_Processing J/\_Extra Info /\_Info /\_Warning /\_Critical Warning /%_Error /\_Suppressed /\_Flag /

a |

:gilMeSSBQE + = ILocauon: Locate

0% 00:00:00

Figure 7-42 A blank verilog file

34. Type the following Verilog into the blank file, as shown in Figure 7-43. The module
DEO_NANO_SOPC is the system created by SOPC Builder and its Verilog can be found in the
DEO_NANO_SOPC.v file, as shown in
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Open File

Look in; J =3 mlirst_niosii

s - ®EckE-

|53 sopc_builder

)

cpu_rult_cell.v

hy Documents

|| DED. MR

jEag_uart.y
myFirst_niosii, v
onchip_memaryE v

pio_led. v

Db
MyRecent  [C5)DED_MANO SOPC_sim
Documents |:|:|L| =
@ cpu_]'tag_debug_mudule_sysclk.\-'
cpu_itag_del:uug_mu:udule_tck.v
[Deszkiop

cpu_]'tag_del:uug_mu:udule_wrapper.v

@ cpu_oci_test_bench.y
cpu_test_bench,w
DEQ_MARNOD_SOPC.ptf
DEQ_MAND_SOPC.sopc

=] DED_MaND_SoPC,sapdinfo

DEO_MAND_SOPC_insk,w

@

b Metwork, File name:
Flaces
Files of type: .
Open as:

\DE0_NAND_SOFC.v

2

]Design Files [*.tdf *.vhd * vhdl *.v *vig “.verilu:ug_:!

[~ &dd file to current project

J.-'l'l.utn

2|

Open 1
Cancel

o

Figure 7-44 and Figure 7-45.

module myfirst_niosii

(
CLOCK_50,
LED
);
input CLOCK_50;

output [7:0] LED;

DEO_NANO_SOPC DEO_NANO_SOPC_inst

(CLOCK_50),

(1'v1)

(
.clk 50
.out_port_from_the_pio_led (LED),
.reset_n
);
endmodule
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File Edit WView Project Assignments

DEHE & sB@ -~

Processing Tools Window Help

|myfirst_niosi

Project Navigator

ﬁlx ! & myfirst_niosii.v a

Entity

¥

Cyclone IV E: EP4CE22F 1706 32
G pbd myfirst_niosii e_ﬁﬂ

B o #NT

A%FH%RHB 1T BB | =

/" Major Functions: myfirst niosii

/ Rewvision History :

Ver :| Author

V1.0 :| Yagun-chang

| Mod. Date

| D2/16/2011

42 [Hmodule myfirst niosii

43 B

54 CLOCK_50,

45 LED

46 F)s

&7 input CLOCE 50;

43 output [7:0] LED:

49 DEO_NAENC SOPC DEQ_HANO SOBC inst
50 H (

51 .clk 50

52 .out port from the pio led
53 .reset n

L - 1

L r
5 56 —endmodule

(LED) ,
(1'bl)

Hierardﬁy | Bl Fies |‘ &P Design Urits | ¥

(CLOCK_50),

»

3

0% 00:00:00

Figure 7-43 Input verilog Text

Look ir; | I3 mufirzt_miogi __:J

My Fecent
Documents

Ry
0l

Dezktop

My Documents
by Compriter

-

hdy Metwork.
Flaces

= B cf E-

jrag_uart.w

rryFirsk_niosii. v
onchip_memoryz .«

pin_led.w

|7 sopc_builder

)b

[CTIDED_MAMO_SOPC_sim

CRULY
cpu_]'tag_del:uug_mu:udule_sysclk.v
cpu_itag_dehug_mndule_tck.v
u:pu _jtag_debug_module_wrapper, v
cpu_mule_cell.w

@ cpu_oci_test_bench.v
cpu_test_bench.v
DED_MAND_SOPC,ptf
DED_MANO_SOPC.sopc
DED_MANC_SOPC.sopeinfo
[l|DED_MAND_SORPC.w

DEQ_MAMS SOPC_inst.v

File name: \DEO_NAND_SOFC.v |

Files of type: JDesign Files [*.tdf " vhd " vhdl *v *vig ”.verilng_:]
™ Add file to currert project

Open az: J.-’-'uutn _L]

Open |
Cancel

,

Figure 7-44 Open DEO_NANO_SOPC.v
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File Edit Miew Project Assignments Processing Tools Window Help

DEE@ & éé@._nt_“x

et ot RY @O T PN BD OB 25 0O

Praject Navigator ax| & myfirst_niosii,v 0| £ oeonwoscecy @ |

o BANT FE ARARA VS B S | =32
Cyclone IV E: EPACE22F17C6 2087

I8 ket viot o] 2088 [module DEJ_NANO SOPC |

2088 // 1) global signals:

2080 clk 50,

2091 reset_m,

2092
2093 // the pio led

2094 o'at_part_from_the_pio_lled
2085 - )

2096
2097
2098 output [ 7: 0] out_port from the pic led;

2099 input clk 30; ==
2100 input reset_n;

i ] I ¥ [|z101 B

o T 2102 wire elk 50 reset n: v
ierarchy | Fies | @ DesignUnits | ¢ | 5

>3

Type| Message

| \_System /f\_Processing /\_Extra Info /\ Info /\_Warning /% Critical Warning /% _Error f\ Suppressed f\ Flag /
[Message: 4+ ¥ ‘Lc-cahon: Pt

Messages

0% 00:00:00

Figure 7-45 DEO_NANO_SOPC module

35. Save the newly created Verilog file as myfirst_niosii.v, as shown in Figure 7-46.

Save As E] @
Savein |Lf}myfirst_niusii ‘IJ e = B

|3 .sopc_builder

db

MyRecent |25 DE0_MAMO_SOPC_sim
Documents cpu.v

?"_L ; cpu_jtag_debug_rodule_swsclk,w
cpu_jtag_debug_mu:udule_tck.v
cpu_jtag_del:uug_mu:udule_wrapper.v
cpu_riulk_cel.w

@ cpu_oci_test_bench,w
cpu_test_bench.v
DEQ_MAND_SOPC v
DEO_MAMNG_SOPC_insk.w
jbag_uart.w

onchip_memaoryZ, v

pio_led. v

Dezktop

¥

hy Documents

@

by Comprater

= 'I‘
¥

by Metwork:,
Places
File name: rnl,lfir:s: :_j Save |
Save az ype: JVeriIu:ug HOL Files [ *vIg * verilog) _1_'1 Cancel
v Add file to current project
Figure 7-46 Save the Verilog file
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36. Compile the project, by selecting Processing > Start Compilation, as shown in Figure 7-47.
Figure 7-48 shows the compilation process.

r=t_niosii/myfirst niosii — mayfirst_niosii

Window  Help

npilation
@ Analyze Current File
Start '
Update Memary Initialization File
Compilation Report Cirl+R. =ii

ﬂ PowerPlay Power Analyzer Tool
TR 55M Analyzer Tool

R
[ input CLOCE_50;
T ocutput [T:0] LED;
| 5 8 DE MANC SCOPC DE NANO SOFC
e s o i
T | 10 .clk 50
— 11 .out_port from the p
& X 1z .reset_n
 Time 42 )i
14 -

Figure 7-47 Start Compilation

Quartus I1 - D:/ayfirst niosii/ayfirst niosii - ayfirst niosii - [B]x]

D Ed

5 5 b@ oo

 myfrst_riosi ¥ 223 PP WD &8 4L 0@
Project Navigator & x| | myfirst_niosil.v B | & Compilation Report (x|
: | Table of Contents =/
thty - B2 Flow Summary Flow Status In progress - Thu Jan 13 17:59:27 2011
Cydlone IV E: EP4CE22F17Co = ) Quartus II Version 10,1 Build 153 11/29/2010 5 Full Version
- myfirst_niosii s Froil St ) Revision Name myfirst_niosii
= : 5 ER Flow Non-Default Global Settings Topdevel Entity Mame  myfirst_niosi
- BH Flow Elapsed Time Family Cydone IVE

BER Flow OS Summary

’ Flow Log
& Analysis & Synthesis
& i il b3
&% Hierarchy Fles | oF Designunits |
Status 8 x|
Module % Progress 0]
Full Compilation ™ 11% 00:

- Analysis & Synthesis [W—Ti0s |00

itter 0% 0o

- Assembler 0% 00:

- TimeQuest Timing Analyzer 0% 00;

Ll il | >

; Type| Message ﬁ
y Info: Elaborating entity "DE NANO S0PC"™ for hierarchy "DE NANO SOPC:DE NANO SOPC inst™ E |
y Info: Elaborating entity "cpu jtag debug module arbitrator"™ for hierarchy "DE NANO SOPC:DE NANO SOPC in:
; ji.’ Info: Elaborating entity "cpu data master arbitrator™ for hierarchy "DE NANO SOPC:DE NANC SO0PC inst|cpu
y Info: Elaborating entity "cpu instruection master arbitrator™ for hierarchy "DE_NANO_SOPC:DE_NANO_SOPC_i]v_

wll< | ¥

7\ _System f\_Processing (161) /\_Extra Info /\_Info (1500 /\ Warning (11) /\_Critical Warning /\_Error /\_Suppressed (4) /\_Flaa /

i

= lMessage:Dof“lS? ‘B 9 |Locahon: | Locate

1% 3 oo:00:29

Figure 7-48 Execute Compile
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37. A dialog box will appear upon successful completion of the compile, as shown in Figure 7-49.

- [5]x]

PEHE & sB2@E o o

Cyclone 1V E: EPACE22F17CE

&

= B Flow Summary
- BB Flow Settings

Quartus IT

>

- Flow Status
- Quartus IT Version

vdlbtal logic elements

el - Total combinational functions
- Dedicated logic registers

[oyvs o UKy 7 @WG Tr T 0O OB AL 0O
Project Navigatar =0 | i myfirst_niosii.v (%] I & Compilation Report B
: | Table of Contents 3l Flow Summary
Entity e :

=89 myfirst niosii . - Revision Name myfirst_niosii
ir = Tyirs?niost & - - BB Flow Non-Default Global Settings - Top-evel Entity Name myfirst_niosii
¥, DE NANO_SOPCDE NANO_SOPCins ||  pmm e Hdagie
58 oid hubeato hab Flow Elapsed Time ! iy yclone IV,
e - ER Flow 05 Summary : Dfn‘;c;nﬂodels E:::EEHFHCG

i ) Full Compilation was successful (72 warnings)

HierarchyI | Files || & Design Lnits |
& x|

Status

Successful - Thu Jan 13 18:01:03
10. 1 Build 153 11/29/2010 53 Full

2,759 /22,320 (12 %)
2,479 /22,320 ( 11 %)
1,665 /22,320 (7 %)
1685

9154 (6 %)

a

271,360 [ 608,256 {45 % )
4/132(3%)
0/4{0%)

Madule
Full Compilation

7% Progress

- Analysis & Synthesis
- Fitter ___100% i
- Assembler
TimeQuest Timing Analyzer | 100% )| O
< | > < >
; Type Message o)
P é.) Info: Elaborating entity "DE NANC SOPC" for hierarchy "DE NANC SCPC:DE NANC SOPC inst"™ 3
y Info: Elaborating entity "cpu jtag debug module arbitrator” for hierarchy "DE NANQ SOPC:DE NANOQ SCPC in
i) Info: E1 orating entity "cpu data master arbitrator aor hierarchy E HAb 5 :DE HNAY 5 inst | cpu
1 i lab o . d b _arb i "DE_NAMNQ SOPC:DE_NANQ SOPC g
= i) Info: E1 orating entity "cpu instruction master arbitrator ar hierarchy E HNAK 5 :DE NAK 5 i
i £ lab - & L _arb il - "DE_NANWC SOPC:DE NANC SOPC i@
ol i | iR
3 \_System /\ Processing (268) /\ Extra Info /\ Info (245) /\ Warning (18) /\_Critical Warning (S) /\_Error /\_Suppressed {10} /\ Flaa /
@ .
12 |Message: 0 of 957 + B |L0cah’on: Locate
100% 00:01:4a, .

Figure 7-49 Compile project completely

38. Now, we will assign the inputs and outputs of the circuit to specific pins. Select Assignments >
Pin Planner from the menubar, as shown in Figure 7-50. The pin planner is shown in Figure 7-51.

fayfirst nioziifmyfirst niosii — myfir

Ctrl +5hift -+

Pin Planner

Remowve Assignments...

- ri Back-Annotate Assignments. ..
hil Import Assignments...

- Export Assignments...

Assignment Groups...

alL.

S LogicLock Regions Window Alt+
] E.E'IE Design Partitions Window Alt+D

it BEEERG - Processing  Tools  Window  Help

£ 92 Device...

— & Settings... Cirl4+5hift+E |
= TimeQuest Timing Analyzer Wizard. .. —
— & Assignment Editor Ctrl+Shift+a |

5 | o DesignUnits | [ ™ T HsSemoE

Figure 7-50 Pins menu
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X | Named:| = hd Edit:| 3 || "

5 Node Mame Direction Location 10 Bank VREF Group 1O Standard Reserved
= CLOCK_S0 Input 2.5V (default)
& LED[7] Output 2.5V {default)
& LED[A] Output 2.5V (default)
L LED[S] Output 2.5V {default)
& LED[4] Output 2.5V {default)
L LED[3] Output 2.5V {default)
& LED[?] Output 2.5V {default)
& LED[1] Output 2.5V (default)
L LED[0] Output 2.5V {default)

<<new node==

Figure 7-51 Blank Pins

39. Input Location values as shown in Figure 7-52.

MNode Name Direction Location If0 Bank VREF Group /0 Standard Reserved

I+ CLOCK_50 Input PIN_RS 3 B3_NO 2.5V (default)
L LED[7] Output PIN_L3 2 B2_NO 2.5V (default)
i LED[] Output PIN_B1 1 B1 NO 2.5V {defalt)
¥ LED[5] Qutput PIN_F3 1 E1_MNO 2.5V (default)
L LED[4] Output PIN D1 1 B1 MO 2.5V {default)
£ LED[3] Cutput PIN_A11 7 B7_NO 2.5V (default)
4 LED[Z] Output PIN_B13 7 B7_MO 2.5V {default)
L LED[1] Output PIN_A13 7 B7_MND 2.5V {default)
£ LED[0] Qutput PIN_A1S 7 E7_MNO 2.5V (default)
<<new node=> »

Figure 7-52 Set Pins

40. Close the pin planner and recompile the project.

7.3 Download the Hardware Design

This section describes how to download the configuration file to the board.

Download the FPGA configuration file (i.e. the SRAM Object File (.sof) that contains the NIOS II
based system) to the board by performing the following steps:

1. Connect the board to the host computer via the USB download cable.

2. Start the NIOS II IDE.

3. After the welcome page appears, click Workbench.

4. Select Tools > Quartus IT Programmer.

5. Click Auto Detect. The device on your development board should be detected automatically.

6. Click the top row to highlight it.
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7. Click Change File.

8. Browse to the myfirst_niosii project directory.
9. Select the programming file (myfirst_niosii.sof).
10. Click OK.

11. Click Hardware Setup in the top, left comer of the Quartus II programmer window. The
Hardware Setup dialog box appears.

12. Select USB-Blaster from the currently selected hardware drop-down list box, as shown in
Figure 7-53.

Note: If the appropriate download cable does not appear in the list, you must first install drivers
for the cable. Refer to Quartus II Help for information on how to install the driver.

> Hardware Set up E'

Hardware Settings | JTAG Settings

Select a programming hardware setup to use when programming devices, This programming
hardware setup applies only to the current programmer window,

Currently selected hardware:  |USB-Blaster [USB-0] g

Mo Hardware
LISB-Blaster [USB-0]

Available hardware items

Hardware SErVer Port Add Hardware. ..

|JSE-Blaster Local JSE-0
Femove Hardware

Close

Figure 7-53 Hardware Setup Window
13. Click Close.

14. Make sure the Program/Configure option for the programming file (see Figure 7-54 for an
example).

15. Click Start.
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b Quartus IT Programmer — [Chainl. cdfls E]@|'z|
File Edit Vew Processing Tools Help |

[;E; Hardware Semp...] |USE—EIaster [UsB-0] Mode: EJTAG VI Progress: 100%: (Sucnawﬁﬂj'; j

[] Enable real-time ISP to allow background programming {for MAX II and MAX V devices)

File Device Checksum Usercode Program/ Werify Blank- Examine
Wi 5t Configure Check

D:/myfirst_niosijmyfirst_... EP4CE115F29 0081D85C FFFFFFFF

il Stop

it Auto Detect
¥ Delete
B Add Fle..,
@ Change File. ..
m’ Save File J\l

(2 Add Device...

ooooooooo o
f}"'—":‘ AlTERRAN

.“:ﬁ Dawn el K “ |

| ‘ Tvpe Meszage ki

oooooooo

L.,

y Info: Configuring device index 1

- i) Info: Device containg JTAG ID code Ox020F70DD
- y Info: Configuration succeeded —— 1 dewvice (s} configured
3_} Info: Successfully performed operatcion(s)

- y Info: Ended Programmer operation at Fri Jan 14 089:

(V]
W
[}
=
L
[
[
=
(=]
<

Evstem (5] 7\ Processing /\_Extra Info /\_Info /\ Warning /\_Critical Warning /\_Error /\_Suppressed /\ Flag [

5 |Message: Oofé t ‘P ILDce'nc-rl: I Locate

Messages

Figure 7-54 Quartus Il Programmer

The Progress meter sweeps to 100% after the configuration finished. When configuration is
complete, the FPGA is configured with the Nios II system, but it does not yet have a C program in
memory to execute.

The Nios II IDE build flow is an easy-to-use graphical user interface (GUI) that automates build
and makefile management. The Nios II IDE integrates a text editor, debugger, the Nios II flash
programmer, the Quartus II Programmer, and the Nios II C-to-Hardware (C2H) compiler GUI. The
included example software application templates make it easy for new software programmers to get
started quickly. In this section you will use the Nios II IDE to compile a simple C language example
software program to run on the Nios II system on your development board. You will create a new
software project, build it, and run it on the target hardware. You will also edit the project, re-build it,
and set up a debug session.
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7.4 Create a hello_world Example Project

In this section you will create a new NIOS II C/C++ application project based on an installed
example. To begin, perform the following steps in the NIOS II IDE:

1. Return to the NIOS II IDE.

Note: you can close the Quartus Il Programmer or leave it open in the background if you want to
reload the processor system onto your development board quickly.

2. Select File > New > NIOS II C/C++ Application to open the New Project Wizard.
3. In the New Project wizard, make sure the following things:

a. Select the Hello World project template.

b. Give the project a name. (hello_world_0 is default name)

c. Select the target hardware system’s PTF file that is located in the previously created hardware
project directory, as shown in Figure 7-55.
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JHew FProject

Nios IT C/ C++ Application

Click Finish to create application with a default system library as
I hmyfirst_niosiihSoftwarehello world 0

Hame: !helll:-_wc-rl 4.0 |

Specify Location

Location: iD:"nmyfirst_nio_sii"nﬂl:-ftware ! [Erl:-wse. s ]

Zelect Target Hardware.

SOPC Builder System PTF File: |D:myfirst_niosii‘\DE_NAND_SOPC. ptf v | [Erowze. |

CFI; I cpu b |

Select Project Template

Elanl: PI_’-:lel:t ; Description

E':'arf g%ag;n-:nstms Frintz "Helle from Hioz II'

ount Binary

Hello Freesztanding Details

Hello MicroC,/05-IT - T : T

Hello World Hella World prints “Hello from Wias IT to STDOUT. A
Hello Horld Small _ ; : : 3
Memory Test Thiz example runs with or without the MicroC/05-II RTOS
Memory Test Small and requires an STOOUT dewice in wour system’ s hardwars.

Simple Socket Serwver
Simple Socket Serwer (RGMII)

Web Server For details, elick Finish to create the project and refer
Yeb Serwver (RGMIL) to the readme txt file in the project directory. v
@ Bk | Hext > || Fimish ||  Cameel |

Figure 7-55 Nios Il IDE New Project Wizard

5. Click Finish. The NIOS II IDE creates the hello_world_0 project and returns to the NIOS II
C/C++ project perspective, as shown in Figure 7-56.
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JNios II C/C+H+ — hello world.c — Nios II IDE

File Edit Refactor HNavigate Search Project Tools Run Windew Help

e R e Er e %00 ™ i I I ics 11 oo |
- Fios IL C/CH Projects 1 SRS B 1ot voria S

-
&

altera components
hello_world 0
hello_world 0_syslib [DE_WAWD_SOPC|

)

66

finclude <stdio.h>
int main()
printf("Hello from Niogs II!\n"):

return 0:

[£ Problens 57 Consele| Properties

i
4

i
0

0 errors, 0 warnings, 0 infos

Description Resource Path Location

0* Hritable Smart Tnsert |11

Figure 7-56 Nios Il IDE C++ Project Perspective for hello_world_0

When you create a new project, the NIOS II IDE creates two new projects in the NIOS II C/C++
Projects tab:

m hello_world_0 is your C/C++ application project. This project contains the source and header
files for your application.

m hello_world_0_syslib is a system library that encapsulates the details of the Nios II system
hardware.

Note: When you build the system library for the first time the NIOS II IDE automatically generates
files useful for software development, including:

e Installed IP device drivers, including SOPC component device drivers for the NIOS II hardware
system

e Newlib C library: a richly featured C library for the NIOS II processor.

e NIOS II software packages which includes NIOS II hardware abstraction layer, Nichestack
TCP/IP Network stack, NIOS II host file system, NIOS II read-only zip file system and Micrium’s
pUC/OS-II realtime operating system (RTOS).

e system.h: a header file that encapsulates your hardware system.
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e alt_sys_init.c: an initialization file that initializes the devices in the system.

e Hello_world_0.elf: an executable and linked format file for the application located in
hello_world_0 folder under the Debug directory.

7.5 Build and Run the Program

In this section you will build and run the program.

To build the program, right-click the hello_world_0 project in the Nios II C/C++ Projects tab and
select Build Project. The Build Project dialog box appears and the IDE begins compiling the
project. When compilation completes, a message ‘Build complete’ will appear in the Console tab, as
shown in Figure 7-57.

JHios IT C/C++ — hello world.c — NHios ITI IDE
File Edit Refactor HNawigate Search Project Tools Run Window Help

= Th= D oEr B [ G- : - Q- Q- @ (B ¥io= I CiT++ |

BB Fios II C/CH Frojects 2 = 0| [€ hello_world c i3 =5

=

al.tera. component‘s
hello world 0O
€ Binaries
(2 Tncludes
[ Debug
[€] hello_werld c
|=| application. stf
D readme. txt
== == hello_world 0_syslib [DE_WAWO_SOFC

=

-g-8-8-e [0

St
£ ¥
Problems S_FHE Properties S G| e |

C-Build [hello_world 0]
TITT O Dan. B STZ0 BYLCED I 1Ur SLCECE + Hnedp. .d\

Creating generated app.sh. ..

Post—processing to coreate onchip memoryZ.hex

g creation of hardware sim
ti ymbol files. (Mote: This does not affect the
instraction set 3'_1".’.'_:;&\:0"_’.]

ompleted in 22.203 seconds

w
:
I
I
[*
]

Figure 7-57 Nios Il IDE hello_world_0 Build Completed

Note: If there appears in the console tab, an error, ‘region onchip_memory2 is
Sfull(hello_world_0.elf section .text). Region needs to be XXX bytes larger.” , please right-click
hello_world_0 , select System Library Properties menu, then pop a window. In the System Library
Properties window, select Small C Library, then click OK to close the window. Rebuild the project.
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After a successful compilation, right-click the hello_world_0 project, select Run As > NIOS II
Hardware. The IDE will download the program to the target FPGA development board and begin
execution. When the target hardware begins executing the program, the message 'Hello from Nios
IT!” will appear in the NIOS II IDE Console tab, as shown in Figure 7-58 for an example.

JNios II C/C++ — hello world.c — Nios II IDE

File Edit Refactor MNavigate Search Project Tools Run Window Help

£ o i@  F-0-Qr ™ML B ; 5 BB Wios 1T c/cH+ |
T ATpE— * "Hello World" example.
ER=Fhello world 0

#- <) Binaries

# (2 Includes
# (2= Debug
- [£] hello_world. e
= application. stf
[2) readme. txt
# =5 hello_world 0_syslib [DE2_115_SOPQ

#include <stdio.h>
int main()
printf("Hello from Nios II!\n");

return 0;

Problems | B Console i3 Froperties x B \ff; B-rs-=08
hello_world 0 Nios IT H¥ configuration [Nios IT Hardware] Nios II Terminal Window (10-5-17 E511:48)

ni 2 i 1: connected to hardware target using JTAG UART on cable L
n : "USB-Blaster [ )]", device 1, ance 0

1: (Use the IDE stop button or Ctrl-C to terminate)

nios2-ter

Hello from Nios II!

3 b /hello_world 0

Figure 7-58 Hello_World_0 Program Output

Now you have created, compiled, and run your first software program based on NIOS II. And you
can perform additional operations such as configuring the system properties, editing and re-building
the application, and debugging the source code.

7.6 Edit and Re-Run the Program

You can modify the hello_world.c program file in the IDE, build it, and re-run the program to
observe your changes, as it executes on the target board. In this section you will add code that will
make the green LEDs, on the DEO-Nano board, blink.

Perform the following steps to modify and re-run the program:
1. In the hello_world.c file, add the text shown in blue in the example below:

#include <stdio.h>

124

Terasic DEO-Nano User Manual www.terasic.com

Www. Lerasic. com,




AVOTS RYA),

#include "system.h"

#include "altera_avalon_pio_regs.h"
int main()

{

printf("Hello from Nios II!\n");

int count = 0;

int delay;

while(1)

{
IOWR_ALTERA_AVALON_PIO_DATA(PIO_LED_BASE, count & 0x01);
delay = 0;

while(delay < 2000000)

{

delay++;

count++;

J

return O;

}

2. Save the project.

3. Recompile the project by right-clicking hello_world_0 in the NIOS II C/C++ Projects tab and
choosing Run > Run As > Nios II Hardware.

Note: You do not need to build the project manually; the Nios II IDE automatically re-builds the
program before downloading it to the FPGA.

4. Orient your development board so that you can observe LEDs blinking.
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7.7 Why the LED Blinks

The Nios II system description header file, system.h, contains the software definitions, name,
locations, base addresses, and settings for all of the components in the Nios II hardware system. The
system.h file is located in the in the hello_world_0_syslib\Debug\system_description directory,
and is shown in Figure 7-59.

JHios II CFCHE — system - h — Hios II IDE

File Edit Refactor Hawigate Search FProject Tools Eun Window Help
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3}
+
E=|
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|- 4» Binaries
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# (2= Tebug :def_ o
tdefine

£ lc] hello world e , z

= : 2 #define
=| application. stf gderine

El readme. txt ':*d f'_ 5
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S25 hello_world O_syslib [DE_HAK T
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=+ Archi
<-> . #define

=8 Includes

3
== Debuz fdefine
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Gl
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#define
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= [= system_description
(5= _Iﬁ system. h
@ [€] alt_sws_init. e
| gemerated. gdb
=] genmerated. =h
< =] gzenerated. x
<@ generated all. mk
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crtl. o — [alteraniosZ]) Fu?
libhello_world_0_syslil < =
w4 = — >
i c‘;k o [Problems Properties & e | £ L el
L makefile

- Bl readme. txt e R T g e I

system. st generated.X. ..

Build completed in 159.60% secaonds

Figure 7-59 The system.h file

If you look in the system.h file for the Nios II project example used in this tutorial, you will notice
the pio_led function. This function controls the LEDs. The Nios II processor controls the PIO ports
(and thereby the LEDs) by reading and writing to the register map. For the PIO, there are four
registers: data, direction, interruptmask, and edgecapture. To turn the LED on and off, the
application writes to the PIO’s data register.

The PIO core has an associated software file altera_avalon_pio_regs.h. This file defines the core’s
register map, providing symbolic constants to access the low-level hardware. The
altera_avalon_pio_regs.h file is located in the directory,
altera\10.1\ip\sopc_builder_ip\altera_avalon_pio.

When you include the altera_avalon_pio_regs.h file, several useful functions that manipulate the
PIO core registers are available to your program. In particular, the macro

IOWR_ALTERA_AVALON_PIO_DATA(base, data)
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can write to the PIO data register, turning the LED on and off. The PIO is just one of many SOPC
peripherals that you can use in a system. To learn about the PIO core and other embedded peripheral
cores, refer to Quartus II Version 10.1 Handbook Volume 5: Embedded Peripherals.

When developing your own designs, you can use the software functions and resources that are

provided with the Nios II HAL. Refer to the Nios II Software Developer’s Handbook for extensive
documentation on developing your own Nios II processor-based software applications.

7.8 Debugging the Application

Before you can debug a project in the NIOS II IDE, you need to create a debug configuration that
specifies how to run the software. To set up a debug configuration, perform the following steps:

1. In the hello_world.c , double-click the front of the line where you would like to set breakpoint,
as shown in Figure 7-60.

JNios II C/C++ — hello world.c — Nios II IDE

File Edit Refactor HNavigate Search Project Tools Run Hindow Help
e A A A A R R B e e e i (BB wios 1z /ot |
B fios IT C/CH Projects &7 = O | i s =
[ -~
@ S altera. components
125 hello_world 0
[#-p Binaries
(2 Includes
[#l(= Debug
#- [ hello_world. e
[Z] spplication. stf
[E] readms. txt
@125 hello_world O_syslib [DE2_115_SOFC
, count & Ox01);
delay++: e
Froblems & Consele i2  Properties Eu gl |[etB-rs-= 0]
hello world 0 Wies TT HY configmration [Wias TT Havdware] Wiss TT Terminal Windew (10-B-18 T8 36)
na ected To hardware target using JIAG UART on cable 1)
laster [US
the IDE
2
£ &
uh Fritable Smart Insert |23 @1

Figure 7-60 Set Breakpoint

2. To debug your application, right-click the application, hello_world_0, and select Debug as >
Nios II Hardware.

3. If the Confirm Perspective Switch message box appears, click Yes.

After a moment, the main() function appears in the editor. A blue arrow next to the first line of code
indicates that execution stopped at that line.
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5. Select Run > Resume to resume execution.

When debugging a project in the Nios II IDE, you can pause, stop or single step the program, set
breakpoints, examine variables, and perform many other common debugging tasks.

Note: To return to the Nios Il C/C++ project perspective from the debug perspective, click the two
arrows >> in the top right corner of the GUL

7.9 Configure System Library

In this section you will learn how to configure some advanced options in the Nios II IDE. By
performing the following steps, you can change all the available settings:

1. In the Nios II IDE, right-click hello_world_0 and select System Library Properties. The
Properties for hello_world_0_syslib dialog box opens.

2. Click System Library in the tree on the left side. The System Library page contains settings
related to how the program interacts with the underlying hardware. The settings have names that
correspond to the targeted NIOS II hardware.

3. In the Linker Script box, observe which memory has been assigned for Program
memory(.text), Read-only data memory(.rodata), Read/write data memory(.rwdata), Heap
memory, and Stack memory, see Figure 7-61. These settings determine which memory is used to
store the compiled executable program. You can also specify which interface you want to use for
stdio , stdin, and stderr. You can also add and configure an RTOS for your application and configure
build options to support C++, reduced device drivers, etc.

4. Select onchip_memory2 for all the memory options in the Linker Script box, as shown in
Figure 7-61.
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Figure 7-61 Configuring System Library Properties

5. Click OK to close the Properties for hello_world_0_syslib dialog box and return to the IDE
workbench.

Note: If you make changes to the system properties you must rebuild your project. To rebuild,
right-click the hello_world_0 project in the Nios II C/C++ Projects tab and select Build Project.
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Chapter 8

DEO-Nano Demonsitrations

8.1 System Requirements

Make sure Quartus II and NIOS II are installed on your PC.

8.2 Breathing LEDs

This demonstration shows how to use the FPGA to control the luminance of the LEDs by means of
pulse-width modulation (PWM) scheme. The LEDs are divided into two groups, while one group
dims the other group brightens, vice versa. Users can change the PWM wave's duty ratio and
frequency to control the LED luminance and repetition rate.

PWM

>

Figure 8-1 Shows a diagram of PWM signals to drive LED.
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90% Brightness

U

50% Brightness

10% Brightness

||

Pulse Width Modulation

Figure 8-2 Pulse Width Modulation

Figure 8-2 shows the relationship between duty cycle and LED luminance.
Demonstration Source Code

e Project directory: DEO_NANQO_Default

e Bit stream used: DEO_NANO.sof

Demonstration Batch File

Demo Batch File Folder: DEO_ NANO_Default\demo_batch
The demo batch file includes the following files:

e FPGA Configure File: DEO_NANO.sof

Demonstration Setup

e Make sure Quartus II and Nios II are installed on your PC.
e Connect USB cable to the DEO-Nano board and install the USB Blaster driver if necessary.

e FExecute the demo batch file “DEO_NANO.bat” under the batch file folder,
DEO_NANO_ Default |demo_batch. This will load the demo into the FPGA.
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8.3 ADC Reading

This demonstration illustrates steps which can be used to evaluate the performance of the 8-channel
12-bit A/D Converter. The DC 3.3V on the 2x13 header is used to drive the analog signals and by
using a trimmer potentiometer, the voltage can be adjusted within the range of 0~3.3V. The 12-bit
voltage measurements are indicated on the 8 LEDs. Since there are only 8 LEDs, only bit-4 through
bit-11 from the ADC are represented on the LEDs.

B Design Concept

This section describes the design concepts for this demo. Figure 8-3 shows the block diagram.

FPGA

Output Control

ADC Controller ;ﬂ—b ‘

DIP Switch Ees==" Channel Select s

2X13 Header

DEO0O-Nano Board

Figure 8-3 ADC Reading Block Diagram

The ADC Controller reads the voltage from the A/D converter through a serial interface and
displays its measurement on the LEDs. The on-board dip-switch determines which channel to read
from. Table 8-1 lists the DIP Switch settings and its corresponding ADC channel.
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Table 8-1 DIP Switch Settings
DIP Switch (SW1) Setting ADC Channel

0000 Analog_In0
0001 Analog_In1
0010 Analog_In2
0011 Analog_In3
0100 Analog_In4
0101 Analog_In5
0110 Analog_In6
0111 Analog_In7

Figure 8-4 depicts the pin arrangement of the 2X13 header. Connect the trimmer to the ADC
channel which is selected by the DIP Switches (Analog_In0O ~ Analog_In7).
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Figure 8-4 2X13 Header

B System Requirements

The following items are required for the ADC Reading demonstration

e DEO-Nano board x1
e Trimmer Potentiometer x1
e Wire Strip x3

B Hardware Setup

e Figure 8-5 shows the hardware setup for the ADC Reading demonstration.
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I

220

Figure 8-5 ADC Reading hardware setup

Note: the setup shown above is connected ADC channel 1.

Demonstration Source Code

e Project directory: DEO_NANO_ADC
e Bit stream used: DEO_ NANO.sof

Demonstration Batch File

Demo Batch File Folder: DEO NANO_ADC\demo_batch
The demo batch file includes the following files:

e FPGA Configure File: DEO_NANO.sof

Demonstration Setup

e Make sure Quartus II is installed on your PC.

e Connect the trimmer to corresponding ADC channel to read from, as well as the +3.3V and
GND signals.

e Adjust the DIP switch according to the ADC channel connected

e Connect USB cable to the DEO-Nano board and install the USB Blaster driver if necessary.

e Execute the demo batch file “DEO_NANO_ADC.bat” under the batch file folder,
DEO_NANO_ADC\demo_batch. This will load the demo into the FPGA.

e Adjust the voltage using the trimmer and observe the measurements on the LEDs. Note a fully
lit LED bar indicates the voltage is 3.3V and similarly no LED lit indicates OV.
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8.4 SOPC Demo

This demostration illustrates how to use the SOPC Builder to create a system with the following
functions:

Control accelerometer through 3-wire SPI interface

Control analog to digital conversion through 4-wire SPI interface
Access EEPROM memory through 12C interface

Access EPCS memory

B System Block Diagram

This section describes the SOPC System Block Diagram of this demo, as shown in Figure 8-6.

FPGA

Tl |

&= P|O Controller

21Ige }98UU0DIBIU| WSSAS

NIOS Il [S=
\ )

JTAG |<=¥i

S

G
N
i

Figure 8-6 SOPC Block Diagram

A 50 MHz Clock is required for the SOPC System. A NIOS II processor is included in the system
for flow control. The PLL is used to generate clocks, including 100 MHz, 10 MHz and 2MHz. The
NIOS II Processor and SDRAM are running at 100 MHZ. The SDRAM is used to store the NIOS II
Program. The ADC SPI Controller is running at 2 MHz. The other peripheral controllers are running
at 10 MHz. The ADC SPI Controller and the Accelerometer SPI Controller are custom SOPC
component. The source code, for these two controllers, is located in the “ip” folder under this
Quartus II project. The other components are standard SOPC Builder components.
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B KEY

The KEY button is driven by PIO Controller with interrupt enabled. It is design to generate an
interrupt event when users click KEYO or KEY1. The interrupt event is used to terminate
accelerometer and analog to digital conversion process in this demo.

For default, the interrupt is disabled in the PIO Controller. Users can enable it with the parameter
setting as shown in below Figure 8-7.

& PO (Parallel 1/0) |
MegoCors’  altera_avalon_pio

|' Basic Settings —| A
Width (1-32 bits): 5
Direction: ) Bidir
(&) Input
O InOut
) Output

Output Port Reset Value:

[~ output Register |

|' Edge capture register |

Synchronously capture
Edge Type: FALLING ||

|:| Enable bit-clearing for edue capture register

|' Interrupt
Generate IRQ

IRQ Type: EDGE v |

Level: Interrupt CPU when any unmasked 10 pin is logic true
Edge: Interrupt CPU wwhen any unmasked hit in the edge-capture
redister is logic true. Svailable when synchronous capture is enabled

Figure 8-7 PIO Controller

B Accelerometer Control

The accelerometer controller is a custom SOPC component developed by Terasic. The source code
is available under the folder \DEO_NANO_SOPC_DEMO\ip\TARASIC_SPI_3WIRE.

In this demo, the accelerometer is controlled through a 3-wire SPI. Before reading any data from the
accelerometer, master should set 1 on the SPI bit in the Register 0x31 — DATA_FORMAT register,
as shown in below Figure 8-8, to set the device to 3-wire SPI mode.

Register Ox31—DATA_FORMAT (Read/Write)
D7 D6 | D5 D4 | D3 o2 D1 | Do

SELF_TEST (] SPI | INT_INVERT | 0 | FULL_RES | Justify | Range

Figure 8-8 DATA_FORMAT Register
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The data format is configured as 10 bits, right-justify, +/- 2g mode. The output data rate is
configured as 400 HZ. The X/Y/Z value is read using polling mode. Before reading X/Y/Z, the
master needs to make sure data is ready by reading the register 0x30-INT_SOURCE, as shown
below Figure 8-9, and checking the DATA_READY bit. In the demo, multiple-byte read of six
bytes X/Y/Z, register from 0x32 to 0x37, is performed to prevent a change in data between reads of
sequential register. Note, the output data is twos complement with DATAXO as the least significant

byte and DATAXx1 as the most significant byte, where x represent X, Y, or Z.

Register Ox30—INT_SOURCE (Read Only)

b7 De D5 D4
DATA READY SINGLE_TAP CCUBLE_TAP Activity
D3 D2 D1 Do
Inactivity FREE_FALL Watermark Crverrun

Figure 8-9 Register 0x30

The SPI timing scheme follows clock polarity (CPOL)=1 and clock phase (CPHA)=1. (CPOL)=1
means the clock is high in idle. (CPHA)=1 means data is captured on clock’s rising edge and data is
propagated on a falling edge. The timing diagram of 3-wire SPI is shown below Figure 8-10:

]

f-ide]

ETUP -ty - -tz 1z == Tang
i H 31 it £ b
X R }{ ] X A5 X v K A X oT | i oo
i i I
¥ A d
ADDRESS BITS DATA BITS

B ADC Control

Figure 8-10 3-wire SPI Timing Diagram

The Analog to Digital Conversion is controller through a 4-wire SPI interface with the timing dialog
given below Figure 8-11. Note, the DIN signal is used to specify the channel (INO~IN7) for the
next data conversion. The DOUT signal is used to read the data conversion result whose channel is
specified in previous transaction. The first conversion result after power-up will be on INO. The
output format of conversion result is straight binary.
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Figure 8-11 4-wire SPI Timing Diagram

B EEPROM Control

EEPROM is accessed through the 12C interface. In this demo, 12C signal is toggle by NIOS II
through the PIO controller. The 12C clock signal is driver by an OUTPUT PIO Controller and the
12C data signal is driver by a BIDIRECTION PIO Controller. The I2C C code is located in:

DEO_NANO_SOPC_DEMO\software\DEO_NANO\terasic_lib\I2C.c

B EPCS Control

EPCS64 is accessed through the EPCS interface. In Quartus 10.0 or later, the EPCS pin assignment
is required and should be connected the pins to EPCS Controller as shown below Figure 8-12:

// the _epcs
.datal_to_the epcs(EPCS _DATAO)],
.delk from the epes (EPCS _DCLE] ,
.8ce _from the epces(EPCS _NC30),
.3do_from the epcs (EPC3 _AZDO),

Figure 8-12 EPCS interface connection

For the EPCS access functions, users can refer to:

DEO_NANO_SOPC_DEMO\software\DEO_NANO\terasic_lib\Flash.c
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Demonstration Source Code

e Project directory: DEO_NANO_SOPC_DEMO
e Bit stream used: DEO_NANO.sof
e NIOS II elf file: DEO_NANO.elf

Demonstration Batch File

e Demo Batch File Folder: DEO_ NANO_SOPC_DEMO\demo_batch
The demo batch file includes the file:

e Batch File: test.bat and test_bashrc
e FPGA Configure File: DEO_NANO.sof
e Nios II Program: DEO_NANO.elf

Demonstration Setup

Make sure Quartus II and Nios II are installed on your PC.
Connect a USB cable to the DEO-Nano board and install USB Blaster driver if necessary.
Execute the demo batch file “test.bat” under the batch file folder,

DEO NANO_SOPC_DEMO\demo_batch. This will load the demo into the FPGA.
After executing the batch file, a selection menu appears as follows:

= Nios Il EDS 10.1 [gee3]

Example designs can be found in
seygdrivescralterasiB._B-nios2edsrexamples

{You may add a startup script: ci/alterars18.B8-/nios2eds/user.bashrc)

Downloaded 84KB in 1.4z (68.0KB/s>
erified QK
Starting processor at address BxB20001C8
iogZ2—-terminal: connected to hardware target using JTAG UART on cable
ios2-terminal: "USB-Blaster [USB-B1". device 1, instance B
ios2-terminal: {Use the IDE stop button or Ctrl-C to terminatel

DE-Nano Demo

Selection function:
[AIACCELEROMETER
[11ADC

[2 IEEPROM

e Input “0” to start the accelerometer demo. The demo starts by displaying the accelerometer’s
chip ID, and then continues by displaying the X/Y/Z values every 1.0 second. To
terminate the demo, press KEYO or KEY1 on the DEO-Nano board. Upon exiting the
demo, the selection menu will be displayed.
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onitor Accerometer Ualue. Press KEYO or KEY1 to terminal the monitor process.
i=—20 ng, ¥Y=—4 mng. Z=872 my

32 mg. ¥Y=8 ng.
28 mg,. Y=8 ng.
H=—20 ng. ¥Y=4 ng.
H=12 mg,. ¥Y=12 ng.
$=36 mg,. Y=—8 nmng.
$=—32 mg., Y=8 mg.
—28 my, ¥Y=B myg.

Z=976 mg
Z=95%6 mg
Z=980 mg
Z=1804 my
Z=972 mg
Z=768 mg
Z=780 mg

e Input “1” to start Analog to Digital Conversion demo. The demo repeatedly displays the
voltage on eight channels. To terminate the process, press KEYO or KEY1 on the
DEO-Nano board. Upon exiting the demo, the selection menu will be displayed.

- Mios Il EDS 1

Select:Demo ADC

u

e Input “2” to start EEPROM Content Dump demo. The demo displays the values in the first 16
bytes of the EEPROM. The demo automatically exists, and returns to the selection menu.

* Mios Il EDS 10.1 [geed]

Select:Demo EEPROM

e Input “3” to start EPCS demo. The demo displays the memory size of EPCS. The demo
automatically exists, and returns to the selection menu.

Selection function:
[ IACCELEROMETER
[114ADC

[2 IEEPROM

[31EPCS

Select:Demo EPCE

Terasic DEO-Nano User Manual
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8.5 G-Sensor

This demonstration illustrates how to use the digital accelerometer on the DEO-Nano board to measure
the static acceleration of gravity in tilt-sensing applications. As the board is tilted from left to right and
right to left, the digital accelerometer detects the tilting movement and displays it on the LEDs.

W

Moddd

Figure 8-13 DEO-Nano on level surface

B Design Concept

This section describes the design concepts for this demo. Figure 8-14 shows the block diagram.

DEO-Nano Board

FPGA

LED D

3-wire SPI

Controller

Figure 8-14 G-Sensor block diagram
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In this demo, the accelerometer is controlled through a 3-wire SPIL. Before reading any data from the
accelerometer, the controller sets 1 on the SPI bit in the Register 0x31 — DATA_FORMAT register.
The 3-wire SPI Controller block reads the digital accelerometer X-axis value, to determine the tilt
of the board. The LEDs are lit up as if they were a bubble, floating to the top of the board.

Demonstration Source Code

e Project directory: DEO_NANO_GSensor
e Bit stream used: DEO_ NANO_G_Sensor.sof

Demonstration Batch File
Demo Batch File Folder: DEO_ NANO_GSensor\demo_batch
The demo batch file includes the following files:

e FPGA Configure File: DEO_NANO_G_Sensor.sof

Demonstration Setup

Make sure Quartus II is installed on your PC.

Connect USB cable to the DEO-Nano board and install the USB Blaster driver if necessary.

Execute the demo batch file “test.bat” under the batch file folder,
DEO_NANO_GSensor\demo_batch. This will load the demo into the FPGA.

Tilt the DEO-Nano board from side to side and observe the result on the LEDs.

8.6 SDRAM Test by Nios Il

Many applications use SDRAM to provide temporary storage. In this demonstration hardware and
software designs are provided to illustrate how to perform memory access in QSYS. We describe
how the Altera’s SDRAM Controller IP is used to access a SDRAM, and how the Nios II processor
is used to read and write the SDRAM for hardware verification. The SDRAM controller handles the
complex aspects of using SDRAM by initializing the memory devices, managing SDRAM banks,
and keeping the devices refreshed at appropriate intervals.

B System Block Diagram

Figure 8-15 shows the system block diagram of this demonstration. The system requires a 50 MHz
clock provided from the board. The SDRAM controller is configured as a 32MB controller. The
working frequency of the SDRAM controller is 100MHz, and the Nios II program is running in the
SDRAM.
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FPGA

QSYS
50 MHz

Nios II “

SDRAM

System Intercoment Fabric

Figure 8-15 Block diagram of the SDRAM Basic Demonstration

The system flow is controlled by a Nios II program. First, the Nios II program writes test patterns
into the SDRAM. Then, it calls Nios II system function, alt_dcache_flush_all, to make sure all data
has been written to SDRAM. Finally, it reads data from SDRAM for data verification. The program
will show progress in JTAG-Terminal when writing/reading data to/from the SDRAM. When
verification process is completed, the result is displayed in the JTAG-Terminal.

B Design Tools

e Quartus II 13.0 SP1
e Nios II Eclipse 13.0 SP1

B Demonstration Source Code

e Quartus Project directory: DEO_NANO_SDRAM_Nios_Test
e Nios II Eclipse: DEO_NANO_SDRAM_Nios_Test \Software

B Nios II Project Compilation

e Before you attempt to compile the reference design under Nios II Eclipse, make sure the project
is cleaned first by clicking ‘Clean’ from the ‘Project” menu of Nios II Eclipse.
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B Demonstration Batch File

Demo Batch File Folder: DEO_ NANO_SDRAM_Nios_Test \demo_batch
The demo batch file includes following files:

e Batch File for USB-Blaster : DEO_ NANO_SDRAM_Nios_Test.bat,
DEO_NANO_SDRAM _Nios_Test.sh

e FPGA Configure File : DEO_NANO_SDRAM_Nios_Test.sof

e Nios II Program: DEO_NANO_SDRAM_Nios_Test.elf

B Demonstration Setup

e Make sure Quartus II and Nios II are installed on your PC.

e Connect a USB cable to the DEO-Nano board and install USB Blaster driver if necessary.
Execute the demo batch file “ DEO_ NANO_SDRAM_Nios_Test .bat” under the batch file
folder, DEO_ NANO_SDRAM_Nios_Test \demo_batch

e After Nios Il program is downloaded and executed successfully, a prompt message will be
displayed in nios2-terminal.

e Press KEY1~KEYO of the DEO-Nano board to start SDRAM verify process. Press KEYO0 for
continued test.

e The program will display progressing and result information, as shown in Figure 8-16.

@ Altera Nios I EDS 13.0sp1 [gecd] o[ )

Pausing target processor: OK

Initializing CPU cache (if present)

0K

Downloaded 61KB in 0.8s (76.2KB/s)

Uerified 0K

Starting processor at address Ox000001B4

nios2-terminal: connected to hardware target using JTAG UART on cable
nios2-terminal: "USB-Blaster [USB-0]1", device 1, instance 0
nios2-terminal: (Use the IDE stop button or Ctrl-C to terminate)

SDRAM Test! Size=32MB (CPU Clock:100000000)

Press any KEY to start test [KEY® for continued test]
> SDRAM Testing, Iteration: 1
write. ..
104 20% 307 40% 507 60X 70 804 90% 100%
read/uverify. ..
10% 207% 30% 40% 50% 6O% TO0%L 80% 90% 100%
SDRAM test:Pass, 12 seconds
> SDRAM Testing, Iteration: 2
write. ..
10% 20% 30% 40% 50% 60% 70X 80% 907 100%
read/verify. ..
10% 20% 30%

Figure 8-16 Display Progress and Result Information for the SDRAM Demonstration
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Chapter 9

Appendix

9.1 Programming the Serial Configuration Device

This section describes how to program the serial configuration device with Serial Flash Loader
(SFL) function via the JTAG interface. User can program serial configuration devices with a JTAG
indirect configuration (.jic) file. To generate JIC programming files with the Quartus II software,
users need to generate a user-specified SRAM object file (.sof) of the circuit they wish to put in the
serial configuration device. Next, users need to convert the SOF to a JIC file. To convert a SOF to a
JIC file in Quartus II software, follow these steps:

B Convert SOF to JIC

1. Select File > Convert Programming Files...

2. In the Convert Programming Files dialog box, set the Programming file type field to JTAG
Indirect Configuration File ( jic).

3. In the Configuration device field, specify the targeted serial configuration device, EPCS64.

4. In the File name field, browse to the target directory and specify an output file name.

5. Highlight the SOF Data row in the table, as shown in Figure 9-1.

6. Click Add File.

7.  Select the SOF that you want to convert to a JIC file.

*

Click Open.
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9. Highlight the Flash Loader and click Add Device, as shown in Figure 9-2.

10. Click OK. The Select Devices page displays.

lij Conwert Programming File — D:/CD/DE Nano/DED Nano wl.0.9 CDRO. .. E|@g|
File  WWindow

Specify the input files to convert and the type of programming file to generate.
You can also import input file information from other files and save the conversion setup information created here for
future use,

Conversion setup files

Open Conversion Setup Data... ] [ Save Conversion Setup...

Qutput programming file

Programming file type: iJTAG Indirect Configuration File {.jic) YI
Cptions. .. Configuration device: |EP'CSE4 Vi Mode: iﬁ.cux—'& Serial |
File name: !uutmt_ﬁ]e.jic | [I]

[ Advanced... ] Remote/Local update difference file: |HCIHE

Memory Map File

Input files to convert

File/Data area Properties Start Address |Add Hex Daml
Flash Loader
Add Sof Page
Add File...
Up
Down

e

Generate ][ Cloze [ Help ]

Figure 9-1 Convert Programming Files Dialog Box
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Iy Convert Programming File — D:/CD/DE_Nano/DE0_Nano_vi.0.9_cpro... [=|[B]X]
File  WWindow

Specify the input files to convert and the type of programming file to generate.
You can also import input file information from other files and save the conversion setup information created here for
future use,

Conversion setup files

Open Conversion Setup Data... ] [ Save Conversion Setup...

Qutput programming file

Programming file type: iJTAG Indirect Configuration File {.jic) YI

Cptions. .. Configuration device: |EP'CSE4 Vi Mode: iﬁ.cux—'& Serial |
File name: !uutmt_ﬁ]e.jic | [I]
[ Advanced... ] Remote/Local update difference file: |HCIHE |

Memory Map File

Input files to convert

File/Data area Properties Start Address |ﬁ.dd Hex Daml
Flash Loader
= S0F Data Page_0 <auto= Add Sof Page
DED_MAMO,sof EPACE22F17
Add Device...
Remove
Up
Down
Properties

Generate ] [ Cloze ] [ Help

11.

12.

13.

14.

Figure 9-2 Highlight Flash Loader
Select the targeted FPGA, Cyclone IV E EPACE22, as shown in Figure 9-3.

Click OK. The Convert Programming Files page displays, should look like Figure 9-4.

Select the .sof file, and Click the Properties. Select Compression, click OK, as shown in
Figure 9-5.

Click Generate.
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]

{".'."P Select Dewices

Device family Device name

[ apexa0k [ er4ace1o New...
[ arria Gx [ ep4ce1is

[ amria 11 Gx [ ep4cels Import...
[] arman Gz EP4CEZ2

D Cydone Export...
D Cydone II D )

[] cydone 11 [0 eracess Ealeagt
[] cydone 11 LS [ ep4ces ——
Cyclone IV E [ ep4ceTs

[[] cydone v G Uncheck Al

] maxm

] max v

[] stratix

[[] stratix Gx
[] stratix 1t
[[] stratix 11 Gx
[[] stratix 111
[] stratix v

0K ] [ Cancel

Figure 9-3 Select Devices Page
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lij Conwert Programming File — D:/CD/DE Nano/DED Nano wl.0.9 CDRO. .. E|@g|
File  Window

Specify the input files to convert and the type of programming file to generate.

You can also import input file information from other files and save the conversion setup information created here for
future use,

Conversion setup files

Open Conversion Setup Data... ] [ Save Conversion Setup...

Qutput programming file

Remove

Down

Properties

Programming file type: iJTAG Indirect Configuration File {.jic) Y|
Cptions. .. Configuration device: |EP'CSE4 Vi Mode: iﬁ\.cuxf& Serial |
File name: !uutput_ﬁ]e.jic | [I]
[ Advanced... ] Remote/Local update difference file: |HOP-JE |
Memory Map File
Input files to convert
File/Data area Properties Start Address |Add Hex Daml
[=} Flash Loader
. Add Sof Page
[=} SOF Data Page_ 0 <ALt =
DED_MANC.sof EP4CE2IF17 Add Device...

) I
=]

Generate ] [ Cloze ] [ Help

Figure 9-4 Convert Programming Files Page
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mvert Programming File — D:/CD/DE_Nano/DEO_Hano_v1.0.9 CDRO... IEJEEI

Specify the input files to convert and the type of programming file to generate.
You can also import input file information from other files and save the conversion setup information created here for
future use,

Conversion setup files

—

[ Open Conversion Setup Data... ] [ Save Conversion Setup...

Qutput programming file

Programming file type: iJTAG Indirect Configuration File {.jic) Y|
Cptions. .. Configuration device: |EP'CSE4 Vi Mode: Iﬂ.cmf& Serial |
File name: | [I]
[ Advanced. .. liy SOF File Properties |
Input files to convert L oK J [ s ] [ Help ]
File/Data area I mlt Address |ndd Hex Daml
[=} Flash Loader
| EP4CE22 Add Sof Page
[=}- SOF Data Page_ 0 <auto =
DEQ_MAMO, sof EPACE22F17 Add Eile...
Up
Down

Properties

e

[ Generate ][ Cloze [ Help ]

Figure 9-5 Compression the sof file

B Write JIC File into Serial Configuration Device

To program the serial configuration device with the JIC file that you just created, add the file to the
Quartus IT Programmer window and follow the steps:

1. When the SOF-to-JIC file conversion is complete, add the JIC file to the Quartus II
Programmer window:
i.  Select Tools > Programmer. The Chainl.cdf window displays.
ii. Click Add File. From the Select Programming File page, browse to the JIC file.
iii. Click Open.
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2. Program the serial configuration device by checking the corresponding Program/Configure
box, a Factory default SFL image will be load (See Figure 9-6).

® Programser — D:/CD/DE_Fano/DED_Kano_vl. 0. 9_CDRON/DEO_Hano_vl.0.8_CDRON/Demonstra. .. = |[B][X]

File Edit View Processing Tools  \Window

| &, Hardware Setup...| |UsB-Blaster [Usa-0] | Mode: |ITAG | progress: | ]

[] Enable real-time 15P to allow backoround programming (for MAX IT devices)

File Device Chedksum |Usercode Program/ Verify Blank- Exan
P siart Configure Check [
g | Factory default enhanced... EP4CE22 0017776C FFFFFFFF |
Stop output_file.jic EPCSE4 70940117
i Auto Detect
W Delete
2 Add File...
@ Change File...
L1 ' 3|
@’ Save File A_i
oooooooooo |
EPCSa4
2 add Device..,
S
ﬂ]LID oopoooooooo
ooooooooo
E FAlTERA E
TDI o o
P o } o —
o o
a (=]
oooooooono
EP4CE22
TDO
4
b | oy I

Figure 9-6 Quartus Il programmer window with one JIC file

3. Click Start to program serial configuration device.

B Erase the Serial Configuration Device

To erase the existed file in the serial configuration device, follow the steps listed below:
1. Select Tools > Programmer. The Chainl.cdf window displays.

2. Click Add File. From the Select Programming File page, browse to a JIC file.

3. Click Open.

4. Erase the serial configuration device by checking the corresponding Erase box, a Factory
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default SFL image will be load (See Figure 9-7).

<» Programmer — D:/CD/DE_Nano/DED, Nano wl.0.9 CDRON/DE0 Nano wvl.0.9 CDRON/Demonstration/DED_HANO default...
File Edit View Processing Tools Window

[;:; Hardware Semp...] |USB-BIaster [UsB-0] | Mode: |ITAG Vl Progress: [ ]

[] Enable real-time ISP to allow background programming (for MAX II devices)

[ . File Device Checksum Usercode Program/ Verify Blank- Examine Security Eraze i |
Configure Check Eit CL
Factory default enhanced... EP4CE22 0017776C FFFEFFFF
wli 5top t fil 7C4D117 I T
E Change File...
>
m’ Savefile || A~
[ ==
&£ :
4 up | EEEFEEEEEL,
-l}" Down T
of /BER B
T0I o H
— :
EP4CE22
d 700 ™
N w
Figure 9-7 Erasing setting in Quartus Il programmer window
5. Click Start to erase the serial configuration device.
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9.2 EPCS Programming via nios-2-flash-programmer

Before programming the EPCS via nios-2-flash-programmer, users must add an EPCS patch file
nios-flash-override.txt into the Nios II EDS folder. The patch file is available in the folder
Demonstation\EPCS_Patch of DE(O-Nano System CD. Please copy this file to the folder
[QuartusInstalledFolder]\nios2eds\bin (e.g. C:\altera\l11.1\nios2eds\bin)

If the patch file is not included into the Nios II EDS folder, an error will occur as shown in Figure
9-8.

Figure 9-8 EPCS Message

9.3 Revision History

Version Change Log

V1.0 Initial Version (Preliminary)

V1.3 Add Table 3-1,3-2 and 3-3

Vi4 Modified Digital Accelerometer Description on page 31
V1.5 Modified ADC description on page 32

V1.6 Corrected Digital Accelerometer Schematic on page 23
V1.7 Modified Altera EPCS16 to be Spansion EPCS64

V1.8 Add SDRAM test section

V1.9 Modify National logo to Ti

V2.0 Remove CD from Kit. CD is downloaded from Terasic Web.
V2.1 Modify Figure 3-10

V2.2 Modify Figure 8-5

V2.3 Replace the board picture

9.4 Copyright Statement

Copyright © Terasic Technologies. All rights reserved.
Always visit the DEO-Nano webpage for new applications.

We will continue providing interesting examples and labs on our DEO-Nano webpage. Please visit
www.altera.com or DEOQ-Nano.terasic.com for more information.
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