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STOP

Atlas Scientific does not make consumer electronics.

This equipment is intended for electrical engineers. If you are not familiar
with electrical engineering or embedded systems programing, this product
may not be for you.

This device was developed and tested using a Windows computer. It was not
tested on Mac, Atlas Scientific does not know if these instructions are
compatible with a Mac system.
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Operating principle

The Wi-Fi hydroponics kit has been designed to provide the engineer with a simple way
of remotely monitoring and controlling a hydroponics system's chemistry. Sensor data
is uploaded to ThingSpeak ™, a free, cloud-based data acquisition and visualization
platform. The Wi-Fi hydroponics kit has also been designed to be easily modified by the
engineer. Feel free to change the sensors or functionality of the device to meet your
specific needs.

Overview
CPU

The Wi-Fi hydroponics kit is controlled using an Adafruit HUZZAH32 as its CPU. The
HUZZAH is programmed using the Arduino IDE and uses an onboard ESP32 as its Wi-Fi
transmitter. Adafruit HUZZAH32 datasheet.

[ B | L1 -
. 3v GND
([ XXXXXX)

Sensor ports

The Wi-Fi hydroponics kit PCB has 5 sensor ports. Three of the ports are electrically
isolated. The isolated ports are marked pH, Conductivity, and AUX. The isolated ports
are needed to take noise-free electrochemical readings. Because the sensing element of
a temperature sensor is never in direct contact with the water, electrical isolation is not
needed for temperature sensing.

The AUX port can be used to add an additional sensor of your choice. The terminal block
marked Port 5 has been designed to connect one or more dosing pumps to the device.
However, the port could also be used to connect a gas sensor.

AtlasScientific
Hydroponics Kit

Conductivity Temperature




PCB

The overall design of the PCB is quite simple. The CPU is powered and programmed
through the panel-mount USB connector. The CPUs USB pin supplies the board's power bus
with 5V.

AtlasScientifico ¥ ooty
e - o4 T Adafruit HUZZAH32 —”‘
o o D Bivgscvoaonty.f gl—

: —

(A # (A i :J

Each of the four main sensor ports have an enable pin, which must be set correctly to
power the sensor. The enable pins are found here:

The first three pins (pH, Cond and Aux) must be set low to power on the sensor.
The last pin (Temp) must be set high to power on the sensor.

Truth table

Aux

Temp

Sensor port 5 (the terminal block) does not have an enable pin and can not be turned off.

. AtlasScientific

4 Copyright © Atlas Scientific LLC A T e ironmental Robotics



Data protocol

The CPU communicates with all peripheral sensors using the 12C data protocol. All data
lines are directly connected to the CPUs I2C port. Using a different data protocol with this
circuit board is not possible.

It is important to keep in mind that all Atlas Scientific components default to UART mode.

When adding a new Atlas Scientific component to the kit, it must first be put into 12C
mode. Refer to the component's datasheet for instructions on how to switch it over.

Adding more of the same
sensor or component type

Adding additional components of the same type, such as an additional pH or conductivity
sensor, is not hard to do. As mentioned above, you must set the device to 12C mode, and
you must make sure that its I2C address is not the same as the already existing component.

AtlasScientifico
Hydroponics Kit -

pH VCC PRB PGND

20" @ @
Conductivity Temperature AUX
1 1
1 1

12C Address 12C Address 12C Address 12C Address
99 (0x63) 100 (0x64) « 102 (0x66) « 99 (0x63)

- AtlasScientific
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This table lists the default 12C address of components commonly added to this kit.

12C Address

12C Address

EZO EC 100 (0x64)
EZO RTD 102 (Ox66)
EZO PMP 103 (0x67)

Dosing pump

An optional external dosing pump can be added to the Wi-Fi hydroponics kit.
Using the SGL-PMP-BX is the simplest way to add on a dosing pump.

EZO pH 99 (0x43)

EZO ORP 98 (0x62)
EZO DO 97 (0x61)

;Scienti_ﬁ_c )

lrAanar® E

L1

Temperature

A stand-alone EZO-PMP can be used instead of the expansion pump kit; however, you
must manually put the pump in 12C mode and remove the data cable connector.

6 Copyright © Atlas Scientific LLC



Uploading sensor data
to the cloud

The Atlas-Scientific Wi-Fi hydroponics kit has been designed to upload sensor data to
ThingSpeak™, a free, cloud-based data acquisition and visualization platform. You will be
required to set up a free account with ThingSpeak™ to upload and visualize the data. With
a free account, you can upload data once every 15 seconds. A paid account lets you
upload data once per-second; look here for more info about various ThingSpeak™
services.

Atlas Scientific has no business relationship with ThingSpeak™; we just like how it works.
If you want to use a different service, modify the device as you see fit.

Setting up your Wi-Fi kit
Step 1 .o ermingspe accons

Because the sensor data is stored / viewed on ThingSpeak, you will need
to setup a ThingSpeak account. Create your ThingSpeak account by clicking HERE.

D ThingSpeak" Channels Apps  Support~ Commercial Use  How to Buy

To use ThingSpeak, you must sign in with your existing MathWorks account or create a new one.

Non-commercial users may use ThingSpeak for free. Free accounts offer limits on certain functionality. Commercial users are eligible for a time-limited free evaluation. To
get full access to the MATLAB analysis features on ThingSeak, log in to ThingSpeak using the email address associated with your university or organization.

To send data faster to ThingSpeak or to send more data from more devices, consider the paid license options for commercial, academic, home and student usage.

Email

4\ MathWorks- % )

DATA AGGREGATION

—
‘ | o AND ANALYTICS
No EfU:(.Junl.‘? Create one! . . -_I Q Thingspeak
By signing in you agree to our privacy policy. f,.‘-‘;‘ NIATL!\B
v —
e 2 B
Next =l & Y
- T ¢ > /_". il I
—
i_’ SMART CONNECTED DEVICES g ;l.
2_' ALGORITHM DEVELOPMENT
SENSOR ANALYTICS

- AtlasScientific
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Ste p 2 Create a Channel

Your data is uploaded to ThingSpeak through a ‘Channel.” Select New Channel

D ThingSpeak“‘ Channels ~ Apps ~ Support- Commercial Use How to Buy

My Channels Help
. ot Collect data in a ThingSpeak channel from a device,
—— i - from another channel, or from the web.

Click New Channel to create a new ThingSpeak
channel.

Click on the column headers of the table to sort by the
entries in that column or click on a tag to show
channels with that tag.

|:| Th Ing S pe ak™ channels~  Apps~  Support- Commercial Use  Howto Buy

New Channel Help

Channels store all the data that a ThingSpeak application collects. Each channel includes

Name Atlas Sensors
eight fields that can hold any type of data, plus three fields for location data and one for
status data. Once you collect data in a channel, you can use ThingSpeak apps to analyze and
Description visualize it.

Channel Settings

Field 1 pH [} * Percentage complete: Calculated based on data entered into the various fields of a

channel. Enter the name, description, location, URL, video, and tags to complete your
) channel.
Field 2 EC (uSfem)
¢ Channel Name: Enter a unigue name for the ThingSpeak channel.
Field 3 Temp (°C) » Description: Enter a description of the ThingSpeak channel.

Fill out the highlighted boxes. (Be sure to click on the checkboxes to enable field 2 and 3)
For reference, this is what we entered.

Name Atlas Sensors
Field1 pH

Field 2 EC (pS/cm)
Field 3 Temp (°C)

Scroll to the bottom of the page and click Save Channel.

- AtlasScientific
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Ste p 3 Get ThingSpeak API keys

After you saved your channel settings, you will be redirected to your channel page.
Click on API keys.

D ThingSpeak“‘ Channels ~ Apps ~ Support~ Commercial Use How to Buy

My Channels Help
. it e Collect data in a ThingSpeak channel from a device,
— i 2 from another channel, or from the web.

Click New Channel to create a new ThingSpeak
Name Created Updated channel.
Click on the column headers of the table to sort by the

entries in that column or click on a tag to show
channels with that tag.

@ Atlas Sensors 2020-02-14 2020-05-1123:04

l Private ‘ Public ‘ Settings | Sharing ‘ APl Keys ‘ Data Import / Export

Learn to create channels, explore and transform
data.

Learn more about ThingSpeak Channels.

I:l ThingSpeak“ Channels ~ Support~ Commercial Use  How to Buy

Atlas Sensors

Channel 1D: XXXXXX
Author:
Access: Private

Private View Public View Channel Settings Sharing APl Keys Data Import / Export

Write API Key Help

AP| keys enable you to write data to a channel or read data from a private channel. API
keys are auto-generated when you create a new channel.

Key P 8.9.0.¢.9.0.0.6.6.4.6.6.0.6.0.4
APl Keys Settings
= Write API Key: Use this key to write data to a channel. If you feel your key has

been compromised, click Generate New Write API Key.
» Read API Keys: Use this key to allow other people to view your private channel

Be sure to save your Channel ID and Write API Key we are going to need these, in the
next few steps.

- AtlasScientific
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Ste p 4 Make sure your Arduino IDE libraries are up to date

A Make sure you have the correct path for the Esp32 Library

In the IDE, go to File > Preferences
Locate the Additional Boards Manager URLS text box.

Preferences oo

Settings  Metwork

Sketchbook location:

l;:_‘n, | | Browse
Editor language: EE\;-'stem Default w | {reguires restart of Arduino)

Editor font size: 1z

Interface scale: Automatic | 100 : 8% {requires restart of Arduing)

Theme: Default theme ~ ({requires restart of Arduino)

Show verbose output during: [ ] compilation [ ] upload

Compiler warnings: -_r_*.lqrje v |

Display line numbers [] Enable Code Folding

Verify code after upload [] Use external editor

Check for updates on startup Save when verifying or uploading

[] Use accessibility features

Additional Boards Manager URLs:  https://raw.githubusercontent, com/fespressif/arduino-esp 32 /ah-pages /package_esp32_index.json ﬁ

ok | | Cancel

Make sure this URL is in the textbox

https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json
Click OK.

- AtlasScientific
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B Update the esp32 board

In the IDE, go to Tools > Board > Boards Manager

File Edit Sketch Tools Help

hydroponics_K

enum reading |
flfatep 1 tell
ff3tep 2 cons
/fstep 4 tell
ffatep 3 cong
enum reading |

kool polling
bool send to |

int return_cof
uint32 t next
const unsigns
unsigned int

const unsigne

const unsigns
const unsigne

void setup()

Auto Format

Archive Sketch

Fixx Encoding & Reload
Manage Libraries...
Serial Monitor

Serial Plotter

WiFi101 / WiFiNINA Firraware Updater

Board:

Upload Speed: "115200"

CPU Frequency: "80 MHz"

Flash Size: "4MB (F5:2MB OTA:~1019KB)"
Debug port: "Disabled”

Debug Level: "None"

wiP Variant: "v2 Lower Memory"

VTables: "Flash"

Exceptions: "Legacy (new can return nullptr)”
Erase Flash: "Only Sketch"

551 Support: "All 55L ciphers {(most compatible)”
Part

Get Board Info

Prograrnmer: "AVRISP mkll"

Burn Bootloader

Crl+T

Ctrl+Shift+] |
Ctrl+ Shift+M
Ctrl+Shift+L

[EVICES, READ RESEONSE }:

Ig we just received

A

Arduino AYR Boards
Arduino Yin

Arduine Uno

Arduine Duemilanove or Diecimila
Arduino Nano

Arduino Mega or Mega 2560
Arduine Mega ADK
Arduine Leonardo

Arduine Leonardo ETH
Arduine Micro

Arduine Esplora

Arduine Mini

Arduino Ethernet

Do ouTTUIy,

& Boards Manager X
Type | Al w | esp32

esp32 ~

by Espressif Systems version 1.0.5 THSTALLED

Boards included in this package:

ESP32 Dev Module, WEMOS LoLin32, WEMOS D1 MINI ESP32.

More Info

|Select version - Install Update Remove |

v

Close

In the search bar of the Boards Manager, lookup esp32.
Update to the most recent version if you don't already have it.

(Version 1.0.5 in not the most recent version)

11 Copyright © Atlas Scientific LLC
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C Download the ThingSpeak library for Arduino

Click HERE to download the latest version of the ThingSpeak library.
Don’t unzip it!

Import the .ZIP file into your Arduino IDE.
To import the .ZIP file go to Sketch > Include Library > Add .ZIP Library

File Edit Sketch Tools Help

Verify/Compile Ctrl+R,
Upload Ctrl+U
hydrop Upload Using Programmer  Ctrl+Shift+L
Export compiled Binary Ctrl+Alt+5 |
£NUM e D COMPENSATE, REQUEST DEVICES, RELD RESPONSE }1:
ffatep Show Sketch Folder Ctrl+K |ﬂ§
(== | include Libiary | A
jj:g:i Aiddi File... Manage Libraries... Ctrl+Shift+|

D Add the EZO 12C Library

To download the Ezo_I2c¢ library file, click HERE.

¥ master = P 1branch 0 tags Go to file

(2 Clone @

HTTPS GitHub CLI

@ Atlas-5Scientific removed redundant examples, aquaponics kit has pump code by ¢

& Examples removed redundant examples, aquapon WEEDS - /7 Bithih. ConfAL Tas-Seiehtificy [l
[ Ezo_i2ccpp added the get address() method to the  Use Git or checkout with SYN using the web URL,
D Ezo_i2ch added the get_address() method to the
X1 Open with GitHub Desktop
[ Ezo_i2c_util.cpp Created libraries for common functions
[ Ezo_i2c_utilh Created libraries for common functions  [j) Download ZIP
M LICENSE Initial commit 2 years ago
™ READMEmd Update README.md 18 days ago

Don’t unzip it!
Import the .ZIP file to your Arduino IDE.
To import the .ZIP file go to Sketch > Include Library > Add .ZIP Library

- AtlasScientific
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Ste p 5 Flash the Hydroponics meter with the correct code

A Select, open and adjust the code you want to use for your Wi-Fi Kit

File> Examples> EZO_I2C_lib-master> Examples> IOT_kits> hydroponics_kit

File Edit Sketch Tools Help

New Ctrl+N
Open... Ctrl+ 0
Open Recent 3
Sketchbook
Examples i 'y ifi hydroponics kit that uses the Adafruit huzzah32 as its computer.
Close Ctrl+W Eleks 2
Save Ctrl+S HEtlos 2
e ChrlsShift+ S Preferences H //include wifi library
5D ] //include thingspeak library
Page Setup  Crl+Shift+P 50_MMC ) //imports a 4 function segquencer
Print Ctrl+P SirnpleBLE 3 //imports a 1 function segquencer
Preferences  Chrle Comma 5P| » //brings in common print statements
SPIFES +C library from https://github.com/Atlas-Scientifie/Ezo I2c lib
Quit Ctrl+Q Ticker y2c library
=
S Update >
12 WwiFiclient clien LB . f/declare that this device connects to a Wi-Fi netwo
13
WebServer > .
S >Lng5pea3r_ Credentials—————-—
iFi
15 |const String ssi //The name of the Wi-Fi network you are connecting -
i s WiFiClientSecure » . )
1& const String pas //¥Your WiFi network password
- 3
17 lconst long myCha Weitee //Your Thingspeak channel number
18 const char * myW Examples from Customn Libraries KXHHE" ; //¥our ThingSpeak Write API Rey
19 ffmmmmmmmm e ACROBOTIC SSD1306 e
20 Adafruit BME230 Library >
21 Ezo board PH = E Adafruit BMESS0 Library | //fcreate a PH circuit object, who's address is 99 and name is "PH"
22 Ezo _board EC = E Adafruit BuslO 4| //create an EC circuit object who's address is 100 and name is "EC"
23 Ezo_board RTD = Adafruit ESPAZ66G o| //create an RID circuit object who's address is 102 and name is "RTD"
24 Ezo_board PMP = Adafruit GEX Library ,| //create an PMP circuit object who's address is 103 and name is "PMP"
25
: Adafruit HTU21DF Library > ) o
& Ezo boar evice an array o oards used for sending commands to a or specific boards
26 Ezo board d AR |77 v of board d £ ding ds to all pecific board
7 T afruit Liqur a
27| PH, e
og EC, Adafruit SHT31 Library >
i i »
55 RTD, Adafruit 57021 Library
20 St atlas_gravity »
31 }; EspSoftwareSerial
s Ezo_12c_fib-master 1 Examples. I2¢_lib_examples %
153156 Board* defad Ezo_uart_lib-rnaster *1: //used 1 |1OT_kits aquaponics_kit
24 MCUFRIEND_kby > Praducts hydroponics_ki
35 //gets the lengt PID *lly so we Projects hydroponics_kit_with_DO add new boards
36 const uintd t de StepperDriver *rice list) Sequencer_lib_examples legacy_hydroponics_kit
ThingSpeak » legacy_hydroponics_kit_with_DO
INCOMPATIELE > legacy_pool_kit
| i | pool_kit
thingspeak_example

- AtlasScientific
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B Fill in your Wi-Fi / ThingSpeak credentials

Fill in your Wi-Fi name and Password, along with the Channel ID and Write API Key to the
code. (see step 3)

vl

finclude <iot_cmd.h>

4 #include <WiFi.h> f/include wifi library

5 #include "ThingSpeak.h" /finclude thingspeak library

& #include <segquencer4.h> //imports a 4 function segquencer

7 #include <sequencerl.h> //imports a 1 function segquencer

B finclude <Ezo i2c util.h> /fbrings in common print statements

%]

#include <Ezo_iZ2c.h*> //include the EZO I2C library from https://github.com/Atlas-Scientific/Ezo I2c 1ib

10 finclude <Wire.h> /finclude arduincs iZec library

[

WiFiClient client /fdeclarse that this device connects to a Wi-Fi network,c

I
%]
[

fad

R RIS PR Fill in your Wi-Fi / Thinggheak Credentials—————-—

tring ssid = "Wifi Mam="; //The name of the Wi-Fi network you are connecting to
. String pass = "Wifi Password"; //Your WiFi network password
t long myChannelNumber = 1234566; //Your Thingspeak channel number

char * myWriteAPIEKey = "0O000000000000MX"; J{¥our ThingSpeak Write API Eey

Check here to see which version you have.

Temperature

= b e For version 1.4 use these enable pins for each circuit-—---—--
38 |//eonst - int EN BPH = 13;

s

0 //const int EN_EC = 12; If version 1.4
1 /fconst int EN RTD = 33; use these enable pins.

ey

42 //const int EN _AUX = 27;

e e
14

45 | Jf———— For version 1.5 uss these snable pins for sach circuit—————
45 const int EN PH = 12; .

47 const int EN:EC = 27; If version 105

%8 const int EN RTD = 15; use these enable pins.
49 const int EN AUX = 33;

wn

&

s
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
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|
|
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D Setting up your pump

If you do not have a pump attached, you can just skip this part. The code is rather
self explanatory. You set what parameters will trigger the pump to engage.

(==

//parameters for setting the pump cutput

5

58 #defins FUME_BOARD EMP //the pump that will do the ocutput (if theres more than one)

5% fdefine FUMP_DOSE —0.5 //the dose that the pump will dispense in milliliters

&0 $defins EZ0Q BOARD EC //the circuit that will be the target of comparison

6l #define IS GREATER THAN true //true means the circuit's reading has to be greater than the comparison wvalue,
£2 fdefins COMPARISON VATUE 1000 //the threshold above or below which the pump is activated

Ste p 6 Setting up the HUZZAH board

A Set the target CPU to flash

Tools> Board> ESP32 Arduino > Adafruit ESP32 Feather

File Edit Sketch Tools Help

Auto Format Ctrl+T
Archive Sketch
: Fix Encoding & Reload

hydroponice o .

Manage Libraries... Ctrl+Shift+]
1 //This I (e CirisShifts |1 hydroponics kit that uses the Adafruit i
2 Serial Plotter Ctrl+ Shift+L
3 #inclu
4 fincla WIF101 7 WiFiMNINA Firmware Updater HrRE s TR s
5 finclu Board: "Adafruit ESP32 Feather" ] B Manager... /{include thingspeal
4 ilnd“ Upload Speed: "921600" ! Arduino AVR Boards Nlmm"‘i‘s"a‘—*—i“m“
T ifinelual ; . S ‘
8 |$inciu et 1| ESP32 Arduino. ESP32 Wrover Module
i B Partition Scheme: "Default” H ESP2266 Boards (3.0.1) ESP32 Pico Ki
oy | : [ ico Kit
5 #inclu e e : SRR e

ore Debug Level: "None
10 #inclu ? : library TinyPICO
5 Fad 50D Uttra v
12 WiFicl et Baartindo MagicBit
13 Programmer 3 Turta loT Mede
14 |/f——— Burn Bootloader igSpeak Credential TTGO LoRa32-0OLED V1
15 const String ss5id = "Wifi HName"; TTGO T
16 const Btring pass = "Wifi Password"; TTGO T7 V1.2 Mini32
17 const long myChannelNumber = 1234366; TIGO T7 V1.4 Mini32
18 lconst char * myWritelPIFey = "X000O0D0ONDINENK"; Adafruit ESP32 Feather
L e e T e T T e R T T R T TR R T TR RS TR T SparkFun ESP32 Thing
20 SparkFun ESP32 Thing Plus
21 [Ezo board PH = Ezo board(52, "PH"); //create a PH circ u-blox NINA-W1D series (ESP32)
22 Ezo board EC = Ezo board (100, "EC"); //fcreate an EC cir Widora AR
o 1= " mwy . = = -1 .
22 Ezo _board RTD Ezo board(1lC2, "RTD"); /fecreate an RTD ci Electronic SwestPeas - ESPI20
TA Team emmasd TR — Team o D000 LR 2 ¥ 0 oL F e e mam TIRATI




B Adjust CPU Settings

Make sure the CPU settings on the Adafruit HUZZAH32 are correct.
To adjust the CPU settings, click Tools.

For reference, this is what Atlas Scientific set the CPU settings to.
(your options may not be exactly the same, just try and match them as closely as possible.
Don't forget to set the correct com port for your device.)

File Edit Sketch | Tools| Help

hydroponics_K

W5 R S I S

L e
M ke e e dk e e Bk

I
Cad s}

|
B 1 0 R &

-0

[P (R TR TR
2B g g -Bg
O 0O 0O 0 0
juml fd |l fd
g o B o B
g gogda

Jd
a2
]
J=st
=
E.

constc 5
const Si
b |

CoOnsSn AL

const cf

Auto Format Ctrl+T
Archive Sketch

Fix Encoding & Reload

Manage Libraries... Ctrl+Shift+|
Serial Monitor Ctrl+Shift+ M
Serial Plotter Ctrl+5hift+L

WiFi101 / WikiNINA Firmware Updater

Board: "Adafruit ESP32 Feather”
Upload Speed: "921600"

Flash Frequency: "20MHz"
Partition S5cheme: "Default”
Core Debug Level: "None”

Port: "COMSE"

Get Board Info

Prograrmmer

Burn Bootloader

C Compile and upload

& hydroponics_kit | Arduino 1,813
File Edit Sketch Teols Help

COREEE=m

Compile and upload the code.

16 Copyright © Atlas Scientific LLC

. AtlasScientific

R ~——Environmental Robotics



Ste p 7 See the readings

Open your Arduino serial monitor.

(You must have the serial monitor set to the com port from the Adafruit HUZZAH32)

€ - O X
| || send |
Autoseroll [ ] Show timestamp Carriage return « | 9500 baud w |_Claa|' output I

Set to carriage return and 9600 baud.

The Wi-Fi Hydroponics Meter will always attempt to connect to ThingSpeak on bootup.

o) - O X
|. - || serd |
RTD: 25.90 PH: 4.49 EC: 146.40

RTD: 25.91 PH: 4.49 EC: 146.40

RTD: 25.91 PH: 4.4% EC: 146.30

RTD: 25.91 PH: 4.49% EC: 146.30

RTD: 25.91 PH: 4.49 EC: 14&.30

ETD: 25.91 PH: 4.49 EC: 146.30

sent to thingspeak

RTD: 25.90 PH: 4.4% EC: 146.40

RTD: 25.91 PH: 4.49 EC: 146.40

RTD: 25.91 PH: 4.49% EC: 146.30

RTD: 25.91 PH: 4.49 EC: 146.30

RTD: 25.91 PH: 4.4% EC: 146.30

BETD: 25.91 PH: 4.49 EC: 14€.30

sent to thingspeak

RTD: 25.90 PH: 4.4%9 EC: 146.40

BRTO- 25 §1 DH- 4 48 - 146 40

[/ Autoscroll [] Show timestamp | Carriagereturn ~ | 9600baud  + | | Clear output

17 Copyright © Atlas Scientific LLC
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If it cannot connect to your Wi-Fi you will see this:

e - O X

RTD: 25.76 PH: 4.49 EC: 143.20
RTD: 25.76 PH: 4.49 EC: 143.20
RTD: 25.76 PH: 4.49% EC: 143.20
RTD: 25.76 PH: 4.4% EC: 143.00
connecting to wifi

RTD: 25.76 PH: 4.49 EC: 143.00
RTD: 25.76 PH: 4.49% EC: 143.00
RTD: 25.76 PH: 4.49 EC: 143.00
RTD: 25.7¢6 PH: 4.4% EC: 142.80
connecting to wifi

RTD: 25.76 PH: 4.4% EC: 143.20
RTD: 25.76 PH: 4.49 EC: 143.20
RTD: 25.76 PH: 4.49 EC: 143.20
ETD: 25.76& PH: 4.4% EC: 143.00
connecting to wifi

RTD: 25.76 PH: 4.4% EC: 143.00
RTD: 25.76& PH: 4.4% EC: 143.00
RTD: 25.76 PH: 4.4% EC: 143.00
BTD: 25,76 PH;: 4.4% EC: 142,80

[+] Autoscroll [ ] Show timestamp [Eamage return s | .rgﬁﬂﬂbaud ol | Clear output |

Entering the poll command will stop the Wi-Fi Hydroponics Meter from uploading the
readings to thingspeak, while you debug your Wifi problems.

- AtlasScientific
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Step 8 Sensor Calibration

Atlas Scientific created a list of calibration commands that are built into the library.
Type in help to see a list of commands.

@E = O P
|| send [
> help
Atlas Scientific I2C hydroponics kit
Commands :
datalog Takes readings of all sensors every 135 sec send to thingspeak
Entering any commands stops datalog mode.
poll Takes readings continuocusly of all sensors
ph:cal, mid, 7 calibrate to pH 7
ph:cal,low, 4 calibrate to pH 4
ph:cal, high, 10 calibrate to pH 10
ph:cal,clear clear calikration
ec:cal,dry calibrate a dry EC probe
ec:k, [n] used to switch K values, standard probes values are 0.1, 1, and 10
ec:cal,clear clear calibration

For Kl probes, these are the recommended calibration values:
ec:cal, low, 12880 calibrate EC probe to 12,880us

ec:cal, high, 80000 calibrate EC probe to 80, 000us

rtd:ical, t calibrate the temp probe to any temp value
t= the temperature you have chosen
rtd:cal,clear clear calibration
[+] Autoscrall [] Show timestamp Carriage return ~- | | 9600 baud | | Clear output

A The poll command

Send the command poll; This will let you see the readings once per second and it will stop
uploading to ThingSpeak while you calibrate.

- AtlasScientific
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B Calibrate pH

Remove the soaker bottle and rinse off the pH probe. Remove the top of the pH
7.00 calibration solution pouch. Place the pH probe inside the pouch and let the probe sit
in the calibration solution until the readings stabilize. This will take about 1 — 2 mins.

Calibration

= O X
6.917 |
7.126 — X Unstabilized : -
7.223 | X Once the readings have stabilized,
7.225 | issue the Mid point calibration
7.225 . command. ph:cal,mid,7
7 225 —JStablllzed ——
7.225] After 20 mins, the calibration solution inside an
ph:cal,mid,7 open pouch is no longer considered accurate.

Dispose of the unused solution, after calibration.

Rinse off the probe and repeat this process for both pH 4.00 and pH 10.00.

C Calibrate Conductivity

Setting the Conductivity probe type

If your probe # K 1.0 (default), then set the probe type by using the ec:k,n command.
(where n = K value of your probe)

Example, if you have a K 0.1 conductivity probe issue the command ec:k,0.1

When calibrating Conductivity, you must always calibrate a dry probe first.

Make sure that the probe is dry before issuing this command, ec:cal,dry



Once the dry calibration has been completed, place the probe into a small cup of the low
point calibration solution. Shake the probe to make sure you do not have trapped air
bubbles in the sensing area. You should see readings that are off by 1 = 40% from
the stated value of the calibration solution. Wait for readings to stabilize.

12,880pS 12,880pS

Trapped air in sensing check probe connection,
area (shake to remove) +/- 40% you cannot calibrate to 0.

— O X
16,247
15,491 [~ X Unstabilized
14,053
13,756

13,756 oo
13,756 —Q/Stablllzed

13,756 Once the readings stabilize, issue the low point
ec:cal,low,12880 calibration command. ec:cal,low,12880
- (Readings will NOT change)

Rinse off the probe before calibrating to the high point. Pour a small amount of the high
point calibration solution into a cup. Shake the probe to remove trapped air. Again, the
readings may be off by 1 — 40% Wait for readings to stabilize.

— O X
51,674 |
53,826 — X Unstabilized
55,193
56,493 |

56,493 .
56,493 _«Stablllzed

56,493 Once the readings stabilize, issue the high point
ec:cal,high,80000 calibration command. ec:cal,high,80000
- (Readings will change, calibration complete).

- AtlasScientific
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D Calibrate Temperature

Calibrating the PT-1000 temperature probe is not required. However, if you want to,
a simple method to calibrate the probe is to place the PT-1000 into boiling water. Then
issue command rtd:cal,t

100 °C

Elevation in meters

305
229
152
76

0
-76
-152

Calibration Complete
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Step 9 it ione

Once you are finished with calibration, issue the datalog command to resume taking a
reading every 15 seconds and uploading it to thingspeak.

To see the data on your phone, download the ThingSpeak app.

Min isg
f o1
:S'pu),‘ Max 34
ax 359, ,qm-‘?‘-:;ss,, 1232

esrea,,

4 Ma
ﬁﬂ?; 834,00 19

1 :
1225 Sep 1247 Seo 1227

1240
1222

=

R o
e ——

221

Setup Complete!

- AtlasScientific
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