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Kickstart Development Kit
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IMPORTANT NOTICE

Texas Instruments and its subsidiaries (TI) reserve the right to make changes to their products or to discontinue any
product or service without notice, and advise customers to obtain the latest version of relevant information to verify,
before placing orders, that information being relied on is current and complete. All products are sold subject to the
terms and conditions of sale supplied at the time of order acknowledgement, including those pertaining to warranty,
patent infringement, and limitation of liability. TI warrants performance of its semiconductor products to the
specifications applicable at the time of sale in accordance with TI’s standard warranty. Testing and other quality control
techniques are utilized to the extent TI deems necessary to support this warranty. Specific testing of all parameters of
each device is not necessarily performed, except those mandated by government requirements.

CERTAIN APPLICATIONS USING SEMICONDUCTOR PRODUCTS MAY INVOLVE POTENTIAL RISKS OF
DEATH, PERSONAL INJURY, OR SEVERE PROPERTY OR ENVIRONMENTAL DAMAGE (“CRITICAL
APPLICATIONS”). TI SEMICONDUCTOR PRODUCTS ARE NOT DESIGNED, AUTHORIZED, OR
WARRANTED TO BE SUITABLE FOR USE IN LIFE-SUPPORT DEVICES OR SYSTEMS OR OTHER
CRITICAL APPLICATIONS. INCLUSION OF TI PRODUCTS IN SUCH APPLICATIONS IS UNDERSTOOD TO
BE FULLY AT THE CUSTOMER’S RISK.

In order to minimize risks associated with the customer’s applications, adequate design and operating safeguards must
be provided by the customer to minimize inherent or procedural hazards. TT assumes no liability for applications
assistance or customer product design. T does not warrant or represent that any license, either express or implied, is
granted under any patent right, copyright, mask work right, or other intellectual property right of TI covering or relating
to any combination, machine, or process in which such semiconductor products or services might be or are used. TI’s
publication of information regarding any third party’s products or services does not constitute TI’s approval, warranty
or endorsement thereof.

Copyright ©2004, Texas Instruments Incorporated

Note: The TMS470R1A256 is functionally compatible with the
TMS470R1VF346 and TMS470R1VF348.
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1 Getting Started

This chapter provides installation and programming instructions for the starter kit TM S-FET470A256 TMS470 IAR
Kickstart Development Kit.

1.1 Kit Contents

+ One TMS-FET470R1A256 CD-ROM.
+ One TMS-FET470R1A256 IAR Kickstart Development Board
+ One TMS-FET470R1A256 IAR J-Link USB-JTAG Debugger

1.2 Installing the Embedded Workbench KickStart-16

Exit all MS-Windows programs prior to loading this software.

The setup program installs all necessary files for running programs on the IAR KickStart Environment. The setup
program adds the appropriate program group and icons to the Windows program manager. Included on this CD is a 16
Kbytes code-sized limited Embedded Workbench KickStart C/C++ compiler debugger.

1. To install it select Install Software and then select KickStart Version. Note: If the program does not install
automatically click the open file and this will begin the installation.This will start the installer (below).

Welcome to the united world of lAR.
IAR Embedded Workbench™ Kickstart for ARM

%

ﬁ Install the In=stall the IAR Embedded Workbench
e AR Embedded Workbench™ on your computer. This includes
project handler, editor, compiler,
assembler, linker, and debugger

SIAR

SYSTEMS

Different Architectures. One Solution. www.iar.com

Yy

2. Click Install the IAR Embedded Workbench and follow the instructions in the installation application. If the
files does not automatically open click open the file. We recommend that you use the default directories, and
the Full installation option.

Exitthe installer application.

4. Note: Run any update after installing the workbench.
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1.3 Installing IAR J-Link USB to JTAG debugger

Before you start the Embedded Workbench it is a good idea to install the J-Link USB to JTAG debugger.

Note: J-Link is not compatible with Windows 98.

1.

Plug the USB cable into the J-Link.
Important: Do not connect the J-Link to the target PCB before this installation procedure is completed!

Connect the other end of the USB cable to the USB port on your PC. The green light on the J-Link will start to
blink indicating that J-Link has not found a driver.

Your PC will search for a driver. This might take a few seconds. When it has located New Hardware, it will
start the Install wizard.

Choose Install from a specific location.

Click the Browse button and browse to the J-Link directory. If you used the default directory they will be at:
C:\Program Files\IAR Systems\Embedded Workbench 4.0 Kickstart\ARM\drivers\JLink

Note that WinXP shows a warning that the driver is not certified by Microsoft. Ignore this warning and click
continue anyway.

Click Finish. Windows will tell you that everything is OK and the green light on J-Link will stop flashing.
J-Link is now installed.

Hardware Installation

With the J-Link Connected to the PC. Connect the 20 conductor ribbon cable between the J-Link and the target
EVM.

Connecta 6 — 9 VDC power supply to the EVM (not included) with a 5.5mmO.D. x 2.1mm [.D. connector.

Verify the jumper configuration with the “Descriptions of the jumpers on the TMS470R1VF346 board’
document named “TMS470JumperDescriptions.pdf” on the supplied CD ROM, in the Product_Info
directory.

Now you are ready to start the workbench and try an example program.
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1.5 Starting the Embedded Workbench and running the demo
application

1. From the Start menu choose Programs>IA R Systems>IAR Embedded Workbench for ARM>IAR
Embedded Workbench. The IAR Embedded Workbench for ARM will start.

2. Choose Example workspaces

Embedded Workbench SEartup x|

LCreate new project in curent workspace

Add exizting project to current waorkspace

=)=

Open exizting waork space

=
] i)
==
([

E=ample worlk.zpaces

Becent waorkzpaces:
trnsd 710

[ Do not show this window at startup.

Claze |
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3. Navigate to the TexasInstruments\TMS470R1A256\ChipDemo example project. Check the “Do not prompt
for working copy directory” box and click Open.

x

- A B Open |

-] AnalogDevices

H-L Am Cancel |

- Atmel

- Cimus

-] Freescale

&L Ok

&1 Phiips

- 5T

ED T exazlnstruments
=0 TM5470R14256

- % ChipDemo

L]

¥ Do not prompt for warking copy directon.

4. Inthe Workspace window, the select the compilation target. In this case “TOGGLE” and “flash”.

] x
flash |
ERER
= B TOGGLE - flash v
B trns470_low lewel . *
Faftrns470r1 a256_01.c
3 Output

Double clicking on any of the files in the list will open the editor window.
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5. Click the C-SPY “Debug” button. This will automatically compile the project, if necessary, start C-SPY
“Debug” and then download and Flash.

.7 1AR Embedded Workbench IDE
i File Edit “iew Project Tools Window Help

= 1= I AN | R AL X T L AXFC)
Workspacs * | kms470_low_level_init_flash.c tms470r1a256_0L.c |
I_' IHaSh ;I i _'|_I)’/*******:E*=E***********=E**:E*:E*******=?************************ FEXEEXELEE
i Filas | o | m‘lﬂ ' 2/ IM5470 Demo — Software Toggle HETA.31 OQutputs
= FTARRIF - flach v o

6. Should you get the following dialog box after starting a debug session, a J-Link firmware update has been
performed. Close this dialog box by clicking Abort. Then, disconnect and reconnect the J-Link interface to
complete the firmware update process. Now you can start the debug session.

%

Firmware update requires reboat |
Please close this application
Disconnect J-Link

Reconnect J-Link
Restart the application

abort I Retry Ignore

7. Click on the GO button to start the program.

/2 IAR Embedded Workbench IDE

File Edit “iew Project Debug Disassembly  J-Linl
D@ S| R ™|

| 82T LECS

=

| Filae [ &= [ B |

kms470_low_level_init_flash.c  tms470r1az5

24 #include <Lintrinsic. b=
28 #include "iotms4d70rlazb

8. The LEDs 1 and 16 or HETO and HET3 1 should now be blinking on the target board.
9. To stop the debugger click the BREAK button.

i /2 IAR Embedded Workbench IDE
i File Edit View Project Debug Disassembly
I

& &5 L8

b

tf— 3

k=4 70_low_level_init_flash.c b
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10. To exit the debugger click the EXIT button.

/2 IAR Embedded Workbench IDE

File Edit ‘iew Project

Debug  Disassembly  J-Linl

DSHE| =] 4 2 < |
Sl e LE2XEB
workspace * | tms470_low_level init_Flash.c  tms470r1a25

[ flash |

| Filae [ s~ pm |

Congratulations.

You have just run your first Embedded Workbench for ARM application and debug session.

2d #include <intrinsic.lc-
23 #include "iotmsdY0rlaZs

1.6 Documentation and Information

For more information, please refer to the IAR Embedded Workbench help menu.

Comprehensive and up-to-date documentation and information can be found on the Web at http://www.ti.com/tms470 .
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2 Helpful Hints

2.1 Setting up a new workbench with the predefined templates

1. From the Start menu choose Programs>IAR Systems>IAR Embedded Workbench for ARM>IAR
Embedded Workbench. The IAR Embedded Workbench for ARM will start. Then click on
Help>StartupScreen.

ded Workbench IDE

Project Tools Window | Help
& B | o o | Content. .. L&
x Index...

Search...

Release notes

ARM Embedded Workbench User Guide
ARM C/C++ Compiler Reference Guide

IAR. MISRA C Reference Guide

ARM Assembler Reference Guide

ARM Embedded Workbench Migration Guide

Linker and Library Tools Reference Guide
[AR on the Web
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2. Afterselecting the startup screen, select ““Create new project in current workspace”.

bedded Workbenc

Create new project in current wgflkzpace

Add exizting project ko current wark zpace

Open existing workzpace

Example workzpaces

Recent waorkzpaces:

ChipDemo
ChipDemo
ChipDiemo
FB1_wWS
tutorialz

Open

™ Do not show this window at startup.

Cancel |

3. Inthe C project template select the TMS470R1A256 main template. This offers a complete setup for RAM
and FLASH download with all sub settings completed and an empty main.c program, for a quick start. If you
get this far and do not see the TMS470R1A256main template , please install the updates.

Create New Projeck X|

Toal chair: [4RM =l

Froject templates:

-- azm ;I
-- C++

=E

S Th5470R 14256 main
i Externally built executable

Dezcription:

THS470R 142586 C project uzing default tool zettings for Flazh and Fabkd dowr

4| | i
k. I Canicel |
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2.2 Setting up a new workbench from scratch

Start a new work space
Add a new project. Project>Create a New Project Name and save it to you project directory.
Add the program files (or create a new program file then add it) Project>Add a New File.
Example : main.c , tms470_cstartup.s79 and tms470_low_level_init.c
Select the project.
Select options for the project. Project>Options.
Select the General Options Category and Confirm the Target Window.
a. Select the chip variantin use, ARM Mode, Big-Endian Mode and 4 bytes.
8. Select the Linker Category and Confirm the Output Window.
a. Select Allow C-SPY specific extra output file
9. Change to Extra Output Window and select Generate extra output file
10. Change to Config Window and select Override default for the Linker Command file
11. Select the appropriate CMD file for part, RAM or Flash.
12. Select the Debugger Category and Confirm the Setup Window.
a. Change Driver to J-Link.
b. Change Setup Macros by checking the Use Macro file to the appropriate macro (Ram or Flash)
c¢. Change to Download Window and select Verify download and if you are going to flash the part
check the Flash download
d. Close the window and you are now ready to start.

N swN =
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