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TVP5151 Evaluation Module
Description

The TVP5151EVM is a four-layer printed circuit board designed for evaluation of the TVP5151
PAL/NTSC/SECAM video decoder. A THS8200 triple DAC is included on the circuit board to convert the
ITU-R BT.656 YCbCr digital output from the TVP5151 to YPbPr component video. Two composite video
(CVBS) input connectors and one YPbPr component video output connector are provided on the board for
input and output connections. 1°C communication with the EVM is provided by a host PC USB port and the
VCC (Video Control Center) software tool provided with the EVM. All required power for TVP5151EVM is
supplied by the USB port. This user's guide outlines the necessary hardware and software setup required
to provide full evaluation of the TVP5151.

Functional Overview

The TVP5151EVM uses a host PC USB port to emulate the I°C bus, providing communication with the
TVP5151 video decoder and the THS8200 encoder. The VCC application software provided on the
TVP5151EVM CR-ROM communicates with the devices via the PC USB port.

The analog video inputs supported by the TVP5151AEVM include two composite video inputs. In general,
the video decoder converts the analog video input signal into 8-bit ITU-R BT.656 YCbCr digital component
data. This data and the associated clock from the video decoder are sent to the THS8200 for conversion
to analog YPbPr component video.

To experiment with the programmable features of the TVP5151 video decoder and the THS8200, the USB
port of the TVP5151EVM is connected to the USB port of a PC. VCC, a Windows™ compatible
application, provides the user interface for performing register-level and high-level control of the TVP5151
video decoder and the THS8200 encoder DAC. A PAL or NTSC composite video source and a monitor
capable of displaying YPbPr component video are required for evaluation.

6
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Board-Level Description

2 Board-Level Description

Figure 1 illustrates the primary components on the TVP5151EVM.
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Figure 1. TVP5151EVM Board Layout

2.1 Analog Video Inputs

Two RCA video connectors are provided for connecting NTSC or PAL composite video sources to the
TVP5151EVM. CH1 is connected to the AIP1A input of the TVP5151, while CH2 is connected to the
AIP1B input. Both video inputs pass through anti-alias filters, termination resistors, and AC coupling
capacitors prior to connecting to the TVP5151 input. CH1 is the default channel selected by the TVP5151
input MUX and EVM software and is the recommended input when connecting a single video source.
S-video can be supported by connecting the Y (luminance) input to CH1 and the C (chrominance) input to
CH2.

2.2 Analog Component Video Output

RCA connectors are provided for connecting the YPbPr component video output to a suitable monitor. The
component video outputs are driven by the THS8200 DAC through filters similar to those used for the
composite video inputs. The THS8200 output and filters are designed for a 75-Q video load. When viewing
the outputs on an oscilloscope, the component video outputs must be properly terminated with 75 Q for
correct output levels. Composite video out is not supported with the TVP5151EVM.
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2.3

2.4

2.5

USB Interface and Power

A USB cable must be connected between the host PC and TVP5151EVM. The USB interface cable
provides the 1°C communication required to program the TVP5151 and THS8200 and also provides the
5-V power required for the TVP5151EVM. An optional power jack (J1) is provided on the board to allow
use of a separate power supply if desired. If a separate 5-V power supply is used, R1 and R2 must be
removed from the TVP5151EVM and D1 installed. The USB interface circuitry remains powered by the
USB interface, if this separate supply is used. Voltage regulators on the EVM are used to generate the
1.8-V and 3.3-V levels required for the components on the board. LEDS are included on the board to
indicate the presence of 5-V power and USB connectivity.

Board Jumpers

The TVP5151 provides support for either 1.8-V or 3.3-V 1/O levels. The 1/O levels used by the
TVP5151EVM can be selected by moving the 0-Q SMT resistor at J2. The EVM is shipped from the
factory with 3.3-V I/O selected. The J2 setting affects all digital I/O levels on the TVP5151EVM, including
the TVP5151, THS8200, I>)C, and RESET.

The J7 power-down jumper can be used to place the TVP5151 in a low-power state. In this power-down
state, the TVP5151 I>C is not functional. See Table 1 for a summary of jumper options.

Table 1. Jumper Settings

Jumper

Designator Function Default Setting Comment

Selects TVP5151, THS8200, and I°C I/O levels, 0-Q
SMT

J6 TVP5151 12CA select B8h TVP5151 I°C address, 0-Q SMT

J2 1.8-V/3.3-V I/O select 3.3-V

1-2, normal

17 TVP5151 power down operation

I2C disabled during power down

J9 Reserved for test Installed Must be installed for USB I°C functionality
J10 Analog/digital GND connection Installed 0-Q SMT
J11 Analog/digital GND connection Not installed Optional

Test Points

Test points are provided on the TVP5151EVM to assist in evaluation of the TVP5151. All TVP5151 digital
outputs are brought out to the P1 dual row header that can be used for testing and external connections.
See Table 2 and Figure 2 for available test points.

Table 2. Test Points

Test Point
Designator

TP1 3.3V Main 3.3-V supply for the board
TP2, TP19 DGND Digital ground

TP3 1.8V Main 1.8-V supply for the board

TP5 AGND Analog ground

TP17 SDA I>)C data

TP18 SCL I>C clock

Function Comment

8
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2.6

1 P1

yo | () ()| GND
Yt | () ()| 6ND
v2 | () ()| eND

v3 | () ()| INTREQ/GPCL/VBLK

Y4 | () ()| AVID/ICLK_IN
vs | () ()| Hs

ve [() ()] vs

y7 | () ()| FipieLco
GND | () ()| GND

sck | () (O] 6ND

Figure 2. P1 Header Pinout

TVP5151 Crystal Requirements

The TVP5151EVM is shipped from the factory with a 5.0-mm x 3.2-mm 27-MHz crystal installed. An
additional footprint is also included on the PCB (see Figure 3) for evaluation of smaller 2.0-mm x 1.6-mm
crystals. This smaller crystal is a 4-pin device and must be oriented correctly on the EVM. C62 and C59
are load capacitors for the crystal and must be sized according to the specification of the crystal used. The
TVP5151EVM is shipped from the factory with 33-pF load capacitors installed in support of the crystal
used. The frequency stability of the crystal used must be within £50 ppm.

The TVP5151 also supports the use of a 27-MHz oscillator or clock source via connections to either the
XTAL1/OSC or AVID_CLK_IN pins. 1.8-V logic levels must be used when connecting a clock source to
the XTAL1/OSC pin of the TVP5151. Clock sources with 3.3-V output levels are supported by the
AVID/CLK_IN pin, but only when jumper J2 is configured for 3.3-V I/O. Additionally, the XTAL1/OSC pin
must be tied to GND to activate AVID/CLK_IN clock functionality. The XTAL1/OSC pin can be grounded
by replacing C62 with a 0-Q resistor.

Bottom Side

C62 R23 C59
Figure 3. PCB Crystal Footprint
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3.1

3.2

Software Installation

This section summarizes the steps for setup and operation of the TVP5151EVM. If TVP5151EVM software
has been previously installed on the PC, you will be prompted to first uninstall the previous version.

Uninstalling Previous Version

To uninstall a previous version of TVP5151EVM software:

1. Click Start > Control Panel > Add or Remove Programs; wait for the list to populate.
2. Find and select "TVP5151EVM Software".

3. Click the remove button.
4,

When prompted with "Are you sure you want to remove the TVP5151EVM Software from your
computer?"”, click Yes.

TVP5151EVM Software Installation

The TVP5151EVM Software package includes the Windows Control Center (VCC) application, device
initialization files, and documentation. This must be installed from the enclosed CD-ROM onto the PC that
will be used to control the TVP5151EVM via the PC USB port.

To install the software:

1. Insert the CD-ROM into the computer that will emulate the 1°C bus via the USB port.

2. Run SETUP.EXE to install TVP5151EVM software and documentation.

3. Click Next at all prompts and click Finish to complete the installation process (see Figure 4 through
Figure 7).

% TVP5151EVM Software

Welcome to the TVPb151EVM Software Setup
Wizard

The installer will guide you through the steps required to install TYPS151EVM Software on your
computer.

WARNING: This computer program is protected by copyright law and international treaties.
Unauthorized duplication or distribution of this program, or any portion of it, may result in severe civil
of criminal penalties, and will be prosecuted to the marimum extent possible under the law.

‘ Cancel | Next » i

Figure 4. TVP5151EVM Software Setup Wizard
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15 TVP5151 EVM Software

Select Installation Folder

The installer will install TYPS151EVM Software to the following folder.

Toinstall in this folder, click "Next”. To install to a difterent folder, enter it below or click "Browse"

Folder:

c\Pragram Files\T exas Instiumentsh TVPST151EVMY Browse...

Install TYPS151EVM Software for yourself, or for anyone who uses this computer:

(©) Everyone

) Just me

l Cancel l t ¢ Back J E ﬂext}

i TVP5151EVM Software

Figure 5. Select Installation Folder

Confirm Installation

The installer is ready ta install TYPS151EYM Software on your computer.

Click "Mext" to start the: installation,

[ Cancel ] [ ¢ Back ] E ' ﬂB}ﬁ")‘ -

Figure 6. Confirm Installation
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& TVP5151 EVM Software

Installation Complete

TYPE151EVM Software has been successtully installed.

Click "Close" to exit.

Please use ‘Windows Update to check for any critical updates to the NET Framework

Close i

Figure 7. Installation Complete

Documentation and a shortcut to the TVP5151EVM VCC application are installed in the Windows Start
menu at:

Start > All Programs > TVP5151EVM > TVP5151EVM User Guide
Start > All Programs > TVP5151EVM > TVP5151EVM Software

12 TVP5151 Evaluation Module SLEU106—November 2009
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4 Hardware Setup
Figure 8 shows a typical TVP5151EVM setup used for evaluation.
Required Equipment
 TVP5151EVM
* NTSC or PAL composite video source such as a test generator or DVD
e Composite video cable

USB cable

* YPbPr component video cable

* NTSC or PAL monitor with YPbPr component input

* Host PC with TVP5151EVM software installed

To prepare the EVM for evaluation, connect the following:
* USB cable from the host PC to the TVP5151EVM

* Analog composite video source to CH1 of the TVP5151EVM
* Analog component video output to an NTSC or PAL compatible monitor.

Pb
NTSOPAL ' ITU BT.656
Video source THS8200 Y TV
Pr Monitor
UsB
. J
Host PC
Figure 8. Typical Hardware Setup
SLEU106—November 2009 TVP5151 Evaluation Module 13
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5

5.1

5.2

5.3

VCC Operation
This section describes operation of the TVP5151EVM VCC6 software.

Getting Started

After software installation (see Section 3) and hardware configuration (see Section 4) have been
completed, VCC may be started for evaluation of the TVP5151EVM.

Starting the VCC Application Program
The VCC6 (Windows™ Video Control Center) application program must have been previously installed on
the PC. Run VCC6 from the Windows Start Menu:

Start > Programs > TVP5151EVM > TVP5151EVM Software

VCC6 Configuration Dialog Box

The VCC Configuration dialog box, as shown in Figure 9, should now be visible. All settings from this
dialog box are stored in the Windows registry and are restored the next time the program is started. After
initial installation, VID_DEC should be set to TVP5151 and the THS8200 selected for DAC output.

The I°C slave addresses for each device must match the I1°C slave address configured on the
TVP5151EVM. This TVP5151EVM is configured by the factory to use I°C address B8h for the TVP5151
and 40h for the THS8200.

It is important to select the correct specific device type. TVP5151 and THS8200 must be selected for the
TVP5151EVM.

YCC Configuration

I3 TEXAS
INSTRUMENTS

12C Systern Configuration
DEVICE FamILy SPECIFIC DEVICE |2C SLAVE ADDR

VID_DEC [EEEE ~| ~ Bsh  BAh

[Analog Video Decoder)

WID_ENC NOT USED '] & 54k (" 5Eh

[Analog Video Encader)

TVP7OO0 NOT USED ~| @ Beh O Bah
[Video/Graphics Digitizer)

THS2200 n .
[HOTY/SDTV/RGE DALC) ]m * 40h " 42h

0K | Exit Program |

Figure 9. VCC Configuration Dialog

Click on OK to proceed and begin USB I2C communication with the selected devices.
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5.4 USB I°’C System Test

If a message occurs indicating that the USB device was not found (see Figure 10), disconnect the USB
cable, wait three seconds, reconnect the USB cable, and click Continue.

LISB: Device Mok Found. Conrnect device ko a USE part, then dick

Continue.

[ Do not display this message

W Exit Program

Figure 10. USB Error

If the USB device is still not found, see Section 6. If the USB link is functioning properly the Real-Time
Polling dialog box shown in Figure 11 appears.

5.5 Real-Time Polling

If the USB link is functioning properly, the Real-Time Polling dialog box in Figure 11 appears. When
real-time polling is enabled, VCC monitors the composite input format and automatically programs the
THS8200 when the input format changes.

Real-Time Polling,

VIDED/GRAPHICS STANDARD AUTO-5WITCH POLLING
[Palls VID_DEC for a standard switch and updates the video output device).

OK

Figure 11. Real-Time Polling

When enabled, real-time polling provides polling functions that continuously execute in the background.
When TVP5151 detects a change in the input video standard, it automatically switches to operation in the
detected standard (which includes all necessary 1°C register initialization) for proper decoding of the input
video. To enable auto-switch on the TVP5151, the Set Video Standard register must be set to auto-switch
mode (register 0x28 = 0x00).

If the VCC auto-switch polling function is enabled, the detected video standard status from the TVP5151 is
polled until a change in the input video standard is detected. When a change is detected, the THS8200 is
reprogrammed as needed for the detected standard. Using this feature, the video source can change its
video standard and the system displays using the new standard without user intervention.

To enable auto-switch polling (recommended), the video-standard auto-switch polling function must be
enabled in the real-time polling dialog (see Figure 11). The real-time polling dialog can also be accessed
when VCC is running by clicking Real-Time Polling in the Tools menu.

Click on OK to proceed with Real-Time Polling enabled.

SLEU106—November 2009 TVP5151 Evaluation Module 15
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5.6 Main Menu
After closing the real-time polling dialog, the Main Menu is displayed as shown in Figure 12. The menus,
which are used to operate VCC, are File, Edit, Tools, Window, and Help. The File menu’s only function is
Exit, which terminates the program. Table 3 is a summary of the main menu contents.
*2 Video Control Center
File Edit Tools Window Help
Ready USE connected
Figure 12. Main Menu
Table 3. Main Menu Summary
Menu Contents
File Exit VCC6
Edit Register Map Editor
Property Sheets
Tools System Initialization
Real-time Polling
USBJ/LPT I>C Options
Window Allows selection of the active window. Multiple windows can be open at the same time.
Initially the Window menu is empty.
Help About VCC
5.7 System Initialization
Clicking System Initialization in the Tools menu displays the dialog shown in Figure 13. This provides the
means for initializing the video decoder and/or video encoder for a particular video mode. The details of
the initialization are contained in the command file (with a CMD file extension).
The command file is opened using the Browse... button. Once the command file is opened, a text list
displays descriptions of the individual "data sets" contained within the command file.
Click once on the desired data set description to select it. Click the Program Device(s) Using Selected
Dataset button to run the selected data set, which loads the devices via the 1°C bus. When the device
initialization has completed, the status indicator reads Ready.
NOTE: If Ready does not display, then the devices are not initialized and the I°’C bus is not
communicating. See Section 6 for a solution.
Click the OK button to close the dialog box.
16 TVP5151 Evaluation Module SLEU106—November 2009
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System Initialization
Command File c:\Program Files\T exas Instruments\TYP5151EVM\nitialization, TYPS151EVM_Setup.cmd Browse...
Command File Operations Butes: Per Block
s (8= Allin 1 block) Feload
REPLACE i APPEND PROGR&M i
Selected Dataset Current Devicels) a .
with Current i Device Settings Using Yerfy.. ‘
Device Settings i tCMDFile Selected Dataset Status
Ready Close
Dataset Descriptions

1 =TWP5151 + TH58200, CVB51 In, Auto-switch, 480i YPbPr out A
2=TYPE151 + TH5B8200, CVBS1 In, Auto-Switch, 576i YPBPT out

Ja

4=

5=

6=

7w

B=

9=
10=
11=
12=

13=
1 v
MNOTES:

1. When using REPLACE or APPEND. click RELOAD whenever the device under test is reset or power-cycled,

Figure 13. System Initialization

5.8 Command Files

The command file is a text file which can be generated using any common editor; however, it must be
saved as plain text. Command files are especially useful for testing and comparing various changes in the
device setup.

A default command file, which should contain most of the desired setups, has been installed with the EVM
software. After installation, when the system initialization tool is opened, the default command file is
selected. This command file is located at:

C:\Program Files\Texas Instruments\TVP5151EVM\Initialization\TVP5151EVM_Setup.cmd

A command file can contain up to 250 data sets. A data set is a set of register settings to initialize the
video decoder and/or video encoder for a particular video mode. Each data set includes a description that
is displayed in one row of the dataset descriptions list. The register settings may be located in the
command file itself and/or may be stored in separate include file(s) (with an INC file extension) and be
included into the command file using the INCLUDE statement.

5.8.1 Example Command File

An example of one data set within a command file is shown in Figure 14. Each command file may contain
individual write to register (WR_REG) commands or include these commands from a separate INC file or
both. The purpose of the INCLUDE feature is to avoid repeating a long list of register settings many times
in a command file and having to maintain that list.

Command File Syntax

1. The comment indicator is the double-slash "//".

2. The command file is not case-sensitive and ignores all white-space characters.
3. All numbers can be entered as hexadecimal (beginning with 0x) or as decimal.
4,

Every data set in a command file begins with BEGIN_DATASET and ends with END_DATASET. The
maximum number of data sets is 250.
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5. The data set text description is entered between double quotes using the DATASET_NAME command.
The enclosed text can be up to 128 characters in length. This text appears in the system initialization
dialog when the command file is opened.

6. The INCLUDE command inserts the contents of an include file (with an INC file extension) in-line in
place of the INCLUDE command. Therefore, the include file should not contain the BEGIN_DATASET,
END_DATASET, and DATASET_NAME commands.

7. The write to register command is written as follows:

WR_REG, <DeviceFamily>, <Number of data bytes (N)>, <subaddress>, <Datal>,...,<DataN>

or

WR_REG,<Literal slave address>,<Number of data bytes (N)>,<subaddress>, <Datal>,...,<DataN>
8. The valid device family mnemonics are:

VID_DEC for the video decoders

THS8200 for the THS8200 device

9. VCCE6 translates the device family mnemonic to the slave address that was selected on the VCC6
configuration dialog upon program startup. This eliminates having to edit command files if the alternate
slave address must be used.

10. If the literal slave address method is used, the slave address entered is used directly.
11. A delay may be inserted between commands using the WAIT command:
WAIT,<# milliseconds>

NOTE: Allincluded files must be located in the same directory as the command (CMD) file.

BEG N_DATASET

DATASET_NAME, "NTSC in, 480i 60 YPbPr out"

/1 TVP5151

WR_REG VI D DEC, 1, 0x03, 0x69 /1 GPCL H GH, YUV output enable
WR_REG, VI D DEC, 1, 0x07, 0x20 /] Pestal control on

/1 THS8200

WR_REG, THS8200, 0x01, 0x03, 0x11 // chip_ctl

WR_REG, THS8200, 0x01, 0x1C, 0x04 // dman_cnt|

WR_REG, THS8200, 0x01, 0x1D, 0x00 // dtg_y_syncl

WR_REG THS8200, 0x01, Ox1E, 0x49 // dtg_y_sync2

WR_REG, THS8200, 0x01, Ox1F, 0x00 // dtg_y_sync3

WR_REG, THS8200, 0x01, 0x20, 0x00 // dtg_chbcr_syncl
WR_REG, THS8200, 0x01, 0x21, 0x00 // dtg_chbcr_sync?2
WR_REG, THS8200, 0x01, 0x22, 0x00 // dtg_cbcr_sync3
WR_REG, THS8200, 0x01, 0x23, 0x22 // dtg_y_sync_upper
WR_REG THS8200, 0x01, 0x24, Ox2A // dtg_chbcr_sync_upper
WR_REG, THS8200, 0x01, 0x25, Ox3E // dtg_spec_a

WR_REG, THS8200, 0x01, 0x26, 0x14 // dtg_spec_b

WR_REG, THS8200, 0x01, 0x27, Ox1E // dtg_spec_c

WR_REG, THS8200, 0x01, 0x28, 0x79 // dtg_spec_d

WR_REG, THS8200, 0x01, 0x29, 0x00 // dtg_spec_d1l

WR_REG, THS8200, 0x01, 0x2A, 0x00 // dtg_spec_e

WR_REG THS8200, 0x01, 0x2B, 0x01 // dtg_spec_h_nsb
WR_REG, THS8200, 0x01, 0x2C, 0x6B // dtg_spec_h_Isb
WR_REG, THS8200, 0x01, 0x2D, 0x03 // dtg_spec_i _nsb
WR_REG, THS8200, 0x01, Ox2E, 0x1B // dtg_spec_i _I| sb
WR_REG THS8200, 0x01, Ox2F, Ox11 // dtg_spec_k_Isb
WR_REG THS8200, 0x01, 0x30, 0x00 // dtg_spec_k_nsb
WR_REG, THS8200, 0x01, 0x31, Ox0A // dtg_spec_kl

WR_REG, THS8200, 0x01, 0x32, OXAD // dtg_speg_g_I sb
WR_REG, THS8200, 0x01, 0x33, 0x01 // dtg_speg_g_nsb
WR_REG, THS8200, 0x01, 0x34, 0x03 // dtg_total _pixel _nmsb
WR_REG, THS8200, 0x01, 0x35, Ox5A // dtg_total _pixel _I sb

18

TVP5151 Evaluation Module SLEU106—November 2009
Submit Documentation Feedback
Copyright © 2009, Texas Instruments Incorporated


http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLEU106

I

TEXAS
INSTRUMENTS

www.ti.com

VCC Operation

5.8.2

WR_REG THS8200, 0x01, 0x36, 0x00
WR_REG THS8200, 0x01, 0x37, 0x01
WR_REG, THS8200, 0x01, 0x38, 0x84
WR_REG, THS8200, 0x01, 0x39, 0x21

/1
11
/1
/1

WR_REG, THS8200, 0x01, 0x3A, Ox0D //

WR_REG THS8200, 0x01, 0x3B, 0x07
WR_REG THS8200, 0x01, 0x3C, 0x80
WR_REG THS8200, 0x01, 0x41, 0x40
WR_REG, THS8200, 0x01, 0x42, 0x40
WR_REG, THS8200, 0x01, 0x43, 0x40
WR_REG, THS8200, 0x01, 0x44, 0x53
WR_REG THS8200, 0x01, 0x45, Ox3F
WR_REG THS8200, 0x01, 0x46, Ox3F
WR_REG THS8200, 0x01, 0x47, 0x40
WR_REG, THS8200, 0x01, 0x48, 0x40
WR_REG, THS8200, 0x01, 0x49, 0x40

11
/1
11
/1
/1
/1
11
/1
11
/1
/1

WR_REG, THS8200, 0x01, 0x4A, OXFC //

WR_REG THS8200, 0x01, 0x4B, 0x44

11

WR_REG, THS8200, 0x01, 0x4C, OXAC //

WR_REG THS8200, 0x01, 0x4D, 0x91
WR_REG, THS8200, 0x01, Ox4E, 0x91
WR_REG, THS8200, 0x01, Ox4F, OxFF
WR_REG, THS8200, 0x01, 0x70, 0x40
WR_REG THS8200, 0x01, 0x71, 0x03
WR_REG THS8200, 0x01, 0x72, 0x59
WR_REG THS8200, 0x01, 0x73, 0x04
WR_REG, THS8200, 0x01, 0x74, 0x00
WR_REG, THS8200, 0x01, 0x75, 0x04
WR_REG, THS8200, 0x01, 0x76, 0x04
WR_REG THS8200, 0x01, 0x77, 0x01
WR_REG THS8200, 0x01, 0x78, 0x0B
WR_REG THS8200, 0x01, 0x79, 0x00
WR_REG, THS8200, 0x01, Ox7A, 0x44
WR_REG, THS8200, 0x01, 0x7B, 0x00
WR_REG, THS8200, 0x01, 0x7C, 0x00
WR_REG THS8200, 0x01, 0x82, 0x27

END_DATASET

Figure 14. Example CMD File

11
/1
/1
/1
11
/1
11
/1
/1
/1
11
/1
11
/1
/1
/1
11

dtg_linecnt_mnsb
dtg_linecnt_|sb

dt g_node
dtg_frame_fiel d_nsb
dtg_franme_size_| sb
dtg field_size_|lsb
dt g_vesa_cbhar_si ze
csmclip_gy_| ow
csmclip_bcb_I ow
csmclip_rcr_|ow
csmclip_gy_high
csmclip_bcb_high
csmclip_rcr_high
csmshift_gy
csmshift_bcb
csmshift_rcr
csmmult_gy nmsb
csmmult_bcb_rcr_nsb
csmmult_gy |sb
csmmult_bcb Isb
csmmlt_rcr_Isb
csm node
dtg_hlength_l sb
dtg_hdly_nsb
dtg_hdly_Isb
dtg_vlength_| sb
dtg vdly_nsb

dtg vdly Isb
dtg_vlength2_| sb
dtg_vdly2_nsb
dtg_vdly2_Isb
dtg_hs_in_dly_nsb
dtg hs_in_dly_Isb
dtg vs_in_dly _nsb
dtg vs_in_dly_Isb
pol _cntl

Adding a Custom Data Set to a CMD File

To create a custom dataset, program the EVM via the system initialization tool using the factory-supplied
command file. Through the property sheets tool or I°C Register Map Editor you can then customize the
device register settings to suit your needs and save the settings as a new dataset. To save your custom

settings:

1. Open the System Initialization dialog via the Tools menu.
2. Click Append Current Device Settings to Command File. A dialog requesting a description on the new

data set appears.

3. Optionally, click the dropdown box and select one of the existing descriptions.

»

Modify the description text or type a new description.

5. Click OK. All non-default register values are read from the TVP5151 and THS8200 and are appended
to the current command file as an additional data set.

6. Select the custom data set and press the Program button to send.
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5.9 Register Editing
The next sections describe the two available modes of register editing: register map editors and property
sheets. Each of these functions can be selected from the Edit menu.

5.9.1 TVP5151 Register Map Editor

The register map editor, as shown in Figure 15, allows the display and editing of the entire used register
space of the device within a simple scrolling text box. To open this, click on Edit Register Map in the Edit
menu and click on the device type to edit. Table 4 describes how to use each of the controls in the
register map editor.

TVP5151, (0xBB) Register Map

Address | Data | RAW | Name | Mask | Default | ~
Jui] 0o A2 Yideo Input Source Select 1 0:0B 0x00
01 15 RAY  Analog Channel Ctils Ox1F 0x15
02 0o RAw Dperation Mode Chils 0x7F 0=00
03 oo R Misc. Controls 0sFF 000
04 DC RM Auto-Switch Standard Mask-0ff 0x3C 0:DC
05 oo Ry Mise. Output Controls 0:03 0x00
06 10 RAw Color Killer Ctrls 047F 010
o B0 R Luminance Processing Chil 1 0sFF 060
0e oo RM Luminance Processing Chl 2 Ox4F 0=00 b

NOTE 1: Any address not shown in the list can be accessed by typing the address and then clicking Riead or “Wiite,

Loop Count Loop Count Radi
Address wie | [ 1 Aslesiowie o
[0~ = | Read and Read AlL Dec |
= J [1-939) Hesx (¢
Fiead | Histagram on Loop Count Reads [or Read Alls)
af : | " Enable AND |7FF7 Shaw ‘
[15 =] Read &l Mask i Close

Figure 15. TVP5151 Register Map Editor

Table 4. Register Map Editor Controls

Control

Definition

Register Window

Scrolling text box that displays the address and data for the 1°C registers that are defined for the device.

Address Edit Box

This contains the I°C subaddress that is accessed using the Write and Read buttons. Clicking on a row
selects an address, which then appears in the address edit box.

NOTE: After clicking on a row, the Data Edit Box contains the data that was in the register window. This data
may not correspond to the actual data in the device (until Read or Read All is clicked).

The address up/down arrows are used to jump to the next/previous subaddress that is defined for the
device.

NOTE: If an address is not defined for the device, it can still be accessed by typing the subaddress in the
Address Edit Box.

Data Edit Box

This contains the data to be written to or read from the I1°C subaddress.
The data up/down arrows increases / decreases the data value by 1.

Write Button

Writes the byte in the Data Edit Box to the address in the Address Edit box.
The IC register is written to whether or not the data is different from the last time the register was read.

Read Button

Reads the data from the address in the Address Edit Box into the Data Edit box and the register window.

Read All Button

Reads all defined readable registers from the device and updates the register window.

Hex Button

Displays all values in the register window and address and data edit boxes in hexadecimal format.

Dec Button

Displays all values in the register window and address and data edit boxes in decimal format.

Close Button

Closes the dialog.
NOTE: Multiple edit register map windows can be open at the same time (one for each device). Use the
Window menu to navigate.

Loop Count

Causes subsequent write or read operations to be performed N times. N is entered as a decimal number
from 1 to 999.
Opens the indirect register editor of the TVP5151.
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NOTE: To save current register settings to a file, check the Histogram Enable check box and click

Read All. Click Show to view the saved file.

5.9.2 THS8200 Register Map Editor

The THS8200 register editor, as shown in Figure 16, allows the display and editing of the THS8200

registers. This editor works like the TVP5151 editor.

To open this, click on Edit Register Map in the Edit menu and click on THS8200.

11158200, (0x40) Register Map

| Mask | Default | ~

| Addlessl Data | R | REI]

03 m AW chip_ctl

04 o BA caconicl

05 an RAs cecoafol
06 ao RAW caconc?
a7 o RAw cecopfc2
0s ao RAw ceconcd
09 o BA cacorfcd
[ ao RAW cacogicl

Address

HOTE 1 Any address not shown in the list can be acceszed by byping the addrezs and then clicking Read or wWhite.

Applies towiite,

Loop Caunt Radix
Read and Read A1l Dec O
Hex

Histagran on Loop Count Reads [or Read Alls)

] wirite

[z e |
Read

Data

o

OsFF

0=FF 0x00
0=FF 0=00
OxFF ]
0=FF 0x00
OxFF 0=00
0=FF 0x00
0=FF 0:00

0=FF 000 bt

M LCloze

Figure 16. THS8200 Register Map Editor

5.9.3  Generic I’)C Register Editor

The Generic 12C Editor, as shown in Figure 17, allows the display and editing of any device on the I1°C
bus. This editor works like the Register Map Editor, except that the I>°C slave address must be entered and

the Read All button is disabled.

To open this, click on Edit Register Map in the Edit menu and then click on Generic 12C.

The Generic 12C Editor can be used to communicate with other devices that can be connected to

TVP5151EVM I°C bus.
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Generic 12C (0xEC) Register Map

Address | Data | RAw | Name | Mask | Default | ~
0o oo R 0:FF 0x00
m oo R/Aw O=FF 0=00
0z 04 R 0xFF 0x00
03 - RAw O=FF 0x00
04 - R 0xFF 0x00
L : Raw OFF  0x00
0& - FiAw 0sFF 000
o7 ¥ RAw 0xFF 0x00
0g - FiAw 0:FF 000 v
12C Slave
Address
K
Loop Count Count :
Read Length Address ik % Apﬁ:g to%?kte, Hadlf
" Log Read Data [_1 m =4 e Read and Read All Dec (
W Mulbytel2CResd  q osg) = (1-939) G
" Use Repeated Start Dat Histogram on Loop Count Reads (or Read Alls)
ata o
AMND
K= Bt ik [ 7 M Close

Figure 17. Generic 12C Register Map Editor

5.10 Property Sheets

The property sheets represent the register data in a user-friendly format. The data is organized by
function, with each function having its own page and being selectable via tabs at the top (see Figure 18).

To open this, click on Edit Property Sheets in the Edit menu and select the device type to edit.

When the property sheet function is started, or whenever you tab to a different page, all readable registers

in the device are read from hardware to initialize the dialog pages. Values on th
manipulating the various dialog controls as described in Table 5.

e page are changed by

There are OK, Cancel, and Apply buttons at the bottom of each property page. These are explained in

Table 6.

TVP5151 (0xBE) Property Sheets

analog Video Input
HConipozite Vides 1 b |

¥ Analog Switch Cantral via GPCL
[T GPCLState

Beadall |

Video Famat  Analog Video | Automatic Gain Conlrol | Composke Chioma | Composite Lurna | Synchsorization | Output Corriel | Macrovision Detection | Videa Decader Status |

0K |

Cancel | Apply

Figure 18. TVP5151 Analog Video Property Sheet
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Table 5. Use of Property Sheet Controls
Dialog Control What Do | Do With 1t? When is Hardware Updated?
Read-only edit box Read status information N/A
Check box Toggle a single bit After Apply
Dropdown list Select from a text list After Apply
Edit box Type a number After Apply
. . Up/Down arrows: Immediately
Edit box with up/down arrows Use up/down arrows or type a number Type a number: After Apply
Slider Slide a lever Immediately
Push button Initiate an action Immediately
Table 6. Property Sheet Button Controls
Button -
Control Definition

Writes to all writeable registers whose data has changed. A register is flagged as changed if the value to be
OK written is different from the value last read from that address.

Closes the dialog.

Causes all changes made to the property page since the last Apply to be discarded. Changes made to dialog
controls with immediate hardware update are not discarded, since they have already been changed in hardware.

Cancel Does not write to hardware.
Closes the dialog.
Apply Writes to all writeable registers whose data has changed. A register is flagged as changed if the value to be

written is different from the value last read from that address.

To enable multi-standard auto switching, select multi-standard mode and uncheck the formats that you
want to include (see Figure 19).

TWP5151 (OxBB) Property Sheets

Video Faimat | Analag Video | Autamatic Gain Cantiol | Comgoste Chioma | Compesite Luma | Synchuonization | Output Contiel | Macravision Distection | Videa Dacadst Status
Select Auto-Switch o a Fred Video Standard Detected Video Standard
i ode ~ MINTSC
Video Auto-Swatch Mask
ki
=
v [M]EAL Lock Status
¥ (M) PaL O o
W NTSC 443 @ vLock
e Auto-Switch Status
| ENABLED
Check af video standards to be EXCLUDED
Trom auto-swilch processing,
[% NTSC Cormposie Video Inptt has Blarking Padestal
Auto Update
ead &l | Enabled |
0K | Cancel | Apply

Figure 19. TVP5151 Video Format Property Sheet

Vertical lock, horizontal lock, color lock, and the detected video standard can all be observed with the
TVP5151 Video Decoder Status Property Sheet (see Figure 20).
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TVP5151 (0xBEB) Property Sheets

Video Fermat | Analog Video | Autoratic Gain Contiol | Composte Chiama | Composite Luma | Synchiorization | Output Cortrel | Mactovision Datection Video Decoder Status |

_ Mestical Sync Lock Status
| LOCKED

Harizontal Sync Lock Status Colon 5C Lock Status

Detected Video Standard Sampling Mode
MMNTSC | ITU-R BT 601
Syncheonization Celor Sub-carier Yideo Paramaters

LOCKED | LOCKED

Lozt Lock Detect Status SCH Phase Line-akermiatng Status
| NOT DETECTED | 177188 DEG | HNOM-ALTERNATING
: DEJNED St PAL Color Buist Phase Fisld i blans
| TV MODE | 135 DEG EJHZ

‘wieak / Std Signal Mode Field Sequence Status

MNOT WEAK SIGNAL Ooo FIELD
RO Major FAOM Minos Test Version Dievice 10
@[ ® % o
0K | Cancel | Apply |

Figure 20. TVP5151 Video Decoder Status Property Sheet

The THS8200 Input Controls Property Sheet can be used to check the output format being received from
the TVP5151 (see Figure 21). Pixel Count and Line Count are the total pixels per line and total lines per
frame received from the TVP5151. Clicking on the RESET button followed by Read All ensures a current
Format Detection Status reading. The THS8200 Digital Input Format must be left set to ITU-R BT.656 and
the Timing Source must be left set to Embedded for proper operation.

JTHSB200 (0x40) Property Sheets

Tareng Source
©HS_IM,VS_IN & FID_IM signals
‘s Embedded m digital data

Syne Controls
Fl Ingus + | HS_IN Palarty
& EXTFID
+ | WS_IN Polarty
~ INTFID / :
DATA ENBL + | FID_IN Polanty
| £ 2 HE_IN Delay
03 WS_IN Delay
Fiter Bypass

r Bupass Interpolating FIR Filters 162
[4:2:2 to 4-4:4 conversian)

Inpuit Contiols | DTG | CSC | CSM | Dutput Corwrals |

Digital irput Forrniat

0t YCED 422 (TURBT 656 =)

Synchrorezation Full-Scale Adust
@ Slave Mode v FSADN

7 Master Mode ™~ FSADJ2
Clecking

I Bypass DLL foe VESA mode
[ Bypass DLL [CLKIN = 2<)
DLL Frequency Range
~ High
i+ Low

Power-Dowven / Rezet

I™ DAC Power-down
I Chip Power-down [except 120)

Fournat Detection Status
Fomat |Interaced

Fixal Count | 858

HS High

(Clocks) 1
Line Count | 525
VS High
(HS sadges) | O

MNOTE: Farmat, HS High and V5
High status are only available on

i PG4 or lat ER Register »= 4
~ Bypass Interpolating FIR Filers 3485 N s o dpier VS Fedgtet = 4]
|2 up-samplng befare DACS] (12 reisters retain values)
OK | Cancel ] Apply I

Figure 21. THS8200 Input Controls Property Sheet
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5.10.1 Property Sheet Refresh

The TVP5151 property sheets were designed so that the data displayed is always current. Certain actions
cause the entire register map to be read from the device and to update the property sheets. This happens
when:

» Property sheets are initially opened.

« When tabbing from one page to another.

*  When Read All is clicked.

*  When making the Property Sheets window the active window (by clicking on it).

* When making a register map editor window the active window.

5.10.2 Auto-Update When Activating Windows

When you open both the property sheets and the register map editor at the same time, changes made to
the property sheets (and applied) are updated in the register map window as soon as the register map
window is clicked on. It also works the other way; changes made in the register map editor are updated in
the property sheets as soon as the property sheets window is clicked on.

5.10.3 Property Page Auto Update

When the video decoder Video Format page is showing and the property sheets window is the active
window and the Auto Update button on that page is enabled (default), the TVP5151 register map is read
continuously and the status controls on that page are continuously updated.
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6.1

Troubleshooting the TVP5151EVM
This section discusses ways to troubleshoot the TVP5151EVM.

Troubleshooting Guide

If you are experiencing problems with the TVP5151EVM hardware or the VCC6 software, see Table 7 for

available solutions.

Table 7. Troubleshooting Guide

Symptom

Cause

Solution

Blank screen

Wrong video input is selected.

Go to Edit>Property Sheets>TVP5151, input selection/AGC page, select
the correct video input(s), and click Apply. (CH1 is selected by default.)

Source is connected to the wrong
input connector.

Connect source to the correct input connector.

YCbCr outputs or clock output is
disabled.

Go to Edit>Property Sheets>TVP5151, output page, check enable YCbCr
outputs and enable clock outputs, and click Apply.

Component output cable improperly
connected to the monitor

Check cable with direct video connection to the monitor.

The monitor being used does not
support the video format being
used.

Verify cables and monitor operation by connecting the signal source
directly to the display.

Auto-switch not functioning

See Auto-switch issues below.

Damaged RCA connector or PCB
trace

Check signal traces to and from RCA connectors for damage.

No color

Incorrect video format selected.

See Auto-switch issues below.

Color burst input issue

Check composite signal input levels.

Screen colors are only magenta
and green.

Wrong YCbCr output format.

Go to Edit>Property Sheets>TVP5151, output page, set the YCbCr output
format to 8-bit 4:2:2 YCbCr w/ITU-R BT.656 embedded sync mode and
click Apply. Check THS8200 Input Format setting.

Video standard auto-switch does
not work on the video decoder side.

Auto-switch masks are not set
correctly.

Go to Edit>Property Sheets>TVP5151, mode selection, uncheck all
standards to be included in auto-switch processing, and click Apply.

Video decoder is not in auto-switch
mode.

Go to Edit>Property Sheets>TVP5151, mode selection page, set the
drop-down box to multi-standard and click Apply.

Video standard auto-switch does
not work on the video encoder side.

Auto-switch polling is not enabled.

Click real-time polling in the Tools menu. Click Enable All and OK.

USB: I°C error code 1

TVP5151 I2C slave address is
wrong.

Make sure the TVP5151 I°C slave address selected at start-up is correct.

THS8200 I°C slave address is
wrong.

Make sure the THS8200 I’C slave address selected at start-up is correct.

USB cable is not connected from
TVP5151EVM to the host PC.

Connect cable and make sure the USB Link LED indicator is lit.

EVM has been modified for use
with a separate 5V power supply
that is not connected.

Make sure that the 5V LED indicator is lit indicating the presence of 5V
power.

TVP5151 was placed in
power-down mode.

Place J7 jumper in Normal position.

EVM was configured for an external
12C master.

Reinstall 0-Q resistors R131 and R132.

USB: Device not found

J9 jumper not installed. USB cable
is not connected.

Install jumper and disconnect/reconnect USB cable. USB Link LED should
be on.

USB: Invalid response code receive
form device

Multiple instances of VCC are
running.

Close all but one VCC instance.

Erratic or inconsistent 12C register
read back.

Multiple instances of VCC are
running.

Close all but one VCC instance.

Can't exit VCC

USB cable has been removed.

Attach USB cable and exit or use the Windows Task Manager to end
VCC.

YPbPr output levels are distorted
and too high.

Improper video termination at the
oscilloscope.

Install 75-Q termination resistor at the oscilloscope input.

No red or blue color displayed

Bad cable or damaged RCA
connector

Check cable with direct connect to the monitor

Broken PCB trace

Check signal path and traces connecting to the YPbPr connector.
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6.2 Resolving I°C Communication Problems

When VCC is started, and the VCC Configuration dialog box is closed with OK, a USB I*C functionality
test is performed. If the I1°C system test fails, a dialog box like Figure 22 appears. This figure reports that
an 1°C read from the TVP5151 failed, using slave address 0xBA, subaddress 0x00.

Similarly, a dialog box like Figure 23 appears if there are I>*C communication problems with the THS8200.

If either of these dialog boxes appears, click on Exit Program. Restart VCC and ensure that the 1°C
addresses are set to the correct address. The hardware default addresses are 0xB8 and 0x40 for the
TVP5151 and THS8200, respectively.

vcc

LISB: 12C error code 1, Slave Addr 0xBS, Sub-Address 0x00. 12C
errars accur normally if the reset button is pressed while 12C polling is
active or if the SY power supply is not connected. Check that Sv
power is connected, then click continue.

™ Do not display this message Exit Program

Figure 22. TVP5151 I°C Error Report

vcc

USB: I2C error code 1, Slave Addr 0x42, Sub-Address 0x02, 12C
errors occur normally if the reset button is pressed while 12C palling is
active or if the SY¥ power supply is not connected, Check that Y
power is connected, then click continue.

™ Do nat display this message

Exit Program

Figure 23. THS8200 I*C Error Report

If a dialog box similar to Figure 24 appears, check the USB cable connection and the USB Link LED on
the TVP5151EVM. The USB Link LED is lit if a valid USB link is established. Press the Continue button
after the USB link is established.

vcc

UISB: Invalid response cade received from device.

™ Do nat display this message

Exit Program |

Figure 24. USB Link Error
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IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications, enhancements, improvements,
and other changes to its products and services at any time and to discontinue any product or service without notice. Customers should
obtain the latest relevant information before placing orders and should verify that such information is current and complete. All products are
sold subject to TI's terms and conditions of sale supplied at the time of order acknowledgment.

Tl warrants performance of its hardware products to the specifications applicable at the time of sale in accordance with TI's standard
warranty. Testing and other quality control techniques are used to the extent Tl deems necessary to support this warranty. Except where
mandated by government requirements, testing of all parameters of each product is not necessarily performed.

Tl assumes no liability for applications assistance or customer product design. Customers are responsible for their products and
applications using Tl components. To minimize the risks associated with customer products and applications, customers should provide
adequate design and operating safeguards.

Tl does not warrant or represent that any license, either express or implied, is granted under any Tl patent right, copyright, mask work right,
or other Tl intellectual property right relating to any combination, machine, or process in which Tl products or services are used. Information
published by Tl regarding third-party products or services does not constitute a license from Tl to use such products or services or a
warranty or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual
property of the third party, or a license from Tl under the patents or other intellectual property of TI.

Reproduction of Tl information in Tl data books or data sheets is permissible only if reproduction is without alteration and is accompanied
by all associated warranties, conditions, limitations, and notices. Reproduction of this information with alteration is an unfair and deceptive
business practice. Tl is not responsible or liable for such altered documentation. Information of third parties may be subject to additional
restrictions.

Resale of Tl products or services with statements different from or beyond the parameters stated by Tl for that product or service voids all
express and any implied warranties for the associated Tl product or service and is an unfair and deceptive business practice. Tl is not
responsible or liable for any such statements.

TI products are not authorized for use in safety-critical applications (such as life support) where a failure of the Tl product would reasonably
be expected to cause severe personal injury or death, unless officers of the parties have executed an agreement specifically governing
such use. Buyers represent that they have all necessary expertise in the safety and regulatory ramifications of their applications, and
acknowledge and agree that they are solely responsible for all legal, regulatory and safety-related requirements concerning their products
and any use of Tl products in such safety-critical applications, notwithstanding any applications-related information or support that may be
provided by TI. Further, Buyers must fully indemnify Tl and its representatives against any damages arising out of the use of Tl products in
such safety-critical applications.

Tl products are neither designed nor intended for use in military/aerospace applications or environments unless the Tl products are
specifically designated by Tl as military-grade or "enhanced plastic." Only products designated by TI as military-grade meet military
specifications. Buyers acknowledge and agree that any such use of Tl products which Tl has not designated as military-grade is solely at
the Buyer's risk, and that they are solely responsible for compliance with all legal and regulatory requirements in connection with such use.

Tl products are neither designed nor intended for use in automotive applications or environments unless the specific Tl products are
designated by Tl as compliant with ISO/TS 16949 requirements. Buyers acknowledge and agree that, if they use any non-designated
products in automotive applications, Tl will not be responsible for any failure to meet such requirements.

Following are URLs where you can obtain information on other Texas Instruments products and application solutions:

Products Applications

Amplifiers pmplifier.fi.com Audio vww i.com/audid

Data Converters Automotive vww T.com/automofivd
DLP® Products Broadband [www T.com/broadband
DSP Asp Digital Control www Tr-com/digitalcontro]
Clocks and Timers ww_fT.com/cloc] Medical www i -com/medical
Interface [nferfacedi.co Military www ir-com/military
Logic [ogicicom Optical Networking [vww Ti.com/opficalnetwor
Power Mgmt ower.f.com Security [yww T-com/securi
Microcontrollers hicrocontroller.fi.co Telephony vww T.com/ielephony
RFID www Ti-rfid-cor Video & Imaging yww i-com/vided

RF/IF and ZigBee® Solutions [vww-i.com/lpr] Wireless WW i.com/wirelesg

Mailing Address: Texas Instruments, Post Office Box 655303, Dallas, Texas 75265
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