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Copyrights

© Cypress Semiconductor Corporation, 2008. The information contained herein is subject to change

without notice. Cypress Semiconductor Corporation assumes no responsibility for the use of any cir-

cuitry other than circuitry embodied in a Cypress product. Nor does it convey or imply any license

under patent or other rights. Cypress products are not warranted nor intended to be used for medi-

cal, life support, life saving, critical control or safety applications, unless pursuant to an express writ-

ten agreement with Cypress. Furthermore, Cypress does not authorize its products for use as critical

components in life-support systems where a malfunction or failure may reasonably be expected to

result in significant injury to the user. The inclusion of Cypress products in life-support systems appli-

cation implies that the manufacturer assumes all risk of such use and in doing so indemnifies

Cypress against all charges. 

PSoC Designer�, Programmable System-on-Chip�, PSoC Express�, EZ-Color�, enCoRe�,

and PrISM� are trademarks and PSoC® is a registered trademark of Cypress Semiconductor Corp.

All other trademarks or registered trademarks referenced herein are property of the respective cor-

porations. 

Any Source Code (software and/or firmware) is owned by Cypress Semiconductor Corporation

(Cypress) and is protected by and subject to worldwide patent protection (United States and foreign),

United States copyright laws and international treaty provisions. Cypress hereby grants to licensee a

personal, non-exclusive, non-transferable license to copy, use, modify, create derivative works of,

and compile the Cypress Source Code and derivative works for the sole purpose of creating custom

software and or firmware in support of licensee product to be used only in conjunction with a

Cypress integrated circuit as specified in the applicable agreement. Any reproduction, modification,

translation, compilation, or representation of this Source Code except as specified above is prohib-

ited without the express written permission of Cypress. 

Disclaimer: CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH

REGARD TO THIS MATERIAL, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES

OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. Cypress reserves the

right to make changes without further notice to the materials described herein. Cypress does not

assume any liability arising out of the application or use of any product or circuit described herein.

Cypress does not authorize its products for use as critical components in life-support systems where

a malfunction or failure may reasonably be expected to result in significant injury to the user. The

inclusion of Cypress's product in a life-support systems application implies that the manufacturer

assumes all risk of such use and in doing so indemnifies Cypress against all charges. 

Use may be limited by and subject to the applicable Cypress software license agreement. 
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1. Introduction

This guide provides the developer with a basic, hands-on understanding of the enCoRe V technol-

ogy using the CY3660 Development kit. It presents detailed pictures and step-by-step instructions to 

use the following tutorial examples: HID_Example, BULK_Example, ISOC_Example and 

WUSB_Example.

1.1 Installation

1.1.1 PSoC Designer Installation

Install PSoC Designer 5.0 setup software from the included CY3660 DVK CD-ROM. This software

can be downloaded online at www.cypress.com.

During the installation, if you have not already installed the HI-TECH compiler v9.61 PL4, a dialog

will present you with the option of upgrading to the new version. The patch is necessary to support

new devices and features in PSoC Designer 5.0 SP2. 

1.1.2 PSoC Programmer Installation

Install PSoC Programmer setup software from the included CY3660 DVK CD-ROM. This software

can be downloaded online at www.cypress.com.

1.1.3 Install the CY3660 DVK Software

Install CY3660 enCoRe V/LV DVK setup software (Install_CY3660_DVK_xxx.exe) from the included 

CY3660 DVK CD-ROM. This software can be downloaded online at www.cypress.com.

1.2 Default Jumper Setting

The following is the default jumper setting for the CY3660 Board.

1. J1, place a jumper.

2. J3, place a jumper between VREG and VDD.

3. J5, place a jumper between Pin2 and  3.3V.

4. J12, place a jumper.

5. J13, place a jumper.

6. Leave other jumpers  open.
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Figure 1-1.  CY3660 Board
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1.3 Programming and Emulation Procedures

The following procedure provides a quick programming and emulation overview. 

Note: Programming is done using either the PSoC MiniProg or the ICE-Cube. However, the ICE-

Cube is required for emulation. The ICE-Cube is available in the PSoC development kit and can be 

ordered from Cypress's online store (PSoC Development Kit, CY3215-DK).

1.3.1 Programming Steps

1. If the LP Radio Module is connected to P2, remove it before the next step to avoid 5V being 

applied to the LP Radio Module. An alternative method is to use the CY3210-MPAdapt as a volt-

age translator. Please see the CY3210- MPAdapt Quick Start regarding how to use it. 

2. Connect the USB cable to the PSoC MiniProg and to the PC. Connect the PSoC MiniProg to the 

5-pin ISSP header on the CY3660 DVK board.

Figure 1-2.  PSoC MiniProg

3. Launch PSoC Programmer version 3.00.0.92 or later. In PSoC Programmer, click Programming 

→ File Load to load the desired binary (hex) file.

4. Select the MiniProg port. If the Actions column in the PSoC Programmer status box indicates 

"Firmware update required at ...", the MiniProg's firmware is out of date. Before attempting to 

program the target PSoC chip, go to Utilities → Upgrade Firmware to update the MiniProg's 

firmware.

5. For Programming Mode, select Power Cycle. Ensure the AC adapter is removed from P1, and 

the USB cable is unplugged from P9.

6. From the Device Family menu, select 64300.

7. From the Device menu, select CY7C64300-48LTXCT.

8. Click Program. PSoC Programmer goes through programming and verification modes.

9. Once programming is finished, remove the MiniProg from the CY3660 DVK board.
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Figure 1-3.  PSoC Programmer

1.3.2 Emulation Steps

1. Launch the desired .APP project file project from the C:\CYPRESS\CY3660 DVK\Exam-

ple\<example name>\[PSoC Project name\].

2. Connect one end of the blue CAT 5e cable to the ICE-Cube.

3. Connect the other end of the blue CAT 5e cable to the CY3660 DVK Board.

4. Select Build → Generate Configuration Files for �<Project name>� Project.

5. Select Build → Build �<Project name>� Project or hit [F7].

6. Configure the debug port setting. Select Project → Settings → Debugger then select ICE 

CUBE.

7. Select the Pod Power Source and Pod Supply Voltage. If the External only is selected, 

please keep the default jumper setting. If the ICE may power pod is selected, please choose 

3.3V as Pod Supply Voltage and place a jumper between VDD and VICE at J3. Therefore, the 

LP radio voltage can meet the requirement. 

8. Select Debug → Connect, or select the Connect icon.

9. Select Debug → Download to Emulator, or select the Download to Emulator icon.

10. Select Debug → Go, hit [F5], or select the Go icon.

Step 3 Step 4 Step 8

Step 5 Step 6 Step 7
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Figure 1-4.  PSoC Designers Toolbars

1.4 Conventions

These conventions are used throughout this guide. 

1.5 Document Revision History 

Table 1-1.  Documentation Conventions 

Convention Usage

Courier New

Size 12

Displays file locations and source code:

C:\ �cd\icc\.

Italics Displays file names and reference documentation: 

sourcefile.hex

[bracketed, bold] Displays keyboard commands in procedures:

[Enter] or [Ctrl] [C]

Bold → With → Arrows Represents menu paths, user entered text:

File → New Project → Clone

Bold Displays commands and selections, and icon names in 

procedures:

Click the Debugger icon, and then click Next.

Note: Displays functionality unique to PSoC Designer or the 

PSoC device.

WARNING: Displays cautions that are important to the subject.

Document Title: CY3660-enCoRe V and enCoRe V LV DVK Kit Guide

Document Number: 001-16144

Revision ECN# Issue Date
Origin of 
Change

Description of Change

** 1263046 SFVTMP3 New guide for CY3660 DVK

Step 8 Step 9Step 10
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2. HID Example

The HID_Example demonstrates the basic functionality of a USB HID Mouse. A complete USB HID 

Descriptor is provided that allows enumerations on any USB host that supports a HID device. Follow 

the steps below.

2.1 HID Example Steps

1. Open the HID_Example project in PSoC Designer. The project file is located at 

C:\CYPRESS\CY3660 DVK\Examples\HID_Example\HID_Example.app. Go to Project 

→ Settings → Compiler to choose the applicable compiler.

2. Select Build → Generate Configuration Files for �HID_Example� Project.

3. Build the project. Select Build → Build �HID_Example� Project or hit [F7]. 

4. Program the CY3660 DVK board with the hex file located at C:\CYPRESS\CY3660 

DVK\Examples\HID_Example\HID_Example\output\. Select the Program → PSoC Pro-

grammer in PSoC Designer, and then follow the Programming Steps section on page 7.

5. Wire up Button S1. On the CY3660 DVK board, attach a wire from P0_0 on P7 to S1on P10.

6. Place a jumper on J12.

7. Place a jumper between VDD and VREG on J3.

8. J5 is used to select the fixed 3.3V VREG or Adjustable VREG from 3.66V to 1.63V. In the begin-

ning, it is suggested to use fixed 3.3V VREG. 

9. On a PC, open a simple drawing application (e.g., Paint).

10. On the PC, go to Control Panel → Mouse  → Pointer Options, uncheck �Enhance Pointer Precision�. 

11. Connect the mini-B side of the USB A/Mini-B cable to the CY3660 DVK board.

12. Connect the A side of the USB A/Mini-B cable to the PC.

13. The HID_Example should enumerate on the PC as a USB Mouse HID device.

14. Press the button S1 on the DVK board to toggle the drawing in the drawing application.

[+] Feedback 

http://ccc01.opinionlab.com/o.asp?id=wRiLHxlo&prev=docurate_CY3660_Kit_Guide_pdf_p_11


12 CY3660-enCoRe V and enCoRe V LV DVK Kit Guide, Doc. # 001-41500 Rev. **

HID Example

Figure 2-1.  HID_Example

2.2 HID Example Results

The HID_Example will enumerate on the PC as a bus powered USB Mouse device. It will transmit 

mouse down and mouse movement commands to the PC over the USB Interrupt pipe. Within a 

simle drawing or paint application, the word "USB" will be drawn when the S1 button is pressed. 

Pressing the S1 button again will stop drawing.

When using any of the enCoRe V examples provided, a USB analyzer can be used to inspect the 

USB transactions.

J5

J3

J1

P7

J12

Button S1

Pin S1 of P10
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3. BULK Example

The BULK_Example shows the simplicity of accessing SRAM directly from the enCoRe V USB SIE. 

This example uses the BulkLoop application to send and receive data over the Bulk IN and OUT 

endpoints. To run the BULK_Example, follow the steps below:

3.1 Bulk Example Steps

1. Open the Bulk_Example project in PSoC Designer. The project file is located at 

C:\CYPRESS\CY3660 DVK\Examples\BULK_Example\BULK_FW\BULK_FW.app. Go to 

Project → Settings → Compiler to choose the applicable compiler.

2. Select Build → Generate Configuration Files for �BULK_FW� Project.

3. Build the project. Select Build → Build �BULK_FW� Project or hit [F7].

4. Program the CY3660 DVK board with the hex file located at C:\CYPRESS\CY3660 

DVK\Examples\BULK_Example\BULK_FW\BULK_FW\output\. Select the Program 

→PSoC Programmer in PSoC Designer, and then follow the Programming Steps section on 

page 7.

5. Place a jumper on J12.

6. Place a jumper between VDD and VREG on J3.

7. J5 is used to select the fixed 3.3V VREG or Adjustable VREG from 3.66V to 1.63V. In the begin-

ning, it is suggested to use fixed 3.3V VREG. 

8. Connect the mini-B side of the USB A/Mini-B cable to the CY3660 DVK board.

9. Connect the A side of the USB A/Mini-B cable to the PC.

10. Driver matching sequence: Select the cyusb.inf file located at C:\CYPRESS\CY3660 

DVK\Examples\Driver_For_BULK_ISOC_Example\ <wxp> or <wnet> or <wlh> or 

<w2k>\<x86> or <amd64>\CyUSB.inf. Please see the C:\CYPRESS\CY3660 DVK\Exam-

ples\Driver_For_BULK_ISOC_Example\release_note.txt for details about the driver.

11. Launch the BulkLoop.exe application located at C:\CYPRESS\CY3660 DVK\Exam-

ples\BULK_Example\PC_Host_App\BulkLoop.exe.
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BULK Example

Figure 3-1.  BULK_Example

3.2 Bulk Example Results

The BULK_Example enumerates on the PC using the cyusb.sys driver provided with the enCoRe V 

DVK. Using the BulkLoop.exe application provided, data can be transferred to and from the CY3660 

DVK board.

J5

J3

J1

J12
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4. ISOC Example

The ISOC_Example shows how to create an alternate interface for isochronous applications. This 

example uses the Streamer application to send data over the ISOC IN endpoints. To run the 

ISOC_Example, follow the steps below:

4.1 ISOC Example Steps

1. Open the ISOC_Example project in PSoC Designer. The project file is located at 

C:\CYPRESS\CY3660 DVK\Examples\ISOC_Example\ISOC_FW\ISOC_FW.app. Go to 

Project → Settings → Compiler to choose the applicable compiler.

2. Select Build → Generate Configuration Files for �ISOC_FW� Project .

3. Build the project. Select Build → Build �ISOC_FW� Project or hit [F7].

4. Program the CY3660 DVK board with the hex file located at C:\CYPRESS\CY3660 

DVK\Examples\ISOC_Example\ISOC_FW\ISOC_FW\output\. Select the Program → 

PSoC Programmer in PSoC Designer, and then follow the Programming Steps section on 

page 7.

5. Place a jumper on J12.

6. Place a jumper between VDD and VREG on J3.

7. J5 is used to select the fixed 3.3V VREG or Adjustable VREG from 3.66V to 1.63V. In the begin-

ning, it is suggested to use fixed 3.3V VREG. 

8. Connect the mini-B side of the USB A/Mini-B cable to the CY3660 DVK board.

9. Connect the A side of the USB A/Mini-B cable to the PC.

10. Driver matching sequence: Select the cyusb.inf file located at C:\CYPRESS\CY3660 

DVK\Examples\Driver_For_BULK_ISOC_Example\ <wxp> or <wnet> or <wlh> or 

<w2k>\<x86> or <amd64>\CyUSB.inf. Please see the C:\CYPRESS\CY3660 DVK\Exam-

ples\Driver_For_BULK_ISOC_Example\release_note.txt for details about the driver. 

11. Launch the Streamer application located at C:\CYPRESS\CY3660 DVK\Exam-

ples\ISOC_Example\ PC_Host_App\Streamer.exe.
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ISOC Example

Figure 4-1.  ISOC_Example

4.2 ISOC Example Results

The ISOC_Example enumerates on the PC using the cyusb.sys driver provided with the enCoRe V 

DVK. The ISOC_Example demonstrates the correct behavior of an USB isochronous device by 

enmerating with a default interface that consumes no bandwidth. Then, when data is ready to be 

streamed to or from the USB device, the host application selects the alternate interface with the 

ischronous endpoint descriptor. Using the Streamer application provided, isochronous data can be 

streamed from the CY3660 DVK board.

J5

J3

J1

J12
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5. Wireless USB Example

The WUSB_Example demonstrates the basic functionality of a WirelessUSB HID Keyboard. Two 

dev boards with LP radio modules are used for this example. One board is used as a bridge, which 

will enumerate on the PC as a bus-powered USB composite device supporting keyboard and 

mouse. The other board is used as a keyboard, which will simulate a simple keyboard with three 

keys (Num Lock key, Caps Lock key and Scroll Lock key) and three LEDs (Num Lock LED, Caps 

Lock LED and Scroll Lock LED). Follow the steps below:

5.1 Wireless USB Bridge Steps

1. Open the WUSB_Example bridge project in PSoC Designer. The project file is located at 

C:\CYPRESS\CY3660 DVK\Examples\WUSB_Example\enCoReV_dvk_bridge 

\enCoReV_dvk_bridge.app. Go to Project → Settings → Compiler to choose the applica-

ble compiler.

2. Select Build → Generate Configuration Files for �enCoReV_dvk_bridge� Project.

3. Build the project. Select Build → Build �enCoReV_dvk_bridge� Project or hit [F7].

4. Program the CY3660 DVK board with the hex file located at C:\CYPRESS\CY3660 

DVK\Examples\WUSB_Example\enCoReV_dvk_bridge\enCoReV_dvk_bridge\out-

put\. Select the Program → PSoC Programmer in PSoC Designer, and then follow the Pro-

gramming Steps section on page 7.

5. Attach the WirelessUSB LP Radio module to P2.

6. Wire up Button S1 as a bind button. On the CY3660 DVK board, attach a wire from P0_2 on P7 

to S1on P10.

7. Wire up LED1 and LED2. On the CY3660 DVK board, attach wires from P0_0 on P7 to LED1 on 

P10 and from P0_1 on P7 to LED2 on P10 separately.

8. Place a jumper on J1 and another jumper on J12.

9. Place a jumper between VDD and VREG on J3.

10. J5 is used to select the fixed 3.3V VREG or Adjustable VREG from 3.66V to 1.63V. In the begin-

ning, it is suggested to use fixed 3.3V VREG. 

11. Connect the mini-B side of the USB A/Mini-B cable to the CY3660 DVK board.

12. Connect the A side of the USB A/Mini-B cable to the PC.

13. The WUSB_Example bridge should enumerate on the PC as a Composite USB device support-

ing both keyboard and mouse.
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Wireless USB Example

Figure 5-1.  WUSB_Example Bridge

5.2 Wireless USB Keyboard Steps

1. Open the WUSB Example keyboard project in PSoC Designer. The project file is located at 

C:\CYPRESS\CY3660 DVK\Exam-

ples\WUSB_Example\enCoReV_dvk_keyboard\enCoReV_dvk_keyboard.app. Go to 

Project → Settings → Compiler to choose the applicable compiler.

2. Select Build → Generate Configuration Files for �enCoReV_dvk_keyboard� Project.

3. Build the project. Select Build → Build �enCoReV_dvk_keyboard� Project or hit [F7].

4. Program the CY3660 DVK board with the hex file located at C:\CYPRESS\CY3660 

DVK\Examples\WUSB_Example\enCoReV_dvk_keyboard\ 

enCoReV_dvk_keyboard\output\. Select the Program → PSoC Programmer in PSoC 

Designer, and then follow the Programming Steps section on page 7.

5. Attach the WirelessUSB LP Radio module to P2.

6. Wire up Button S5 as a bind button. On the CY3660 DVK board, attach a wire from P0_6 on P7 

to S5 on P10.

7. Wire up Button S1 as a Num Lock key, Button S2 as a Caps Lock key and Button S3 as a Scroll 

Lock Key. On the CY3660 DVK board, attach wires from P0_3 on P7 to S1 on P10, from P0_4 

on P7 to S2 on P10 and from P0_5 on P7 to S3 on P10 separately.

8. Wire up LED1 as a Num Lock LED, LED2 as a Caps Lock LED and LED3 as a Scroll Lock LED. 

On the CY3660 DVK board, attach wires from P0_0 on P7 to LED1 on P10, from P0_1 on P7 to 

LED2 on P10, and from P0_2 on P7 to LED3 on P10 separately

9. Place a jumper on J1.

10. Place a jumper between VDD and VREG on J3.

J5

J3

J1

J12

P7

P2 for LP

S1 Bind

P10

LED2

Radio

LED1
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Wireless USB Example

11. J5 is used to select the fixed 3.3V VREG or Adjustable VREG from 3.66V to 1.63V. In the begin-

ing, it is suggested to use fixed 3.3V VREG.

12. Connect AC adapter to P1.

Figure 5-2.  WUSB_Example Keyboard

5.3 Results for Bind

After the bridge is enumerated and the LEDs are off, press the Bind button S1 on the bridge and the 

Bind button S5 on the keyboard to complete the 'binding' process. While in the bind mode, the LED2 

on the bridge blinks until the Bind button is pushed on the keyboard. The bridge LED2 stops blinking 

to indicate the keyboard is now ready for normal operation. Please notice that the bridge LED2 also 

will stop blinking after 20 seconds timeout without receiving any bind request from the keyboard.

5.4 Results for Key Pressing

User presses buttons on the keyboard that represent Num Lock key, Caps Lock key, and Scroll Lock 

key. The keystroke data will be sent through the air to the bridge, which will transfer this data to the 

PC. After receiving the data from the bridge, the PC will process the Num /Caps /Scroll Lock data 

and return the LED information to the bridge and then the keyboard. Finally, the keyboard OCD chip 

turns on/off the corresponding LEDs.

J5

J3

J1

P7

P2 for LP
Radio

P10

S1, Num Lock

S2, Caps Lock

S3, Scroll Lock

S5, Bind

LED1, Num

LED2, Caps

LED3, ScrollLED3, Scroll
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Wireless USB Example
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