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STOP

Atlas Scientific does not make consumer electronics.

This equipment is intended for electrical engineers. If you are not familiar
with electrical engineering or embedded systems programing, this product
may not be for you.

This device was developed and tested using a Windows computer. It was not

tested on Mac, Atlas Scientific does not know if these instructions are
compatible with a Mac system.
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The Wi-Fi Aquaponics kit has been designed to provide the engineer with a simple way of
remotely monitoring and controlling an aquaponics system's chemistry. Sensor data
is uploaded to ThingSpeak ™, a free, cloud-based data acquisition and visualization
platform. The Wi-Fi Aquaponics kit has also been designed to be easily modified by the
engineer. Feel free to change the sensors or functionality of the device to meet your
specific needs.

The Wi-Fi Aquaponics kit is controlled using an Adafruit HUZZAH32 as its CPU.
The HUZZAH is programmed using the Arduino IDE and uses an onboard ESP32 as its
Wi-Fi transmitter. Adafruit HUZZAH32 datasheet.
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The Wi-Fi Aquaponics kit PCB has 7 sensor ports. Three of the ports are electrically
isolated. The isolated ports are marked pH, Dissolved Oxygen, and Conductivity. The
isolated ports are needed to take noise-free electrochemical readings. Because the sensing
element of a temperature sensor is never in direct contact with the water, electrical isolation
is not needed for temperature sensing.

Port 5 and 6 are marked Humidity and CO2. The terminal block marked Port 7 has been
designed to connect one or more dosing pumps to the device. However, the port could
also be used to connect a gas sensor.
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The overall design of the PCB is quite simple. The CPU is powered and programmed
through the panel-mount USB connector. The CPUs USB pin supplies the board's power
bus with 5V.
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Each of the six main sensor ports have an enable pin, which must be set correctly to power
the sensor. The enable pins are found here:

The first three pins (pH, D.O and Cond) must be set low to power on the sensors.
While the Temp, CO2 and Hum pins must be set high to power on the sensors.

Pin Adafruit Huzzah32 | | Gtate Sensor Power
GPIO

pH EN 13 LOW ON

D.O. EN 12 LOW ON

Cond EN 27 LOW ON Sensor port 7 (the terminal block)
Temp EN 33 HIGH ON does not have an enable pin and

can not be turned off.

COZ2EN 15 HIGH ON

Hum EN 32 HIGH ON
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On Board 12C/UART Switch

The PCB has a built in protocol toggler which can be used to switch each of the sensors
between [2C/UART modes.

I2C/UART Switch

s

12C/UART Switch I2C/UART Switch

3 :

PUN {
o m m m
pH VCC PRB PGND

;k
20 @ @ B

Xz g RZ
O

RTD EZO
(9]
O
>

Place an EZO circuit onto The EZO circuit in UART mode... ...is now in 12C mode.
the 12C/UART switch pins.

Data protocol

The CPU communicates with all peripheral sensors using the 12C data protocol. All data
lines are directly connected to the CPUs 12C port. Using a different data protocol with this
circuit board is not possible.

It is important to keep in mind that all Atlas Scientific components default to UART mode.
When adding a new Atlas Scientific component to the kit, it must first be put into 12C
mode. Refer to the component's datasheet for instructions on how to switch it over, or use
the on board protocol toggler mentioned above.

| - - AtlasScientific
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Adding more of the same
sensor or component type

Adding additional components of the same type, such as an additional pH or conductivity
sensor, is not hard to do. As mentioned above, you must set the device to 12C mode, and
you must make sure that its I2C address is not the same as the already existing component.

12C/UART Switch
2 S

Humidity

S

H VCC PRB PGND

Dissolved Oxygen Temperature Conductivity

12C Address 12C Address 12C Address 12C Address
99 (0x63) 100 (0x64) « 102 (0x66) « 99 (0x63)

|

Conflicting 12C Address

This table lists the default I2C address of components commonly added to this kit.

. - . AtlasScientific
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Dosing pump

An optional external dosing pump can be added to the Wi-Fi Aquaponics kit.
Using the SGL-PMP-BX is the simplest way to add on a dosing pump.

_VAtlasScientific
Aquaponics Kit

J 12C/UART
Switch

A stand-alone EZO-PMP can be used instead of the expansion pump kit; however, you
must manually put the pump in 12C mode and remove the data cable connector.

<, AtlasScientific
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Uploading sensor data
to the cloud

The Atlas-Scientific Wi-Fi hydroponics kit has been designed to upload sensor data to
ThingSpeak™, a free, cloud-based data acquisition and visualization platform. You will be
required to set up a free account with ThingSpeak™ to upload and visualize the data. With
a free account, you can upload data once every 15 seconds. A paid account lets you
upload data once per-second; look here for more info about various ThingSpeak™
services.

Atlas Scientific has no business relationship with ThingSpeak™; we just like how it works.
If you want to use a different service, modify the device as you see fit.

Setting up your Wi-Fi kit
Step 1 o oz ensor mocie

The CO2 sensor module has been removed to protect it during transport. Before you
begin setting up the aquaponics kit, plug it back into position.

« i
CO2

sensor module

>y
il
Warning:

Do not mix up sensor modules as each is calibrated to a specific EZO-CO2 device.

. - . AtlasScientific
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Because the sensor data is stored / viewed on ThingSpeak, you will need
to setup a ThingSpeak account. Create your ThingSpeak account by clicking HERE.

Commercial Use How to Buy

|:|ThingSpeak"‘ Channels Apps  Support~

To use ThingSpeak, you must sign in with your existing MathWorks account or create a new one.

Non-commercial users may use ThingSpeak for free. Free accounts offer limits on certain functionality. Commercial users are eligible for a time-limited free evaluation. To
get full access to the MATLAB analysis features on ThingSeak, log in to ThingSpeak using the email address associated with your university or organization.

To send data faster to ThingSpeak or to send more data from more devices, consider the paid license options for commercial, academic, home and student usage.

4\ MathWorks- )

Email
I

By signing in you agree to our privacy policy.

DATA AGGREGATION
AND ANALYTICS

CJThingSpeak

MATLAB
Lanl

SMART CONNECTED DEVICES g ;l.

ALGORITHM DEVELOPMENT
SENSOR ANALYTICS

-
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Your data is uploaded to ThingSpeak through a ‘Channel.’ Select New Channel

Commercial Use How to Buy

|:| ThingSpeak“‘ Channels - Apps - Support~

My Channels Help

Collect data in a ThingSpeak channel from a device,
New Channel Search by tag Q e

from another channel, or from the web.

Click New Channel to create a new ThingSpeak
channel.

Click on the column headers of the table to sort by the

entries in that column or click on a tag to show
channels with that tag.

- AtlasScientific
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|:| Th Ing ) pe ak™ cChannels~  Apps~  Support- Commercial Use  Howto Buy

New Channel Help

o A K Channel Settings
Description + Percentage complete: Calculated based on data entered into the various fields of a
channel. Enter the name, description, location, URL, video, and tags to complete your
channel.
Y
* Channel Name: Enter a unique name for the ThingSpeak channel.
H
Field 1 P * Description: Enter a description of the ThingSpeak channel.
Field DO (mg/L » Field#: Check the box to enable the field, and enter a field name. Each ThingSpeak
leki2 g/t channel can have up to 8 fields.
. - « Metadata: Enter information about channel data, including JSON, XML, or CSV data.
Fields | Temp () |
» Tags: Enter keywords that identify the channel. Separate tags with commas.
Field 4 EC ( pS/cm) * Linkto External Site: If you have a website that contains infermation about your
ThingSpeak channel, specify the URL.
Field5 Humidity (%) + Show Channel Location:
o Latitude: Specify the latitude position in decimal degrees. For example, the
Field 6 €02 (ppm) latitude of the city of London is 51.5072.

Fill out the highlighted boxes. (Be sure to click on the checkboxes to enable fields 2 - 6)
For reference, this is what we entered.

Name Atlas Sensors
Field1 pH

Field 2 DO (mg/L)
Field 3 Temp (°C)
Field 4 EC ( puS/cm)
Field 5 Humidity (%)
Field 6 CO2 (ppm)

Scroll to the bottom of the page and click Save Channel.

- AtlasScientific
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After you saved your channel settings, you will be redirected to your channel page.
Click on API keys.

D ThingSpeak“‘ Channels ~ Apps ~ Support~ Commercial Use How to Buy

My Channels Help
. it e Collect data in a ThingSpeak channel from a device,
— i 2 from another channel, or from the web.

Click New Channel to create a new ThingSpeak
Name Created Updated channel.
Click on the column headers of the table to sort by the

entries in that column or click on a tag to show
channels with that tag.

@ Atlas Sensors 2020-02-14 2020-05-1123:04

l Private ‘ Public ‘ Settings | Sharing ‘ APl Keys ‘ Data Import / Export

Learn to create channels, explore and transform
data.

Learn more about ThingSpeak Channels.

I:l ThingSpeak“ Channels ~ = Apps~  Support~ Commercial Use  How to Buy

Atlas Sensors

| Channel ID: 000 |
Author:
Access: Private

Private View Public View Channel Settings Sharing APl Keys Data Import / Export

Write API Key Help

AP| keys enable you to write data to a channel or read data from a private channel. API
keys are auto-generated when you create a new channel.

Key P00 0.0.0.0.0.0.4.4.¢.¢.4

APl Keys Settings

= Write API Key: Use this key to write data to a channel. If you feel your key has
been compromised, click Generate New Write API Key.
» Read API Keys: Use this key to allow other people to view your private channel

Be sure to save your Channel ID and Write API Key we are going to need these, in the
next few steps.

- AtlasScientific
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In the IDE, go to File > Preferences
Locate the Additional Boards Manager URLS text box.

Preferences oo

Settings  Metwork

Sketchbook location:

l;:_‘n, Browse
Editor language: ES\y'stem Default «w | {reguires restart of Arduino)

Editor font size: 12

Interface scale: Automatic | 1|:||j. 2 B {requires restart of Arduino)

Theme: | Default theme ~ ({requires restart of Arduino)

Show verbose output during: [ ] compilation [ ] upload

Compiler warnings: _Nune v

Display line numbers [] Enable Code Folding

Verify code after upload [] Use external editor

Check for updates on startup Save when verifying or uploading

[] Use accessibility features

Additional Boards Manager LIRLs: Ihtn:us:,.",."raw.giﬁ'lubusercu:untent.cnm;"espressif,."arduinn—esp3Efgh—pagesfpadcage_esp32_index.jsnn I ﬁ

ﬁK . Ca.mcel.

Make sure this URL is in the textbox

https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json
Click OK.

AtlasScientific

12 copyr enti 3
Copyright © Atlas Scientific LLC ~————————Environmental Robotics



In the IDE, go to Tools > Board > Boards Manager

File Edit Sketch Help

Auto Format Ctrl+T
Archive Sketch
hydropunlcs:k Fixx Encoding & Reload
Manage Libraries... Ctrl+Shift+] |
snumreRding: I el Monitar CHANSRt kNl | READ RESFONSE )7
/fatep 1 tell
//step 2 cons Serial Plotter Ctrl+ Shift+L
/fstep 4 tell - - . |g we just received
/istep 3 cons) WiFi101 / WiFiNINA Firraware Updater |
enum reading_l _Board; Boards Manager...
Upload Speed: "115200" 2
ok o L, g e L Arduino AVR Boards
BatrEaenito) Flash Size: "4MB (F5:2ME OTA:~1019KB)" A

Debug port: "Disabled”

int return_eco Arduino Uno

Debilg ! suek “thone Arduino Duemilanove or Diecimila
uint32 t next| I e el "

- wiP Yariant: "v2 Lower Memory .
conat unaigne Arduino Nano

unsigned int Viables 3 josh Arduino Mega or Mega 2560
Exceptions: "Legacy (new can return nullptr)” Arduine Mega ADK
const unsigne Erase Flash: "Only Sketch" Badicaer boanarde

R— 551 Support: "All 55L ciphers {(most compatible)” Arduino Leonardo ETH

const unsigne Port Arduino Micro
Get Board Info

Arduine Esplora

void setup() ; &

Programrmer: "AVRISP mkll" | Arduine Mini

Burn Bootloader Arduino Ethernet

_ECyourrULyy
& Boards Manager X
o 5
esp32 ~

by Espressif Systems version 1.0.5 THSTALLED

Boards included in this package:

ESP32 Dev Module, WEMOS LoLin32, WEMOS D1 MINI ESP32.
More Info

iéelectversion =z Install Update [ | Remave |

Close

In the search bar of the Boards Manager, lookup esp32.
Update to the most recent version if you don't already have it.

(Version 1.0.5 in not the most recent version)

AtlasScientific
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Click HERE to download the latest version of the ThingSpeak library.
Don’t unzip it!

Import the .ZIP file into your Arduino IDE.
To import the .ZIP file go to Sketch > Include Library > Add .ZIP Library

File Edit ISketchI Tools Help

Verify/Compile Ctrl+R,
Upload Ctrl+U
hydrop Upload Using Programmer  Ctrl+Shift+L
Export compiled Binary Ctrl+Alt+5 |
£NUM e D COMPENSATE, REQUEST DEVICES, RELD RESPONSE }1:
ffatep Show Sketch Folder Ctrl+K |ﬂ§
/== | [ include by A
jj:g:i Aiddi File... Manage Libraries... Ctrl+Shift+|

To download the Ezo_I2c¢ library file, click HERE.

¥ master = P 1branch 0 tags Go to file

(2 Clone @

HTTPS GitHub CLI

@ Atlas-5Scientific removed redundant examples, aquaponics kit has pump code by ¢

& Examples removed redundant examples, aquapon WEEDS - /7 Bithih. ConfAL Tas-Seiehtificy [l
[ Ezo_i2ccpp added the get address() method to the  Use Git or checkout with SYN using the web URL,
D Ezo_i2ch added the get_address() method to the
X1 Open with GitHub Desktop
[ Ezo_i2c_util.cpp Created libraries for common functions
[ Ezo_i2c_utilh Created libraries for common functions  [j) Download ZIP
M LICENSE Initial commit 2 years ago
™ READMEmd Update README.md 18 days ago

Don’t unzip it!
Import the .ZIP file to your Arduino IDE.
To import the .ZIP file go to Sketch > Include Library > Add .ZIP Library

- AtlasScientific
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File> Examples> EZO_I2C_lib-master> Examples> IOT_kits> aquaponics_kit

File Edit Sketch Tools Help

Mew Ctrl+M

Open... Ctrl+0

Open Recent .

Sketchbook i |

s Chels W ESP32 BLE Arduing ?

S g ESPmDNS 2

SaveAs..  CtrlsShift+S i ]
HTTPClient ¢

Page Setup  Ctrl+Shift+P HTTPUpdate ?

Print Ctrl+P HTTPUpdateServer 4

Preferences  Ctrl+Comma NetBIOS i
Preferences £

Quit Ctrl+ 5D(esp32) »
SD_MMC ?
SimpleBLE &
SPI ;
SPIFFS 2
Ticker ;
Update *
WebServer s
WiFi ?
WiFiClientSecure ’
WiFiProv i

Examples from Custom Libraries

ACROBOTIC 5501306 >

Adafruit BME280 Library >

Adafruit BMEGED Library >

Adafruit ESP2266 >

Adafruit HTU21DF Library >

Adafruit SHT31 Library >

Adafruit 57021 Library >

atlas_gravity >

EspSoftwareSenal >

Ezo_l2c_lib-master 3 Examples il IEc_I[b_examp!es T

Ezo_uart_lib-master > 10T kits : W&BPDD]E_,EL

PID > Projects hydroponics_kit

StepperDriver > Sequencer_lib_examples hydroponics_kit_with_DO

ThingSpeak > pool_kit

INCOMPATIELE > thingspeak_example
W

- AtlasScientific
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Fill in your Wi-Fi name and Password, along with the Channel ID and Write API Key to the
code. (see step 3)

1 ifinclude
2 finclude
$includs

fincluds

[¥5]

s

tinclude
& #include

finclude

o

#includs

(¥}

13 const Btr

4 .const Str

<iot cmd.h>
<WiFi.h>
"Thing3peak.h"
<sequencerd.h>

<secuencerl.h>

<Ezo iZc util.h>

//include wifi library

//finclude thingspeak library
/fimports a 4 function sequencer
//imports a 1 function segquencer

//brings in common print statements

<Ezo_iZc.h> //include the EZ0 IZC library from https://githuk.com/Atlas-Scientific/Ezo I2c 1ib

<Wire.h> /finclude arduinos i2c library

//declare that this device connects to

ing ssid = "Wifi Name"; {/The name of the Wi-Fi network you

ing pass = "Wifi Password";
L5 const long myChannelNumber = 1234566;

1€ const char * myWriteAPIRey =

//Y¥our WiFi network password
/{Your Thingspeak channel number

s esesseesotse s e dil {//¥our ThingSpsak Write RFI Eey

If you do not have a pump attached, you can just skip this part. The code is rather
self explanatory. You set what parameters will trigger the pump to engage.

57 #define PUMP BOARD
58 #define PUMP_DOSE
58 #define EZ0 DBORARD
60 $define IS_GREATER THAN
£l #define COMPRRISON VALUE

16 Copyright © Atlas Scientific LLC

EMFE
=5
EC
true

1000

56 //parameters for setting the pump output

//the pump that will do the output {if theres more than one)

//the dose that the pump will dispense

fithe circuit that will be the target of compariscon

//true means the circuit's reading has to be greater than the comparison

//the threshold above or below which the pump is activated

- AtlasScientific
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Tools> Board> ESP32 Arduino > Adafruit Esp32 Feather

File Edit Sketch Tools| Help

agquaponics_k

I I
e T T O e S RN = - AR EERis T T S L T 0 S O et o Ve LA H LRy g
Se SHe Se SHe S e Bk S

R % TR o B o R I o R o O & R R 8 N o I
e v
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b
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%]
]
[
=

Auto Format

Archive Sketch

Fix Encoding & Reload
Manage Libraries...
Serial Monitor

Serial Plotter
WiFi101 / WiFiNINA Firmware Updater

Board: "Adafruit ESP32 Feather"
Upload Speed: "921600"
Flash Frequency: "80MHz"
Partition 5cheme: "Default”
Core Debug Level "Moneg”
Port: "COME"
Get Board Info

Programmer

Burn Bootloader

Cirl+T

Ctrl+ Shift+|

Ctrl+Shift+ M //include wifi library

Ctrl+ Shift+L //include thingspeak library
{fimports a 4 function seguencer
//imports a 1 function seguencer

ings in common print statements

b.com/Atlas-Scientific/Erzo ¥2¢ 1ib

FI Boards Manager...
1| Arduino AVR Boards 7
1 ESP3266 Boards (2.7.4)
o
|

*r Credentials—————-

Ezo board
Ezo board
Ezo_board
Ezo_board
Ezo_board
Ezo_board

Ezo_board

Ezo board
PH,
e,
RTD,
EC,
EME,
HUM,
co2
bi

Ezo_board* default board = sdevice list[0]; //used to store the boar

//gets the length of the array automatically so we dont have to chan

PH = Ezo board (88, "BH");
DO = Ezo board (97, "DO");
RTD = Ezo board(102, "RTD"};

EC = Ezo _board (100, "EC");

PMP = Ezo_board(103, "EMB");
HUM = Ezo board(111, "HUM");
CO0Z2 = Ezo_board(103, "CO2");

device list[] = |

O |const uint8 £ device list len = sizeof (device list) / sizeof (device

Copyright © Atlas Scientific LLC

//create a PH circuit obje

//create a DO circuit obje
//create an RTD circuit ob
//create an EC circuit obj
//create an PMP circuit ob
//create a HUM circuit obj
f//create a COZ circuit obj

//an array of boards used

i
ESP32 Dev Module

E5SP32 Wrover Module

ESP32 Pico Kit

Adafruit ESP32 Feather

5.0D1 Ultra w1

MagicBit

Turta loT Mode

TTG0 LoRa32-OLED V1

TIGO T

TTE0 T7 V1.3 Mini32

TIGO T7 V1.4 Mini32

KinaBox CWO02

SparkFun E5P32 Thing
SparkFun ESP32 Thing Plus
u-blox MINA-W10 series (ESP32)
Widora AIR

Electronic SweetPeas - ESP320
Mano32

LOLIN D32

LOLIM D32 PRO

WEMOS LOLIN3Z

WEMOS LOLIN3Z Lite
Dongsen Tech Pocket 32
WeMaos WiFi&Bluetooth Battery
ESPeadZ

Noduing Quantum

Modelds

Hornbill ESP32 Dev

Hornbill ESP32 Minima

rcks to a Wi-Fi

£ you are connect

nopyg"
"o
"RTD"

LTl

name 1is
name is
1d name is
name is
"EMP"
llqm{ﬂ
TCoz"®

d name is
name is

i name is

or specific

add new boards

- AtlasScientific
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Make sure the CPU settings on the Adafruit HUZZAH32 are correct.
To adjust the CPU settings, click Tools.

For reference, this is what Atlas Scientific set the CPU settings to.
(your options may not be exactly the same, just try and match them as closely as possible.
Don't forget to set the correct com port for your device.)

File Edit Sketch |Tools| Help
Auto Format Crl+T
Archive Sketch

agquaponics_k Fix Encoding & Reload

1 #111-::1;1:1' Manage Libraries... Ctrl+Shift+]

2 #incl de Serial Monitor Ctrl+Shift+ M

P #incladi  seral Plotter Ctrl+Shift+L

4 #includy

5 #111.:;:,:1F| WIiFi101 / WiFININA Firmware Updater

6 |#includg :

T [T Board: "Adafruit ESP32 Feather" >

| #includg ) )

| et Upload Speed: "3271600 *

= Flash Frequency: "280MHz" -2
10 Wikriclid Partition Scheme: "Default” *
11 Core Debug Level "Mone” »
13 | ff===553 Port: "COME" b
13 const S{ Get Board Info
14 |gon=st S

L : Programmer ?
15 lcomat I
1¢ const ol Burn Bootloader

& aguaponics_kit | Arduine 1.8.13
File Edit Sketch Teols Help

Lipload

Compile and upload the code.

18 Copyright © Atlas Scientific LLC
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Open your Arduino serial monitor.

(You must have the serial monitor set to the com port from the Adafruit HUZZAH32)

@ — O =
| || send |
Autoseroll [ ] Show timestamp IEamage return “"'I IBEUU baud v i. Clear output |

Set to carriage return and 9600 baud.

The Wi-Fi Aquaponics Meter will always attempt to connect to ThingSpeak on bootup.

o) - | X
| | send |
RTD: 24.359 PH: 4.70 DG: 8.57 EC: 47.39 HUM: 34.37 CO02: 1053.00
RTD: Z24.58 BH: 4.70 DO: 8.57 EBEC: 47,40 HUM: 34.3% Co2: 1052.00
RTD: 24.57 PH: 4.65% DO: 8.57 EC: 47.40 HUM: 34.42 (C02: 1052.00
RTD; 24.56 PH: 4.65% DO: 8.58 EC: 47.23 HUM: 34.41 (Co2: 1052.00
RTD: 24.55 PH: 4.89% Do: 8.57 EC: 47.04 HUM: 34.41 CO2: 1052.00
RTD: 24.54 PH: 4.€9 ©DOo: B.57 EC: 485,86 HUM: 34.36 CO2: 105Z.00
sent to thingspeak|

RTD: 24.53 PH: 4.6% DO: 8.57 EC: 46.34 HUM: 34.44 Co2: 1053.00
RTD: 24.52 PH: 4.69 DO: 8.57 EC: 46.34 HUM: 34,41 cCO2: 1053.00
RTD: 24,51 PH: 4.65% DO 8.587 EBEd: 46.1€ HUM: 34,42 (Co2: 1053.00
RTD: 24,50 PH: 4.70 Do: 8.57 EC: 45.9%9 HUM: 34,35 CO2: 1052.00
RTD: 24.50 PH: 4.6% DO: B8.56 EC: 45.83 HUM: 34.27 cCo2: 1052.00
RTD: 24,49 PH: 4.6% DoO: B8.56 EC: 45:64 HUM: 34.24 0©CO02: 1053.00
|sent to thingspaakl

RTD: 24.52 PH: 4.70 D&: 8.56 EC: 45,43 HUM: 34.37 C32: 1053.00
BETD: 24.50 PH: 4.6% DO: 8.56 EC: 45.43 HUM: 34.41 ©CO02: 1054.00
RTD: 24,30 PH: 4.69% DO: 9.56 EC: 45.26 HUM: 34,41 CoO2: 1055.00
RTD: 24.49 PH: 4.69 po: B.56 EC: 45.08 HUM: 34.41 cCo2: 105&.00
[] Autoscrall [] Show timestamp Carriage return - .rgﬁﬂﬂbaud v-! | Clear output

19 Copyright © Atlas Scientific LLC
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If it cannot connect to your Wi-Fi you will see this:

o) - o X
| | send |
RTD: 24.15 PH: 4.69 DO: B.55 EC: 39.62 HUM: 33.70 C02: 1061.00
RTD: 24.16 PH: 4,69 DO: 8.55 EC: 38%.25 HuUM: 33.73 0©02: 1058.00
RTD: 24.16 PH: 4.69% DO: B.58 FEC: 39.24 HUM: 33.72 o©02: 1056.00
RTD: 24.17 PH: 4.70 DO: B.55 EC: 35,07 HUM: 33.71 c<Cp2: 1055.00
Iconnacting to wifil

RTD: 24.15 PH: 4.6% DO: B.55 EC: 3%.62 HUM: 33.70 ¢©02: 1061.00
RTD: 24.1¢ PH: 4.6% DO: B.55 EC: 39.25 HuM: 33.73 ©02: 1058.00
RTD: 24.16 PH: 4.62 DO: B.55 EC: 39.24 HUM: 33.72 C0Z: 1056.00
RTD: 24.17 PH: 4.70 DO: B.55 "EC: 39,07 HUM: 33.71 cC02: 1055.00
| connecting to wifil

RETD: 24.15 PH: 4.€69 DO: B.55 EC: 39.62 HUM: 33.70 ©02: 10&81.00
RTD: 24.1% PH: 4.6% DO: B.55 EC: 3%.25 HUM: 33.73 C©02: 1058.00
RTD: 24.16 PH: 4.69% DO: B.55 EC: 39.24 HUM: 33.72 cC02: 1056.00
RTD: 24.17 PH: 4.70 Do: 8.55 EC: 39.07 HUM: 33.71 cCo02: 1055.00
| connecting to wifil]

RTD: 24.15 PH: 4.6% DO: B.55 EcC: 39.62 HUM: 33.70 co02: 1061.00
RTD: 24.16 PH: 4.6% DO: B.55 EC: 39.25 HUM: 33.73 C02: 1058.00
RTD: 24.16 PH: 4.69 DO: B.55 EC: 39.24 HUM: 33.72 C02: 1056.00

[ Autoscroll [] Show timestamp | Carriagereturn + | 9600baud | | Clear output |

Entering the poll command will stop the Wi-Fi Aquaponics Meter from uploading the

readings to thingspeak, while you debug your Wifi problems.
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Atlas Scientific created a list of calibration commands that are built into the library.
Type in help to see a list of commands.

oc) - o X
| || Send |
> help
Atlas Scientific I2C Agquaponics kit
Commands :
datalog Takes readings of all sensors every 15 sec send to thingspeak
Entering any commands stops datalog mode.

poll Takes readings continucusly of all sensors
ph:cal,mid, 7 calibrate to pH 7
ph:cal, low, 4 calibrate to pH 4
ph:cal high, 10 calibrate to pH 10
ph:cal, clear clear calibraticn
ec:cal,dry calibrate a dry EC probe
ec:k, [n] used to switch K walues, standard probes values are 0.1, 1, and 10
ec:cal,clear clear calibration
For Ei probes, these are the recommended calibration walues:

ec:cal,low,12880 calibrate EC prche te 12,880us

ec:cal,high, 80000 calibrate EC probe to B80,000us
rtd:cal; t calibrate the temp probe to any temp value

t= the temperature you have chosan

rtd:cal,clear clear calibration
do:cal calibrate DO probe to the air
do:cal, 0 calibrate DO probe to O dissolved oxygen
do:cal,clear clear calibration
[+] Butoscrall [] Show timestamp i"Ca_rﬂage return - i‘J_EOUbaJd v | |_Ciea.r output |

Send the command poll; This will let you see the readings once per second and it will stop
uploading to ThingSpeak while you calibrate.

- AtlasScientific
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Remove the soaker bottle and rinse off the pH probe. Remove the top of the pH
7.00 calibration solution pouch. Place the pH probe inside the pouch and let the probe sit
in the calibration solution until the readings stabilize. This will take about 1 — 2 mins.

6.917 |
7.126 — X Unstabilized
7.223 |

7.225
7.225 .
7.225 [ JStablllzed
7.225 |
ph:cal,mid,7

Calibration

Once the readings have stabilized,
issue the Mid point calibration
command. ph:cal,mid,7

After 20 mins, the calibration solution inside an
open pouch is no longer considered accurate.

Dispose of the unused solution, after calibration.

Rinse off the probe and repeat this process for both pH 4.00 and pH 10.00.

Setting the Conductivity probe type
If your probe # K 1.0 (default), then set the probe type by using the ec:k,n command.

(where n = K value of your probe)

Example, if you have a K 0.1 conductivity probe issue the command ec:k,0.1

When calibrating Conductivity, you must always calibrate a dry probe first.

Make sure that the probe is dry before issuing this command, ec:cal,dry



Once the dry calibration has been completed, place the probe into a small cup of the low
point calibration solution. Shake the probe to make sure you do not have trapped air
bubbles in the sensing area. You should see readings that are off by 1 = 40% from
the stated value of the calibration solution. Wait for readings to stabilize.

12,880pS 12,880pS

Trapped air in sensing check probe connection,
area (shake to remove) +/- 40% you cannot calibrate to 0.

— O X
16,247
15,491 [~ X Unstabilized
14,053
13,756

13,756 oo
13,756 —Q/Stablllzed

13,756 Once the readings stabilize, issue the low point
ec:cal,low,12880 calibration command. ec:cal,low,12880
- (Readings will NOT change)

Rinse off the probe before calibrating to the high point. Pour a small amount of the high
point calibration solution into a cup. Shake the probe to remove trapped air. Again, the
readings may be off by 1 — 40% Wait for readings to stabilize.

— O X
51,674 |
53,826 — X Unstabilized
55,193
56,493 |

56,493 .
56,493 _«Stablllzed

56,493 Once the readings stabilize, issue the high point
ec:cal,high,80000 calibration command. ec:cal,high,80000
- (Readings will change, calibration complete).

- AtlasScientific
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D Calibrate Dissolved Oxygen

Let the Dissolved Oxygen probe sit, exposed to air until the readings stabilize. (small
movement from one reading to the next is normal).

U

- 8 x|
15.03

14.45 — X Unstabilized
14.08

13.95

13.95

132 - o stabilized
13.95
do:cal

After calibration is complete, you should see readings between 9.09 - 9.1X mg/L.
(only if temperature, salinity and pressure compensation are at default values)

- AtlasScientific

nvironmental Robotics

24 Copyright © Atlas Scientific LLC



E Calibrate Temperature

Calibrating the PT-1000 temperature probe is not required. However, if you want to,
a simple method to calibrate the probe is to place the PT-1000 into boiling water. Then
issue command rtd:cal,t

100 °C

Elevation in meters

305
229
152
76

0
-76
-152

Calibration Complete
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Once you are finished with calibration, issue the datalog command to resume taking a
reading every 15 seconds and uploading it to thingspeak.

To see the data on your phone, download the ThingSpeak app.
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