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© Cypress Semiconductor Corporation, 2012. The information contained herein is subject to change without notice. Cypress
Semiconductor Corporation assumes no responsibility for the use of any circuitry other than circuitry embodied in a Cypress
product. Nor does it convey or imply any license under patent or other rights. Cypress products are not warranted nor
intended to be used for medical, life support, life saving, critical control or safety applications, unless pursuant to an express
written agreement with Cypress. Furthermore, Cypress does not authorize its products for use as critical components in life-
support systems where a malfunction or failure may reasonably be expected to result in significant injury to the user. The
inclusion of Cypress products in life-support systems application implies that the manufacturer assumes all risk of such use
and in doing so indemnifies Cypress against all charges.

Any Source Code (software and/or firmware) is owned by Cypress Semiconductor Corporation (Cypress) and is protected by
and subject to worldwide patent protection (United States and foreign), United States copyright laws and international treaty
provisions. Cypress hereby grants to licensee a personal, non-exclusive, non-transferable license to copy, use, modify, create
derivative works of, and compile the Cypress Source Code and derivative works for the sole purpose of creating custom soft-
ware and or firmware in support of licensee product to be used only in conjunction with a Cypress integrated circuit as speci-
fied in the applicable agreement. Any reproduction, modification, translation, compilation, or representation of this Source
Code except as specified above is prohibited without the express written permission of Cypress.

Disclaimer: CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS MATE-
RIAL, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials described
herein. Cypress does not assume any liability arising out of the application or use of any product or circuit described herein.
Cypress does not authorize its products for use as critical components in life-support systems where a malfunction or failure
may reasonably be expected to result in significant injury to the user. The inclusion of Cypress’ product in a life-support sys-
tems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies Cypress against all
charges.

Use may be limited by and subject to the applicable Cypress software license agreement.

PSoC® Designer™ is a trademark and PSoC® is a registered trademark of Cypress Semiconductor Corp. All other trade-
marks or registered trademarks referenced herein are property of the respective corporations.

Flash Code Protection

Cypress products meet the specifications contained in their particular Cypress PSoC Data Sheets. Cypress believes that its
family of PSoC products is one of the most secure families of its kind on the market today, regardless of how they are used.
There may be methods, unknown to Cypress, that can breach the code protection features. Any of these methods, to our
knowledge, would be dishonest and possibly illegal. Neither Cypress nor any other semiconductor manufacturer can guaran-
tee the security of their code. Code protection does not mean that we are guaranteeing the product as ‘unbreakable’.

Cypress is willing to work with the customer who is concerned about the integrity of their code. Code protection is constantly
evolving. We at Cypress are committed to continuously improving the code protection features of our products.
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Thank you for your interest in the CY3215A-DK PSoC 1 In-Circuit Emulation (ICE) Lite Development
Kit (DVK) guide. You can use this kit with PSoC Designer™ or PSoC Programmer. The CY3215A-
DK provides debugging functionality for PSoC 1 and manages all the emulation communication
between the debugger software running on the computer (PSoC Designer) and the target PSoC
chip.

PSoC Designer is PSoC 1’s GUI-based Integrated Design Environment (IDE), which includes a pow-
erful set of tools for developing code, prototyping, and debugging. The document gives an overview
of the hardware configurations that can be used to set up a debugging system for PSoC 1 using this
kit. The Code Examples chapter on page 27 demonstrates use of the critical software elements of
the debugging system.

The CY3215A-DK kit supports the following PSoC 1 devices:

CY8C20x34

CY8C20xx6A

CY8C21x23

CY8C21x34

CY8C22xxx/CY8C21x45

CY8C23x33

CY8C24x23A

CY8C24x94

CY8C27x43

CY8C28xxx

CY8C29x66

CY8C95xx

1.1 Kit Contents

The CY3215A-DK kit includes the following:
ICE-Cube in-circuit emulator

ISSP cable

USB 2.0 cable

Blue Cat-5e cable

CY3250 flex cable
Backward-compatibility adapter

12-V 1-A adapter

CY3215A-DK kit CD

o PSoC Designer installation file

CY3215A-DK PSoC 1 In-Circuit Emulation (ICE) Lite Development Kit Guide, Doc. # 001-80377 Rev. *A 5
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PSoC Programmer installation file

Bridge Control Panel installation file (packaged along with PSoC Programmer)
Kit guide

Quick start guide

Release notes

Figure 1-1. CY3215A-DK Kit Contents

[ R I I |

ICE-Cube
12-V 1-A Adapter USB 2.0 Cable

coackward - Gy3250 Flex Cable
European ompatibility Blue Cat-5e Cable

Plug Adapter Adapter ISSP Cable

Inspect the contents of the kit; if any parts are missing, contact your nearest Cypress sales office for
further assistance.

Note The kit ships with only the base ICE debugger unit and its connectors. Pod kits and target
boards need to be purchased separately. In-circuit emulation with the ICE is possible with target
devices that have the on-chip debugger (OCD) function. Visit http://www.cypress.com/go/shop to
find the latest list of pods and PSoC1 target boards.
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Additional Learning Resources

Visit http://www.cypress.com for additional learning resources in the form of datasheets, technical
reference manual, and application notes.

For more information regarding PSoC Designer functionality and releases:
http://www.cypress.com/go/psocdesigner

For more information regarding PSoC Programmer, supported hardware and COM layer:
http://www.cypress.com/go/psocprogrammer

For a list of PSoC Designer-related trainings:
http://www.cypress.com/go/psocdesignertraining

For more information on CY3250-29xxxQFN ICE Pod Schematic:
http://www.cypress.com/go/CY3250-29xxxQFN

For more information on CY3250-FLEXCABLE Mechanical Layout Drawing:
http://www.cypress.com/go/CY3250-29xxxQFN

For more information on CY3250-29xxxQFN ICE Pod Mechanical Layout Drawing:
http://www.cypress.com/go/CY3250-29xxxQFN

Document History

Table 1-1. Revision History

Revision PDFg::"on Origin of Change Description of Change
** 06/06/2012 RKPM Initial version of kit guide
Updated the Introduction chapter and added Figure 1-1.
*A 10/22/2012 RKPM Reorganized chapter 3 and updated image. Added Figure
4-17.

Documentation Conventions

Table 1-2. Document Conventions for Guides

Convention Usage

Courier New

Displays file locations, user entered text, and source code:
C:\...cd\icc\

Italics

Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed, Bold]

Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File >> Open

Represents menu paths:
File >> Open >> New Project

Bold

Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman

Displays an equation:
2+2=4

Text in gray boxes Describes cautions or unique functionality of the product.
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This chapter describes how to install the CY3215A-DK PSoC 1 In-Circuit Emulation (ICE) Lite Devel-
opment Kit.

2.1 Kit Installation

To install the CY3215A-DK kit, follow these steps:

1. Insert the kit CD/DVD into the CD/DVD drive of your computer. The CD/DVD is designed to auto-
run and the kit installer startup screen appears.

Note You can also download the latest kit installer from http://www.cypress.com/go/CY3215A-
DK. Three different types of installers are available for download.

a. CY3215A-DK_ISO: This file (ISO image) is an archive file of the optical disc provided with the
kit. You can use this to create an installer CD/DVD or extract information using WinRar or sim-
ilar tools.

b. CY3215A-DK_ Single Package: This executable file installs the contents of the kit CD/DVD,
which includes PSoC Programmer, PSoC Designer, and user documents.

c. CY3215A-DK_Single Package (without prerequisites): This executable file installs only the kit
contents, which includes kit user documents.

2. Click Install CY3215A-DK to start the installation, as shown in Figure 2-1.
Figure 2-1. Kit Installer Startup Screen

= CY3215A-DK _ o E'?@

g
=4 CypRESS
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CY3215A-DK

Open User Guide...

s Semiconductor Corporation. All rights reserved
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Note If auto-run does not execute, double-click the cyautorun.exe file on the root directory of the
CD/DVD, as shown in Figure 2-2. To access the root directory, click Start > My Computer >
CY3215A-DK <drive:>.

Figure 2-2. CD/DVD Root Directory

EEX
Fle Edit ‘iew Favorites Tools  Help .}'l:
@Eack L D | IT ";.-‘Saarch “ Folders -
address |§ Fiy v Be

"',j CH32LSADK ,/’ Documentation /J Prerequisite /J PSoC Designer
| | I |
[ == e ‘

PSoC Programmer [ Reference 42 ., autorun cyautorun
| | = Setup Information sa3l | DATFllz

L KB

 cyautorun ®
’9'- Cypress Autarun Applet s :estup
= x 48
Cypress Semiconductor & 10 File

LKEB

In the InstallShield Wizard, choose the folder location to install the setup files. You can change
the location of the folder for the setup files using Change, as shown in Figure 2-3.

Click Next to launch the kit installer.
Figure 2-3. InstallShield Wizard

CY3215A-DK - InstallShield Wizard [E

Welcome to the InstallShield Wizard for
CY3215A-DE

The InztallShield wizard will install Cv32154-0F, on your
computer. To continue, click Mest.

Select folder where setup will install files,

G Install Cv' 221 28-DE to:
C:%Program Files\Cypress

: Bacl i Mests .|[ Cancel

On the Product Installation Overview screen, select the installation type that best suits your
requirement. The drop-down menu has three options: Typical, Complete, and Custom, as
shown in Figure 2-4.

. Click Next to start the installation.
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Figure 2-4. Installation Type Options

! Cylnstaller for CY3215A-DK 1.0

Product Installation Overview
Choose the install type that best suits your needs

Chooze the tupe of installation
Product:

Cr32154-DK
Inztallation Type:

. Typical £v3 |

Installs the rost common features of
Cv3215a-Dk,

The following products need to be installed manually
Adobe Feader

[ ][ ]

7. When the installation begins, a list of packages appears on the Installation Page. A green check
mark appears adjacent to every package that is downloaded and installed; see Figure 2-5.

Figure 2-5. Installation Page

* Cylnstaller for CY3215A-DK 1.0

Installation Page
Please wait while setup installs/configures CY'3215&-DF on vour computer

Caching *

4 PSolCProgrammerSetup

@ PSoCProgrammerd.14.0.1126

= ClockProgrammer].3.0.1126
U5BBootloader. 1126
BridgeControlPanei. 4.0.1126 = * a2
ExampleCade. 1125 Ina desugn e
DeviceDatabase. 1126 A Check out our latest PS
PSoCDesignerSetup Development kits af
PSolDesigner_CoreS.2.2851.0 1 www.cypress.com/go/kits
PSoCDesigner_Contentd 2.2551.0 |
PSoCDesigner_Doch 2.2551.0 i

Status
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8. Wait until all the packages are downloaded and installed successfully.
9. Click Finish to complete the kit installation, as shown in Figure 2-6.

Figure 2-6. Installation Complete Page

* Cylnstaller for CY3215A-DK 1.0

After software installation, verify that you have all hardware and drivers set up for the CY3215A-DK
kit by connecting the kit to your computer via its USB interface. Because this is the first time you
have connected this board to this computer, initial drivers are installed. If you encounter any prompt
related to Windows Logo Testing, click the Continue Anyway button to allow the driver installation
to finish. Follow the instructions to complete the installation process.

12 CY3215A-DK PSoC 1 In-Circuit Emulation (ICE) Lite Development Kit Guide, Doc. # 001-80377 Rev. *A
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2.2 PSoC Designer

PSoC Designer is the revolutionary integrated design environment (IDE) that helps to customize
PSoC 1 to meet specific application requirements.

1. To open PSoC Designer, click Start > All Programs > Cypress > PSoC Designer <version> >
PSoC Designer <versions.

2. To create a new project in PSoC Designer, click File > New Project.
3. To open an existing project in PSoC Designer, click File > Open.
Figure 2-7. PSoC Designer Interconnect View

Datasheet Resource Meter

Workspace Explorer

Global Resources Menus Toolbar

% ASM. Example_ADC_UART_L 20 - P5oC Desipner 3.
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Sekects the rominal aperation B ASM E anc | ]
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[EyaCh] souwece. fom wihich .. v § Decimator Totat 1 Used 0

= ol |
|2C Condralles Total 1 Lzed: 0

Parsmeters - ADCL.. w B X/
Mame  ADCINC1Z_1

- b3 >
ClockPha Mem = L

TMR Cloc WC1 o = Liser Modules - 3K ]
It ACEM i | ] User Madidas
= i
EHT GociNCE T i Sea ANEPI9 ADC Selection
E { 3 Anlog Conm Guidi for ather convetars
Name El ! L Courters
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iy this Usor Wodule iret e — Featuqes and
e s 02 ot Overview
?fmt-aﬂn__mm... 00X = 3 Geneic
B PO0] Poi 00, Siolfa| B3 Legacy o 12-bit resolution, 2's
E POT] WA Anzbginpu | i Mize Digha camplemeant
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e | oA 1 5
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User Module Catalog

Pinout Info Chip Editor View

To experiment with the code examples, go to Code Examples on page 27.

Note For more details on PSoC Designer, see the PSoC Designer IDE Guide located at:
<Install_directory>:\PSoC Designer\<version>\Documentation.

See Additional Learning Resources on page 7 for links to PSoC Designer training. The PSoC
Designer quick start guide is available at: http://www.cypress.com/?rID=47954.
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http://www.cypress.com/?rID=47954

2=
=

P/ CYpRrESS

Gettlng Started FPERFORM

2.3 PSoC Programmer

To open PSoC Programmer, click Start > All Programs > Cypress > PSoC Programmer <ver-
sion> > PSoC Programmer <versions.

To successfully program the device, follow these steps:
1. Select the ICE-Cube connectivity in Port Selection, as shown in Figure 2-8.

Figure 2-8. PSoC Programmer Window

&, PSoC Programmier

File |\-'i_ew OpHons Help File Load

@[slelen @D

Fort Selection 'dlb Pragrammer ;_Utilities TAG |

[m USB/073ECT49 : Frogramming Parameters
File Path:

File Iz Mot Present

Program

Prograrrner: USBI735C749

Frogramiming hode: Rezet & Fower Cycle Fower Detect

Werification: @ on O of Connector: Sp 10p
AutoDetection: ® on O Off Clock Speed:

[evice Family
[smon = Programrmer Characteristics Status
1 = Btk ITAG SwD @ 158P a0 Execution Time:

Device 5 Powier Statug,  —
| — ||| ¥oltace: @ 50y © 33V 2BV 18V || oo
|CY7CEMT3PEE v Waoltage: M
Actions Results G
Successfully Connected
to U3IB/0735C749 at IceCube
2:00:17 PM
Opening Port at 2:00:15
M
Device set to
CY7CA0113-PVEC at 5192 FLALZH hbytes
Z:00:15 PH
Device Family =zet to
60100 at Z:00:15 PH
v

Aotive HEX file set at

For Help, press F1 [

2. Click the File Load button to load the hex file.

3. Select the device and device family from the list.

4. Click the Program button to program the selected PSoC 1 device.
5

. Close PSoC Programmer.

Note For more details on PSoC Programmer, see the user guide at the following location:
<Install_directory>\Cypress\Programmer\<version>\Documents

14 CY3215A-DK PSoC 1 In-Circuit Emulation (ICE) Lite Development Kit Guide, Doc. # 001-80377 Rev. *A
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The CY3215A-DK is used to prototype and develop applications with PSoC Designer IDE. This kit
supports in-circuit emulation and the software interface allows access to the contents of specific
memory locations.

3.1 Connecting the ICE-Cube

The new in-circuit emulator replaces the legacy ICE-4000 and USB adapter to allow seamless USB
connection, debugging, and programming. CY3215A-DK is supported by the latest version of PSoC
Designer, which is included with the kit.

Figure 3-1. ICE-Cube

3.1.1 Connect using a USB Port

The ICE-Cube connects to any computer using a standard USB 2.0 cable, included in Cypress
development kits. To connect the ICE-Cube to your computer, power it first by connecting the wall
adapter to the 12-V DC port, plug the USB cable into your computer, and attach the other end to the
ICE-Cube.

The ICE-Cube is a plug-and-play device and it should be recognized automatically by any computer
with PSoC Designer and PSoC Programmer installed. If USB connection problems occur, refer to
Microsoft Windows Help for troubleshooting Windows connectivity issues.

CY3215A-DK PSoC 1 In-Circuit Emulation (ICE) Lite Development Kit Guide, Doc. # 001-80377 Rev. *A 15
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Connect using a Backward-Compatibility Adapter

A backward-compatibility adapter can be used to debug and program PSoC 1 devices.

Figure 3-3. Backward-Compatibility Adapter

Program Device

To program the device using the backward-compatibility adapter, follow these steps:

No oo~

Power on the ICE using the 12-V adapter and connect it to your computer using the USB cable.
Connect the backward-compatibility adapter to the ICE using the port labelled "POD".

Connect the yellow ISSP cable to the ICE-Cube through the backward-compatibility adapter.
Place the 5-pin end of the ISSP cable on the 5-pin programming header of the target board.
Launch PSoC Programmer.

Load the hex file using the File Load button.

Program it successfully.

CY3215A-DK PSoC 1 In-Circuit Emulation (ICE) Lite Development Kit Guide, Doc. # 001-80377 Rev. *A
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3.1.2.2  Debug Device

To debug the device using the backward-compatibility adapter, follow these steps:

1. Power on the ICE using the 12-V adapter and connect it to your computer using the USB cable.
Connect the backward-compatibility adapter to the ICE using the port labelled "POD".

Connect the blue CAT 5e cable to the ICE-Cube through the backward-compatibility adapter.
Connect the other end of the CAT cable to the RJ45 port on the target board.

Launch PSoC Designer and create a project for the target device to start a debugging session.
The device can also be programmed in this hardware configuration.

6. Launch PSoC Programmer, load a hex file, and click on Program to program the device.
Figure 3-5. Backward-Compatibility Adapter Connected to ICE-Cube Pod

ISl A

3.1.3 Connect using a Flex Cable

A flex cable is used to connect the ICE-Cube to the pod main board.

m Pod: Pods connect to target circuits via foot. As each pod contains a fully functional PSoC bond-
out device, pods may be used instead of devices for test purposes. Simply plug a pod into the cir-
cuit without connecting it to an ICE base station. The pod power LED lights up when it is powered
and operational.

CY3215A-DK PSoC 1 In-Circuit Emulation (ICE) Lite Development Kit Guide, Doc. # 001-80377 Rev. *A 17
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Figure 3-6. Flex Cable and 29000-28 DIP

.

oress Semic@nductor
1750-F LEXCABLE

m Foot: A foot is used to connect the pod to the MiniEval board. Each foot has a pinout that models
a PSoC — for example, a 28-pin DIP. A foot that emulates surface-mount components must be
soldered to target circuits. The main board of the pod can then be attached or removed, as

desired.
Figure 3-7. 28-Pin DIP Feet

m Plastic Mask: The plastic mask is used to orient the foot. Plastic masks are provided to expose
only the pins that connect to the foot.

Figure 3-8. Plastic Mask

—
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Before connecting the flex cable to the ICE-Cube, assemble the three pieces (pod, plastic mask, and
foot), as shown in Figure 3-7.

1. Select a foot. The foot should match the pinout of the PSoC 1 device used in the target circuit.
2. Next, select the mask that matches the desired foot.

3. Insert the mask into the bottom of the pod, aligning the chamfered corners of the mask to the
pin-1 triangle on the pod.

4. Insert the foot through the plastic mask. Use the alignment triangles to orient the foot to the pod.
5. Plug/assemble the pod onto the target board using the relevant feet.

Figure 3-9. Assembled Pod with Flex Cable

6. Connect the other end of the flex cable to the ICE-Cube pod connector, as shown in Figure 3-7.
7. Start debugging the project, as explained in Debug a Project on page 21.

Figure 3-10. Flex Pod Connected to ICE-Cube Pod

Table 3-1. Pin Description of Pod Connector

Pin No. Pin Name Pin Description
1 POD EXTRAS3 | Future use
2 GND Ground
3 — —
4 POD_OCDDE |POD_OCD even data I/O
5 GND Ground
6 POD_OCDD) |POD_OCD odd data output
7 POD EXTRA1 | Future use
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Pin No. Pin Name Pin Description
8 POD_XRES | Reset signal (required only for Reset programming mode)
9 GND Ground
10 POD_OCDHC |POD_OCD high speed clock output
11 GND Ground
12 POD_OCDCC |POD_OCD CPU clock output
13 POD EXTRA4 | Future use
14 PODVCC Supply voltage
15 - -
16 PODVCC Supply voltage

Software Installation

After the physical connection is made, you are ready to configure the internal connection from the
computer to the ICE. The ICE enables communication and debugging between PSoC Designer and
the pod. To connect the ICE from within PSoC Designer, perform the following steps:

Confirm that the flex cable and pod are attached to the ICE-Cube.

1.
2
3.
4. Create a project using PSoC Designer. For more information, see My First Code Example on

o o

. Confirm that the ICE is powered from the power adapter.

Confirm that the USB cable is connected from the ICE-Cube to the computer.

page 27.

To access the debugger subsystem, go to Project > Settings > Debugger.

. Select the correct port from the drop-down window. The target board may either be powered by

ICE-Cube or an external source. Select 5 V as Pod Supply Voltage to power the board using the

ICE-Cube.

. Click OK.

Figure 3-11. Debugger Project Setting

“prg ject Settings

|2Crn_EEPRIOM
(= Build
L Compiler
- Linker

- Chip Editor

Select ICE Device: ;FIEE 0, Cube [ 5M: 0735C445 )

-
|

Pod Power Source

3 External anly (%) ICE may power pod

Pod Supply Yaltage 1B v

0k

] [ Cancel
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YT Using ICE-Cube Connector

Click Debug > Connect/Disconnect [F9]. On successful connection, you will receive a notifica-
tion in the Output tab of the Status window; a green indicator displays Connected in the lower-
right corner of the program.

Figure 3-12. PSoC Designer Connected with ICE-Cube

A:00 | ¥:00 |SP:00 | PC:OO000 F: 00 0.0 KHz ICEO | Connecked |Ln 33 Col 2 NS

3.1.5 Debug a Project

The following section gives a brief overview of the debugging features in PSoC Designer. For more
details, see Code Examples chapter on page 27. To successfully debug a project, follow these steps:

1.
2.

7.
8.

Connect the ICE-Cube to the PSoC 1 development board.

Click Start > All Programs > Cypress > PSoC Designer <version> > PSoC Designer <ver-
sion>.

Create a new project in PSoC Designer by clicking File > New Project.

Note To open an existing project, click File > Open.

To connect the ICE-Cube and PSoC 1 development board, go to PSoC Designer > Debug.
Click on Connect/Disconnect or press F9.

Right-click on a line in the project from where the debugging process should start. The Insert/
Delete Break Point option appears.

Figure 3-13. Break Points in main.c

% USBUART (Debugging) - PSoC Designer 5.1

Eile  Edit View Project Interconnect Build Debug  Program  Tools  Window  Help

NEHS. EES 28 GFFE, fHO%S. @@ p p[EE

isbuart . X

(&

=) =22 = LR

Start Page | usbuart [chip] ©” main.c | baot.asm

1 i

Zi A et Line

3

4

5. #include <wSc.h> // part specific conscants and wacros

& #include "PSoCAPI.h" /¢ PSoC API definitions for all User Modules
-

& BYTE txData[] = "PSoC Rocks!":

2; BYTE rxCount, rxDatal ]:
10; wvoid main(void)
i1m 4

1z HBC EnableGInt; //Enable Global Interrupts|
o USEUART 1 Ztart (USEUART 1 SV OPERATICN): //Start USBUART 5Y operation
BL while (!TUSBUART 1 Init(]): //Waic for Device to initialize
@ =
ig {
Power Setting [ Ve 7 SpsClk freq | 1% rxCount = USEUART 1 hGetRxCount(); //Get count of ready dats
Selects the nominal operation voltage and is if (rxCount)
Swstern Clock [SpsClk] source, from which, . 19 {
0 z0 UZEUART 1 RBeadlill(rxData); //Read all data rom RX
Parameters - USEUART_L X 21 while (IUSEUART 1 _hTxIsReady(}); //If TX is ready
i F A o3 if (rxData[.] == 3 // Enter key pressed
23
@ =z USEUART 1 PutCELF (] :
z5
26
a7
- @ 8 USBUART 1 Write (txData,11);
= 29
Na_me . 30 3
Indicates the name used to identify this
User Madule instance | AL i
Gutput

To view memory, registers, and watch variables at a particular location, go to Debug > Windows.
To start the debugging process, go to Debug > Go or press F5.

Use one of the following options for the debugging process:

a. Debug > Step Over (or press F8): Steps over next statement
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Debug > Step Into (or press F9): Steps into next statement
Debug > Step Out (or press Shift + F11): Steps out of current function

d. Debug > Step ASM (or press Shift + F10): If the current line is C code, the line is located in
the first file and that line is executed

Figure 3-14. Debug Options

% [2Cm_EEPROM (Running) - PSoC Designer 5.1

File Edit Wiew Project Interconnect Buld | Debug | Program  Tools  Window Help
NMEEG . TES ®E L E W =] Memery Cubbalt =5 = 2 S@rifyenm @
Gl oram v & X Start Pal 2] output files i Reoisters Chrl+alk+G - 4 b x | Workspace Explarer X
153 i wakch Chrl-al+n —1| [ 2] Workspace '12Cm_EEPROM' [1
- [
: ik == 12Cm_EEPROM [CY8C2
154 = - = ;
e 2 Locals Crri+Al+HL BB 12Cm_EEPROM [Chip)
i | | Run To Cursc el Break Points Chrl+-alt+B = {Zr Loadable Configurati
157 W Halkt shift+Fs | %] Events CrH-AIL+E = Ecn:ggenmme
. m
158 Reset Chrl4+-shift+FS | Trace Curk+Al+T O Lco
| EEl = — = SBEndpoint Data  Ctrkbal+l - 12Cm_EEPAOM [Pirout)
160 :< uffer. ¥You o @[3 12Cm_EEPROM
@ 151 = ke Fl
| 162
TeTilEEs o o £
164 e M = User Modules >3 X
165] ﬂb Connect | Discannect F3 ,,ﬂ User Modules A
1661 [ Download to smulats HiFt+ [ ADCs
167 i -1 Amplifiers
168 i oo ’ REMBuffer into the EEPROM & Analog Comm
| 169 ] TraceMode b | iz the address at which the data should '—:‘J Counters
[ el = S P— [Bufer, 17, 0): [ DACs
171 =) rigald -1 Digital Comm
172 E FR S than that taken by the I2Cm to write. E"—J E‘\Itals.
=l
173 et rfigure LSE Data Tracking ater than Write Cycle timing parsmeter i "J, Eneis
- Legacy
: @ 17+ | -2 ise Digia
Power Setting [ Yoo / SysClk 175 LCD DelaySOul); 'g 1 ML
Selects the nominal operation voltage 176 - @l | = '—J .
and Systemn Clock (SpsClk] source. fro ! | -3 Protocals
S | 2 o [ PwMs v
ubput
[aon [wos [spioe [ pooser [Rcr [ aosmez [ 1ceo [ Cornected

3.1.5.1 Break Points

The break point feature allows you to stop program execution at predetermined address locations.
When a break point is encountered, the program stops at the address of the break point, without
executing the address code. The program can be restarted using the available menu or icon options.

To set break points, first open the file to debug. Right-click the mouse at specific points and select
Insert Break Point. You can view and remove active break points in the Break Points window. To
open the Break Points window, select Debug > Windows > Break Points.

Figure 3-15. Break Points Window

X BPE B S
boot asm, fine 122

mair.c, line 181

main.c, ling 174
mair.c, line 146

mair.c, ling 170

¢ @ € @ o W

main.c, line 161

Cutput |

[ o0 [ wio0 [seoo | poioooo [Rioz [ 3o03mMHz | B0 [ Conmected

3.1.5.2 CPU and Register Views

During debugging, you can read and write in five areas: CPU registers, bank registers 0, bank regis-
ters 1, RAM, and flash. The CPU registers are shown in their own window (Debug > Windows >
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Registers) and in the notification area at the bottom of PSoC Designer. The other four areas can be
viewed in the Memory Window (Debug > Windows > Memory). Select one of the four memory
areas from the Address Space box.

CPU Registers: This window allows you to examine and change the contents of the CPU registers.
Data is entered in hexadecimal notation. CPU register values can be viewed across the bottom of
PSoC Designer.

Figure 3-16. CPU Register in Memory Window

CPL Registers -1

& |03
FLAGS: |C4 [C=1.Z2=0.GIE=0]
PC: |093E
sp (02
«: |E8

Oukpuk

A:09 | W:E& [SP:0Z2 | PC:093B | F: 4 3.03 MHz ICED Connected Ln 146 Col 1 NS

RAM: RAM locations can be modified by clicking the data at the specific location and typing in the
new value. Data is entered in hexadecimal notation.

Flash: The flash window displays the data stored in flash. This is the program memory; it is read-
only.

Bank Registers 0 and 1: You can scroll through the register bank to view the values in the register
bank. Type a new value into the Offset to scroll directly to that offset. Click next to a value and type
a new value for the register.

Figure 3-17. Memory Window

Memary -1
i fAddress: 00000 - |Cﬂ|umns & *  iews
FLASH | RAM{1)  IOBank0 © 10 Bank1 " RAM 4k

oooo 00 00 00 FF 7F 80 00 01 ...¥%....
0003 02 03 04 05 06 07 03 09 ......Ws
00l0 0OA OB OC OD OE OF 10 00 ........
0013 00 00 00 00 00 00 00 00 ........
00z0 00 00 00 00 00 dd 00 o0
00z2a 00 00 00 00 ZE 00 00 00
0030 00 00 00 00 00 dd 00 o0
0038 00 00 00 00 00 00 0O 00
0040 00 00 00 00 00 0O 0O 0o
0048 00 00 00 OO 0O OO OO 00
0050 00 00 00 00 00 0O OO 00

Oukput

Ar00 | X:05 [SP:i07 | PC:0961 F: C7 3.03 MHz ICEQ Connected Ln 170 Col 1 NS

Watch Variables

To set watch variables, right-click a variable in a source file and select Add Watch. You can also
select Global Variables. Right-click Add, Delete, or Properties in the Watch/Global Name window
to add, delete, or modify values.
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Figure 3-18. Watch Variables Window

Mame Walue Location Type
5 |2Cm_bwriteBiytes 070 Flash 0x06&1 char
Cukput
[ aioo [ wos [seeor| poioser [Fcz [ 3osmHz | 1cE0 [ Conmected

3.1.54 Trace

The Trace window is displayed when Debug > Windows > Trace is chosen. It displays a continu-
ous, configurable listing of project symbols and operations from the last break point. The trace
shows symbolic, rather than address data, to enhance readability.

Each time the program executes, the trace buffer is cleared. When the trace buffer becomes full, it
continues to operate and overwrite old data.

Figure 3-19. Trace Window

Start Page | iZcm_eeprom [Chip] | main.c | boot.asm <" Trace.ksk r 4k X

1: PC / STYMEOL INITRUCTICN -

Zi 0O95E MoV E, SP

31 095D main.c.WriteFromBiM PUSH X

4: 094z CALL main.c.WriteFromRAN

5 0940 OR F, 0O1h

6 093F POFP X

Ti 0634 RET

& 0638 MOV BEG[O4h], &

2 0836 MGV A, [0000L] v

Z O95E MoV X, SP Y

F: 095D main.c.WriteFromBiM PUSH X

4: 0942 CALL main.c.WriteFromRAN

5 0940 OFR F, 0O1h

6i 093F FOP X

70634 RET

2 0838 MOV BEG[O4h], &

2l 0636 MOV A, [0000h]

10; 0833 AND [0000h], SFh

11 0631 AMND F, EFh

12! 0O@8zF MCV BEG[O4h], &

13 062D MOV A, [000Z2h]

14 0O6ZE MOV REG[OSh], 4 v
Ckbpuk

|A: ul] | #0585 |SPi07 | PC 0961 F: C7 3.03 MHz ICEQ Connected

3.1.5.5 Locals

A separate window is available for local variables. Whenever execution halts, the local variables are
updated to the current value.
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Figure 3-20. Locals Window

Mame Walue Location Type
B 843 Rak 00705 int
| Qutput
[ acon [ w05 [seor | Poioser [Focr | zoamdz | B0 | Conmected

WARNING The time taken to execute a system supervisory call (SSC) such as FlashRead/Write,
Table Read, and Erase Block is significantly more while emulating a code through ICE-Cube when
compared to the time taken when running the code on chip.

PSoC Programmer

PSoC Programmer is used as a standalone application to program PSoC devices. It can be
launched within PSoC Designer or accessed from the desktop as a standalone program.

Figure 3-21. PSoC Programmer Interface

7.PSaC Programmer BEE
Fle VWiew Options  Hel
8 HEMN B MNP @
iy § ( 210 8 O 8 I
| Pon Selection b | Programmer | unitities | JTAG
@ USEAITIECTAS Frogramming Paramiters
File Patn CADocuments and Sett Kangally D Cen_EEPROM2Cm_EEPROMIZCm_EEFROM hes
Froqrammer; USBID735C743
Programming Mede;  Reset @ Power Gyele  Fowrer Detect
Varificatinn: @ on O Off Cannscar Sp 210
Dayka Famiy dutzDetaction; @ on O off Clock Speed: | & !
[ 20ves | Programmer Characteristics Statis
! Protocol  JTaG  owD ) ISSP 130 Execution Time; 322 secands
Device i 5 x =
P Yoltage: () (8] P28V 18V
[CviczeaPd v PSSO 8% | vahsge i
-

Aclions Resuts

Program Finished at

12:52:38 BU
Frogramming Succesded
Doing Chackswm
Daing Pratect
Verity Succeeded
Verify Starting
Progeanming Succeeded
Programming Starting
Erase Suscesdsd

Device sec to

CYBC20465-24PXT ac 32768 FLISH byces

12:52:07 PU

Deviee Family set to

29u86 at 12:52:07 PH
Automatically Detected Device: CY8C29466-24PXT

Program Requested at .

For Help, press FL

To program a target board using PSoC Programmer via ICE-Cube pod connector, follow these steps:
1. Set up all hardware, including the device to be programmed.

2. Disconnect power from the target board.

3. Launch PSoC Programmer:

a. From the desktop, click Start > All Programs > Cypress > PSoC Programmer.

b. From within PSoC Designer, click Program > Program Part.

Click File Load to select a file for programming.

Select the port used to connect the programmer.

Select the device family and device used to generate the hex file.

Select Reset under programming mode.

N o o s
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8. Apply power to the target board.
9. Click Program to start device programming.
10.The action window reports the status and success of programming.

Figure 3-22. Hardware Configuration with ICE-Cube
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4.1 My First Code Example

411 Project Objective

This project is used to demonstrate blinking an LED at a varying duty cycle using a hardware pulse
width modulator (PWM). Another LED is caused to blink using a software delay. The clock dividers
VC1, VC2, and VC3 are used to divide the 24-MHz system clock by 16, 16, and 256, respectively.
The resulting 366-Hz clock is used as the input to an 8-bit PWM. This in turn produces an LED blink
period of 1.4 Hz. The project also demonstrates how an LED can toggle on/off with a delay of
approximately 1 second.

The following user modules are used in this project:

m PWM - An 8-bit PWM is used to generate a 366-Hz signal. An LED is connected to the PWM out-
put. This LED blinks at 1.4 Hz.

m LED - This module is used to toggle an LED on/off.

41.2 Creating My First PSoC 1 Project

1. Open PSoC Designer 5.1.
2. To create a new project, click File > New Project. The New Project window opens.

3. Inthis window, select the Chip-level icon. Name the project Example_My_First_ PSoC_Project,
as shown in Figure 4-1.

4. Click Browse and navigate to the directory in which the project should be created.

Figure 4-1. New Project Window

MNew Project

Project types:

Y

Chip-lewel

Etreates ah empty project, that supports User Module selection and placement.

Mame: -E xample_kMy_First PSoC_Project

Location: E\
wiorkspace narme: ;.I-f:;am|;|-e_"h-*|._ll,l-_-f:'li.rst_il-‘ga_CiIE‘.roiéct . Create directory for workspace

Workspace: | Create new Workspace w |

Ok ] [ LCancel

5. Click OK. The Select Project Type window opens.
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6. In this window, under Select Target Device, click View Catalog, as shown in Figure 4-2.

Figure 4-2. Select Project Type Window

% Select Project Type - Chip-level

Clone project:
Path: | | ’ Browse. .. ]
Clear Fath
Select Target Device
Device: | CYAC29B5-24P) Tl Yiew Catalog... |
Generate "Main’ file using:
@®cC
) Assembler
[ ok ] [ LCancel ]

7. The Device Catalog window opens. Click the PSoC tab and scroll down to the CY8C29466,
CY8C29566,... section.

8. For this project, click CY8C29466-24PXI and then click Select; see Figure 4-3.
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Figure 4-3. Device Catalog Window

Device Catalog - Chip-level

\
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[ Lighting
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CEC28513-244X]
CyBC28533-24A4X
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CwBC28543-241Tx]
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CYVBC2B485-12PVHE
CYBCZR488-2aPWA
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CYBCZ8465-245X]
CY8C29566-244X]
CYEC25888-12PVHE
CY8C255868-24LFX]
CYBC29666-24PWHA
CYBC28666-24PVX]
Cr8C25866-244K]
CYECLED0MD01-58LTXI
CveCLEDO2D01-58LTXI
CvBCLEDO2D01-56LTX
CYECLEDD2D02-58LTX]
CYaCLEDD2GO1-56LTXI
CYECLEDDAD01-58LTX

| all

v||a||
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v| al '|a||

USB inter

Mmoo R

e

G G we A

3.0t 525 ez
Al 3.010 525 Yes
Al 3.010 5.25 Yes
44 3.010.5.25 Yes
44 3.010.525 £z
44 3010525 =
Z4 47510525 Mis
24 3010 5.25 Mis
Z4 3.0 10 525 Yes

4 3.0105.25 Ves
al 3.010 525 Yes
44 47510 525 Hi&
4d 3.010525 =
44 3.010 525 &
44 3:010 525 Yes
g4 3.0140 525 e
14 4750 E25 HiA
14 47510 5.25 i
14 47510525 A
14 47510 525 MiA
12 47510 525 ML
14 47510525 Mis

[Show Partlmage] [ Select ] [ LCloze

|

9. Under Generate 'Main' File Using:, select C, then click OK.
10.By default, the project opens in chip view, as shown in Figure 4-4.
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Figure 4-4. Default View

< Example_My_First_PSoC_Project - PSaC Designer 5.2
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DACs
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Fiters
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PO[2) Part_0_2, SdCPL, Hic Mise: Digital

PO[3) Pert_0_3, SdCPL, Hic MLKs

PO[4] Port_0_4, SdCPL Hi - Frotocols

PO[S] Pert_0_8, SdCPL, Hic 3 PuiMs

POE] Port_0_6, SdCPL, Hic Random Seq

PO[7) Part_0_7, S1dCPL, Hic RF

P10 Part_1_0, S1dCPL, Hic Temperature

PI[1] Part_1_1, S1dCPL, Hic Timers

Cutput

Ready | 1ce0 | Mot connected

In the User Modules window, expand the PWMs folder. In this folder, right-click on PWM8 and
select Place. The user module (UM) is placed in the first available digital block.

Figure 4-5. User Modules Window
dilzs

- Analog Caornm ”~

{1 Counters

DACs

Digital Cormmn

Filters

Generic

LED Drirnrnitig
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iz Drigital

MLz

Protocols

“i

nfnfuingugnjuiuings

T R e R R e e i e e

e PwMDBIE

e PwMDBR
-1 Random Seq
L3 FF e
1 Temperature

— = A

12.Configure the PWMB8_1 properties, as shown in the following figure.
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Figure 4-6. PWM8 User Module Properties

Clock, W3
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13.Next, route the PWM CompareOut signal to P2[0]. The first step is to configure the lookup table
(LUT) on Row_0_OutputO.

Figure 4-7. Route PWM CompareOut Signal to P2[0]

ROO[0
Roor]

Ruw_o_ouhﬂ\
T
L]

\

RO02]

]

ROO[3]

RI1[0]

RI1[1]

RI[2]

RI1[3]
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14.Click on the LUT node on Row_0_Output_0 to open the Digital Interconnect window.
15.In this window, configure Row_0_Output_0_Drive_0 to connect to GlobalOutEven_0.

[
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Figure 4-8. Digital Interconnect Window

' Start Page »” example_m...ject [Chip]* kX
Digital Interconnect Row _0_QOutput_0

T Goo o7 GOE o
A I GlobalOutOdd 2
e _-““-‘._‘
P _/""
Roa[a] Ll
E ﬂ |' 1. |
v RIO[0] PRt ? >
P RIO]
—— T
L 5 RIO[2] ] Por_ 0.1
o RID[3] e =
BCO = =

Cloze

16.Click Close.
17.Click GlobalOutEven_0. In the window that appears, select the pin as Port_2_0.

Figure 4-9. Select Pin Port_2 0

—— FPorl 20 b
DCB13 —=
Port_2 0 v
Interconnect
% 0k Cancel

18. Click OK to continue.

19.In the User Modules window, expand the Misc Digital folder. In this folder, right-click LED and
select Place; this adds the UM to the project. This UM does not use digital or analog blocks. It
appears in Workspace Explorer > Example_My_First PSoC_Project[CY8C29466-24PXI] >
Example_My_First PSoC_Project[Chip] > Loadable Configurations >
example_my_first_psoc_project - 2 User Modules.
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Figure 4-10. Workspace Explorer

space Explorer
| Wworkspace 'Example_My_First_PSaC_Project [1 project]
={:Z Example_My_First_PSoC_Project [CYBC29466-24P%l]

= E Example_ky_Firzt_PSaC_Project [Chip]

. =z Loadable Configurations

2| emarnple_ry_first_pzoc_project - 2 Uszer Modules
ol PwE

 im

: E Example_My Firzt PSoC_Project [Pinout]

[+ Example_My_First_PSoC_Project

20.Configure the LED properties, as shown in the following figure.

Figure 4-11. LED User Module Properties

Parameters - LED_1

' LED_1
Port Port_2
Fin Port_2 1
Dirive Active High

21.Configure the Global Resources window to match the following figure.

Figure 4-12. Global Resources Window

Global Resources - example_my_ First_pso.., - & X
Power Setting [V 5.0 / 24MHz

|:F'|_|_|:||:||::l=:. S_','S|:|k.-"2 w
32k _Select |nternal
PLL_tode Dizable

Sleep_Timer 312 _Hz
WC1=Sp:Clk/M 16

WE2=WET M 16

W3 Source W2

W3 Divider 206

SysClk Source | Internal
SysClk™2 Dizable Mo

Analog Power SC On/Ref Low
Fef ks [dd/2)+/-BandGap
AGEndBypazs Dizable
Op-tsmp Bias Lo

A Buff_Power | Low
SwitchbdodePump OFF
TripYoltage [LWD 4. 81% [5.000]
LYDThrottleB ack Dizable

W atchdog Enable Dizable

CPU_Clock
Selects the CPU clock speed, from 3375 KHz b 2.
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22.0pen the existing main.c file in Workspace Explorer. Replace the existing main.c content with the
content of the My_First Example_Project Main.c file, which is available as an attachment to this
PDF document.

Figure 4-13. Workspace Explorer Window

Warkspace Explorer
2 Workzpace 'Example_My_Firgt_PSolC_Froject' [1 project)
= {_Z Example_Myp First_PSoC_Project [CY2C29466-24P%1]
= ¥ Example_My_First_PSoC_Project [Chip]
== Loadable Configurations
[=-{.Zr example_rmy_first_pzoc_project - 2 Uzer Modules
B F/hE 1
[ LED_1
: E Example_My_Firzt_PSol_Project [Pinout]
== Example_My_First_PSol_Praoject
= Source Files
el
- boot.asm
[#-[_J Header Files
#-[J lib
: @ flazhzecurity. tat
#-[J Output Files
#-{J Ewternal Headers

23.Save the project.
24.Click Build > Generate/Build 'Example_My_First PSoC_Project'.

25.Connect the ICE-Cube to the computer. Connect the ICE-Cube to the target board (in this case
CY3210-PSoCEval1 kit), as explained in Connecting the ICE-Cube on page 15.

26.In PSoC Designer, select Debug > Connect/Disconnect to connect the ICE to PSoC Designer.

Figure 4-14. Connecting ICE to PSoC Designer

Example_My_First_PSoC_Project - PSoC Designer 5.1

File Edit Miew Project Interconmect  Build | Debug | Program Tools  Window  Help
Jjﬂﬂ, Eﬁ{:ﬂ ﬁ?ﬁ __‘0 Windows FEp bR
alobal Resources - example_mw_first_p... » 3 X E Cutput: files ' m_
Power Setting [ 5.00 / 24MHz [ |apb  Evecdte Programm Fa F——
CPU_Clack SysClk/2 A —
A2K_Select Internal 4 T
PLL_Mode Dizable »

. by Cype

Sleep_Timer 512 _Hz 4 =ub e
WC1=SysClk/M 16 )
YO2= YO /N 15 Reset Zkrl+5hift-+HFS nited 3t
YC3Souece W2 [= reby gri
YC3 Divider 256 = e to ol
SysClk Source  Internal = = Source
SysCIk*2 Disable Ves L= Stom 501
Analog Power  SC Off/Ref Low = on with
Ref bus [Vdd/2)+/-[vVdd/2) - nt. Any
AlGndBypass Dizable | '51‘* Connect | Discannect F9 | entatio:
Op-Amp Bias Low the exp:
A_Buff_Power  Low
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27.0n successful connection, the status bar at the bottom of the PSoC Designer IDE shows the sta-
tus as 'Connected'.

Figure 4-15. ICE-Cube Connected

[aoo [woo [spioo | pcioooo [FRoo [ ookHz | ICED | Connected ILn33 Calz NS

28.If there is an error, ensure that the Debugger settings in Project > Settings match Figure 4-16.

Figure 4-16. Debugger Settings

% project Settings

Example_My_First_PSoC_Project

= Buid Select ICE Device:  ||CE 0, Cube [ 5M: 09180811 ] v
Cornpiler

Linker

Pod Power Source

Chip Editor () External anly (%) ICE may power pod

Pod Supply W oltage Y v

[ 0k H LCancel ]

Note The pod may be powered by the ICE-Cube or through external power. If external power is
used, ensure that the power is on for the ICE to get connected.

29.Click on Debug > Execute Program or the keyboard shortcut F4. The project starts compiling; it
is downloaded to the pod and starts running.

41.3 Verify Output

Verify the output as follows:
1. Two LEDs connected to P2[0] and P2[1] start blinking.

2. Open the main.c file. Right-click on any line in the while(1) loop in the code and select Insert/
Delete Break Point to include a break point at that point. The execution of the code stops at the
point where the break point is inserted — LED controlled by software (connected to P2[1]) stops
blinking. The line is highlighted in yellow when the code execution stops.

3. At this point, you may either continue running the code by selecting Debug > Run (keyboard
shortcut F5) or step through the code by selecting either Debug > Step Over (keyboard shortcut
F8) or Debug > Step Into (keyboard shortcut F11).

Note The Step Over command executes statement one by one and does not enter into the func-
tion calls whereas the Step Into command enters the function calls as well.

Use the debug windows (see Debug a Project on page 21) to explore other debugging features
offered in PSoC Designer. For more details on debugging, debug menu options, and debug strate-
gies, see Help > Help Topics > Debugger.
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Figure 4-17. Verify Output

36 CY3215A-DK PSoC 1 In-Circuit Emulation (ICE) Lite Development Kit Guide, Doc. # 001-80377 Rev. *A



	PSoC® 1 In-Circuit Emulation (ICE) Lite Development Kit Guide
	Contents
	1. Introduction
	1.1 Kit Contents
	1.2 Additional Learning Resources
	1.3 Document History
	1.4 Documentation Conventions

	2. Getting Started
	2.1 Kit Installation
	2.2 PSoC Designer
	2.3 PSoC Programmer

	3. Using ICE-Cube Connector
	3.1 Connecting the ICE-Cube
	3.1.1 Connect using a USB Port
	3.1.2 Connect using a Backward-Compatibility Adapter
	3.1.2.1 Program Device
	3.1.2.2 Debug Device

	3.1.3 Connect using a Flex Cable
	3.1.4 Software Installation
	3.1.5 Debug a Project
	3.1.5.1 Break Points
	3.1.5.2 CPU and Register Views
	3.1.5.3 Watch Variables
	3.1.5.4 Trace
	3.1.5.5 Locals


	3.2 PSoC Programmer

	4. Code Examples
	4.1 My First Code Example
	4.1.1 Project Objective
	4.1.2 Creating My First PSoC 1 Project
	4.1.3 Verify Output




/********************************************************************************

* Copyright (2011), Cypress Semiconductor Corporation.

********************************************************************************

* This software is owned by Cypress Semiconductor Corporation (Cypress)

* and is protected by and subject to worldwide patent protection (United

* States and foreign), United States copyright laws and international treaty

* provisions. Cypress hereby grants to licensee a personal, non-exclusive,

* non-transferable license to copy, use, modify, create derivative works of,

* and compile the Cypress Source Code and derivative works for the sole

* purpose of creating custom software in support of licensee product to be

* used only in conjunction with a Cypress integrated circuit as specified in

* the applicable agreement. Any reproduction, modification, translation,

* compilation, or representation of this software except as specified above 

* is prohibited without the express written permission of Cypress.

*

* Disclaimer: CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH 

* REGARD TO THIS MATERIAL, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 

* WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

* Cypress reserves the right to make changes without further notice to the 

* materials described herein. Cypress does not assume any liability arising out 

* of the application or use of any product or circuit described herein. Cypress 

* does not authorize its products for use as critical components in life-support 

* systems where a malfunction or failure may reasonably be expected to result in 

* significant injury to the user. The inclusion of Cypress' product in a life-

* support systems application implies that the manufacturer assumes all risk of 

* such use and in doing so indemnifies Cypress against all charges. Use may be 

* limited by and subject to the applicable Cypress software license agreement. 

*******************************************************************************/





/*******************************************************************************

* File Name: main.c

*

* Description:

*  This file provides source code for My First PSoC Project example. The 

*  firmware blinks one LED at about 3.6Hz with a PWM, and blinks another LED 

*  with a software timing loop.

*

********************************************************************************/



/******************************************************************************

*   PWM Settings:

*

*		Input Clock      = VC3		  //VC3 = 24MHz/16/16/256 =366.2Hz

*		Enable           = High

*		CompareOut       = Row_0_Output_0  

*		TerminalCountOut = None

*		Period           = 100    Output period = (Period+1)*(1/Input Clock) = 101/366.2 = .275sec 

													or 3.63Hz

* 		PulseWidth       = 50

*		CompareType      = Less Than Or Equal

*		InterruptType    = Terminal Count

*		ClockSync        = Sync to SysClk

*		InvertEnable      = Normal

*

*********************************************************************************/	



#include <m8c.h>        /* part specific constants and macros */

#include "PSoCAPI.h"    /* PSoC API definitions for all User Modules */



unsigned int i;        /* Varible used for delay */



void main(void)

{

    PWM8_1_Start();	/* Turn on the PWM to blink LED on P2.0 */

	LED_1_Start();	/* Enable Software controlled LED */

	

	

	/* The following loop controls the software LED conneted to P2.1 */

	while(1)

	{

		for (i=0; i<60000; i++); /* Length of delay depends on compiler and CPU clock */

		LED_1_Invert();			 /* Toggle the state of the software controlled LED */

		asm("nop");				 /* Assembly "No-Operation" statement - Good place to insert a breakpoint */

	} /* End of while(1) */



}/* End of main */



